Update msmtp package to 1.4.18 adding a patch for OpenSSL 1.0beta.

(fix PR pkg/42054.)

Changes:
- Update gnulib to 2009-09-07.
- Use proper binary prefixes when handling sizes.
- Scripts msmtpq and msmtpQ: do not hardcode IP address of www.google.com
when testing connectivity. Use host name instead. Closes Debian bug #538328.
- Make the option -v an alias for -d/--debug, for compatibility with
other implementations of the sendmail interface. Closes Debian bug #487272.
- Add find_alias_for_msmtp.sh script by Jim Lofft.
- Update gnulib to 2009-08-02.
- Increase SMTP_MAXCMDLEN so that it is large enough to handle the
potentially very long lines generated by the GSSAPI authentication method.
- Update gnulib to 2009-03-07. Remove gnulib modules
fseek/fseeko/lseek because they cause errors on MinGW: files opened with
"r+" cannot be written to.
Provide our own fseeko instead if it does not exist; see configure.ac.
- Use "netrc" as SYSNETRCFILE, not ".netrc". Reported by Jim Pryor.
- Use more gnulib modules to remove more W32 workarounds from the source.
- Add missing gnulib module strerror for meaningful error messages on W32.
This commit is contained in:
taca 2009-09-14 07:08:52 +00:00
parent 45a341ecb6
commit 386094fbeb
3 changed files with 22 additions and 7 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.23 2009/08/26 19:58:45 sno Exp $
# $NetBSD: Makefile,v 1.24 2009/09/14 07:08:52 taca Exp $
DISTNAME= msmtp-1.4.17
PKGREVISION= 1
DISTNAME= msmtp-1.4.18
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=msmtp/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.16 2009/01/06 12:08:01 obache Exp $
$NetBSD: distinfo,v 1.17 2009/09/14 07:08:52 taca Exp $
SHA1 (msmtp-1.4.17.tar.bz2) = 6b7fa1d9c9eee249b571b3f7720ebd779f94f4de
RMD160 (msmtp-1.4.17.tar.bz2) = 749cf22bcbde90dd298f0c96ee0f9e41f93767b6
Size (msmtp-1.4.17.tar.bz2) = 766293 bytes
SHA1 (msmtp-1.4.18.tar.bz2) = f7b42a2a6f4c9c21687dde86dfa827d728a08d76
RMD160 (msmtp-1.4.18.tar.bz2) = 5157815713363e94b62e2de5fe6ba9dd0c330180
Size (msmtp-1.4.18.tar.bz2) = 818691 bytes
SHA1 (patch-ad) = e6a38d412fcd32ff6d807bacfeeb53ce8a2a4b09

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ad,v 1.3 2009/09/14 07:08:52 taca Exp $
Make it portable to OpenSSL 1.0.
--- src/tls.c.orig 2008-12-26 02:58:43.000000000 +0900
+++ src/tls.c
@@ -813,7 +813,7 @@ int tls_check_cert(tls_t *tls, const cha
char *buf;
int bufsize;
/* needed to get the DNS subjectAltNames: */
- STACK *subj_alt_names;
+ STACK_OF(GENERAL_NAME) *subj_alt_names;
int subj_alt_names_count;
GENERAL_NAME *subj_alt_name;
/* did we find a name matching hostname? */