remove wrong patch

(see https://bugzilla.gnome.org/show_bug.cgi?id=588740 comments #24 and
 #29)
ride on last night's update
This commit is contained in:
drochner 2009-12-09 09:41:20 +00:00
parent 8bfefac977
commit 387fc5150a
2 changed files with 1 additions and 26 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.120 2009/12/08 18:54:36 wiz Exp $
$NetBSD: distinfo,v 1.121 2009/12/09 09:41:20 drochner Exp $
SHA1 (gtk+-2.18.5.tar.bz2) = ddb004f0f92f7c8e3b84237e05fcf0ef5affc79c
RMD160 (gtk+-2.18.5.tar.bz2) = 712098237fc31dcb99189645f0320aa165855577
@ -7,5 +7,4 @@ SHA1 (patch-aa) = 105a5b9d0bad708bcceb6f9a801207f0eff96eb3
SHA1 (patch-af) = 372a21cdb884e7c62852680d0029ded12c706efd
SHA1 (patch-aj) = 40d91c8698981662e6926a27e39006b5ec413133
SHA1 (patch-gb) = 6c0728eda2d4a59add4f8962bdab4f05022eda79
SHA1 (patch-iojpeg) = 459db178ba8d44bd32cd089fc33689de5a57556b
SHA1 (patch-ob) = 51cbaa82d534ca4ea5253e3a938daa3a5d1e05fb

View file

@ -1,24 +0,0 @@
$NetBSD: patch-iojpeg,v 1.2 2009/12/06 22:40:02 wiz Exp $
Fix a scaling issue with jpeg7; see
http://bugzilla.gnome.org/show_bug.cgi?id=588740 and
http://bbs.archlinux.org/viewtopic.php?pid=589488#p589488
--- gdk-pixbuf/io-jpeg.c.orig 2009-12-01 03:21:23.000000000 +0000
+++ gdk-pixbuf/io-jpeg.c
@@ -922,13 +922,13 @@ gdk_pixbuf__jpeg_image_load_increment (g
}
cinfo->scale_num = 1;
- for (cinfo->scale_denom = 2; cinfo->scale_denom <= 8; cinfo->scale_denom *= 2) {
+ for (cinfo->scale_denom = 2; cinfo->scale_denom <= 16; cinfo->scale_denom++) {
jpeg_calc_output_dimensions (cinfo);
if (cinfo->output_width < width || cinfo->output_height < height) {
- cinfo->scale_denom /= 2;
break;
}
}
+ cinfo->scale_denom--;
jpeg_calc_output_dimensions (cinfo);
context->pixbuf = gdk_pixbuf_new (GDK_COLORSPACE_RGB,