Use GNU Autoconf to configure this, there are some problems with

the scons source files and it does not create the pkgconfig files
correctly
This commit is contained in:
plunky 2020-04-17 13:31:31 +00:00
parent 0d91bc3f30
commit 38a02d290a
5 changed files with 11 additions and 53 deletions

View file

@ -1,6 +1,6 @@
Brushes used by MyPaint and other software using libmypaint.
This data package is versionned. This are the brushes to be used
This data package is versioned. This are the brushes to be used
by libmypaint 2.x, current development version which has no releases
to the day of writing. If you want brushes for the libmypaint 1.x
releases, do not install mypaint-brushes from master, but from

View file

@ -1,6 +1,7 @@
# $NetBSD: Makefile,v 1.6 2020/03/04 13:11:14 wiz Exp $
# $NetBSD: Makefile,v 1.7 2020/04/17 13:31:31 plunky Exp $
DISTNAME= mypaint-brushes-2.0.2
PKGREVISION= 1
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GITHUB:=mypaint/}
GITHUB_PROJECT= mypaint-brushes
@ -11,21 +12,15 @@ HOMEPAGE= https://github.com/mypaint/mypaint-brushes/
COMMENT= Default MyPaint brushes
LICENSE= cc0-1.0-universal
USE_TOOLS+= pkg-config
GNU_CONFIGURE= yes
AUTOCONF_REQD= 2.62
AUTOMAKE_REQD= 1.13
USE_TOOLS+= autoconf automake gmake pkg-config
USE_LANGUAGES= # none
PKGCONFIG_OVERRIDE+= pkgconfig.pc.in
SCONS_ARGS+= prefix=${DESTDIR}${PREFIX}
pre-configure:
cd ${WRKSRC} && ./autogen.sh
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${SCONSBIN} \
${SCONS_ARGS}
do-install:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${SCONSBIN} \
${SCONS_ARGS} install
PYTHON_FOR_BUILD_ONLY?= yes
.include "../../devel/scons/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.2 2020/03/04 13:11:14 wiz Exp $
@comment $NetBSD: PLIST,v 1.3 2020/04/17 13:31:31 plunky Exp $
share/mypaint-data/2.0/brushes/Dieterle/8B_Pencil#1.myb
share/mypaint-data/2.0/brushes/Dieterle/8B_Pencil#1_prev.png
share/mypaint-data/2.0/brushes/Dieterle/Blender.myb
@ -37,8 +37,6 @@ share/mypaint-data/2.0/brushes/Dieterle/WateryFlatbrush.myb
share/mypaint-data/2.0/brushes/Dieterle/WateryFlatbrush_prev.png
share/mypaint-data/2.0/brushes/Dieterle/arrow#1.myb
share/mypaint-data/2.0/brushes/Dieterle/arrow#1_prev.png
share/mypaint-data/2.0/brushes/FX_blender_prev.png
share/mypaint-data/2.0/brushes/Makefile.am
share/mypaint-data/2.0/brushes/classic/blend+paint.myb
share/mypaint-data/2.0/brushes/classic/blend+paint_prev.png
share/mypaint-data/2.0/brushes/classic/blending_knife.myb
@ -269,9 +267,7 @@ share/mypaint-data/2.0/brushes/kaerhon_v1/smudge_ink(0.7)_sm.myb
share/mypaint-data/2.0/brushes/kaerhon_v1/smudge_ink(0.7)_sm_prev.png
share/mypaint-data/2.0/brushes/kaerhon_v1/wet_paint_sm.myb
share/mypaint-data/2.0/brushes/kaerhon_v1/wet_paint_sm_prev.png
share/mypaint-data/2.0/brushes/label-brush-mypaint.sh
share/mypaint-data/2.0/brushes/order.conf
share/mypaint-data/2.0/brushes/prev-template.xcf.gz
share/mypaint-data/2.0/brushes/ramon/100%_Opaque.myb
share/mypaint-data/2.0/brushes/ramon/100%_Opaque_prev.png
share/mypaint-data/2.0/brushes/ramon/2B_pencil.myb

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.4 2020/03/04 13:11:14 wiz Exp $
$NetBSD: distinfo,v 1.5 2020/04/17 13:31:31 plunky Exp $
SHA1 (mypaint-brushes-2.0.2.tar.gz) = 01722b336fb14ffe83502352a645e3e9d3b61983
RMD160 (mypaint-brushes-2.0.2.tar.gz) = 4edf7a6280fac8c082f9b75389f45d190dc42254
SHA512 (mypaint-brushes-2.0.2.tar.gz) = 89cecd9d78f4de84ada97a3e33fd67b86dfd259880da15c0ecbfad0fceb8c3b0e93790f3c0bff0cc375959bdf6921b01d1f3646e27c3f961715219a349017556
Size (mypaint-brushes-2.0.2.tar.gz) = 1564926 bytes
SHA1 (patch-SConstruct) = ca04983b2c6829f3cca0a7e60bb59499f4f63e5c

View file

@ -1,32 +0,0 @@
$NetBSD: patch-SConstruct,v 1.1 2019/01/02 17:23:04 tnn Exp $
python 3.x compatibility
--- SConstruct.orig 2018-01-01 20:22:53.000000000 +0000
+++ SConstruct
@@ -23,7 +23,7 @@ opts.Update(env)
env.Alias('install', '$prefix')
set_dir_postaction = {}
-def install_perms(env, target, sources, perms=0644, dirperms=0755):
+def install_perms(env, target, sources, perms=0o644, dirperms=0o755):
"""As a normal env.Install, but with Chmod postactions.
The `target` parameter must be a string which starts with ``$prefix``.
@@ -52,14 +52,14 @@ def install_perms(env, target, sources,
d_prev = None
while d != d_prev and d != '$prefix':
d_prev = d
- if not set_dir_postaction.has_key(d):
+ if not d in set_dir_postaction:
env.AddPostAction(file_targ, Chmod(d, dirperms))
set_dir_postaction[d] = True
d = os.path.dirname(d)
return install_targs
-def install_tree(env, dest, path, perms=0644, dirperms=0755):
+def install_tree(env, dest, path, perms=0o644, dirperms=0o755):
assert os.path.isdir(path)
target_root = os.path.join(dest, os.path.basename(path))
for dirpath, dirnames, filenames in os.walk(path):