Initial import of replex-0.1.4, provided by Michael van Elst in PR 32380:
Replex was created to remultiplex transport stream (TS) data taken from a DVB source. The result is supposed to be a program stream (PS) that can be used to burn a DVD (with dvdauthor). Replex can also remultiplex other PSs and AVIs with MPEG2 content.
This commit is contained in:
parent
d648e41c9a
commit
38b5dd87a1
6 changed files with 90 additions and 0 deletions
4
multimedia/replex/DESCR
Normal file
4
multimedia/replex/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Replex was created to remultiplex transport stream (TS) data taken from
|
||||
a DVB source. The result is supposed to be a program stream (PS) that
|
||||
can be used to burn a DVD (with dvdauthor). Replex can also remultiplex
|
||||
other PSs and AVIs with MPEG2 content.
|
14
multimedia/replex/Makefile
Normal file
14
multimedia/replex/Makefile
Normal file
|
@ -0,0 +1,14 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2006/01/11 18:36:11 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= replex-0.1.4
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://www.metzlerbros.org/dvb/
|
||||
|
||||
MAINTAINER= mlelstv@NetBSD.org
|
||||
HOMEPAGE= http://www.metzlerbros.org/dvb/
|
||||
COMMENT= Remultiplexes transport streams from a DVB source
|
||||
|
||||
USE_TOOLS+= gmake
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
4
multimedia/replex/PLIST
Normal file
4
multimedia/replex/PLIST
Normal file
|
@ -0,0 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2006/01/11 18:36:11 wiz Exp $
|
||||
bin/replex
|
||||
share/doc/replex/README
|
||||
@dirrm share/doc/replex
|
7
multimedia/replex/distinfo
Normal file
7
multimedia/replex/distinfo
Normal file
|
@ -0,0 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2006/01/11 18:36:11 wiz Exp $
|
||||
|
||||
SHA1 (replex-0.1.4.tar.gz) = 9d381da25aac0406791e290bff3f27b78ec034ed
|
||||
RMD160 (replex-0.1.4.tar.gz) = 4fc8b1e19ca9dd0b362eeac57a797d76b556b250
|
||||
Size (replex-0.1.4.tar.gz) = 43292 bytes
|
||||
SHA1 (patch-aa) = 11d1835f90742170e204bf3f877359d8508b60af
|
||||
SHA1 (patch-ab) = e1d8876ed8db03599c3e92de157401defc0cd893
|
46
multimedia/replex/patches/patch-aa
Normal file
46
multimedia/replex/patches/patch-aa
Normal file
|
@ -0,0 +1,46 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2006/01/11 18:36:11 wiz Exp $
|
||||
|
||||
--- Makefile.orig 2005-03-27 21:54:24.000000000 +0200
|
||||
+++ Makefile
|
||||
@@ -1,16 +1,17 @@
|
||||
VERSION = 0.1.4
|
||||
DISTNAME = replex-$(VERSION)
|
||||
TARNAME = $(DISTNAME).tar.gz
|
||||
-INCS = -I..
|
||||
+INCS =
|
||||
CFLAGS = -g -Wall -O2 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
|
||||
-LIBS = -L.
|
||||
+LIBS =
|
||||
MFLAG = -M
|
||||
OBJS = element.o pes.o mpg_common.o ts.o ringbuffer.o avi.o multiplex.o
|
||||
|
||||
SRC = avi.c element.c mpg_common.c pes.c replex.c ringbuffer.c ts.c multiplex.c
|
||||
HEADERS = element.h pes.h mpg_common.h ts.h ringbuffer.h avi.h replex.h multiplex.h
|
||||
EXTRA = COPYING README TODO CHANGES
|
||||
-DESTDIR = /usr/local
|
||||
+#DESTDIR =
|
||||
+#PREFIX = /usr/local
|
||||
|
||||
|
||||
.PHONY: depend clean install uninstall
|
||||
@@ -37,13 +38,15 @@ dist: $(SRC) $(HEADERS) Makefile
|
||||
%.o: %.c %.h
|
||||
$(CC) -c $(CFLAGS) $(INCS) $(DEFINES) $<
|
||||
|
||||
-install: libreplex.a replex
|
||||
- install -m 644 libreplex.a $(DESTDIR)/lib/
|
||||
- install -m 755 replex $(DESTDIR)/bin/
|
||||
+install: README replex
|
||||
+ $(BSD_INSTALL_PROGRAM) replex $(PREFIX)/bin/
|
||||
+ $(BSD_INSTALL_DATA_DIR) $(PREFIX)/share/doc/replex/
|
||||
+ $(BSD_INSTALL_DATA) README $(PREFIX)/share/doc/replex/
|
||||
|
||||
uninstall:
|
||||
- rm -f $(DESTDIR)/lib/libreplex.a
|
||||
- rm -f $(DESTDIR)/bin/replex
|
||||
+ rm -f $(PREFIX)/share/doc/replex/README
|
||||
+ rmdir $(PREFIX)/share/doc/replex
|
||||
+ rm -f $(PREFIX)/bin/replex
|
||||
|
||||
|
||||
.depend:
|
15
multimedia/replex/patches/patch-ab
Normal file
15
multimedia/replex/patches/patch-ab
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2006/01/11 18:36:11 wiz Exp $
|
||||
|
||||
--- replex.c.orig 2005-03-27 21:54:23.000000000 +0200
|
||||
+++ replex.c
|
||||
@@ -39,6 +39,10 @@
|
||||
#include "replex.h"
|
||||
#include "pes.h"
|
||||
|
||||
+#ifndef O_LARGEFILE
|
||||
+#define O_LARGEFILE 0
|
||||
+#endif
|
||||
+
|
||||
static int replex_all_set(struct replex *rx);
|
||||
|
||||
int replex_check_id(struct replex *rx, uint16_t id)
|
Loading…
Reference in a new issue