python38: Use gnu99 instead of c99 to avoid "alloca() undefined" problems
Add a missed hunk from python3[67] to patch-configure. This fixes the build on NetBSD/evbarm (aarch64) and probably other ports. PKGREVISION++
This commit is contained in:
parent
1a884fa7f9
commit
38c42992ae
3 changed files with 20 additions and 9 deletions
|
@ -1,8 +1,9 @@
|
||||||
# $NetBSD: Makefile,v 1.2 2019/11/03 19:04:05 rillig Exp $
|
# $NetBSD: Makefile,v 1.3 2020/01/06 22:54:51 leot Exp $
|
||||||
|
|
||||||
.include "dist.mk"
|
.include "dist.mk"
|
||||||
|
|
||||||
PKGNAME= python38-${PY_DISTVERSION}
|
PKGNAME= python38-${PY_DISTVERSION}
|
||||||
|
PKGREVISION= 1
|
||||||
CATEGORIES= lang python
|
CATEGORIES= lang python
|
||||||
|
|
||||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.3 2019/12/28 22:36:13 adam Exp $
|
$NetBSD: distinfo,v 1.4 2020/01/06 22:54:51 leot Exp $
|
||||||
|
|
||||||
SHA1 (Python-3.8.1.tar.xz) = a48fd28a037c0bcd7b7fc4d914c023f584e910ed
|
SHA1 (Python-3.8.1.tar.xz) = a48fd28a037c0bcd7b7fc4d914c023f584e910ed
|
||||||
RMD160 (Python-3.8.1.tar.xz) = 057623eae4d7b82eb037176f8e80c87a30bd3586
|
RMD160 (Python-3.8.1.tar.xz) = 057623eae4d7b82eb037176f8e80c87a30bd3586
|
||||||
|
@ -15,6 +15,6 @@ SHA1 (patch-Modules_nismodule.c) = 1bafe9b06359586d027a77011b103877590d947d
|
||||||
SHA1 (patch-Modules_socketmodule.c) = e99fd9e30e3feafef1747a2f52446d8fec543362
|
SHA1 (patch-Modules_socketmodule.c) = e99fd9e30e3feafef1747a2f52446d8fec543362
|
||||||
SHA1 (patch-Modules_socketmodule.h) = 13a3290eb72078067060d3e71b7baa08f3eb591c
|
SHA1 (patch-Modules_socketmodule.h) = 13a3290eb72078067060d3e71b7baa08f3eb591c
|
||||||
SHA1 (patch-Python_thread__pthread.h) = fb81eaa604b4ed7c1b64c3f4731d58a8aee257be
|
SHA1 (patch-Python_thread__pthread.h) = fb81eaa604b4ed7c1b64c3f4731d58a8aee257be
|
||||||
SHA1 (patch-configure) = 00e3ceec47dbb016e72c11f204a6b27a4d7c182d
|
SHA1 (patch-configure) = 21540fd8328ab721b04d09aae377caf2f2978f8c
|
||||||
SHA1 (patch-pyconfig.h.in) = 4bc6e95441cb5faae94d1d52aeaaa10ae01385b6
|
SHA1 (patch-pyconfig.h.in) = 4bc6e95441cb5faae94d1d52aeaaa10ae01385b6
|
||||||
SHA1 (patch-setup.py) = b6f6fd38ad557680eba4878a9a03ec654c573361
|
SHA1 (patch-setup.py) = b6f6fd38ad557680eba4878a9a03ec654c573361
|
||||||
|
|
|
@ -1,12 +1,22 @@
|
||||||
$NetBSD: patch-configure,v 1.2 2019/10/24 10:44:57 jperkin Exp $
|
$NetBSD: patch-configure,v 1.3 2020/01/06 22:54:51 leot Exp $
|
||||||
|
|
||||||
|
Use gnu99 instead of c99 to avoid "alloca() undefined" problems.
|
||||||
Fix linking on Darwin; don't use -stack_size.
|
Fix linking on Darwin; don't use -stack_size.
|
||||||
Changes for consistency across pkgsrc platforms.
|
Changes for consistency across pkgsrc platforms.
|
||||||
Simplify _sysconfigdata to include only platform name.
|
Simplify _sysconfigdata to include only platform name.
|
||||||
|
|
||||||
--- configure.orig 2019-10-14 13:34:47.000000000 +0000
|
--- configure.orig 2019-12-18 17:21:23.000000000 +0000
|
||||||
+++ configure
|
+++ configure
|
||||||
@@ -9526,7 +9526,6 @@ then
|
@@ -6902,7 +6902,7 @@ UNIVERSAL_ARCH_FLAGS=
|
||||||
|
# tweak BASECFLAGS based on compiler and platform
|
||||||
|
case $GCC in
|
||||||
|
yes)
|
||||||
|
- CFLAGS_NODIST="$CFLAGS_NODIST -std=c99"
|
||||||
|
+ CFLAGS_NODIST="$CFLAGS_NODIST -std=gnu99"
|
||||||
|
|
||||||
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for -Wextra" >&5
|
||||||
|
$as_echo_n "checking for -Wextra... " >&6; }
|
||||||
|
@@ -9514,7 +9514,6 @@ then
|
||||||
# to ensure that tests don't crash
|
# to ensure that tests don't crash
|
||||||
# Note: This matches the value of THREAD_STACK_SIZE in
|
# Note: This matches the value of THREAD_STACK_SIZE in
|
||||||
# thread_pthread.h
|
# thread_pthread.h
|
||||||
|
@ -14,7 +24,7 @@ Simplify _sysconfigdata to include only platform name.
|
||||||
|
|
||||||
if test "$enable_framework"
|
if test "$enable_framework"
|
||||||
then
|
then
|
||||||
@@ -14271,10 +14270,10 @@ _ACEOF
|
@@ -14259,10 +14258,10 @@ _ACEOF
|
||||||
if ac_fn_c_try_compile "$LINENO"; then :
|
if ac_fn_c_try_compile "$LINENO"; then :
|
||||||
|
|
||||||
|
|
||||||
|
@ -27,7 +37,7 @@ Simplify _sysconfigdata to include only platform name.
|
||||||
if test "$ax_cv_c_float_words_bigendian" = unknown; then
|
if test "$ax_cv_c_float_words_bigendian" = unknown; then
|
||||||
ax_cv_c_float_words_bigendian=no
|
ax_cv_c_float_words_bigendian=no
|
||||||
else
|
else
|
||||||
@@ -15160,8 +15159,6 @@ fi
|
@@ -15148,8 +15147,6 @@ fi
|
||||||
|
|
||||||
|
|
||||||
case $ac_sys_system in
|
case $ac_sys_system in
|
||||||
|
@ -36,7 +46,7 @@ Simplify _sysconfigdata to include only platform name.
|
||||||
*)
|
*)
|
||||||
EXT_SUFFIX=${SHLIB_SUFFIX};;
|
EXT_SUFFIX=${SHLIB_SUFFIX};;
|
||||||
esac
|
esac
|
||||||
@@ -15181,11 +15178,7 @@ else
|
@@ -15169,11 +15166,7 @@ else
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
|
||||||
|
|
Loading…
Reference in a new issue