Update to 5.2.5

* Security Enhancements and Fixes in PHP 5.2.5:
Fixed dl() to only accept filenames. Reported by Laurent Gaffie.
Fixed dl() to limit argument size to MAXPATHLEN (CVE-2007-4887). Reported by Laurent Gaffie.
Fixed htmlentities/htmlspecialchars not to accept partial multibyte sequences. Reported by Rasmus Lerdorf
Fixed possible triggering of buffer overflows inside glibc implementations of the fnmatch(), setlocale() and glob() functions. Reported by Laurent Gaffie.
Fixed "mail.force_extra_parameters" php.ini directive not to be modifiable in .htaccess due to the security implications. Reported by SecurityReason.
Fixed bug 42869 (automatic session id insertion adds sessions id to non-local forms).
Fixed bug 41561 (Values set with php_admin_* in httpd.conf can be overwritten with ini_set()).

* Key enhancements in PHP 5.2.5 include:
Upgraded PCRE to version 7.3
Updated timezone database to version 2007.9
Added ability to control memory consumption between request using ZEND_MM_COMPACT environment variable.
Improved speed of array_intersect_key(), array_intersect_assoc(), array_uintersect_assoc(), array_diff_key(), array_diff_assoc() and array_udiff_assoc() functions
Fixed bug 43139 (PDO ignores ATTR_DEFAULT_FETCH_MODE in some cases with fetchAll())
Fixed bug 42785 (json_encode() formats doubles according to locale rather then following standard syntax)
Fixed bug 42549 (ext/mysql failed to compile with libmysql 3.23)
Over 60 bug fixes.

For all the details see:
	http://www.php.net/ChangeLog-5.php#5.2.5
This commit is contained in:
adrianp 2007-11-23 13:20:00 +00:00
parent 32c031733f
commit 393b3d656c
5 changed files with 7 additions and 36 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.61 2007/09/25 21:00:16 jdolecek Exp $
# $NetBSD: Makefile,v 1.62 2007/11/23 13:20:00 adrianp Exp $
PKGNAME= php-${PHP_BASE_VERS}
PKGREVISION= 3
CATEGORIES= lang
HOMEPAGE= http://www.php.net/

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile.common,v 1.27 2007/09/02 21:12:41 jdolecek Exp $
# $NetBSD: Makefile.common,v 1.28 2007/11/23 13:20:00 adrianp Exp $
.if !defined(DISTNAME)
DISTNAME= php-${PHP_BASE_VERS}
@ -15,7 +15,7 @@ EXTRACT_SUFX?= .tar.bz2
MAINTAINER?= jdolecek@NetBSD.org
HOMEPAGE?= http://www.php.net/
PHP_BASE_VERS= 5.2.4
PHP_BASE_VERS= 5.2.5
PHP_EXTENSION_DIR= lib/php/20040412
PLIST_SUBST+= PHP_EXTENSION_DIR=${PHP_EXTENSION_DIR:Q}

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.49 2007/09/11 20:14:46 jdolecek Exp $
$NetBSD: distinfo,v 1.50 2007/11/23 13:20:00 adrianp Exp $
SHA1 (php-5.2.4/php-5.2.4.tar.bz2) = 0e8f42d1363b17fbaeb3e7732ab1a501a9a12c8e
RMD160 (php-5.2.4/php-5.2.4.tar.bz2) = 22728d27ec3ba3287943ea878fefbba0b4ffdc00
Size (php-5.2.4/php-5.2.4.tar.bz2) = 7608429 bytes
SHA1 (php-5.2.5/php-5.2.5.tar.bz2) = 6b46fd095891183b328163b70cdb5acd30a24b7a
RMD160 (php-5.2.5/php-5.2.5.tar.bz2) = 2d5755f2ae8884e80f0a5c70e8fdfdb6deed46bc
Size (php-5.2.5/php-5.2.5.tar.bz2) = 7773024 bytes
SHA1 (patch-aa) = 20bc3831e435182d014b11ae9f1f6c537a21af20
SHA1 (patch-ad) = b324c33b1e70adee5b89dcecdd7690dcadcc18ec
SHA1 (patch-ag) = 4ccb67ba6f5370b1d16b087e3e714de3e5ae604e
@ -11,7 +11,5 @@ SHA1 (patch-aj) = 54812097499c81e5cb0196ab949cc86a4f24a9cc
SHA1 (patch-ak) = 0a6445b5cf390cb63de8474d75c6e8a4c058afab
SHA1 (patch-al) = 0ee37782cc0d3bf5ede1a583de0589c2c1316b50
SHA1 (patch-an) = f07a08f8ee1a18f6371af9bd6c482d936e9220e4
SHA1 (patch-ao) = 4f22a112e5626b2f9fa029363c9e451e77136e97
SHA1 (patch-ap) = 5eb0e0e4244a993da93e36f8fcb5553454207fce
SHA1 (patch-aq) = 0c9d48547da2fa80aa8357d23ad8505d1c0330df
SHA1 (patch-ar) = 10f4394dc62acd9b9e20fb86321fe2dcaca7e282

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ao,v 1.5 2007/09/02 21:13:43 jdolecek Exp $
--- ext/bz2/php_bz2.h.orig 2007-09-02 20:11:08.000000000 +0200
+++ ext/bz2/php_bz2.h
@@ -51,7 +51,7 @@ PHP_BZ2_API php_stream *_php_stream_bz2o
#define php_stream_bz2open_from_BZFILE(bz, mode, innerstream) _php_stream_bz2open_from_BZFILE((bz), (mode), (innerstream) STREAMS_CC TSRMLS_CC)
#define php_stream_bz2open(wrapper, path, mode, options, opened_path) _php_stream_bz2open((wrapper), (path), (mode), (options), (opened_path), NULL STREAMS_CC TSRMLS_CC)
-php_stream_filter_factory php_bz2_filter_factory;
+extern php_stream_filter_factory php_bz2_filter_factory;
extern php_stream_ops php_stream_bz2io_ops;
#define PHP_STREAM_IS_BZIP2 &php_stream_bz2io_ops

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ar,v 1.3 2007/09/11 20:14:46 jdolecek Exp $
--- Zend/zend_extensions.c.orig 2007-09-11 22:00:50.000000000 +0200
+++ Zend/zend_extensions.c
@@ -243,7 +243,7 @@ void *zend_mh_bundle_load(char* bundle_p
return NULL;
}
- bundle_handle = NSLinkModule(bundle_image, bundle_path, NSLINKMODULE_OPTION_PRIVATE);
+ bundle_handle = NSLinkModule(bundle_image, bundle_path, NSLINKMODULE_OPTION_NONE);
NSDestroyObjectFileImage(bundle_image);
/* call the init function of the bundle */