Initial import of html2text-1.2.1, an advanced HTML to text converter.
This commit is contained in:
parent
198112270b
commit
393e51a3f7
7 changed files with 126 additions and 0 deletions
18
textproc/html2text/Makefile
Normal file
18
textproc/html2text/Makefile
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 1999/12/28 10:42:20 rh Exp $
|
||||
#
|
||||
|
||||
DISTNAME= html2text-1.2.1
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www.gmrs.de/
|
||||
|
||||
MAINTAINER= rh@netbsd.org
|
||||
HOMEPAGE= http://www.gmrs.de/html2text.html
|
||||
|
||||
HAS_CONFIGURE= YES
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/html2text ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/html2text.1 ${PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/html2textrc.4 ${PREFIX}/man/man5/html2textrc.5
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
3
textproc/html2text/files/md5
Normal file
3
textproc/html2text/files/md5
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: md5,v 1.1.1.1 1999/12/28 10:42:20 rh Exp $
|
||||
|
||||
MD5 (html2text-1.2.1.tar.gz) = 29038b68c127b7dda1454c7d840362be
|
3
textproc/html2text/files/patch-sum
Normal file
3
textproc/html2text/files/patch-sum
Normal file
|
@ -0,0 +1,3 @@
|
|||
$NetBSD: patch-sum,v 1.1.1.1 1999/12/28 10:42:20 rh Exp $
|
||||
|
||||
MD5 (patch-aa) = 8ba850d707da151ae808b92d524573cd
|
85
textproc/html2text/patches/patch-aa
Normal file
85
textproc/html2text/patches/patch-aa
Normal file
|
@ -0,0 +1,85 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/12/28 10:42:20 rh Exp $
|
||||
|
||||
--- configure.orig Fri Dec 17 15:05:01 1999
|
||||
+++ configure Tue Dec 28 11:28:11 1999
|
||||
@@ -13,7 +13,7 @@
|
||||
# $CXX
|
||||
#
|
||||
|
||||
-$echo 'Checking C++ compiler... \c';
|
||||
+$echo -n 'Checking C++ compiler... ';
|
||||
cat <<EOF >$tmp_file.C;
|
||||
#include <iostream.h>
|
||||
int main(int, char **) {
|
||||
@@ -38,7 +38,7 @@
|
||||
# $SYS_POLL_MISSING
|
||||
#
|
||||
|
||||
-$echo 'Checking <sys/poll.h>... \c';
|
||||
+$echo -n 'Checking <sys/poll.h>... ';
|
||||
SYS_POLL_MISSING=unknown;
|
||||
cat <<EOF >$tmp_file.C;
|
||||
#ifdef SYS_POLL_MISSING /* { */
|
||||
@@ -78,7 +78,7 @@
|
||||
# $SOCKET_LIBRARIES
|
||||
#
|
||||
|
||||
-$echo 'Checking for socket libraries... \c';
|
||||
+$echo -n 'Checking for socket libraries... ';
|
||||
SOCKET_LIBRARIES=unknown;
|
||||
cat >$tmp_file.C <<EOF;
|
||||
extern "C" int socket();
|
||||
@@ -108,7 +108,7 @@
|
||||
# $BOOL_DEFINITION
|
||||
#
|
||||
|
||||
-$echo 'Checking "bool"... \c';
|
||||
+$echo -n 'Checking "bool"... ';
|
||||
BOOL_DEFINITION=unknown;
|
||||
cat <<EOF >$tmp_file.C;
|
||||
#ifdef BOOL_DEFINITION
|
||||
@@ -145,7 +145,7 @@
|
||||
# $EXPLICIT
|
||||
#
|
||||
|
||||
-$echo 'Checking "explicit"... \c';
|
||||
+$echo -n 'Checking "explicit"... ';
|
||||
EXPLICIT=unknown;
|
||||
cat <<EOF >$tmp_file.C;
|
||||
struct C {
|
||||
@@ -176,7 +176,7 @@
|
||||
# $LIBSTDCXX_INCLUDES, $LIBSTDCXX_LIBS
|
||||
#
|
||||
|
||||
-$echo 'Checking Standard C++ library... \c';
|
||||
+$echo -n 'Checking Standard C++ library... ';
|
||||
cat <<EOF >$tmp_file.C;
|
||||
#include <string>
|
||||
#include <list>
|
||||
@@ -203,7 +203,7 @@
|
||||
# $AUTO_PTR_BROKEN
|
||||
#
|
||||
AUTO_PTR_BROKEN="";
|
||||
-$echo 'Checking "auto_ptr"... \c';
|
||||
+$echo -n 'Checking "auto_ptr"... ';
|
||||
cat <<EOF >$tmp_file.C;
|
||||
#include <memory>
|
||||
#include <string>
|
||||
@@ -234,7 +234,7 @@
|
||||
# $MAKEDEPEND_INCLUDES
|
||||
#
|
||||
MAKEDEPEND_INCLUDES="";
|
||||
-$echo 'Checking "makedepend" includes... \c';
|
||||
+$echo -n 'Checking "makedepend" includes... ';
|
||||
echo "#include <iostream.h>" >$tmp_file.C;
|
||||
MAKEDEPEND_INCLUDES=`$CXX -E $tmp_file.C 2>/dev/null |
|
||||
sed -n \
|
||||
@@ -267,7 +267,7 @@
|
||||
MAKEDEPEND_INCLUDES; \
|
||||
do cmd="$cmd -e \"s|@$i@|\$$i|g\""; done;
|
||||
for dir in $makedirs; do
|
||||
- $echo "Creating \"$dir/Makefile\" from \"$dir/Makefile.in\"... \\c";
|
||||
+ $echo -n "Creating \"$dir/Makefile\" from \"$dir/Makefile.in\"... ";
|
||||
cat <<EOF >$dir/Makefile;
|
||||
|
||||
#
|
1
textproc/html2text/pkg/COMMENT
Normal file
1
textproc/html2text/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
an advanced HTML-to-text converter
|
12
textproc/html2text/pkg/DESCR
Normal file
12
textproc/html2text/pkg/DESCR
Normal file
|
@ -0,0 +1,12 @@
|
|||
Html2text reads HTML 3.2 documents from the input-urls, formats each
|
||||
into a stream of ASCII characters and writes the result to standard
|
||||
output (or into output-file, if the -o command line option is used).
|
||||
It also accepts syntactically incorrect input and attempts to inter-
|
||||
pret it "reasonably".
|
||||
|
||||
Documents that are specified by a URL that begins with "http:" are
|
||||
retrieved with the Hypertext Transfer Protocol. URLs that begin with
|
||||
"file:" and URLs that do not contain a colon specify local files.
|
||||
|
||||
Html2text was written by Arno Unkrig and is available under a
|
||||
BSD-style licence.
|
4
textproc/html2text/pkg/PLIST
Normal file
4
textproc/html2text/pkg/PLIST
Normal file
|
@ -0,0 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 1999/12/28 10:42:20 rh Exp $
|
||||
bin/html2text
|
||||
man/man1/html2text.1
|
||||
man/man5/html2textrc.5
|
Loading…
Reference in a new issue