Always use tradcpp. Fix prototypes. Bump revision.
This commit is contained in:
parent
453ac2271e
commit
39446bcd26
6 changed files with 124 additions and 38 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.41 2013/05/31 12:41:44 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.42 2013/07/02 12:15:36 joerg Exp $
|
||||
|
||||
DISTNAME= tightvnc-1.3.10
|
||||
PKGREVISION= 8
|
||||
PKGREVISION= 9
|
||||
CATEGORIES= net x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=vnc-tight/}
|
||||
DISTFILES= ${DISTNAME}_unixsrc.tar.bz2
|
||||
|
@ -20,8 +20,18 @@ MAKE_JOBS_SAFE= no
|
|||
|
||||
BUILD_TARGET= World
|
||||
|
||||
TOOLS_DEPENDS+= tradcpp-[0-9]*:../../devel/tradcpp
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
CPPFLAGS+= -DDEFAULT_CPP=\"${PREFIX}/bin/tradcpp\"
|
||||
|
||||
.include "../../mk/compiler.mk"
|
||||
|
||||
.if !empty(PKGSRC_COMPILER:Mclang)
|
||||
CPPFLAGS+= -Wno-error=return-type
|
||||
.endif
|
||||
|
||||
# XXX - this should go into Xvnc's NetBSD.cf, but imake doesn't
|
||||
# seem to pick it up. Someone with strong X-fu needs to look at it.
|
||||
.if !empty(MACHINE_PLATFORM:MNetBSD-*-x86_64)
|
||||
|
|
|
@ -1,13 +1,15 @@
|
|||
$NetBSD: distinfo,v 1.18 2010/03/24 21:35:12 sbd Exp $
|
||||
$NetBSD: distinfo,v 1.19 2013/07/02 12:15:36 joerg Exp $
|
||||
|
||||
SHA1 (tightvnc-1.3.10_unixsrc.tar.bz2) = ab4ed3d8e9d5188edf0ff27fce3027495f1a8851
|
||||
RMD160 (tightvnc-1.3.10_unixsrc.tar.bz2) = 0c24207ec13c1d41f445ccbdea16ce2b5d0729a7
|
||||
Size (tightvnc-1.3.10_unixsrc.tar.bz2) = 1780510 bytes
|
||||
SHA1 (patch-Xvnc_lib_Xdmcp_WC16.c) = 8f4d2facef5ef2d3a7d437536d7041361fd87fe1
|
||||
SHA1 (patch-Xvnc_lib_Xdmcp_WC8.c) = 076552089770f7968ce4059a12a8352db6808868
|
||||
SHA1 (patch-aa) = 3445af5bc4b85f7a45049378f5806a5c993503f4
|
||||
SHA1 (patch-ab) = b610979131497edae24119961bb56122e9d5a5c4
|
||||
SHA1 (patch-ab) = a136934fb7683674bd16f7e74f88a9749af756b8
|
||||
SHA1 (patch-ac) = de1acb24b39b5b0d262c91bf6539edcb38217573
|
||||
SHA1 (patch-ad) = ea79684c715de8a8364c391b5df38945b0a56ad1
|
||||
SHA1 (patch-ae) = f541c3d7f143145798eb2d3eca3d2a1992619a50
|
||||
SHA1 (patch-ae) = 550d02431805fe358de456472efc7067900d62f3
|
||||
SHA1 (patch-af) = 372b8ca93a93dab938363c6b9408ab82155a172d
|
||||
SHA1 (patch-ag) = 1a70437d0ad5ace5565d35010617ed0c319e304e
|
||||
SHA1 (patch-ah) = 013acd16171cdfdc4b97529af60978afb9b4d861
|
||||
|
|
15
net/tightvnc/patches/patch-Xvnc_lib_Xdmcp_WC16.c
Normal file
15
net/tightvnc/patches/patch-Xvnc_lib_Xdmcp_WC16.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-Xvnc_lib_Xdmcp_WC16.c,v 1.1 2013/07/02 12:15:36 joerg Exp $
|
||||
|
||||
--- Xvnc/lib/Xdmcp/WC16.c.orig 2013-06-25 21:44:37.000000000 +0000
|
||||
+++ Xvnc/lib/Xdmcp/WC16.c
|
||||
@@ -34,9 +34,7 @@ in this Software without prior written a
|
||||
#include <X11/Xdmcp.h>
|
||||
|
||||
int
|
||||
-XdmcpWriteCARD16 (buffer, value)
|
||||
- XdmcpBufferPtr buffer;
|
||||
- CARD16 value;
|
||||
+XdmcpWriteCARD16 (XdmcpBufferPtr buffer, unsigned value)
|
||||
{
|
||||
if (!XdmcpWriteCARD8 (buffer, value >> 8))
|
||||
return FALSE;
|
15
net/tightvnc/patches/patch-Xvnc_lib_Xdmcp_WC8.c
Normal file
15
net/tightvnc/patches/patch-Xvnc_lib_Xdmcp_WC8.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-Xvnc_lib_Xdmcp_WC8.c,v 1.1 2013/07/02 12:15:36 joerg Exp $
|
||||
|
||||
--- Xvnc/lib/Xdmcp/WC8.c.orig 2013-06-25 21:43:55.000000000 +0000
|
||||
+++ Xvnc/lib/Xdmcp/WC8.c
|
||||
@@ -34,9 +34,7 @@ in this Software without prior written a
|
||||
#include <X11/Xdmcp.h>
|
||||
|
||||
int
|
||||
-XdmcpWriteCARD8 (buffer, value)
|
||||
- XdmcpBufferPtr buffer;
|
||||
- CARD8 value;
|
||||
+XdmcpWriteCARD8(XdmcpBufferPtr buffer, unsigned value)
|
||||
{
|
||||
if (buffer->pointer >= buffer->size)
|
||||
return FALSE;
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
||||
$NetBSD: patch-ab,v 1.4 2013/07/02 12:15:36 joerg Exp $
|
||||
|
||||
--- Xvnc/config/cf/NetBSD.cf.orig 2000-06-11 12:00:51.000000000 +0000
|
||||
+++ Xvnc/config/cf/NetBSD.cf 2004-01-03 11:41:23.000000000 +0000
|
||||
@@ -2,9 +2,37 @@
|
||||
+++ Xvnc/config/cf/NetBSD.cf
|
||||
@@ -2,9 +2,37 @@ XCOMM platform: $XConsortium: NetBSD.cf
|
||||
|
||||
|
||||
|
||||
|
@ -41,7 +41,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
#ifndef OSName
|
||||
#define OSName DefaultOSName OSBinaryType
|
||||
#endif
|
||||
@@ -14,24 +42,34 @@
|
||||
@@ -14,24 +42,34 @@ XCOMM platform: $XFree86: xc/config/cf/
|
||||
#ifndef OSMinorVersion
|
||||
#define OSMinorVersion DefaultOSMinorVersion
|
||||
#endif
|
||||
|
@ -78,7 +78,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
#define HasNdbm YES
|
||||
#define HasPutenv YES
|
||||
#define HasSnprintf YES
|
||||
@@ -61,7 +99,20 @@
|
||||
@@ -61,7 +99,20 @@ XCOMM operating system: OSName (OSMajor
|
||||
(OSMajorVersion == 1 && OSMinorVersion == 2 && OSTeenyVersion < 2))
|
||||
# define HasDlsymBug YES
|
||||
#endif
|
||||
|
@ -100,7 +100,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
#if (!(OSMajorVersion == 0 || \
|
||||
(OSMajorVersion == 1 && OSMinorVersion < 2)))
|
||||
#define HasMkstemp YES
|
||||
@@ -85,9 +136,10 @@
|
||||
@@ -85,9 +136,10 @@ XCOMM operating system: OSName (OSMajor
|
||||
#define NeedVarargsPrototypes YES
|
||||
#define NeedWidePrototypes NO
|
||||
|
||||
|
@ -112,14 +112,15 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
#define StandardCppDefines -traditional
|
||||
#define PreProcessCmd CppCmd
|
||||
#define PreIncDir /usr/include
|
||||
@@ -96,13 +148,15 @@
|
||||
@@ -96,13 +148,15 @@ XCOMM operating system: OSName (OSMajor
|
||||
#define CcCmd gcc
|
||||
#if defined(UseInstalled) && (!defined(XF86LinkKit) || !XF86LinkKit)
|
||||
#define DefaultCCOptions /**/
|
||||
+#elif defined(arm32Architecture)
|
||||
+#define DefaultCCOptions -ansi -Dasm=__asm -fsigned-char -fomit-frame-pointer
|
||||
+#define DefaultCCOptions $(CPPFLAGS) -Dasm=__asm -fsigned-char -fomit-frame-pointer
|
||||
#else
|
||||
#define DefaultCCOptions -ansi -Dasm=__asm
|
||||
-#define DefaultCCOptions -ansi -Dasm=__asm
|
||||
+#define DefaultCCOptions $(CPPFLAGS) -Dasm=__asm
|
||||
#endif
|
||||
|
||||
#define GccGasOption -DGCCUSESGAS
|
||||
|
@ -129,7 +130,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
/* UseElfFormat defaults to YES if __ELF__ set */
|
||||
#ifndef UseElfFormat
|
||||
# ifdef __ELF__
|
||||
@@ -114,60 +168,234 @@
|
||||
@@ -114,60 +168,234 @@ XCOMM operating system: OSName (OSMajor
|
||||
#endif
|
||||
|
||||
/*
|
||||
|
@ -386,7 +387,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
#endif
|
||||
|
||||
#define StandardDefines -DCSRG_BASED
|
||||
@@ -177,7 +405,18 @@
|
||||
@@ -177,7 +405,18 @@ XCOMM operating system: OSName (OSMajor
|
||||
#define ExtraLibraries /**/
|
||||
#endif
|
||||
#ifndef UseGnuMalloc
|
||||
|
@ -405,7 +406,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
#endif
|
||||
#ifndef GnuMallocLibrary
|
||||
#define GnuMallocLibrary -lgnumalloc
|
||||
@@ -191,6 +430,13 @@
|
||||
@@ -191,6 +430,13 @@ XCOMM operating system: OSName (OSMajor
|
||||
#endif
|
||||
#endif
|
||||
|
||||
|
@ -419,7 +420,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
#define AdmDir /var/log
|
||||
|
||||
/*
|
||||
@@ -200,8 +446,17 @@
|
||||
@@ -200,8 +446,17 @@ XCOMM operating system: OSName (OSMajor
|
||||
#define StripInstalledPrograms YES
|
||||
#define CompressAllFonts YES
|
||||
#define GzipFontCompression YES
|
||||
|
@ -439,7 +440,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
|
||||
#ifdef InstallCmd
|
||||
# undef InstallCmd
|
||||
@@ -212,11 +467,23 @@
|
||||
@@ -212,11 +467,23 @@ XCOMM operating system: OSName (OSMajor
|
||||
# define ExtraFilesToClean *.core
|
||||
#endif
|
||||
|
||||
|
@ -465,7 +466,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
#define EqnCmd eqn -Tps
|
||||
#define TroffCmd groff -Tps
|
||||
|
||||
@@ -264,7 +531,10 @@
|
||||
@@ -264,7 +531,10 @@ install.man::
|
||||
-@if [ -f file.0 ]; \ @@\
|
||||
then \ @@\
|
||||
$(INSTALL) -c $(INSTMANFLAGS) file.0 $(DESTDIR)destdir/dest.0; \@@\
|
||||
|
@ -477,7 +478,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
|
||||
#define InstallGenManPageLong(file,destdir,dest,suffix) @@\
|
||||
InstallManPageLong(file,destdir,dest)
|
||||
@@ -281,7 +551,16 @@
|
||||
@@ -281,7 +551,16 @@ install.man:: @@\
|
||||
done
|
||||
|
||||
#define InstallMultipleMan(list,dest) @@\
|
||||
|
@ -495,7 +496,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
|
||||
#define InstallManPageAliases(file,destdir,aliases) @@\
|
||||
install.man:: @@\
|
||||
@@ -299,13 +578,10 @@
|
||||
@@ -299,13 +578,10 @@ install.man:: @@\
|
||||
/*
|
||||
* Shared libraries supported starting in 1.0 on a.out platforms,
|
||||
* and on all ELF platforms.
|
||||
|
@ -511,7 +512,7 @@ $NetBSD: patch-ab,v 1.3 2004/01/03 14:18:57 mrg Exp $
|
|||
# ifndef HasSharedLibraries
|
||||
# define HasSharedLibraries YES
|
||||
# endif
|
||||
@@ -327,51 +603,179 @@
|
||||
@@ -327,51 +603,179 @@ install.man:: @@\
|
||||
#include <bsdLib.rules>
|
||||
#endif /* HasSharedLibraries */
|
||||
|
||||
|
|
|
@ -1,22 +1,65 @@
|
|||
$NetBSD: patch-ae,v 1.3 2003/11/27 17:27:29 abs Exp $
|
||||
$NetBSD: patch-ae,v 1.4 2013/07/02 12:15:36 joerg Exp $
|
||||
|
||||
--- Xvnc/config/imake/imakemdep.h.orig 2003-02-19 16:39:54.000000000 +0000
|
||||
+++ Xvnc/config/imake/imakemdep.h
|
||||
@@ -253,9 +253,12 @@ in this Software without prior written a
|
||||
#ifdef _CRAY
|
||||
#define DEFAULT_CPP "/lib/pcpp"
|
||||
#endif
|
||||
@@ -222,56 +222,6 @@ in this Software without prior written a
|
||||
* If use cc -E but want a different compiler, define DEFAULT_CC.
|
||||
* If the cpp you need is not in /lib/cpp, define DEFAULT_CPP.
|
||||
*/
|
||||
-#ifdef hpux
|
||||
-#define USE_CC_E
|
||||
-#endif
|
||||
-#ifdef WIN32
|
||||
-#define USE_CC_E
|
||||
-#define DEFAULT_CC "cl"
|
||||
-#endif
|
||||
-#ifdef apollo
|
||||
-#define DEFAULT_CPP "/usr/lib/cpp"
|
||||
-#endif
|
||||
-#if defined(clipper) || defined(__clipper__)
|
||||
-#define DEFAULT_CPP "/usr/lib/cpp"
|
||||
-#endif
|
||||
-#if defined(_IBMR2) && !defined(DEFAULT_CPP)
|
||||
-#define DEFAULT_CPP "/usr/ccs/lib/cpp"
|
||||
-#endif
|
||||
-#if defined(sun) && (defined(SVR4) || defined(__svr4__) || defined(__SVR4) || defined(__sol__))
|
||||
-#define DEFAULT_CPP "/usr/ccs/lib/cpp"
|
||||
-#endif
|
||||
-#ifdef __bsdi__
|
||||
-#define DEFAULT_CPP "/usr/bin/cpp"
|
||||
-#endif
|
||||
-#ifdef __uxp__
|
||||
-#define DEFAULT_CPP "/usr/ccs/lib/cpp"
|
||||
-#endif
|
||||
-#ifdef __sxg__
|
||||
-#define DEFAULT_CPP "/usr/lib/cpp"
|
||||
-#endif
|
||||
-#ifdef _CRAY
|
||||
-#define DEFAULT_CPP "/lib/pcpp"
|
||||
-#endif
|
||||
-#if defined(__386BSD__) || defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
|
||||
+#if defined(__386BSD__)
|
||||
#define DEFAULT_CPP "/usr/libexec/cpp"
|
||||
#endif
|
||||
+#if defined(__NetBSD__) || defined(__OpenBSD__) || defined(__FreeBSD__)
|
||||
+#define USE_CC_E
|
||||
+#endif
|
||||
#if defined(__sgi) && defined(__ANSI_CPP__)
|
||||
#define USE_CC_E
|
||||
#endif
|
||||
@@ -290,6 +293,11 @@ in this Software without prior written a
|
||||
-#define DEFAULT_CPP "/usr/libexec/cpp"
|
||||
-#endif
|
||||
-#if defined(__sgi) && defined(__ANSI_CPP__)
|
||||
-#define USE_CC_E
|
||||
-#endif
|
||||
-#ifdef MACH
|
||||
-#define USE_CC_E
|
||||
-#endif
|
||||
-#ifdef __minix_vmd
|
||||
-#define DEFAULT_CPP "/usr/lib/cpp"
|
||||
-#endif
|
||||
-#if defined(__EMX__)
|
||||
-/* expects cpp in PATH */
|
||||
-#define DEFAULT_CPP "cpp"
|
||||
-#endif
|
||||
-#ifdef __MACH__
|
||||
-#define DEFAULT_CPP "/usr/bin/cpp"
|
||||
-#endif
|
||||
|
||||
/*
|
||||
* Step 5: cpp_argv
|
||||
@@ -290,6 +240,11 @@ in this Software without prior written a
|
||||
* that support multiple operating systems).
|
||||
*/
|
||||
|
||||
|
|
Loading…
Reference in a new issue