Fix build on SunOS and GCC>=4.6.
This commit is contained in:
parent
51c85ed596
commit
3956738c2f
4 changed files with 51 additions and 3 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile.common,v 1.5 2011/10/17 02:10:31 schnoebe Exp $
|
||||
# $NetBSD: Makefile.common,v 1.6 2012/06/11 12:40:31 fhajny Exp $
|
||||
#
|
||||
# used by devel/poco/Makefile
|
||||
# used by databases/poco-data/Makefile
|
||||
|
@ -37,5 +37,20 @@ CONFIGURE_ARGS+= --config=FreeBSD
|
|||
.if ${OPSYS} == "NetBSD"
|
||||
# NetBSD doesn't have fenv.h. We should add one.
|
||||
CONFIGURE_ARGS+= --no-fpenvironment
|
||||
CONFIGURE_ARGS+= --no-shaedmemory
|
||||
CONFIGURE_ARGS+= --no-sharedmemory
|
||||
.endif
|
||||
|
||||
.if ${OPSYS} == "SunOS"
|
||||
.include "../../mk/compiler.mk"
|
||||
. if ${PKGSRC_COMPILER} == "sunpro"
|
||||
CONFIGURE_ARGS+= --config=SunOS-SunStudio
|
||||
. elif ${PKGSRC_COMPILER} == "gcc"
|
||||
CONFIGURE_ARGS+= --config=SunOS-GCC
|
||||
. if !empty(MACHINE_PLATFORM:MSunOS-5.1[0-9]-*) && \
|
||||
!empty(CC_VERSION:Mgcc-4.[6-9].*)
|
||||
USE_LANGUAGES= c c++ c99
|
||||
. endif
|
||||
. else
|
||||
CONFIGURE_ARGS+= --config=SunOS
|
||||
. endif
|
||||
.endif
|
||||
|
|
|
@ -1,9 +1,10 @@
|
|||
$NetBSD: distinfo,v 1.5 2011/10/17 07:56:57 sbd Exp $
|
||||
$NetBSD: distinfo,v 1.6 2012/06/11 12:40:32 fhajny Exp $
|
||||
|
||||
SHA1 (poco-1.4.2p1-all.tar.gz) = ef1bc69812179b7856c88aa4b5c157747c0a0e48
|
||||
RMD160 (poco-1.4.2p1-all.tar.gz) = 8288c10e3e96de26f56296da0bbbebff58b8b424
|
||||
Size (poco-1.4.2p1-all.tar.gz) = 3922854 bytes
|
||||
SHA1 (patch-Foundation_include_Poco_Platform.h) = a7d81c20902af7e23ce8a10eb90fc1a98d7cc412
|
||||
SHA1 (patch-Foundation_src_SharedMemory.cpp) = fa73fa21d79934319b87ad980b0000a1efd873f0
|
||||
SHA1 (patch-aa) = be1c72c9c63b65e8d4211abab9dd036255ed6233
|
||||
SHA1 (patch-ab) = 0709ba35fe938f7efc94650dde4afd84c427de0f
|
||||
SHA1 (patch-ac) = e3ee4b43e458f1ab1227aa029a00fcebf5f53541
|
||||
|
@ -14,3 +15,4 @@ SHA1 (patch-ag) = 945a594376393462e1cc0f881532d2294adf5816
|
|||
SHA1 (patch-ah) = f8debbf7b416fc562f5af321be739e0d4481a130
|
||||
SHA1 (patch-ai) = 9feef00a05372578d957c68b53657e6468f65f6a
|
||||
SHA1 (patch-build_config_Linux) = ba79d12efeea09e0e24e0d95a457dcbce265cd75
|
||||
SHA1 (patch-build_config_SunOS-GCC) = d9d63bf2945498b9123bdbca623b1f1469b01838
|
||||
|
|
14
devel/poco/patches/patch-Foundation_src_SharedMemory.cpp
Normal file
14
devel/poco/patches/patch-Foundation_src_SharedMemory.cpp
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-Foundation_src_SharedMemory.cpp,v 1.1 2012/06/11 12:40:32 fhajny Exp $
|
||||
|
||||
_XOPEN_SOURCE=600 or higher is needed on SunOS and GCC>=4.6.
|
||||
--- Foundation/src/SharedMemory.cpp.orig 2011-10-20 06:59:15.850534958 +0000
|
||||
+++ Foundation/src/SharedMemory.cpp
|
||||
@@ -36,7 +36,7 @@
|
||||
|
||||
#if defined(__sun)
|
||||
#undef _XOPEN_SOURCE
|
||||
-#define _XOPEN_SOURCE 500
|
||||
+#define _XOPEN_SOURCE 600
|
||||
#endif
|
||||
|
||||
|
17
devel/poco/patches/patch-build_config_SunOS-GCC
Normal file
17
devel/poco/patches/patch-build_config_SunOS-GCC
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-build_config_SunOS-GCC,v 1.1 2012/06/11 12:40:32 fhajny Exp $
|
||||
|
||||
_XOPEN_SOURCE=600 or higher is needed on SunOS and GCC>=4.6.
|
||||
--- build/config/SunOS-GCC.orig 2010-12-16 05:43:24.000000000 +0000
|
||||
+++ build/config/SunOS-GCC
|
||||
@@ -63,9 +63,9 @@ RELEASEOPT_LINK = -O2
|
||||
#
|
||||
# System Specific Flags
|
||||
#
|
||||
-SYSFLAGS = -D_XOPEN_SOURCE=500 -D_REENTRANT -D_THREAD_SAFE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
|
||||
+SYSFLAGS = -D_XOPEN_SOURCE=600 -D_REENTRANT -D_THREAD_SAFE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE
|
||||
|
||||
#
|
||||
# System Specific Libraries
|
||||
#
|
||||
-SYSLIBS = -lpthread -ldl -lrt
|
||||
+SYSLIBS = -lpthread -ldl -lrt -lxnet -lsocket -lnsl -lresolv -ldl
|
Loading…
Reference in a new issue