Fix apr-config and apu-config scripts when run from

${BUILDLINK_DIR}/bin.  This may help fix ap2-perl, but won't help
ap2-php4.
This commit is contained in:
epg 2003-05-30 10:14:21 +00:00
parent c3f6f25755
commit 3959af46f0
3 changed files with 93 additions and 1 deletions

View file

@ -1,7 +1,9 @@
$NetBSD: distinfo,v 1.2 2003/05/29 01:02:28 itojun Exp $
$NetBSD: distinfo,v 1.3 2003/05/30 10:14:21 epg Exp $
SHA1 (httpd-2.0.46.tar.gz) = c739c4c296054697e264f7d1ac19f9f1e2d47553
Size (httpd-2.0.46.tar.gz) = 6031023 bytes
SHA1 (patch-aa) = 17e79d6c54c855c4210f68e5facca1002d2512fa
SHA1 (patch-ab) = bb9a9f0fbf5d48748f2a0826509a19b915d2bc72
SHA1 (patch-an) = 64006f0f1b5c3f20df6f47624e56aac0d99ae056
SHA1 (patch-ao) = 25d44b0028772535da908895444d2bfe56f44120
SHA1 (patch-ap) = 41c36538dcd6d84f3e26ee02e9f1953e715d2c80

View file

@ -0,0 +1,49 @@
$NetBSD: patch-aa,v 1.1 2003/05/30 10:14:22 epg Exp $
--- apr/apr-config.in.orig Mon Apr 21 09:21:59 2003
+++ apr/apr-config.in
@@ -143,12 +143,17 @@ if test "$tmpbindir" = "$thisdir"; then
location=installed
elif test "$APR_SOURCE_DIR" = "$thisdir"; then
location=source
+elif echo "$thisdir" | grep buildlink > /dev/null 2>&1; then
+ location=buildlink
+ BUILDLINK_DIR="`dirname $thisdir`"
else
location=build
fi
if test "$location" = "installed"; then
LA_FILE="$libdir/lib${APR_LIBNAME}.la"
+elif test "$location" = "buildlink"; then
+ LA_FILE="$BUILDLINK_DIR/lib/lib${APR_LIBNAME}.la"
else
LA_FILE="$thisdir/lib${APR_LIBNAME}.la"
fi
@@ -180,6 +185,8 @@ while test $# -gt 0; do
flags="$includedir"
elif test "$location" = "source"; then
flags="$APR_SOURCE_DIR/include"
+ elif test "$location" = "buildlink"; then
+ flags="$BUILDLINK_DIR/include/apr-${APR_MAJOR_VERSION}"
else
# this is for VPATH builds
flags="$thisdir/include $APR_SOURCE_DIR/include"
@@ -212,6 +219,8 @@ while test $# -gt 0; do
flags="$flags -I$includedir $EXTRA_INCLUDES"
elif test "$location" = "source"; then
flags="$flags -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
+ elif test "$location" = "buildlink"; then
+ flags="$flags -I$BUILDLINK_DIR/include/apr-${APR_MAJOR_VERSION} $EXTRA_INCLUDES"
else
# this is for VPATH builds
flags="$flags -I$thisdir/include -I$APR_SOURCE_DIR/include $EXTRA_INCLUDES"
@@ -222,7 +231,7 @@ while test $# -gt 0; do
exit 0
;;
--installbuilddir)
- if test "$location" = "installed"; then
+ if test "$location" = "installed" || test "$location" = "buildlink"; then
echo "${installbuilddir}"
elif test "$location" = "source"; then
echo "$APR_SOURCE_DIR/build"

View file

@ -0,0 +1,41 @@
$NetBSD: patch-ab,v 1.1 2003/05/30 10:14:22 epg Exp $
--- apr-util/apu-config.in.orig Sat Mar 22 22:32:57 2003
+++ apr-util/apu-config.in
@@ -129,6 +129,9 @@ if test "$tmpbindir" = "$thisdir"; then
location=installed
elif test "$APU_SOURCE_DIR" = "$thisdir"; then
location=source
+elif echo "$thisdir" | grep buildlink > /dev/null 2>&1; then
+ location=buildlink
+ BUILDLINK_DIR="`dirname $thisdir`"
else
location=build
fi
@@ -139,6 +142,8 @@ if test "$location" = "installed"; then
LIBS=`echo "$LIBS" | sed -e "s $APU_BUILD_DIR/xml/expat $prefix g" -e "s $prefix/lib/libexpat.la -lexpat g"`
LDFLAGS=`echo "$LDFLAGS" | sed -e "s $APU_BUILD_DIR/xml/expat $prefix g"`
INCLUDES=`echo "$INCLUDES" | sed -e "s $APU_BUILD_DIR/xml/expat $prefix g" -e "s -I$prefix/lib g"`
+elif test "$location" = "buildlink"; then
+ LA_FILE="$BUILDLINK_DIR/lib/lib${APRUTIL_LIBNAME}.la"
else
LA_FILE="$thisdir/lib${APRUTIL_LIBNAME}.la"
fi
@@ -173,6 +178,8 @@ while test $# -gt 0; do
flags="$includedir"
elif test "$location" = "source"; then
flags="$APU_SOURCE_DIR/include"
+ elif test "$location" = "buildlink"; then
+ flags="$BUILDLINK_DIR/include/apr-${APRUTIL_MAJOR_VERSION}"
else
# this is for VPATH builds
flags="$thisdir/include $APU_SOURCE_DIR/include"
@@ -185,6 +192,8 @@ while test $# -gt 0; do
flags="$flags -I$includedir $INCLUDES"
elif test "$location" = "source"; then
flags="$flags -I$APU_SOURCE_DIR/include $INCLUDES"
+ elif test "$location" = "buildlink"; then
+ flags="$flags -I$BUILDLINK_DIR/include/apr-${APRUTIL_MAJOR_VERSION} $INCLUDES"
else
# this is for VPATH builds
flags="$flags -I$thisdir/include -I$APU_SOURCE_DIR/include $INCLUDES"