Initial import of gtk-vnc-0.3.8nb1 from pkgsrc-wip:
gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines allowing it to be completely asynchronous while remaining single threaded. It provides a core C library, and bindings for Python (PyGTK).
This commit is contained in:
parent
6c8004e1e2
commit
39608f3c9f
9 changed files with 140 additions and 0 deletions
4
net/gtk-vnc/DESCR
Normal file
4
net/gtk-vnc/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
gtk-vnc is a VNC viewer widget for GTK. It is built using coroutines
|
||||
allowing it to be completely asynchronous while remaining single
|
||||
threaded. It provides a core C library, and bindings for Python
|
||||
(PyGTK).
|
36
net/gtk-vnc/Makefile
Normal file
36
net/gtk-vnc/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2009/04/06 10:17:32 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gtk-vnc-0.3.8
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gtk-vnc/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://gtk-vnc.sourceforge.net/
|
||||
COMMENT= VNC viewer widget for GTK
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
PKGCONFIG_OVERRIDE+= gtk-vnc-1.0.pc.in
|
||||
PY_PATCHPLIST= yes
|
||||
|
||||
CONFIGURE_ARGS+= --with-coroutine=gthread
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
#VIEW_REQUIRED=0.6.0
|
||||
#libview
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/gtkglext/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.gnutls+= gnutls>=1.4.0
|
||||
.include "../../security/gnutls/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.gtk2+= gtk2+>=2.10.0
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
7
net/gtk-vnc/PLIST
Normal file
7
net/gtk-vnc/PLIST
Normal file
|
@ -0,0 +1,7 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/04/06 10:17:32 wiz Exp $
|
||||
include/gtk-vnc-1.0/vncdisplay.h
|
||||
${PLIST.firefox}lib/firefox/plugins/gtk-vnc-plugin.so
|
||||
lib/libgtk-vnc-1.0.la
|
||||
lib/pkgconfig/gtk-vnc-1.0.pc
|
||||
${PLIST.python}${PYSITELIB}/gtkvnc.la
|
||||
@dirrm include/gtk-vnc-1.0
|
18
net/gtk-vnc/buildlink3.mk
Normal file
18
net/gtk-vnc/buildlink3.mk
Normal file
|
@ -0,0 +1,18 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2009/04/06 10:17:32 wiz Exp $
|
||||
|
||||
BUILDLINK_TREE+= gtk-vnc
|
||||
|
||||
.if !defined(GTK_VNC_BUILDLINK3_MK)
|
||||
GTK_VNC_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.gtk-vnc+= gtk-vnc>=0.3.7
|
||||
BUILDLINK_PKGSRCDIR.gtk-vnc?= ../../wip/gtk-vnc
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../graphics/gtkglext/buildlink3.mk"
|
||||
.include "../../security/gnutls/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.endif # GTK_VNC_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -gtk-vnc
|
8
net/gtk-vnc/distinfo
Normal file
8
net/gtk-vnc/distinfo
Normal file
|
@ -0,0 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/04/06 10:17:32 wiz Exp $
|
||||
|
||||
SHA1 (gtk-vnc-0.3.8.tar.gz) = 58b729504df8ce8a043bfbf6351d751e8c8b8a09
|
||||
RMD160 (gtk-vnc-0.3.8.tar.gz) = d0fe46cf6fba4e68165e91a54f9373eff3d77932
|
||||
Size (gtk-vnc-0.3.8.tar.gz) = 610526 bytes
|
||||
SHA1 (patch-aa) = e59cd2080d9d88d4d689f10ed15738aa3309dcf3
|
||||
SHA1 (patch-ab) = e4e34a1f664de13a1c27c3c53eeed5b62d9f988c
|
||||
SHA1 (patch-ac) = fe2e85bcbe8df464ab50cdb17afc80ba74ab999b
|
24
net/gtk-vnc/options.mk
Normal file
24
net/gtk-vnc/options.mk
Normal file
|
@ -0,0 +1,24 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2009/04/06 10:17:32 wiz Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.gtk-vnc
|
||||
PKG_SUPPORTED_OPTIONS= python firefox
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
PLIST_VARS= python
|
||||
.if !empty(PKG_OPTIONS:Mpython)
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../x11/py-gtk2/buildlink3.mk"
|
||||
USE_TOOLS+= gmake
|
||||
PLIST.python= yes
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-python=no
|
||||
.endif
|
||||
|
||||
PLIST_VARS+= firefox
|
||||
.if !empty(PKG_OPTIONS:Mfirefox)
|
||||
.include "../../devel/nspr/buildlink3.mk"
|
||||
.include "../../www/firefox/buildlink3.mk"
|
||||
CONFIGURE_ARGS+= --enable-plugin=yes
|
||||
PLIST.firefox= yes
|
||||
.endif
|
15
net/gtk-vnc/patches/patch-aa
Normal file
15
net/gtk-vnc/patches/patch-aa
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/04/06 10:17:32 wiz Exp $
|
||||
|
||||
--- src/gvnc.c.orig 2008-12-07 20:35:14.000000000 +0100
|
||||
+++ src/gvnc.c
|
||||
@@ -59,6 +59,10 @@
|
||||
#endif
|
||||
|
||||
|
||||
+#ifndef AI_ADDRCONFIG
|
||||
+#define AI_ADDRCONFIG 0
|
||||
+#endif
|
||||
+
|
||||
struct wait_queue
|
||||
{
|
||||
gboolean waiting;
|
15
net/gtk-vnc/patches/patch-ab
Normal file
15
net/gtk-vnc/patches/patch-ab
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2009/04/06 10:17:32 wiz Exp $
|
||||
|
||||
--- src/coroutine_ucontext.c.orig 2008-09-05 12:32:16.000000000 +0000
|
||||
+++ src/coroutine_ucontext.c
|
||||
@@ -14,6 +14,10 @@
|
||||
#include <stdlib.h>
|
||||
#include "coroutine.h"
|
||||
|
||||
+#ifndef MAP_ANONYMOUS
|
||||
+#define MAP_ANONYMOUS MAP_ANON
|
||||
+#endif
|
||||
+
|
||||
int coroutine_release(struct coroutine *co)
|
||||
{
|
||||
return cc_release(&co->cc);
|
13
net/gtk-vnc/patches/patch-ac
Normal file
13
net/gtk-vnc/patches/patch-ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ac,v 1.1.1.1 2009/04/06 10:17:32 wiz Exp $
|
||||
|
||||
--- plugin/Makefile.in.orig 2008-09-05 12:32:30.000000000 +0000
|
||||
+++ plugin/Makefile.in
|
||||
@@ -230,7 +230,7 @@ target_os = @target_os@
|
||||
target_vendor = @target_vendor@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-@ENABLE_PLUGIN_TRUE@plugindir = $(libdir)/mozilla/plugins
|
||||
+@ENABLE_PLUGIN_TRUE@plugindir = $(libdir)/firefox/plugins
|
||||
@ENABLE_PLUGIN_TRUE@plugin_LTLIBRARIES = gtk-vnc-plugin.la
|
||||
@ENABLE_PLUGIN_TRUE@gtk_vnc_plugin_la_SOURCES = \
|
||||
@ENABLE_PLUGIN_TRUE@ gtk-vnc-plugin.c gtk-vnc-plugin.h npshell.c npunix.c
|
Loading…
Reference in a new issue