Update to 0.60.2.
New in 0.60.2: * Added the `munch-list' command to the aspell utility. The `munch' program in the `myspell/' directory will disappear in Aspell 0.61. The `munchlist' script will also likely disappear or be replaced when Aspell 0.61 is released since it doesn't work correctly anyway. * Several important bug fixes some of which rendered some non-English languages unusable. * Other minor changes. New in 0.60.1.1: * Fix bug involving checking of capitalized word when affix compression is used. * Compile fixes. * Added an option to disable using the "wide" curses version in case it causes compile problems. * Minor manual updates * Avoided including some unnecessary files in the distribution. New in 0.60.1: * Lots of compile fixes for various platforms. * Miscellaneous bug fixes. * Added Nroff filter thanks to Sergey Poznyakoff. * The default filter mode when in pipe mode is now nroff for compatibility with Ispell. * Added Texinfo filter. * Added a section detailing the differences between Ispell and Aspell. * Updated the section on thread safety. * Other miscellaneous manual changes such as updating the To Do and Authors section. Changes since 0.50.5: * Added support for Affix Compression. Affix compression stores the root word and then a list of prefixes and suffixes that the word can take, and thus saves a lot of space. The codebase comes from MySpell found in OpenOffice. It uses the same affix file that OpenOffice (and Mozilla) use. Affix compression will even work with soundslike lookup to a limited extent. * Added support for accepting all input and printing all output in UTF-8 or some other encoding different from the one Aspell uses. This includes support for Unicode normalization. Aspell can now support any language with no more than 210 distinct characters, including different capitalizations and accents, _even if_ there is not an existing 8-bit encoding that supports the language. * Added support for loadable filters and customizable filter modes thanks to Christoph Hintermüller. * Enhanced SGML filter to also support skipping sgml tags such as "script" blocks thanks to Tom Snyder. * Added gettext support thanks to Sergey Poznyakoff * Reworked the compiled dictionary format. Compiled dictionaries now take up less space (less than 80% for the English language) and creating them is significantly faster (over 4 times for the English language). * Reworked suggestion code. It is significantly faster when dealing with short words (up to 10 times). Also added support for MySpell Replacement Tables and n-gram lookup. In addition, added basic support for compound words. * Manual has has been converted to texinfo format thanks to the work of Chris Martin. * Reworked the build system so that a single Makefile is used for most of the code. * All data, by default, is now included in `LIBDIR/aspell-0.60'. Also added a built time option to increment the major version number of the shared library. This should allow both Aspell version 0.50 and 0.60 to coexist. The major version number is _not_ incremented by default as Aspell 0.60 is binary compatible with Aspell 0.50. NOTE: this is not true for pkgsrc. * The code to handle dictionaries has been rewritten. Because of this support for the dictionary option `strip-accents' has been removed. In addition the `ignore-accents' option is currently unimplemented. * Lots of other minor changes due to massive overhaul of the source code.
This commit is contained in:
parent
306dd04a0e
commit
398352ff8a
11 changed files with 102 additions and 254 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.27 2004/12/19 00:21:59 grant Exp $
|
||||
# $NetBSD: Makefile,v 1.28 2004/12/24 02:55:53 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= aspell-0.50.5
|
||||
PKGREVISION= 3
|
||||
DISTNAME= aspell-0.60.2
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=aspell/}
|
||||
|
||||
|
@ -18,13 +17,23 @@ USE_GNU_TOOLS+= make
|
|||
USE_LIBTOOL= yes
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
NOT_FOR_COMPILER+= xlc
|
||||
INFO_FILES= aspell-dev.info aspell.info
|
||||
|
||||
CONFIGURE_ARGS+= --enable-doc-dir=${PREFIX}/share/doc/aspell
|
||||
CONFIGURE_ARGS+= --enable-curses=ncurses
|
||||
CONFIGURE_ARGS+= --enable-pkgdatadir=${PREFIX}/share/aspell
|
||||
CONFIGURE_ARGS+= --enable-dict-dir=${PREFIX}/lib/aspell
|
||||
|
||||
REPLACE_PERL= scripts/aspell-import
|
||||
|
||||
SUBST_CLASSES+= bash
|
||||
SUBST_STAGE.bash= post-build
|
||||
SUBST_MESSAGE.bash= bash is not really necessary, use sh.
|
||||
SUBST_FILES.bash= scripts/precat scripts/preunzip scripts/prezip
|
||||
SUBST_SED.bash= "s!/bin/bash!/bin/sh!"
|
||||
|
||||
NOT_FOR_COMPILER= xlc
|
||||
|
||||
LIBS.SunOS+= -lm
|
||||
|
||||
.include "../../mk/compiler.mk"
|
||||
|
@ -33,13 +42,7 @@ LIBS.SunOS+= -lm
|
|||
LIBS.SunOS+= -lCrun -lCstd
|
||||
.endif
|
||||
|
||||
pre-patch:
|
||||
.if !empty(PKGSRC_COMPILER:Msunpro)
|
||||
@cd ${WRKSRC} && ${PATCH} -p1 -s < suncc/aspell-0.50.4.1-suncc.diff
|
||||
.endif
|
||||
|
||||
# Create directory for dictionaries.
|
||||
#
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/lib/aspell
|
||||
|
||||
|
|
|
@ -1,110 +1,90 @@
|
|||
@comment $NetBSD: PLIST,v 1.6 2004/09/22 08:09:54 jlam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.7 2004/12/24 02:55:53 wiz Exp $
|
||||
bin/aspell
|
||||
bin/aspell-import
|
||||
bin/precat
|
||||
bin/preunzip
|
||||
bin/prezip
|
||||
bin/prezip-bin
|
||||
bin/pspell-config
|
||||
bin/run-with-aspell
|
||||
bin/word-list-compress
|
||||
include/aspell.h
|
||||
include/pspell/pspell.h
|
||||
lib/aspell/ccpp.amf
|
||||
lib/aspell/comment.amf
|
||||
lib/aspell/email.amf
|
||||
lib/aspell/html.amf
|
||||
lib/aspell/none.amf
|
||||
lib/aspell/nroff.amf
|
||||
lib/aspell/perl.amf
|
||||
lib/aspell/sgml.amf
|
||||
lib/aspell/tex.amf
|
||||
lib/aspell/texinfo.amf
|
||||
lib/aspell/url.amf
|
||||
lib/libaspell.la
|
||||
lib/libpspell.la
|
||||
share/aspell/ASCII.dat
|
||||
share/aspell/cp1250.dat
|
||||
share/aspell/cp1251.dat
|
||||
share/aspell/cp1252.dat
|
||||
share/aspell/cp1253.dat
|
||||
share/aspell/cp1254.dat
|
||||
share/aspell/cp1255.dat
|
||||
share/aspell/cp1256.dat
|
||||
share/aspell/cp1257.dat
|
||||
share/aspell/cp1258.dat
|
||||
man/man1/aspell-import.1
|
||||
man/man1/aspell.1
|
||||
man/man1/pspell-config.1
|
||||
man/man1/run-with-aspell.1
|
||||
man/man1/word-list-compress.1
|
||||
share/aspell/cp1250.cmap
|
||||
share/aspell/cp1250.cset
|
||||
share/aspell/cp1251.cmap
|
||||
share/aspell/cp1251.cset
|
||||
share/aspell/cp1252.cmap
|
||||
share/aspell/cp1252.cset
|
||||
share/aspell/cp1253.cmap
|
||||
share/aspell/cp1253.cset
|
||||
share/aspell/cp1254.cmap
|
||||
share/aspell/cp1254.cset
|
||||
share/aspell/cp1255.cmap
|
||||
share/aspell/cp1255.cset
|
||||
share/aspell/cp1256.cmap
|
||||
share/aspell/cp1256.cset
|
||||
share/aspell/cp1257.cmap
|
||||
share/aspell/cp1257.cset
|
||||
share/aspell/cp1258.cmap
|
||||
share/aspell/cp1258.cset
|
||||
share/aspell/dvorak.kbd
|
||||
share/aspell/iso8859-1.dat
|
||||
share/aspell/iso8859-10.dat
|
||||
share/aspell/iso8859-13.dat
|
||||
share/aspell/iso8859-14.dat
|
||||
share/aspell/iso8859-15.dat
|
||||
share/aspell/iso8859-2.dat
|
||||
share/aspell/iso8859-3.dat
|
||||
share/aspell/iso8859-4.dat
|
||||
share/aspell/iso8859-5.dat
|
||||
share/aspell/iso8859-6.dat
|
||||
share/aspell/iso8859-7.dat
|
||||
share/aspell/iso8859-8.dat
|
||||
share/aspell/iso8859-9.dat
|
||||
share/aspell/iso-8859-1.cmap
|
||||
share/aspell/iso-8859-1.cset
|
||||
share/aspell/iso-8859-10.cmap
|
||||
share/aspell/iso-8859-10.cset
|
||||
share/aspell/iso-8859-11.cmap
|
||||
share/aspell/iso-8859-11.cset
|
||||
share/aspell/iso-8859-13.cmap
|
||||
share/aspell/iso-8859-13.cset
|
||||
share/aspell/iso-8859-14.cmap
|
||||
share/aspell/iso-8859-14.cset
|
||||
share/aspell/iso-8859-15.cmap
|
||||
share/aspell/iso-8859-15.cset
|
||||
share/aspell/iso-8859-16.cmap
|
||||
share/aspell/iso-8859-16.cset
|
||||
share/aspell/iso-8859-2.cmap
|
||||
share/aspell/iso-8859-2.cset
|
||||
share/aspell/iso-8859-3.cmap
|
||||
share/aspell/iso-8859-3.cset
|
||||
share/aspell/iso-8859-4.cmap
|
||||
share/aspell/iso-8859-4.cset
|
||||
share/aspell/iso-8859-5.cmap
|
||||
share/aspell/iso-8859-5.cset
|
||||
share/aspell/iso-8859-6.cmap
|
||||
share/aspell/iso-8859-6.cset
|
||||
share/aspell/iso-8859-7.cmap
|
||||
share/aspell/iso-8859-7.cset
|
||||
share/aspell/iso-8859-8.cmap
|
||||
share/aspell/iso-8859-8.cset
|
||||
share/aspell/iso-8859-9.cmap
|
||||
share/aspell/iso-8859-9.cset
|
||||
share/aspell/ispell
|
||||
share/aspell/koi8-f.dat
|
||||
share/aspell/koi8-r.dat
|
||||
share/aspell/koi8-u.dat
|
||||
share/aspell/koi8-r.cmap
|
||||
share/aspell/koi8-r.cset
|
||||
share/aspell/koi8-u.cmap
|
||||
share/aspell/koi8-u.cset
|
||||
share/aspell/spell
|
||||
share/aspell/split.kbd
|
||||
share/aspell/standard.kbd
|
||||
share/aspell/viscii.dat
|
||||
share/doc/aspell/dev-html/devel.css
|
||||
share/doc/aspell/dev-html/devel.html
|
||||
share/doc/aspell/dev-html/index.html
|
||||
share/doc/aspell/dev-html/nx_grp_g.png
|
||||
share/doc/aspell/dev-html/prev_g.png
|
||||
share/doc/aspell/dev-html/up_g.png
|
||||
share/doc/aspell/dev-text/devel.txt
|
||||
share/doc/aspell/dev-text/index.txt
|
||||
share/doc/aspell/devel.aux
|
||||
share/doc/aspell/devel.dvi
|
||||
share/doc/aspell/devel.tex
|
||||
share/doc/aspell/devel2.lyx
|
||||
share/doc/aspell/man-html/1_Introduction.html
|
||||
share/doc/aspell/man-html/2_Getting.html
|
||||
share/doc/aspell/man-html/3_Basic.html
|
||||
share/doc/aspell/man-html/4_Customizing.html
|
||||
share/doc/aspell/man-html/5_Working.html
|
||||
share/doc/aspell/man-html/6_Writing.html
|
||||
share/doc/aspell/man-html/7_Adding.html
|
||||
share/doc/aspell/man-html/8_How.html
|
||||
share/doc/aspell/man-html/A_Changelog.html
|
||||
share/doc/aspell/man-html/About_this.html
|
||||
share/doc/aspell/man-html/B_Do.html
|
||||
share/doc/aspell/man-html/C_Credits.html
|
||||
share/doc/aspell/man-html/Contents.html
|
||||
share/doc/aspell/man-html/D_Glossary.html
|
||||
share/doc/aspell/man-html/E_Copyright.html
|
||||
share/doc/aspell/man-html/contents.png
|
||||
share/doc/aspell/man-html/crossref.png
|
||||
share/doc/aspell/man-html/index.html
|
||||
share/doc/aspell/man-html/manual.css
|
||||
share/doc/aspell/man-html/manual.html
|
||||
share/doc/aspell/man-html/next.png
|
||||
share/doc/aspell/man-html/next_g.png
|
||||
share/doc/aspell/man-html/prev.png
|
||||
share/doc/aspell/man-html/prev_g.png
|
||||
share/doc/aspell/man-html/up.png
|
||||
share/doc/aspell/man-html/up_g.png
|
||||
share/doc/aspell/man-text/1_Introduction.txt
|
||||
share/doc/aspell/man-text/2_Getting.txt
|
||||
share/doc/aspell/man-text/3_Basic.txt
|
||||
share/doc/aspell/man-text/4_Customizing.txt
|
||||
share/doc/aspell/man-text/5_Working.txt
|
||||
share/doc/aspell/man-text/6_Writing.txt
|
||||
share/doc/aspell/man-text/7_Adding.txt
|
||||
share/doc/aspell/man-text/8_How.txt
|
||||
share/doc/aspell/man-text/A_Changelog.txt
|
||||
share/doc/aspell/man-text/About_this.txt
|
||||
share/doc/aspell/man-text/B_Do.txt
|
||||
share/doc/aspell/man-text/C_Credits.txt
|
||||
share/doc/aspell/man-text/Contents.txt
|
||||
share/doc/aspell/man-text/D_Glossary.txt
|
||||
share/doc/aspell/man-text/E_Copyright.txt
|
||||
share/doc/aspell/man-text/index.txt
|
||||
share/doc/aspell/man-text/manual.txt
|
||||
share/doc/aspell/manual.aux
|
||||
share/doc/aspell/manual.dvi
|
||||
share/doc/aspell/manual.tex
|
||||
share/doc/aspell/manual2.lyx
|
||||
@dirrm share/doc/aspell/man-text
|
||||
@dirrm share/doc/aspell/man-html
|
||||
@dirrm share/doc/aspell/dev-text
|
||||
@dirrm share/doc/aspell/dev-html
|
||||
@dirrm share/doc/aspell
|
||||
@dirrm share/aspell
|
||||
@exec ${MKDIR} %D/lib/aspell
|
||||
@dirrm lib/aspell
|
||||
@dirrm include/pspell
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.5 2004/10/07 16:36:47 tv Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.6 2004/12/24 02:55:53 wiz Exp $
|
||||
|
||||
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
|
||||
ASPELL_BUILDLINK3_MK:= ${ASPELL_BUILDLINK3_MK}+
|
||||
|
@ -11,8 +11,7 @@ BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Naspell}
|
|||
BUILDLINK_PACKAGES+= aspell
|
||||
|
||||
.if !empty(ASPELL_BUILDLINK3_MK:M+)
|
||||
BUILDLINK_DEPENDS.aspell+= aspell>=0.50.3nb2
|
||||
BUILDLINK_RECOMMENDED.aspell+= aspell>=0.50.5nb3
|
||||
BUILDLINK_DEPENDS.aspell+= aspell>=0.60.2
|
||||
BUILDLINK_PKGSRCDIR.aspell?= ../../textproc/aspell
|
||||
.endif # ASPELL_BUILDLINK3_MK
|
||||
|
||||
|
|
|
@ -1,11 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.10 2004/07/24 19:05:37 salo Exp $
|
||||
$NetBSD: distinfo,v 1.11 2004/12/24 02:55:53 wiz Exp $
|
||||
|
||||
SHA1 (aspell-0.50.5.tar.gz) = 0b17272e1773ef133775d5e6be9fbccc8689ff58
|
||||
Size (aspell-0.50.5.tar.gz) = 1016586 bytes
|
||||
SHA1 (patch-aa) = d13759da18b0c2f166839c31a2ff0b7b54d8de5f
|
||||
SHA1 (patch-ab) = 9b3e6dfbdf27b9bc0a10384be057685fba734aa7
|
||||
SHA1 (patch-ac) = 2a83265b7738bc9ed24de163cfee32ee13bbd231
|
||||
SHA1 (patch-ad) = 61af6b5b4c0294e018097afd9cae54bfe3253eb7
|
||||
SHA1 (patch-ae) = 77b1574a3e3bad6fdbf987fc5a315f0319174e17
|
||||
SHA1 (patch-af) = bc220d18c599a61a0f4a7dd95ccad6bad9b03b56
|
||||
SHA1 (patch-ag) = e2ddbe1449e55136bd8347a5faef441549a497eb
|
||||
SHA1 (aspell-0.60.2.tar.gz) = 2429ceeddc5ad68e11aaca404d1eaa2e4997bef1
|
||||
Size (aspell-0.60.2.tar.gz) = 1577570 bytes
|
||||
SHA1 (patch-ac) = 659fac33603b1b56c4c8149c7d8e94811e22f4b6
|
||||
SHA1 (patch-ag) = 04b34f2b780a632a5045120ae408ceea591a66de
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.5 2004/07/24 19:05:37 salo Exp $
|
||||
|
||||
--- modules/speller/default/speller_impl.cpp.orig Sat Jan 31 02:06:07 2004
|
||||
+++ modules/speller/default/speller_impl.cpp Sat Jul 24 20:07:19 2004
|
||||
@@ -239,12 +239,27 @@
|
||||
}
|
||||
words[0].set(s.word, *i == m ? m : '\0');
|
||||
words[1].clear();
|
||||
+#ifndef __SUNPRO_CC
|
||||
if ((!check_if_valid || !c.mid_required()) // if check then !s.mid_required()
|
||||
&& check(i, word_end, run_together_limit - 1, end_pos, words + 1))
|
||||
return true;
|
||||
+#else
|
||||
+ if (!check_if_valid || !c.mid_required()) {
|
||||
+ bool bool_op;
|
||||
+ bool_op = check(i, word_end, run_together_limit - 1, end_pos, words + 1);
|
||||
+ if (bool_op)
|
||||
+ return true;
|
||||
+ }
|
||||
+#endif
|
||||
if ((check_if_valid ? *i == m : strchr(run_together_middle_, *i) != 0)
|
||||
&& word_end - (i + 1) >= static_cast<int>(run_together_min_)) {
|
||||
+#ifndef __SUNPRO_CC
|
||||
if (check(i+1, word_end, run_together_limit - 1, end_pos, words + 1))
|
||||
+#else
|
||||
+ bool bool_op;
|
||||
+ bool_op = check(i+1, word_end, run_together_limit - 1, end_pos, words + 1);
|
||||
+ if (bool_op)
|
||||
+#endif
|
||||
return true;
|
||||
else // already checked word (i+1) so no need to check it again
|
||||
++i;
|
|
@ -1,19 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.3 2003/09/30 17:26:58 mycroft Exp $
|
||||
|
||||
--- modules/speller/default/split.cpp.orig 2001-11-30 03:55:48.000000000 +0000
|
||||
+++ modules/speller/default/split.cpp 2003-09-30 17:23:23.000000000 +0000
|
||||
@@ -1,4 +1,4 @@
|
||||
-#include <strstream>
|
||||
+#include <sstream>
|
||||
#include "split.hpp"
|
||||
|
||||
using namespace std;
|
||||
@@ -8,7 +8,7 @@
|
||||
|
||||
vector<String> split(const String & str) {
|
||||
vector<String> data;
|
||||
- istrstream s(str.c_str());
|
||||
+ istringstream s(str.c_str());
|
||||
String item;
|
||||
while (s >> item) {
|
||||
data.push_back(item);
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ac,v 1.3 2003/10/02 01:07:52 itojun Exp $
|
||||
$NetBSD: patch-ac,v 1.4 2004/12/24 02:55:53 wiz Exp $
|
||||
|
||||
--- prog/check_funs.cpp- 2003-10-02 09:59:27.000000000 +0900
|
||||
+++ prog/check_funs.cpp 2003-10-02 09:59:39.000000000 +0900
|
||||
@@ -205,7 +205,8 @@
|
||||
--- prog/check_funs.cpp.orig 2004-08-08 07:04:57.000000000 +0200
|
||||
+++ prog/check_funs.cpp
|
||||
@@ -210,7 +210,8 @@ static void layout_screen() {
|
||||
choice_w = 0;
|
||||
nonl();
|
||||
noecho();
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.3 2004/07/24 19:05:37 salo Exp $
|
||||
|
||||
--- modules/speller/default/readonly_ws.cpp.orig Sat Jan 31 02:06:06 2004
|
||||
+++ modules/speller/default/readonly_ws.cpp Sat Jul 24 17:15:14 2004
|
||||
@@ -194,7 +194,7 @@
|
||||
typedef const char * Key;
|
||||
static const bool is_multi = false;
|
||||
Key key(Value v) const {return block_begin + v;}
|
||||
- hash<const char *> hash;
|
||||
+ acommon::hash<const char *> hash;
|
||||
bool equal(Key rhs, Key lhs) const {return strcmp(rhs,lhs) == 0;}
|
||||
bool is_nonexistent(Value v) const {return v == u32int_max;}
|
||||
void make_nonexistent(const Value & v) const {abort();}
|
|
@ -1,47 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.3 2004/07/24 19:05:37 salo Exp $
|
||||
|
||||
--- modules/speller/default/suggest.cpp.orig Sat Jul 27 03:27:10 2002
|
||||
+++ modules/speller/default/suggest.cpp Sat Jul 24 20:20:51 2004
|
||||
@@ -311,7 +311,15 @@
|
||||
new_word[i+1] = new_word[i];
|
||||
new_word[i] = '\0';
|
||||
|
||||
+#ifndef __SUNPRO_CC
|
||||
if (speller->check(new_word) && speller->check(new_word + i + 1)) {
|
||||
+#else
|
||||
+ bool bool_op1;
|
||||
+ bool bool_op2;
|
||||
+ bool_op1 = speller->check(new_word);
|
||||
+ bool_op2 = speller->check(new_word + i + 1);
|
||||
+ if (bool_op1 && bool_op2) {
|
||||
+#endif
|
||||
new_word[i] = ' ';
|
||||
add_nearmiss(new_word, parms.edit_distance_weights.del2,
|
||||
dont_count, do_need_alloc);
|
||||
@@ -634,11 +642,26 @@
|
||||
string::size_type pos;
|
||||
while((word = i->repl_list->next()) != 0) {
|
||||
dup_pair = duplicates_check.insert(fix_case(word));
|
||||
+#ifndef __SUNPRO_CC
|
||||
if (dup_pair.second &&
|
||||
((pos = dup_pair.first->find(' '), pos == String::npos)
|
||||
? (bool)speller->check(*dup_pair.first)
|
||||
: (speller->check((String)dup_pair.first->substr(0,pos))
|
||||
&& speller->check((String)dup_pair.first->substr(pos+1))) ))
|
||||
+#else
|
||||
+ bool bool_op1 = false;
|
||||
+ bool bool_op2;
|
||||
+ bool bool_op3;
|
||||
+ if (pos = dup_pair.first->find(' '), pos == String::npos)
|
||||
+ bool_op1 = (bool)speller->check(*dup_pair.first);
|
||||
+ else {
|
||||
+ bool_op2 = speller->check((String)dup_pair.first->substr(0,pos));
|
||||
+ bool_op3 = speller->check((String)dup_pair.first->substr(pos+1));
|
||||
+ if (bool_op2 && bool_op3)
|
||||
+ bool_op1 = true;
|
||||
+ }
|
||||
+ if (dup_pair.second && bool_op1)
|
||||
+#endif
|
||||
near_misses_final->push_back(*dup_pair.first);
|
||||
}
|
||||
} else {
|
|
@ -1,18 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1 2004/07/24 19:05:37 salo Exp $
|
||||
|
||||
--- prog/aspell.cpp.orig Sat Jul 24 19:56:05 2004
|
||||
+++ prog/aspell.cpp Sat Jul 24 20:24:15 2004
|
||||
@@ -619,7 +619,13 @@
|
||||
<< ":";
|
||||
AspellStringEnumeration * els
|
||||
= aspell_word_list_elements(suggestions);
|
||||
+#ifndef __SUNPRO_CC
|
||||
if (options->retrieve_bool("reverse")) {
|
||||
+#else
|
||||
+ bool bool_op;
|
||||
+ bool_op = options->retrieve_bool("reverse");
|
||||
+ if (bool_op) {
|
||||
+#endif
|
||||
Vector<String> sugs;
|
||||
sugs.reserve(aspell_word_list_size(suggestions));
|
||||
while ( ( w = aspell_string_enumeration_next(els)) != 0)
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ag,v 1.1 2004/07/24 19:05:37 salo Exp $
|
||||
$NetBSD: patch-ag,v 1.2 2004/12/24 02:55:53 wiz Exp $
|
||||
|
||||
--- examples/Makefile.in.orig Wed Feb 11 02:05:53 2004
|
||||
+++ examples/Makefile.in Sat Jul 24 17:39:23 2004
|
||||
@@ -81,7 +81,7 @@
|
||||
--- examples/Makefile.in.orig 2004-08-23 03:22:40.000000000 +0200
|
||||
+++ examples/Makefile.in
|
||||
@@ -86,7 +86,7 @@ AUTOCONF = @AUTOCONF@
|
||||
AUTOHEADER = @AUTOHEADER@
|
||||
AUTOMAKE = @AUTOMAKE@
|
||||
AWK = @AWK@
|
||||
|
@ -10,4 +10,4 @@ $NetBSD: patch-ag,v 1.1 2004/07/24 19:05:37 salo Exp $
|
|||
+CC = @CXX@
|
||||
CCDEPMODE = @CCDEPMODE@
|
||||
CFLAGS = @CFLAGS@
|
||||
CPP = @CPP@
|
||||
COMPILE_IN_FILTERS_FALSE = @COMPILE_IN_FILTERS_FALSE@
|
||||
|
|
Loading…
Reference in a new issue