fix type for LP64 systems. (unsigned -> size_t)

This commit is contained in:
dmcmahill 2001-05-12 21:54:13 +00:00
parent 0fb6bd22cf
commit 39b6b9772b
2 changed files with 22 additions and 1 deletions

View file

@ -1,4 +1,5 @@
$NetBSD: distinfo,v 1.2 2001/04/19 11:07:48 skrll Exp $
$NetBSD: distinfo,v 1.3 2001/05/12 21:54:13 dmcmahill Exp $
SHA1 (x3270-3213.tgz) = ce92607384f72761bd85bc7f5cd37d59f52a4452
Size (x3270-3213.tgz) = 500073 bytes
SHA1 (patch-aa) = fa17fb709185bb319462c32048addbecdd39b8dd

View file

@ -0,0 +1,20 @@
$NetBSD: patch-aa,v 1.5 2001/05/12 21:54:13 dmcmahill Exp $
fix types (needed on LP64)
--- pr3287/pr3287.c.orig Thu Sep 14 10:41:12 2000
+++ pr3287/pr3287.c Sat May 12 17:49:49 2001
@@ -97,5 +97,5 @@
/* Memory allocation. */
void *
-Malloc(unsigned len)
+Malloc(size_t len)
{
void *p = malloc(len);
@@ -115,5 +115,5 @@
void *
-Realloc(void *p, unsigned len)
+Realloc(void *p, size_t len)
{
void *pn;