Changes 5.6.36:

* Windows builds now use the default runtime libraries (builds use the /MD flag).
* CMake support was added for compiling with Developer Studio 12.6.
MySQL failed to compile if -DENABLE_DEBUG_SYNC=OFF AND -DWITH_DEBUG=ON were both given. The ENABLE_DEBUG_SYNC option has been removed and enabling WITH_DEBUG enables Debug Sync.
* Changes in RPM package structure require a larger set of packages to be removed to install MySQL Server cleanly.
* To avoid potential race conditions, Debian packages now use the GNU install utility rather than a combination of mkdir, touch, and chown.
* CMake-generated packaging for Debian/Ubuntu packages was refactored for improved maintainability. The change includes updated logic for correctly replacing native distribution packaging in Debian and Ubuntu.
* Reminder: MySQL 5.6 requires the Microsoft Visual C++ 2010 Redistributable Package to run on Windows platforms. Users should make sure the package has been installed on the system before starting the server. The package is available at the Microsoft Download Center.
* The linked OpenSSL library for the MySQL Commercial Server has been updated to version 1.0.2k. For a description of issues fixed in this version, see http://www.openssl.org/news/vulnerabilities.html.
* The mysql_options() C API function now supports a MYSQL_OPT_SSL_MODE option.
This commit is contained in:
adam 2017-04-11 20:21:02 +00:00
parent 5cac68417e
commit 39d699701a
4 changed files with 29 additions and 13 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile.common,v 1.38 2016/12/12 19:21:33 adam Exp $
# $NetBSD: Makefile.common,v 1.39 2017/04/11 20:21:02 adam Exp $
#
# used by databases/mysql56-client/Makefile
# used by databases/mysql56-server/Makefile
DISTNAME= mysql-5.6.35
DISTNAME= mysql-5.6.36
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_MYSQL:=MySQL-5.6/}

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.41 2016/12/16 17:55:48 jperkin Exp $
$NetBSD: distinfo,v 1.42 2017/04/11 20:21:02 adam Exp $
SHA1 (mysql-5.6.35.tar.gz) = a971f01d711addd87c860fb534d51139a73d5319
RMD160 (mysql-5.6.35.tar.gz) = 3a54baba27b940b5c18787a6d213e1cc6530ea28
SHA512 (mysql-5.6.35.tar.gz) = 106c4b05c52cd2bb5378376e4a453aeb55eda0adce527862c435068597c3e60f44e3c64476011befefd688e6fdf30f2245e28320d57d9fccbb2415d87498e7f2
Size (mysql-5.6.35.tar.gz) = 32167628 bytes
SHA1 (mysql-5.6.36.tar.gz) = 6a94c75880c249cb2ec832bfcd3786944b0e7df5
RMD160 (mysql-5.6.36.tar.gz) = 9e02b6607e7d855db6afee2f80505d29dfcd454b
SHA512 (mysql-5.6.36.tar.gz) = b3e3bcb1d1e913994f274f4c6dc72c77f1f52b132389e784c675d1720b5913788ce035f045b99ef3754d1b257db55e8300b5c7622ec79c33afafec5968801c18
Size (mysql-5.6.36.tar.gz) = 32192348 bytes
SHA1 (sphinx-2.2.11-release.tar.gz) = 34e83f43de0e69e258bf749ea00348c60a51632a
RMD160 (sphinx-2.2.11-release.tar.gz) = 5804b4cce64bc03fa20bac26c7391cd661cecc77
SHA512 (sphinx-2.2.11-release.tar.gz) = cf1a262a5b0fbf0bd2827ec6ec629edeaf709ce855a6e7b509b65342baaeb26c02717ca63f1578d32c83d21e2fd6d1e92dceb34660e6351b93cd96fd4e623689
@ -14,7 +14,7 @@ SHA1 (patch-client_mysqladmin.cc) = e1650ef3695675bcc01375bacdebcb7318218b93
SHA1 (patch-client_sql_string.h) = f26aff4ce4cf6dfef44c85ef95120331ca8fef52
SHA1 (patch-cmake_dtrace.cmake) = d953fdf976f3a7e7f0c2c16a9a2d2615f2777396
SHA1 (patch-cmake_libutils.cmake) = c3e5ab66d2bef43dc2308369e27550553e0f5356
SHA1 (patch-cmake_os_SunOS.cmake) = 1ef310e6395653be3219044fc2ea58977a1b0ce3
SHA1 (patch-cmake_os_SunOS.cmake) = 60ba9f81c28bbb78295b8a12fe6cd3b176c03f91
SHA1 (patch-cmake_plugin.cmake) = 03e7a7debd61e870bd76d5c5b253a620662b3595
SHA1 (patch-cmake_readline.cmake) = 6bec6ca87b45c739d0614493477a18bb7c56d981
SHA1 (patch-cmake_ssl.cmake) = a5a25b00010c6586e5a3e099975ddabe369d4247

View file

@ -1,10 +1,10 @@
$NetBSD: patch-cmake_os_SunOS.cmake,v 1.1 2016/12/16 17:55:48 jperkin Exp $
$NetBSD: patch-cmake_os_SunOS.cmake,v 1.2 2017/04/11 20:21:02 adam Exp $
Backport section from MySQL 5.7 to fix SunOS/gcc.
--- cmake/os/SunOS.cmake.orig 2016-11-28 13:36:22.000000000 +0000
--- cmake/os/SunOS.cmake.orig 2017-03-18 06:43:12.000000000 +0000
+++ cmake/os/SunOS.cmake
@@ -19,7 +19,13 @@ INCLUDE(CheckCSourceCompiles)
@@ -19,7 +19,13 @@ INCLUDE(CheckCSourceCompiles)
# We require SunStudio 12u2 (CC 5.11)
IF(NOT FORCE_UNSUPPORTED_COMPILER)
@ -17,5 +17,5 @@ Backport section from MySQL 5.7 to fix SunOS/gcc.
+ ENDIF()
+ ELSEIF(CMAKE_C_COMPILER_ID MATCHES "SunPro")
# CC -V yields
# CC: Studio 12.6 Sun C++ 5.15 SunOS_sparc Beta 2016/12/19
# CC: Studio 12.5 Sun C++ 5.14 SunOS_sparc Dodona 2016/04/04
# CC: Sun C++ 5.13 SunOS_sparc Beta 2014/03/11

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.28 2016/12/12 19:21:33 adam Exp $
@comment $NetBSD: PLIST,v 1.29 2017/04/11 20:21:02 adam Exp $
bin/innochecksum
bin/my_print_defaults
bin/myisam_ftdump
@ -3514,8 +3514,10 @@ share/mysql/test/suite/innodb/r/checksum.result
share/mysql/test/suite/innodb/r/create-index.result
share/mysql/test/suite/innodb/r/create_isl_with_direct.result
share/mysql/test/suite/innodb/r/dropdb.result
share/mysql/test/suite/innodb/r/end_range_check.result
share/mysql/test/suite/innodb/r/flush-hang.result
share/mysql/test/suite/innodb/r/foreign_key.result
share/mysql/test/suite/innodb/r/ibuf_not_empty.result
share/mysql/test/suite/innodb/r/import.result
share/mysql/test/suite/innodb/r/import_update_stats.result
share/mysql/test/suite/innodb/r/index_tree_operation.result
@ -3659,6 +3661,7 @@ share/mysql/test/suite/innodb/r/innodb_gis.result
share/mysql/test/suite/innodb/r/innodb_i_s_innodb_locks.result
share/mysql/test/suite/innodb/r/innodb_i_s_innodb_trx.result
share/mysql/test/suite/innodb/r/innodb_information_schema_buffer.result
share/mysql/test/suite/innodb/r/innodb_io_pf.result
share/mysql/test/suite/innodb/r/innodb_lock_wait_timeout_1.result
share/mysql/test/suite/innodb/r/innodb_misc1.result
share/mysql/test/suite/innodb/r/innodb_multi_update.result
@ -3699,6 +3702,7 @@ share/mysql/test/suite/innodb/r/sp_temp_table.result
share/mysql/test/suite/innodb/r/strict_checksum.result
share/mysql/test/suite/innodb/r/strict_mode.result
share/mysql/test/suite/innodb/r/tmpdir.result
share/mysql/test/suite/innodb/r/undo_space_id.result
share/mysql/test/suite/innodb/r/xa_recovery.result
share/mysql/test/suite/innodb/t/add_foreign_key.test
share/mysql/test/suite/innodb/t/alter_rename_existing.test
@ -3713,8 +3717,11 @@ share/mysql/test/suite/innodb/t/create_isl_with_direct-master.opt
share/mysql/test/suite/innodb/t/create_isl_with_direct.test
share/mysql/test/suite/innodb/t/disabled.def
share/mysql/test/suite/innodb/t/dropdb.test
share/mysql/test/suite/innodb/t/end_range_check.test
share/mysql/test/suite/innodb/t/flush-hang.test
share/mysql/test/suite/innodb/t/foreign_key.test
share/mysql/test/suite/innodb/t/ibuf_not_empty-master.opt
share/mysql/test/suite/innodb/t/ibuf_not_empty.test
share/mysql/test/suite/innodb/t/import.test
share/mysql/test/suite/innodb/t/import_update_stats.test
share/mysql/test/suite/innodb/t/index_tree_operation.test
@ -3887,6 +3894,7 @@ share/mysql/test/suite/innodb/t/innodb_gis.test
share/mysql/test/suite/innodb/t/innodb_i_s_innodb_locks.test
share/mysql/test/suite/innodb/t/innodb_i_s_innodb_trx.test
share/mysql/test/suite/innodb/t/innodb_information_schema_buffer.test
share/mysql/test/suite/innodb/t/innodb_io_pf.test
share/mysql/test/suite/innodb/t/innodb_lock_wait_timeout_1-master.opt
share/mysql/test/suite/innodb/t/innodb_lock_wait_timeout_1.test
share/mysql/test/suite/innodb/t/innodb_misc1-master.opt
@ -3937,6 +3945,7 @@ share/mysql/test/suite/innodb/t/sp_temp_table.test
share/mysql/test/suite/innodb/t/strict_checksum.test
share/mysql/test/suite/innodb/t/strict_mode.test
share/mysql/test/suite/innodb/t/tmpdir.test
share/mysql/test/suite/innodb/t/undo_space_id.test
share/mysql/test/suite/innodb/t/xa_recovery.test
share/mysql/test/suite/innodb_fts/r/fts_compatibility.result
share/mysql/test/suite/innodb_fts/r/fts_compatibility_win.result
@ -5759,6 +5768,7 @@ share/mysql/test/suite/perfschema/r/stage_mdl_function.result
share/mysql/test/suite/perfschema/r/stage_mdl_global.result
share/mysql/test/suite/perfschema/r/stage_mdl_procedure.result
share/mysql/test/suite/perfschema/r/stage_mdl_table.result
share/mysql/test/suite/perfschema/r/start_server_1_digest.result
share/mysql/test/suite/perfschema/r/start_server_disable_idle.result
share/mysql/test/suite/perfschema/r/start_server_disable_stages.result
share/mysql/test/suite/perfschema/r/start_server_disable_statements.result
@ -6136,6 +6146,8 @@ share/mysql/test/suite/perfschema/t/stage_mdl_global-master.opt
share/mysql/test/suite/perfschema/t/stage_mdl_global.test
share/mysql/test/suite/perfschema/t/stage_mdl_procedure.test
share/mysql/test/suite/perfschema/t/stage_mdl_table.test
share/mysql/test/suite/perfschema/t/start_server_1_digest-master.opt
share/mysql/test/suite/perfschema/t/start_server_1_digest.test
share/mysql/test/suite/perfschema/t/start_server_disable_idle-master.opt
share/mysql/test/suite/perfschema/t/start_server_disable_idle.test
share/mysql/test/suite/perfschema/t/start_server_disable_stages-master.opt
@ -6319,6 +6331,7 @@ share/mysql/test/suite/rpl/r/rpl_LD_INFILE.result
share/mysql/test/suite/rpl/r/rpl_alter.result
share/mysql/test/suite/rpl/r/rpl_alter_db.result
share/mysql/test/suite/rpl/r/rpl_alter_repository.result
share/mysql/test/suite/rpl/r/rpl_alter_user.result
share/mysql/test/suite/rpl/r/rpl_apply_binlog_with_anonymous_gtid.result
share/mysql/test/suite/rpl/r/rpl_apply_binlog_with_anonymous_gtid_when_gtid_mode_on.result
share/mysql/test/suite/rpl/r/rpl_apply_binlog_with_gtid_when_gtid_mode_off.result
@ -6669,6 +6682,7 @@ share/mysql/test/suite/rpl/r/rpl_row_utf32.result
share/mysql/test/suite/rpl/r/rpl_row_view01.result
share/mysql/test/suite/rpl/r/rpl_row_wide_table.result
share/mysql/test/suite/rpl/r/rpl_savepoint.result
share/mysql/test/suite/rpl/r/rpl_sbm_fake_rotate_event.result
share/mysql/test/suite/rpl/r/rpl_sbm_previous_gtid_event.result
share/mysql/test/suite/rpl/r/rpl_seconds_behind_master.result
share/mysql/test/suite/rpl/r/rpl_semi_sync.result
@ -6796,6 +6810,7 @@ share/mysql/test/suite/rpl/t/rpl_LD_INFILE.test
share/mysql/test/suite/rpl/t/rpl_alter.test
share/mysql/test/suite/rpl/t/rpl_alter_db.test
share/mysql/test/suite/rpl/t/rpl_alter_repository.test
share/mysql/test/suite/rpl/t/rpl_alter_user.test
share/mysql/test/suite/rpl/t/rpl_apply_binlog_with_anonymous_gtid.test
share/mysql/test/suite/rpl/t/rpl_apply_binlog_with_anonymous_gtid_when_gtid_mode_on.test
share/mysql/test/suite/rpl/t/rpl_apply_binlog_with_gtid_when_gtid_mode_off.test
@ -7328,6 +7343,7 @@ share/mysql/test/suite/rpl/t/rpl_row_utf32.test
share/mysql/test/suite/rpl/t/rpl_row_view01.test
share/mysql/test/suite/rpl/t/rpl_row_wide_table.test
share/mysql/test/suite/rpl/t/rpl_savepoint.test
share/mysql/test/suite/rpl/t/rpl_sbm_fake_rotate_event.test
share/mysql/test/suite/rpl/t/rpl_sbm_previous_gtid_event-slave.opt
share/mysql/test/suite/rpl/t/rpl_sbm_previous_gtid_event.test
share/mysql/test/suite/rpl/t/rpl_seconds_behind_master.test