update tunesbrowser to 0.3.0

update the url to www.craz.net

patch-aa is no more necessary (SA_NOMASK is no more used)

Main changelog entries:
- password support. You will be prompted for a password if a server requires a password
- playlist support.
- Several bug and portablity fixes

approved by cube@
This commit is contained in:
tonio 2005-08-05 12:58:49 +00:00
parent 6bfe681a97
commit 39fdfb43f1
6 changed files with 26 additions and 70 deletions

View file

@ -1,13 +1,13 @@
# $NetBSD: Makefile,v 1.6 2005/07/21 16:29:44 wiz Exp $
# $NetBSD: Makefile,v 1.7 2005/08/05 12:58:49 tonio Exp $
#
DISTNAME= tunesbrowser-0.2.0
DISTNAME= tunesbrowser-0.3.0
CATEGORIES= audio
MASTER_SITES= http://crazney.net/programs/itunes/files/
MASTER_SITES= http://craz.net/programs/itunes/files/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://crazney.net/programs/itunes/libopendaap.html
HOMEPAGE= http://craz.net/programs/itunes/libopendaap.html
COMMENT= Front-end for DAAP client
GNU_CONFIGURE= yes
@ -15,15 +15,12 @@ USE_LIBTOOL= yes
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
CONFIGURE_ARGS+= --datadir=${PREFIX}/share/tunesbrowser
DEPENDS+= gst-plugins-esound>=0.8.1:../../audio/gst-plugins-esound
DEPENDS+= gst-plugins-mad>=0.8.1:../../audio/gst-plugins-mad
BUILDLINK_DEPENDS.libopendaap+= libopendaap>=0.3.0
BUILDLINK_DEPENDS.libopendaap+= libopendaap>=0.4.0
.include "../../audio/gst-plugins-mad/buildlink3.mk"
# XXX Enable this dependency after the package is created (couldn't be done at
# XXX the moment because we were preparing the pkgsrc-2005Q1 branch).
# XXX When that happens, do not depend gst-plugins-mad, and adjust patch-ab to
# XXX not disable spider use.
#.include "../../audio/gst-plugins-spider/buildlink3.mk"
.include "../../multimedia/gst-plugins/buildlink3.mk"
.include "../../audio/libopendaap/buildlink3.mk"
.include "../../devel/libglade2/buildlink3.mk"
.include "../../devel/pkg-config/buildlink3.mk"

View file

@ -1,9 +1,11 @@
@comment $NetBSD: PLIST,v 1.3 2005/03/20 15:21:04 jmmv Exp $
@comment $NetBSD: PLIST,v 1.4 2005/08/05 12:58:49 tonio Exp $
bin/tunesbrowser
man/man1/tunesbrowser.1
share/tunesbrowser/comp.blue.png
share/tunesbrowser/comp.red.png
share/tunesbrowser/sound1.png
share/tunesbrowser/sound2.png
share/tunesbrowser/soundfile.png
share/tunesbrowser/tips.txt
share/tunesbrowser/tunesbrowser.glade
@dirrm share/tunesbrowser

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.5 2005/03/20 15:21:04 jmmv Exp $
$NetBSD: distinfo,v 1.6 2005/08/05 12:58:49 tonio Exp $
SHA1 (tunesbrowser-0.2.0.tar.bz2) = 79195c25d6f6bfdeebe9b1e8eb34b5ca0e185764
RMD160 (tunesbrowser-0.2.0.tar.bz2) = 365aee4d25f4a77efb751b268874bcf0ec64db70
Size (tunesbrowser-0.2.0.tar.bz2) = 208472 bytes
SHA1 (patch-aa) = be573330eee471791d68baba1cd9a048f6a1c6b8
SHA1 (patch-ab) = 3120984ffdf4f7e6fcae9b1f7e6d0f84cfed1c86
SHA1 (patch-ad) = 4929d3c46ece66b5546edcfcc119cb0730c25396
SHA1 (tunesbrowser-0.3.0.tar.bz2) = d1b543347af523d9da375019dc8a17c08f1cb27c
RMD160 (tunesbrowser-0.3.0.tar.bz2) = a3be956f34ec7e0817a637a7d3d9dbd4df64bc60
Size (tunesbrowser-0.3.0.tar.bz2) = 222593 bytes
SHA1 (patch-ab) = 1b5719009ebfb659e5adb62e4c2cdf6b351d2c11
SHA1 (patch-ad) = d8db8a91f0208aa211356389a5fcd5adb6d8f900

View file

@ -1,33 +0,0 @@
$NetBSD: patch-aa,v 1.3 2005/03/20 15:21:04 jmmv Exp $
--- main.c.orig 2005-01-04 03:58:29.000000000 +0100
+++ main.c
@@ -38,7 +38,7 @@ static void sighandler_sigsegv(__UNUSED_
{
fprintf(stderr, "Oops! TunesBrowser has crashed. Sorry about that!\n");
fprintf(stderr, "This probably won't be of any use unless you feel like debugging,\n");
- fprintf(stderr, "but the crash occured because of %p being bad.\n", siginfo->si_ptr);
+ fprintf(stderr, "but the crash occured because of %p being bad.\n", siginfo->si_addr);
#if 0
fprintf(stderr, "\n\nRaised SIGSTOP. You can now attach a debugger.\n");
fprintf(stderr, "Attach to PID %i\n", getpid());
@@ -66,11 +66,19 @@ static void install_sighandlers()
int ret;
sa.sa_handler = (void*)sighandler_sigsegv;
+#ifdef SA_NOMASK
sa.sa_flags = SA_NOMASK | SA_SIGINFO;
+#else
+ sa.sa_flags = SA_NODEFER | SA_SIGINFO;
+#endif
ret = sigaction(SIGSEGV, &sa, NULL);
sa.sa_handler = (void*)sighandler_sigpipe;
+#ifdef SA_NOMASK
sa.sa_flags = SA_NOMASK | SA_SIGINFO;
+#else
+ sa.sa_flags = SA_NODEFER | SA_SIGINFO;
+#endif
ret = sigaction(SIGPIPE, &sa, NULL);
}

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.4 2005/03/20 15:21:04 jmmv Exp $
$NetBSD: patch-ab,v 1.5 2005/08/05 12:58:49 tonio Exp $
--- audioplayer.c.orig 2004-12-20 09:03:55.000000000 +0100
+++ audioplayer.c
@@ -148,11 +148,11 @@ static void cb_eos(__UNUSED__ GstElement
--- audioplayer.c.orig 2005-08-04 11:07:43.000000000 +0200
+++ audioplayer.c 2005-08-04 11:10:48.000000000 +0200
@@ -167,11 +167,11 @@
static void cb_error (__UNUSED__ GstElement *gstelement,
__UNUSED__ GstElement *arg1,
@ -17,7 +17,7 @@ $NetBSD: patch-ab,v 1.4 2005/03/20 15:21:04 jmmv Exp $
}
static void cb_iterate(GstBin *bin, __UNUSED__ gpointer data)
@@ -176,6 +176,7 @@ static void audioplayer_destroy_pipeline
@@ -197,6 +197,7 @@
/* remove the source and decoder from the pipeline */
gst_bin_remove_many (GST_BIN (pipeline_thread), srcelem, decoder, NULL);
@ -25,12 +25,3 @@ $NetBSD: patch-ab,v 1.4 2005/03/20 15:21:04 jmmv Exp $
gst_object_unref(GST_OBJECT(pipeline_thread));
}
@@ -203,7 +204,7 @@ static void audioplayer_setup_pipeline(e
}
if (!srcelem) goto gst_element_err;
-#if (GST_VERSION_MINOR < 8)
+#if (1)
/* older versions of gstreamer seem to crash when I use the
* spider plugin
*/

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ad,v 1.2 2005/03/20 11:09:47 jmmv Exp $
$NetBSD: patch-ad,v 1.3 2005/08/05 12:58:49 tonio Exp $
--- misc_ui.c.orig 2005-01-02 02:53:52.000000000 +0100
+++ misc_ui.c
@@ -202,9 +202,9 @@ static void cb_update_songpos(int second
--- misc_ui.c.orig 2005-08-04 11:06:21.000000000 +0200
+++ misc_ui.c 2005-08-04 11:06:42.000000000 +0200
@@ -233,9 +233,9 @@
if (seconds >= 0)
{