BIND 9.6.0

Full NSEC3 support
Automatic zone re-signing
Default PID file location
New tool: dnssec-dsfromkey
Randomize server selection on queries

http://oldwww.isc.org/sw/bind/view/?release=9.6.0
https://www.isc.org/software/bind/new-features/9.6
This commit is contained in:
adrianp 2009-01-04 00:21:36 +00:00
parent 46270377fd
commit 3a0e31e052
16 changed files with 1072 additions and 0 deletions

13
net/bind96/DESCR Normal file
View file

@ -0,0 +1,13 @@
BIND, the Berkeley Internet Name Daemon, version 9 is a major rewrite
of nearly all aspects of the underlying BIND architecture. Some
of the important features of BIND-9 are:
- DNS Security
- IP version 6
- DNS Protocol Enhancements
- Views
- Multiprocessor Support
- Improved Portability Architecture
- Full NSEC3 support
- Automatic zone re-signing
- New update-policy methods tcp-self and 6to4-self

10
net/bind96/MESSAGE Normal file
View file

@ -0,0 +1,10 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
Please consider running BIND under the pseudo user account "${BIND_USER}"
in a chroot environment for security reasons.
To achieve this, set the variable "named_chrootdir" in /etc/rc.conf to
the directory with the chroot environment e.g. "${BIND_DIR}".
===========================================================================

65
net/bind96/Makefile Normal file
View file

@ -0,0 +1,65 @@
# $NetBSD: Makefile,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
DISTNAME= bind-${BIND_VERSION}
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/bind9/${BIND_VERSION}/
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.isc.org/sw/bind/
COMMENT= Version 9 of the Berkeley Internet Name Daemon, implementation of DNS
CONFLICTS+= bind<9.6.0
PKG_DESTDIR_SUPPORT= user-destdir
BIND_VERSION= 9.6.0
.include "../../mk/bsd.prefs.mk"
BUILD_DEFS+= BIND_DIR VARBASE
.include "options.mk"
USE_TOOLS+= pax perl
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
#CONFIG_SHELL= sh -x
CONFIGURE_ARGS+= --with-libtool
CONFIGURE_ARGS+= --sysconfdir=/etc
CONFIGURE_ARGS+= --localstatedir=${VARBASE:Q}
CONFIGURE_ARGS+= --disable-openssl-version-check
CONFIGURE_ARGS+= --with-openssl=${SSLBASE:Q}
PKG_GROUPS_VARS+= BIND_GROUP
PKG_USERS_VARS+= BIND_USER
PKG_GROUPS= ${BIND_GROUP}
PKG_USERS= ${BIND_USER}:${BIND_GROUP}
PKG_GECOS.${BIND_USER}= Named pseudo-user
PKG_HOME.${BIND_USER}= ${BIND_DIR}
PTHREAD_OPTS+= native
PTHREAD_AUTO_VARS= yes
FILES_SUBST+= BIND_GROUP=${BIND_GROUP:Q} \
BIND_USER=${BIND_USER:Q} PAX=${PAX:Q}
MESSAGE_SUBST+= BIND_DIR=${BIND_DIR} BIND_USER=${BIND_USER}
DOCDIR= ${DESTDIR}${PREFIX}/share/doc/bind9
RCD_SCRIPTS= lwresd named9
INSTALLATION_DIRS= ${DOCDIR} share/doc/bind9/arm share/doc/bind9/draft \
share/doc/bind9/rfc
post-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/NSEC3-NOTES ${DOCDIR}
${INSTALL_DATA} ${WRKSRC}/doc/arm/*.html ${DOCDIR}/arm
${INSTALL_DATA} ${WRKSRC}/doc/arm/*.html ${DOCDIR}/arm
${INSTALL_DATA} ${WRKSRC}/doc/draft/draft-*.txt ${DOCDIR}/draft
${INSTALL_DATA} ${WRKSRC}/doc/rfc/rfc*.txt ${DOCDIR}/rfc
.include "../../security/openssl/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

505
net/bind96/PLIST Normal file
View file

@ -0,0 +1,505 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
bin/dig
bin/host
bin/isc-config.sh
bin/nslookup
bin/nsupdate
include/bind9/check.h
include/bind9/getaddresses.h
include/bind9/version.h
include/dns/acl.h
include/dns/adb.h
include/dns/byaddr.h
include/dns/cache.h
include/dns/callbacks.h
include/dns/cert.h
include/dns/compress.h
include/dns/db.h
include/dns/dbiterator.h
include/dns/dbtable.h
include/dns/diff.h
include/dns/dispatch.h
include/dns/dlz.h
include/dns/dnssec.h
include/dns/ds.h
include/dns/enumclass.h
include/dns/enumtype.h
include/dns/events.h
include/dns/fixedname.h
include/dns/iptable.h
include/dns/journal.h
include/dns/keyflags.h
include/dns/keytable.h
include/dns/keyvalues.h
include/dns/lib.h
include/dns/log.h
include/dns/master.h
include/dns/masterdump.h
include/dns/message.h
include/dns/name.h
include/dns/ncache.h
include/dns/nsec.h
include/dns/peer.h
include/dns/portlist.h
include/dns/rbt.h
include/dns/rcode.h
include/dns/rdata.h
include/dns/rdataclass.h
include/dns/rdatalist.h
include/dns/rdataset.h
include/dns/rdatasetiter.h
include/dns/rdataslab.h
include/dns/rdatastruct.h
include/dns/rdatatype.h
include/dns/request.h
include/dns/resolver.h
include/dns/result.h
include/dns/rootns.h
include/dns/sdb.h
include/dns/sdlz.h
include/dns/secalg.h
include/dns/secproto.h
include/dns/soa.h
include/dns/ssu.h
include/dns/tcpmsg.h
include/dns/time.h
include/dns/tkey.h
include/dns/tsig.h
include/dns/ttl.h
include/dns/types.h
include/dns/validator.h
include/dns/version.h
include/dns/view.h
include/dns/xfrin.h
include/dns/zone.h
include/dns/zonekey.h
include/dns/zt.h
include/dst/dst.h
include/dst/gssapi.h
include/dst/lib.h
include/dst/result.h
include/isc/app.h
include/isc/assertions.h
include/isc/atomic.h
include/isc/base64.h
include/isc/bitstring.h
include/isc/boolean.h
include/isc/buffer.h
include/isc/bufferlist.h
include/isc/commandline.h
include/isc/condition.h
include/isc/dir.h
include/isc/entropy.h
include/isc/error.h
include/isc/event.h
include/isc/eventclass.h
include/isc/file.h
include/isc/formatcheck.h
include/isc/fsaccess.h
include/isc/hash.h
include/isc/heap.h
include/isc/hex.h
include/isc/hmacmd5.h
include/isc/httpd.h
include/isc/int.h
include/isc/interfaceiter.h
include/isc/lang.h
include/isc/lex.h
include/isc/lfsr.h
include/isc/lib.h
include/isc/list.h
include/isc/log.h
include/isc/magic.h
include/isc/md5.h
include/isc/mem.h
include/isc/msgcat.h
include/isc/msgs.h
include/isc/mutex.h
include/isc/mutexblock.h
include/isc/net.h
include/isc/netaddr.h
include/isc/netdb.h
include/isc/offset.h
include/isc/once.h
include/isc/ondestroy.h
include/isc/os.h
include/isc/parseint.h
include/isc/platform.h
include/isc/print.h
include/isc/quota.h
include/isc/radix.h
include/isc/random.h
include/isc/ratelimiter.h
include/isc/refcount.h
include/isc/region.h
include/isc/resource.h
include/isc/result.h
include/isc/resultclass.h
include/isc/rwlock.h
include/isc/serial.h
include/isc/sha1.h
include/isc/sha2.h
include/isc/sockaddr.h
include/isc/socket.h
include/isc/stdio.h
include/isc/stdlib.h
include/isc/stdtime.h
include/isc/string.h
include/isc/symtab.h
include/isc/syslog.h
include/isc/task.h
include/isc/taskpool.h
include/isc/thread.h
include/isc/time.h
include/isc/timer.h
include/isc/types.h
include/isc/util.h
include/isc/version.h
include/isc/xml.h
include/isccc/alist.h
include/isccc/base64.h
include/isccc/cc.h
include/isccc/ccmsg.h
include/isccc/events.h
include/isccc/lib.h
include/isccc/result.h
include/isccc/sexpr.h
include/isccc/symtab.h
include/isccc/symtype.h
include/isccc/types.h
include/isccc/util.h
include/isccc/version.h
include/isccfg/aclconf.h
include/isccfg/cfg.h
include/isccfg/grammar.h
include/isccfg/log.h
include/isccfg/namedconf.h
include/isccfg/version.h
include/lwres/context.h
include/lwres/int.h
include/lwres/ipv6.h
include/lwres/lang.h
include/lwres/list.h
include/lwres/lwbuffer.h
include/lwres/lwpacket.h
include/lwres/lwres.h
include/lwres/net.h
include/lwres/netdb.h
include/lwres/platform.h
include/lwres/result.h
include/lwres/version.h
lib/libbind9.la
lib/libdns.la
lib/libisc.la
lib/libisccc.la
lib/libisccfg.la
lib/liblwres.la
man/man1/dig.1
man/man1/host.1
man/man1/nslookup.1
man/man1/nsupdate.1
man/man3/lwres.3
man/man3/lwres_addr_parse.3
man/man3/lwres_buffer.3
man/man3/lwres_buffer_add.3
man/man3/lwres_buffer_back.3
man/man3/lwres_buffer_clear.3
man/man3/lwres_buffer_first.3
man/man3/lwres_buffer_forward.3
man/man3/lwres_buffer_getmem.3
man/man3/lwres_buffer_getuint16.3
man/man3/lwres_buffer_getuint32.3
man/man3/lwres_buffer_getuint8.3
man/man3/lwres_buffer_init.3
man/man3/lwres_buffer_invalidate.3
man/man3/lwres_buffer_putmem.3
man/man3/lwres_buffer_putuint16.3
man/man3/lwres_buffer_putuint32.3
man/man3/lwres_buffer_putuint8.3
man/man3/lwres_buffer_subtract.3
man/man3/lwres_conf_clear.3
man/man3/lwres_conf_get.3
man/man3/lwres_conf_init.3
man/man3/lwres_conf_parse.3
man/man3/lwres_conf_print.3
man/man3/lwres_config.3
man/man3/lwres_context.3
man/man3/lwres_context_allocmem.3
man/man3/lwres_context_create.3
man/man3/lwres_context_destroy.3
man/man3/lwres_context_freemem.3
man/man3/lwres_context_initserial.3
man/man3/lwres_context_nextserial.3
man/man3/lwres_context_sendrecv.3
man/man3/lwres_endhostent.3
man/man3/lwres_endhostent_r.3
man/man3/lwres_freeaddrinfo.3
man/man3/lwres_freehostent.3
man/man3/lwres_gabn.3
man/man3/lwres_gabnrequest_free.3
man/man3/lwres_gabnrequest_parse.3
man/man3/lwres_gabnrequest_render.3
man/man3/lwres_gabnresponse_free.3
man/man3/lwres_gabnresponse_parse.3
man/man3/lwres_gabnresponse_render.3
man/man3/lwres_gai_strerror.3
man/man3/lwres_getaddrinfo.3
man/man3/lwres_getaddrsbyname.3
man/man3/lwres_gethostbyaddr.3
man/man3/lwres_gethostbyaddr_r.3
man/man3/lwres_gethostbyname.3
man/man3/lwres_gethostbyname2.3
man/man3/lwres_gethostbyname_r.3
man/man3/lwres_gethostent.3
man/man3/lwres_gethostent_r.3
man/man3/lwres_getipnode.3
man/man3/lwres_getipnodebyaddr.3
man/man3/lwres_getipnodebyname.3
man/man3/lwres_getnamebyaddr.3
man/man3/lwres_getnameinfo.3
man/man3/lwres_getrrsetbyname.3
man/man3/lwres_gnba.3
man/man3/lwres_gnbarequest_free.3
man/man3/lwres_gnbarequest_parse.3
man/man3/lwres_gnbarequest_render.3
man/man3/lwres_gnbaresponse_free.3
man/man3/lwres_gnbaresponse_parse.3
man/man3/lwres_gnbaresponse_render.3
man/man3/lwres_herror.3
man/man3/lwres_hstrerror.3
man/man3/lwres_inetntop.3
man/man3/lwres_lwpacket_parseheader.3
man/man3/lwres_lwpacket_renderheader.3
man/man3/lwres_net_ntop.3
man/man3/lwres_noop.3
man/man3/lwres_nooprequest_free.3
man/man3/lwres_nooprequest_parse.3
man/man3/lwres_nooprequest_render.3
man/man3/lwres_noopresponse_free.3
man/man3/lwres_noopresponse_parse.3
man/man3/lwres_noopresponse_render.3
man/man3/lwres_packet.3
man/man3/lwres_resutil.3
man/man3/lwres_sethostent.3
man/man3/lwres_sethostent_r.3
man/man3/lwres_string_parse.3
man/man5/named.conf.5
man/man5/rndc.conf.5
man/man8/dnssec-dsfromkey.8
man/man8/dnssec-keyfromlabel.8
man/man8/dnssec-keygen.8
man/man8/dnssec-signzone.8
man/man8/lwresd.8
man/man8/named-checkconf.8
man/man8/named-checkzone.8
man/man8/named-compilezone.8
man/man8/named.8
man/man8/rndc-confgen.8
man/man8/rndc.8
sbin/dnssec-dsfromkey
sbin/dnssec-keyfromlabel
sbin/dnssec-keygen
sbin/dnssec-signzone
sbin/lwresd
sbin/named
sbin/named-checkconf
sbin/named-checkzone
sbin/named-compilezone
sbin/rndc
sbin/rndc-confgen
share/doc/bind9/NSEC3-NOTES
share/doc/bind9/README
share/doc/bind9/arm/Bv9ARM.ch01.html
share/doc/bind9/arm/Bv9ARM.ch02.html
share/doc/bind9/arm/Bv9ARM.ch03.html
share/doc/bind9/arm/Bv9ARM.ch04.html
share/doc/bind9/arm/Bv9ARM.ch05.html
share/doc/bind9/arm/Bv9ARM.ch06.html
share/doc/bind9/arm/Bv9ARM.ch07.html
share/doc/bind9/arm/Bv9ARM.ch08.html
share/doc/bind9/arm/Bv9ARM.ch09.html
share/doc/bind9/arm/Bv9ARM.ch10.html
share/doc/bind9/arm/Bv9ARM.html
share/doc/bind9/arm/man.dig.html
share/doc/bind9/arm/man.dnssec-dsfromkey.html
share/doc/bind9/arm/man.dnssec-keyfromlabel.html
share/doc/bind9/arm/man.dnssec-keygen.html
share/doc/bind9/arm/man.dnssec-signzone.html
share/doc/bind9/arm/man.host.html
share/doc/bind9/arm/man.named-checkconf.html
share/doc/bind9/arm/man.named-checkzone.html
share/doc/bind9/arm/man.named.html
share/doc/bind9/arm/man.nsupdate.html
share/doc/bind9/arm/man.rndc-confgen.html
share/doc/bind9/arm/man.rndc.conf.html
share/doc/bind9/arm/man.rndc.html
share/doc/bind9/draft/draft-baba-dnsext-acl-reqts-01.txt
share/doc/bind9/draft/draft-daigle-napstr-04.txt
share/doc/bind9/draft/draft-danisch-dns-rr-smtp-03.txt
share/doc/bind9/draft/draft-dnsext-opcode-discover-02.txt
share/doc/bind9/draft/draft-durand-dnsop-dynreverse-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-2929bis-01.txt
share/doc/bind9/draft/draft-ietf-dnsext-axfr-clarify-09.txt
share/doc/bind9/draft/draft-ietf-dnsext-dns-name-p-s-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-dnssec-2535typecode-change-06.txt
share/doc/bind9/draft/draft-ietf-dnsext-dnssec-bis-updates-01.txt
share/doc/bind9/draft/draft-ietf-dnsext-dnssec-experiments-03.txt
share/doc/bind9/draft/draft-ietf-dnsext-dnssec-online-signing-02.txt
share/doc/bind9/draft/draft-ietf-dnsext-dnssec-opt-in-07.txt
share/doc/bind9/draft/draft-ietf-dnsext-dnssec-rsasha256-06.txt
share/doc/bind9/draft/draft-ietf-dnsext-dnssec-trans-02.txt
share/doc/bind9/draft/draft-ietf-dnsext-ds-sha256-05.txt
share/doc/bind9/draft/draft-ietf-dnsext-ecc-key-07.txt
share/doc/bind9/draft/draft-ietf-dnsext-forgery-resilience-02.txt
share/doc/bind9/draft/draft-ietf-dnsext-interop3597-02.txt
share/doc/bind9/draft/draft-ietf-dnsext-keyrr-key-signing-flag-12.txt
share/doc/bind9/draft/draft-ietf-dnsext-mdns-46.txt
share/doc/bind9/draft/draft-ietf-dnsext-nsid-01.txt
share/doc/bind9/draft/draft-ietf-dnsext-rfc2536bis-dsa-07.txt
share/doc/bind9/draft/draft-ietf-dnsext-rfc2539bis-dhk-07.txt
share/doc/bind9/draft/draft-ietf-dnsext-rfc2671bis-edns0-01.txt
share/doc/bind9/draft/draft-ietf-dnsext-rfc2672bis-dname-13.txt
share/doc/bind9/draft/draft-ietf-dnsext-signed-nonexistence-requirements-01.txt
share/doc/bind9/draft/draft-ietf-dnsext-tkey-renewal-mode-05.txt
share/doc/bind9/draft/draft-ietf-dnsext-trustupdate-threshold-00.txt
share/doc/bind9/draft/draft-ietf-dnsext-trustupdate-timers-05.txt
share/doc/bind9/draft/draft-ietf-dnsext-tsig-sha-06.txt
share/doc/bind9/draft/draft-ietf-dnsext-wcard-clarify-10.txt
share/doc/bind9/draft/draft-ietf-dnsop-bad-dns-res-05.txt
share/doc/bind9/draft/draft-ietf-dnsop-default-local-zones-05.txt
share/doc/bind9/draft/draft-ietf-dnsop-inaddr-required-07.txt
share/doc/bind9/draft/draft-ietf-dnsop-ipv6-dns-configuration-06.txt
share/doc/bind9/draft/draft-ietf-dnsop-ipv6-dns-issues-11.txt
share/doc/bind9/draft/draft-ietf-dnsop-ipv6-transport-guidelines-01.txt
share/doc/bind9/draft/draft-ietf-dnsop-key-rollover-requirements-02.txt
share/doc/bind9/draft/draft-ietf-dnsop-name-server-management-reqs-01.txt
share/doc/bind9/draft/draft-ietf-dnsop-respsize-06.txt
share/doc/bind9/draft/draft-ietf-dnsop-serverid-06.txt
share/doc/bind9/draft/draft-ietf-enum-e164-gstn-np-05.txt
share/doc/bind9/draft/draft-ietf-ipv6-node-requirements-08.txt
share/doc/bind9/draft/draft-ietf-secsh-dns-05.txt
share/doc/bind9/draft/draft-ihren-dnsext-threshold-validation-00.txt
share/doc/bind9/draft/draft-kato-dnsop-local-zones-00.txt
share/doc/bind9/draft/draft-park-ipv6-extensions-dns-pnp-00.txt
share/doc/bind9/rfc/rfc1032.txt
share/doc/bind9/rfc/rfc1033.txt
share/doc/bind9/rfc/rfc1034.txt
share/doc/bind9/rfc/rfc1035.txt
share/doc/bind9/rfc/rfc1101.txt
share/doc/bind9/rfc/rfc1122.txt
share/doc/bind9/rfc/rfc1123.txt
share/doc/bind9/rfc/rfc1183.txt
share/doc/bind9/rfc/rfc1348.txt
share/doc/bind9/rfc/rfc1535.txt
share/doc/bind9/rfc/rfc1536.txt
share/doc/bind9/rfc/rfc1537.txt
share/doc/bind9/rfc/rfc1591.txt
share/doc/bind9/rfc/rfc1611.txt
share/doc/bind9/rfc/rfc1612.txt
share/doc/bind9/rfc/rfc1706.txt
share/doc/bind9/rfc/rfc1712.txt
share/doc/bind9/rfc/rfc1750.txt
share/doc/bind9/rfc/rfc1876.txt
share/doc/bind9/rfc/rfc1886.txt
share/doc/bind9/rfc/rfc1982.txt
share/doc/bind9/rfc/rfc1995.txt
share/doc/bind9/rfc/rfc1996.txt
share/doc/bind9/rfc/rfc2052.txt
share/doc/bind9/rfc/rfc2104.txt
share/doc/bind9/rfc/rfc2119.txt
share/doc/bind9/rfc/rfc2133.txt
share/doc/bind9/rfc/rfc2136.txt
share/doc/bind9/rfc/rfc2137.txt
share/doc/bind9/rfc/rfc2163.txt
share/doc/bind9/rfc/rfc2168.txt
share/doc/bind9/rfc/rfc2181.txt
share/doc/bind9/rfc/rfc2230.txt
share/doc/bind9/rfc/rfc2308.txt
share/doc/bind9/rfc/rfc2317.txt
share/doc/bind9/rfc/rfc2373.txt
share/doc/bind9/rfc/rfc2374.txt
share/doc/bind9/rfc/rfc2375.txt
share/doc/bind9/rfc/rfc2418.txt
share/doc/bind9/rfc/rfc2535.txt
share/doc/bind9/rfc/rfc2536.txt
share/doc/bind9/rfc/rfc2537.txt
share/doc/bind9/rfc/rfc2538.txt
share/doc/bind9/rfc/rfc2539.txt
share/doc/bind9/rfc/rfc2540.txt
share/doc/bind9/rfc/rfc2541.txt
share/doc/bind9/rfc/rfc2553.txt
share/doc/bind9/rfc/rfc2671.txt
share/doc/bind9/rfc/rfc2672.txt
share/doc/bind9/rfc/rfc2673.txt
share/doc/bind9/rfc/rfc2782.txt
share/doc/bind9/rfc/rfc2825.txt
share/doc/bind9/rfc/rfc2826.txt
share/doc/bind9/rfc/rfc2845.txt
share/doc/bind9/rfc/rfc2874.txt
share/doc/bind9/rfc/rfc2915.txt
share/doc/bind9/rfc/rfc2929.txt
share/doc/bind9/rfc/rfc2930.txt
share/doc/bind9/rfc/rfc2931.txt
share/doc/bind9/rfc/rfc3007.txt
share/doc/bind9/rfc/rfc3008.txt
share/doc/bind9/rfc/rfc3071.txt
share/doc/bind9/rfc/rfc3090.txt
share/doc/bind9/rfc/rfc3110.txt
share/doc/bind9/rfc/rfc3123.txt
share/doc/bind9/rfc/rfc3152.txt
share/doc/bind9/rfc/rfc3197.txt
share/doc/bind9/rfc/rfc3225.txt
share/doc/bind9/rfc/rfc3226.txt
share/doc/bind9/rfc/rfc3258.txt
share/doc/bind9/rfc/rfc3363.txt
share/doc/bind9/rfc/rfc3364.txt
share/doc/bind9/rfc/rfc3425.txt
share/doc/bind9/rfc/rfc3445.txt
share/doc/bind9/rfc/rfc3467.txt
share/doc/bind9/rfc/rfc3490.txt
share/doc/bind9/rfc/rfc3491.txt
share/doc/bind9/rfc/rfc3492.txt
share/doc/bind9/rfc/rfc3493.txt
share/doc/bind9/rfc/rfc3513.txt
share/doc/bind9/rfc/rfc3596.txt
share/doc/bind9/rfc/rfc3597.txt
share/doc/bind9/rfc/rfc3645.txt
share/doc/bind9/rfc/rfc3655.txt
share/doc/bind9/rfc/rfc3658.txt
share/doc/bind9/rfc/rfc3757.txt
share/doc/bind9/rfc/rfc3833.txt
share/doc/bind9/rfc/rfc3845.txt
share/doc/bind9/rfc/rfc3901.txt
share/doc/bind9/rfc/rfc4025.txt
share/doc/bind9/rfc/rfc4033.txt
share/doc/bind9/rfc/rfc4034.txt
share/doc/bind9/rfc/rfc4035.txt
share/doc/bind9/rfc/rfc4074.txt
share/doc/bind9/rfc/rfc4159.txt
share/doc/bind9/rfc/rfc4193.txt
share/doc/bind9/rfc/rfc4255.txt
share/doc/bind9/rfc/rfc4343.txt
share/doc/bind9/rfc/rfc4367.txt
share/doc/bind9/rfc/rfc4398.txt
share/doc/bind9/rfc/rfc4408.txt
share/doc/bind9/rfc/rfc4431.txt
share/doc/bind9/rfc/rfc4470.txt
share/doc/bind9/rfc/rfc4634.txt
share/doc/bind9/rfc/rfc4641.txt
share/doc/bind9/rfc/rfc4648.txt
share/doc/bind9/rfc/rfc4701.txt
share/doc/bind9/rfc/rfc5155.txt
share/doc/bind9/rfc/rfc952.txt
share/examples/rc.d/lwresd
share/examples/rc.d/named9
@dirrm share/doc/bind9/rfc
@dirrm share/doc/bind9/draft
@dirrm share/doc/bind9/arm
@dirrm share/doc/bind9
@dirrm include/lwres
@dirrm include/isccfg
@dirrm include/isccc
@dirrm include/isc
@dirrm include/dst
@dirrm include/dns
@dirrm include/bind9

19
net/bind96/buildlink3.mk Normal file
View file

@ -0,0 +1,19 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
BIND_BUILDLINK3_MK:= ${BIND_BUILDLINK3_MK}+
.if ${BUILDLINK_DEPTH} == "+"
BUILDLINK_DEPENDS+= bind
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nbind}
BUILDLINK_PACKAGES+= bind
BUILDLINK_ORDER:= ${BUILDLINK_ORDER} ${BUILDLINK_DEPTH}bind
.if ${BIND_BUILDLINK3_MK} == "+"
BUILDLINK_API_DEPENDS.bind+= bind>=9.6.0
BUILDLINK_PKGSRCDIR.bind?= ../../net/bind96
.endif # BIND_BUILDLINK3_MK
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

92
net/bind96/builtin.mk Normal file
View file

@ -0,0 +1,92 @@
# $NetBSD: builtin.mk,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
BUILTIN_PKG:= bind
BUILTIN_FIND_FILES_VAR:= EXE_NAMED
BUILTIN_FIND_FILES.EXE_NAMED= /usr/sbin/named
BUILTIN_FIND_LIBS:= bind
.include "../../mk/buildlink3/bsd.builtin.mk"
###
### Figure out the version of BIND if an ISC BIND named exists on the
### system.
###
.if !defined(BUILTIN_VERSION.bind) && \
empty(EXE_NAMED:M__nonexistent__) && \
empty(EXE_NAMED:M${LOCALBASE}/*)
BUILTIN_VERSION.bind!= \
${EXE_NAMED} -v 2>/dev/null | ${HEAD} -1 | \
${AWK} 'BEGIN { v = "4.9.11"; } \
/^BIND / { v = $$2; sub("-.*", "", v); } \
/^named / { v = $$2; sub("-.*", "", v); } \
END { print v; }'
.endif
MAKEVARS+= BUILTIN_VERSION.bind
###
### Determine if there is a built-in implementation of the package and
### set IS_BUILTIN.<pkg> appropriately ("yes" or "no").
###
.if !defined(IS_BUILTIN.bind)
IS_BUILTIN.bind= no
. if defined(BUILTIN_VERSION.bind)
IS_BUILTIN.bind= yes
. endif
.endif
MAKEVARS+= IS_BUILTIN.bind
###
### If there is a built-in implementation, then set BUILTIN_PKG.<pkg> to
### a package name to represent the built-in package.
###
.if !defined(BUILTIN_PKG.bind) && \
!empty(IS_BUILTIN.bind:M[yY][eE][sS]) && \
defined(BUILTIN_VERSION.bind)
BUILTIN_PKG.bind= bind-${BUILTIN_VERSION.bind}
.endif
MAKEVARS+= BUILTIN_PKG.bind
###
### Determine whether we should use the built-in implementation if it
### exists, and set USE_BUILTIN.<pkg> appropriate ("yes" or "no").
###
.if !defined(USE_BUILTIN.bind)
. if ${PREFER.bind} == "pkgsrc"
USE_BUILTIN.bind= no
. else
USE_BUILTIN.bind= ${IS_BUILTIN.bind}
. if defined(BUILTIN_PKG.bind) && \
!empty(IS_BUILTIN.bind:M[yY][eE][sS])
USE_BUILTIN.bind= yes
. for dep in ${BUILDLINK_API_DEPENDS.bind}
. if !empty(USE_BUILTIN.bind:M[yY][eE][sS])
USE_BUILTIN.bind!= \
if ${PKG_ADMIN} pmatch ${dep:Q} ${BUILTIN_PKG.bind:Q}; then \
${ECHO} yes; \
else \
${ECHO} no; \
fi
. endif
. endfor
. endif
. endif # PREFER.bind
.endif
MAKEVARS+= USE_BUILTIN.bind
###
### The section below only applies if we are not including this file
### solely to determine whether a built-in implementation exists.
###
CHECK_BUILTIN.bind?= no
.if !empty(CHECK_BUILTIN.bind:M[nN][oO])
. if !empty(USE_BUILTIN.bind:M[yY][eE][sS])
. if !empty(BUILTIN_LIB_FOUND.bind:M[yY][eE][sS])
BUILDLINK_LDADD.bind?= -lbind
. endif
. elif !empty(USE_BUILTIN.bind:M[nN][oO])
BUILDLINK_LDADD.bind?= -lbind
. endif
.endif # CHECK_BUILTIN.bind

11
net/bind96/distinfo Normal file
View file

@ -0,0 +1,11 @@
$NetBSD: distinfo,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
SHA1 (bind-9.6.0.tar.gz) = f9b4ac7632ade64645570ef2ba7a4bbf8a0740f6
RMD160 (bind-9.6.0.tar.gz) = 33fde250e9f88114d6364ab363e71b195cf6d6b6
Size (bind-9.6.0.tar.gz) = 6525672 bytes
SHA1 (patch-ab) = dd12c457791a75a8b43d9dfd0c0b236dcdbe31a5
SHA1 (patch-ac) = 4df1ece91d59b2b36fc7a4316604f1c112cf70ba
SHA1 (patch-ad) = b229db208df08efe25aa8840d62904f39b88aecf
SHA1 (patch-ag) = 9d61e0f527a76977bf8457355997d201fa37dd4e
SHA1 (patch-aj) = c3bbf84a8a735298552f918ac38331e06a1b68a1
SHA1 (patch-am) = bb267f13dbd30d492f4dfcf9c278b941efa97bed

View file

@ -0,0 +1,18 @@
#!/bin/sh
#
# $NetBSD: lwresd.sh,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
#
# PROVIDE: lwresd
# REQUIRE: SERVERS
. /etc/rc.subr
name="lwresd"
rcvar=${name}
command="@PREFIX@/sbin/${name}"
pidfile="/var/run/${name}.pid"
extra_commands="reload"
load_rc_config ${name} # check /etc/rc.conf.d/named9
run_rc_command "$1"

View file

@ -0,0 +1,51 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: named9.sh,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
#
# PROVIDE: named
# REQUIRE: SERVERS
# BEFORE: DAEMON
# KEYWORD: chrootdir
. /etc/rc.subr
name="named"
rcvar="${name}9"
command="@PREFIX@/sbin/${name}"
pidfile="/var/run/${name}.pid"
start_precmd="named_precmd"
extra_commands="reload"
required_dirs="$named_chrootdir" # if it is set, it must exist
named_precmd()
{
# Die if $named is also set (i.e. the system's named is not disabled
if checkyesno named ; then
warn \
"disable 'named' when setting 'named9'!"
return 1
fi
if [ -z "$named_chrootdir" ]; then
return 0;
fi
if [ ! -c "${named_chrootdir}/dev/null" ]; then
@RM@ -f "${named_chrootdir}/dev/null"
( cd /dev ; @PAX@ -rw -pe null "${named_chrootdir}/dev" )
fi
if [ -f /etc/localtime ]; then
@CMP@ -s /etc/localtime "${named_chrootdir}/etc/localtime" || \
@CP@ -p /etc/localtime "${named_chrootdir}/etc/localtime"
fi
@RM@ -f ${pidfile}
@LN@ -s "${named_chrootdir}${pidfile}" ${pidfile}
# Change run_rc_commands()'s internal copy of $named_flags
#
rc_flags="-u @BIND_USER@ -t ${named_chrootdir} $rc_flags"
}
load_rc_config "$rcvar"
run_rc_command "$1"

76
net/bind96/options.mk Normal file
View file

@ -0,0 +1,76 @@
# $NetBSD: options.mk,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.bind96
PKG_SUPPORTED_OPTIONS= bind-xml-statistics-server inet6 threads
PKG_SUPPORTED_OPTIONS+= mysql pgsql ldap dlz-filesystem
.include "../../mk/pthread.buildlink3.mk"
.if defined(PTHREAD_TYPE) && (${PTHREAD_TYPE} == "none") || \
!empty(MACHINE_PLATFORM:MNetBSD-*-vax) || \
!empty(MACHINE_PLATFORM:MNetBSD-*-sparc) || \
!empty(MACHINE_PLATFORM:MNetBSD-*-sparc64) || \
!empty(MACHINE_PLATFORM:MNetBSD-*-m68k)
# don't touch PKG_SUGGESTED_OPTIONS
.else
PKG_SUGGESTED_OPTIONS+= threads
.endif
.include "../../mk/bsd.options.mk"
###
### The mysql pgsql ldap dlz-filesystem options are all for BIND
### DLZ (Dynamically Loadable Zones) functionality
###
### NOTE: bdb is excluded on purpose as pkgsrc does not contain
### a bdb v4.1 or 4.2 package which is what BIND needs.
### The majority of these are compile tested only
###
.if !empty(PKG_OPTIONS:Mmysql)
.include "../../mk/mysql.buildlink3.mk"
CONFIGURE_ARGS+= --with-dlz-mysql=${BUILDLINK_PREFIX.mysql-client}
.endif
.if !empty(PKG_OPTIONS:Mpgsql)
.include "../../mk/pgsql.buildlink3.mk"
CONFIGURE_ARGS+= --with-dlz-postgres=${BUILDLINK_PREFIX.${PGSQL_TYPE}}
CONFIGURE_ENV+= ac_cv_path_PG_CONFIG=${PREFIX}/bin/pg_config
.endif
.if !empty(PKG_OPTIONS:Mldap)
.include "../../databases/openldap-client/buildlink3.mk"
CONFIGURE_ARGS+= --with-dlz-ldap=${BUILDLINK_PREFIX.openldap-client}
.endif
.if !empty(PKG_OPTIONS:Mdlz-filesystem)
CONFIGURE_ARGS+= --with-dlz-filesystem
.endif
###
### The statistics server in bind95 and later needs libxml2
###
.if !empty(PKG_OPTIONS:Mbind-xml-statistics-server)
.include "../../textproc/libxml2/buildlink3.mk"
CONFIGURE_ARGS+= --with-libxml2
.else
CONFIGURE_ARGS+= --without-libxml2
.endif
###
### IPv6 support
###
.if !empty(PKG_OPTIONS:Minet6)
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
###
### pthreads support (also see magic above)
###
.if !empty(PKG_OPTIONS:Mthreads)
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads
.endif

View file

@ -0,0 +1,32 @@
$NetBSD: patch-ab,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
--- lib/lwres/getnameinfo.c.orig 2004-08-28 08:25:24.000000000 +0200
+++ lib/lwres/getnameinfo.c 2004-10-03 08:56:21.000000000 +0200
@@ -63,6 +63,10 @@
#include <lwres/netdb.h>
#include "print_p.h"
+#ifdef __KAME__
+#include <net/if.h>
+#endif
+
#include "assert_p.h"
#define SUCCESS 0
@@ -211,13 +215,10 @@
((const struct sockaddr_in6 *)sa)->sin6_scope_id) {
char *p = numaddr + strlen(numaddr);
const char *stringscope = NULL;
-#if 0
+#ifdef __KAME__
if ((flags & NI_NUMERICSCOPE) == 0) {
- /*
- * Vendors may want to add support for
- * non-numeric scope identifier.
- */
- stringscope = foo;
+ stringscope = if_indextoname(
+ ((const struct sockaddr_in6 *)sa)->sin6_scope_id);
}
#endif
if (stringscope == NULL) {

View file

@ -0,0 +1,39 @@
$NetBSD: patch-ac,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
--- lib/lwres/getaddrinfo.c.orig 2005-06-10 08:54:33.000000000 +0900
+++ lib/lwres/getaddrinfo.c
@@ -30,6 +30,10 @@
#include <lwres/netdb.h>
#include <lwres/stdlib.h>
+#ifdef __KAME__
+#include <net/if.h>
+#endif
+
#define SA(addr) ((struct sockaddr *)(addr))
#define SIN(addr) ((struct sockaddr_in *)(addr))
#define SIN6(addr) ((struct sockaddr_in6 *)(addr))
@@ -252,14 +256,22 @@ lwres_getaddrinfo(const char *hostname,
p = strchr(ntmp, '%');
ep = NULL;
+#ifdef __KAME__
+ if (p != NULL) {
+ scopeid = if_nametoindex(p + 1);
+ if (scopeid)
+ p = NULL;
+ }
+#endif
/*
* Vendors may want to support non-numeric
* scopeid around here.
*/
- if (p != NULL)
+ if (p != NULL) {
scopeid = (lwres_uint32_t)strtoul(p + 1,
&ep, 10);
+ }
if (p != NULL && ep != NULL && ep[0] == '\0')
*p = '\0';
else {

View file

@ -0,0 +1,62 @@
$NetBSD: patch-ad,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
--- configure.orig 2008-10-29 10:09:21.000000000 +0000
+++ configure
@@ -6972,6 +6972,8 @@ case $host in
use_threads=false ;;
*-freebsd*)
use_threads=false ;;
+*-dragonfly*)
+ use_threads=false ;;
*-bsdi234*)
# Thread signals do not work reliably on some versions of BSD/OS.
use_threads=false ;;
@@ -7060,7 +7062,7 @@ echo "$as_me: WARNING: linking with PTL2
echo "${ECHO_T}native" >&6; }
LIBS="-lpthread $LIBS"
else
- if test ! -d $LOCALBASE/pthreads
+ if test ! -d $LOCALBASE/pthreads -a ! -f /usr/include/pthread.h
then
{ echo "$as_me:$LINENO: result: none" >&5
echo "${ECHO_T}none" >&6; }
@@ -7071,14 +7073,23 @@ echo "$as_me: error: \"could not find th
if $use_threads
then
- { echo "$as_me:$LINENO: result: mit-pthreads/unproven-pthreads" >&5
+ if test -f /usr/include/pthread.h
+ then
+ { echo "$as_me:$LINENO: result: native pthreads" >&5
+echo "${ECHO_T}native pthreads" >&6; }
+ LIBS="-lpthread $LIBS"
+ CPPFLAGS="$CPPFLAGS -I/usr/include"
+ STD_CINDLUES="$STD_CINDLUES -I/usr/include"
+ else
+ { echo "$as_me:$LINENO: result: mit-pthreads/unproven-pthreads" >&5
echo "${ECHO_T}mit-pthreads/unproven-pthreads" >&6; }
- pkg="$LOCALBASE/pthreads"
- lib1="-L$pkg/lib -Wl,-R$pkg/lib"
- lib2="-lpthread -lm -lgcc -lpthread"
- LIBS="$lib1 $lib2 $LIBS"
- CPPFLAGS="$CPPFLAGS -I$pkg/include"
- STD_CINCLUDES="$STD_CINCLUDES -I$pkg/include"
+ pkg="$LOCALBASE/pthreads"
+ lib1="-L$pkg/lib -Wl,-R$pkg/lib"
+ lib2="-lpthread -lm -lgcc -lpthread"
+ LIBS="$lib1 $lib2 $LIBS"
+ CPPFLAGS="$CPPFLAGS -I$pkg/include"
+ STD_CINCLUDES="$STD_CINCLUDES -I$pkg/include"
+ fi
fi
fi
fi
@@ -31037,7 +31048,7 @@ echo "${ECHO_T}no" >&6; }
fi
if test -n "-L$use_dlz_postgres_lib -lpq"
then
- DLZ_DRIVER_LIBS="$DLZ_DRIVER_LIBS -L$use_dlz_postgres_lib -lpq"
+ DLZ_DRIVER_LIBS="$DLZ_DRIVER_LIBS -L${PREFIX}/lib -lpq"
fi

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ag,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
--- lib/dns/rbt.c.orig 2004-03-08 21:06:27.000000000 +0000
+++ lib/dns/rbt.c 2005-03-16 13:45:23.000000000 +0000
@@ -165,6 +165,10 @@
static void dns_rbt_printnodename(dns_rbtnode_t *node);
#endif
+#if !defined(inline) && defined(__powerpc__)
+#define inline /**/
+#endif
+
static inline dns_rbtnode_t *
find_up(dns_rbtnode_t *node) {
dns_rbtnode_t *root;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aj,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
--- lib/Makefile.in.orig 2004-03-08 18:04:25.000000000 +0900
+++ lib/Makefile.in
@@ -23,7 +23,7 @@ top_srcdir = @top_srcdir@
# Attempt to disable parallel processing.
.NOTPARALLEL:
.NO_PARALLEL:
-SUBDIRS = isc isccc dns isccfg bind9 lwres tests
+SUBDIRS = bind isc isccc dns isccfg bind9 lwres tests
TARGETS =
@BIND9_MAKE_RULES@

View file

@ -0,0 +1,51 @@
$NetBSD: patch-am,v 1.1.1.1 2009/01/04 00:21:36 adrianp Exp $
--- config.threads.in.orig 2005-03-16 07:59:16.000000000 +0900
+++ config.threads.in
@@ -48,6 +48,8 @@ case $host in
use_threads=false ;;
*-freebsd*)
use_threads=false ;;
+*-dragonfly*)
+ use_threads=false ;;
*-bsdi[234]*)
# Thread signals do not work reliably on some versions of BSD/OS.
use_threads=false ;;
@@ -121,7 +123,7 @@ then
AC_MSG_RESULT(native)
LIBS="-lpthread $LIBS"
else
- if test ! -d $LOCALBASE/pthreads
+ if test ! -d $LOCALBASE/pthreads -a ! -f /usr/include/pthread.h
then
AC_MSG_RESULT(none)
AC_MSG_ERROR("could not find thread libraries")
@@ -129,13 +131,21 @@ then
if $use_threads
then
- AC_MSG_RESULT(mit-pthreads/unproven-pthreads)
- pkg="$LOCALBASE/pthreads"
- lib1="-L$pkg/lib -Wl,-R$pkg/lib"
- lib2="-lpthread -lm -lgcc -lpthread"
- LIBS="$lib1 $lib2 $LIBS"
- CPPFLAGS="$CPPFLAGS -I$pkg/include"
- STD_CINCLUDES="$STD_CINCLUDES -I$pkg/include"
+ if test -f /usr/include/pthread.h
+ then
+ AC_MSG_RESULT(native pthreads)
+ LIBS="-lpthread $LIBS"
+ CPPFLAGS="$CPPFLAGS -I/usr/inclue"
+ STD_CINDLUES="$STD_CINDLUES -I/usr/include"
+ else
+ AC_MSG_RESULT(mit-pthreads/unproven-pthreads)
+ pkg="$LOCALBASE/pthreads"
+ lib1="-L$pkg/lib -Wl,-R$pkg/lib"
+ lib2="-lpthread -lm -lgcc -lpthread"
+ LIBS="$lib1 $lib2 $LIBS"
+ CPPFLAGS="$CPPFLAGS -I$pkg/include"
+ STD_CINCLUDES="$STD_CINCLUDES -I$pkg/include"
+ fi
fi
fi
fi