py-magic-wormhole-mailbox-server: convert to wheel.mk

Fix build with Python 3.12

Bump PKGREVISION.
This commit is contained in:
wiz 2023-11-05 22:45:48 +00:00
parent 12142ca80a
commit 3a28e76182
4 changed files with 30 additions and 10 deletions

View File

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.3 2022/01/04 20:54:29 wiz Exp $
# $NetBSD: Makefile,v 1.4 2023/11/05 22:45:48 wiz Exp $
DISTNAME= magic-wormhole-mailbox-server-0.4.1
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_PYPI:=m/magic-wormhole-mailbox-server/}
@ -11,6 +11,7 @@ HOMEPAGE= https://github.com/magic-wormhole/magic-wormhole-mailbox-server
COMMENT= Main server for Magic Wormhole
LICENSE= mit
TOOL_DEPENDS+= ${PYPKGPREFIX}-wheel-[0-9]*:../../devel/py-wheel
DEPENDS+= ${PYPKGPREFIX}-attrs>=16.3.0:../../devel/py-attrs
DEPENDS+= ${PYPKGPREFIX}-autobahn>=0.14.1:../../www/py-autobahn
DEPENDS+= ${PYPKGPREFIX}-six-[0-9]*:../../lang/py-six
@ -22,5 +23,5 @@ PYTHON_VERSIONS_INCOMPATIBLE= 27 # py-autobahn
USE_LANGUAGES= # none
.include "../../lang/python/egg.mk"
.include "../../lang/python/wheel.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -1,9 +1,9 @@
@comment $NetBSD: PLIST,v 1.1 2021/06/27 16:33:17 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
@comment $NetBSD: PLIST,v 1.2 2023/11/05 22:45:48 wiz Exp $
${PYSITELIB}/${WHEEL_INFODIR}/LICENSE
${PYSITELIB}/${WHEEL_INFODIR}/METADATA
${PYSITELIB}/${WHEEL_INFODIR}/RECORD
${PYSITELIB}/${WHEEL_INFODIR}/WHEEL
${PYSITELIB}/${WHEEL_INFODIR}/top_level.txt
${PYSITELIB}/twisted/plugins/magic_wormhole_mailbox.py
${PYSITELIB}/twisted/plugins/magic_wormhole_mailbox.pyc
${PYSITELIB}/twisted/plugins/magic_wormhole_mailbox.pyo

View File

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.4 2022/11/14 19:01:21 wiz Exp $
$NetBSD: distinfo,v 1.5 2023/11/05 22:45:48 wiz Exp $
BLAKE2s (magic-wormhole-mailbox-server-0.4.1.tar.gz) = dff245eb1ef6cbda843b096749ca23f87444cc2cd6bed57b4b6d63e3c8f1e3f0
SHA512 (magic-wormhole-mailbox-server-0.4.1.tar.gz) = 17e66d61589b2a9620d56a4df82489d0c9aad40b6d61ff89c6b44e2ab96f8f4f12849879d5950025cbc7a657a2cd6f1afb36505adad52566f57571de645b70a4
Size (magic-wormhole-mailbox-server-0.4.1.tar.gz) = 64830 bytes
SHA1 (patch-setup.py) = 60b8b1061834f328dc866a716962f628484744cf
SHA1 (patch-versioneer.py) = f9c50d788d018ca4aa50d421939a7b6e3b784c40

View File

@ -0,0 +1,18 @@
$NetBSD: patch-versioneer.py,v 1.1 2023/11/05 22:45:48 wiz Exp $
Fix build with Python 3.12.
--- versioneer.py.orig 2018-02-18 09:14:32.000000000 +0000
+++ versioneer.py
@@ -339,9 +339,9 @@ def get_config_from_root(root):
# configparser.NoOptionError (if it lacks "VCS="). See the docstring at
# the top of versioneer.py for instructions on writing your setup.cfg .
setup_cfg = os.path.join(root, "setup.cfg")
- parser = configparser.SafeConfigParser()
+ parser = configparser.ConfigParser()
with open(setup_cfg, "r") as f:
- parser.readfp(f)
+ parser.read_file(f)
VCS = parser.get("versioneer", "VCS") # mandatory
def get(parser, name):