Remove clutter-0.8 packages from pkgsrc.
obsolated and nothing is using them in pkgsrc.
This commit is contained in:
parent
8e72d8eacb
commit
3a8f3223fa
31 changed files with 2 additions and 651 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.652 2013/06/13 13:47:25 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.653 2013/06/13 14:01:34 obache Exp $
|
||||
#
|
||||
|
||||
COMMENT= Graphics tools and libraries
|
||||
|
@ -50,12 +50,9 @@ SUBDIR+= circos
|
|||
SUBDIR+= claraocr
|
||||
SUBDIR+= clutter
|
||||
SUBDIR+= clutter-box2d
|
||||
SUBDIR+= clutter-cairo
|
||||
SUBDIR+= clutter-gtk
|
||||
SUBDIR+= clutter-mx
|
||||
SUBDIR+= clutter-qt
|
||||
SUBDIR+= clutter08
|
||||
SUBDIR+= clutter08-gtk
|
||||
SUBDIR+= cnxtview
|
||||
SUBDIR+= comix
|
||||
SUBDIR+= compface
|
||||
|
|
|
@ -1,4 +0,0 @@
|
|||
An experimental clutter cairo 'drawable' actor. Sucks a bit as renders
|
||||
cairo via an image surface and thus no real cairo rendering
|
||||
acceleration. Experiments with glitz and sharing GL contexts for such
|
||||
acceleration proved problematic. Needs more investigation.
|
|
@ -1,23 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.22 2013/06/06 12:53:50 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= clutter-cairo-0.8.2
|
||||
PKGREVISION= 18
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.clutter-project.org/sources/clutter-cairo/0.8/
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= http://www.clutter-project.org/
|
||||
COMMENT= Clutter Cairo integrarion library
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
PKGCONFIG_OVERRIDE+= clutter-cairo.pc.in
|
||||
|
||||
BUILDLINK_API_DEPENDS.cairo+= cairo>=1.4
|
||||
.include "../../graphics/cairo/buildlink3.mk"
|
||||
.include "../../graphics/clutter08/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,4 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/06/14 17:59:08 joerg Exp $
|
||||
include/clutter-0.8/clutter-cairo/clutter-cairo.h
|
||||
lib/libclutter-cairo-0.8.la
|
||||
lib/pkgconfig/clutter-cairo-0.8.pc
|
|
@ -1,17 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.20 2013/06/06 12:53:50 wiz Exp $
|
||||
#
|
||||
|
||||
BUILDLINK_TREE+= clutter-cairo
|
||||
|
||||
.if !defined(CLUTTER_CAIRO_BUILDLINK3_MK)
|
||||
CLUTTER_CAIRO_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.clutter-cairo+= clutter-cairo>=0.8.0
|
||||
BUILDLINK_ABI_DEPENDS.clutter-cairo+= clutter-cairo>=0.8.2nb18
|
||||
BUILDLINK_PKGSRCDIR.clutter-cairo?= ../../graphics/clutter-cairo
|
||||
|
||||
.include "../../graphics/cairo/buildlink3.mk"
|
||||
.include "../../graphics/clutter08/buildlink3.mk"
|
||||
.endif # CLUTTER_CAIRO_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -clutter-cairo
|
|
@ -1,5 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2008/12/14 11:04:35 obache Exp $
|
||||
|
||||
SHA1 (clutter-cairo-0.8.2.tar.gz) = 2ef3c4383166c5ed77060e206f1240d70b3451ed
|
||||
RMD160 (clutter-cairo-0.8.2.tar.gz) = 01780bb414e7c398bfaa37cd365baec55cd5b4de
|
||||
Size (clutter-cairo-0.8.2.tar.gz) = 341500 bytes
|
|
@ -1,3 +0,0 @@
|
|||
Clutter-GTK is a library providing facilities to integrate Clutter into GTK+
|
||||
applications. It provides a GTK+ widget, GtkClutterEmbed, for embedding the
|
||||
default ClutterStage into any GtkContainer.
|
|
@ -1,35 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.18 2013/06/06 12:53:50 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= clutter-gtk-0.8.3
|
||||
PKGNAME= ${DISTNAME:S/clutter/clutter08/}
|
||||
PKGREVISION= 16
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.clutter-project.org/sources/clutter-gtk/0.8/
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= http://www.clutter-project.org/
|
||||
COMMENT= GTK+ Integration library for Clutter
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
# Workaround for Upstream Bug#562310.
|
||||
# for more detail, see also PR#41475.
|
||||
TOOLS_NOOP+= gtkdoc-rebase
|
||||
|
||||
MAKE_ENV+= DOC_MODULE_VERSION=0.8
|
||||
|
||||
PKGCONFIG_OVERRIDE+= clutter-gtk.pc.in
|
||||
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.clutter08+= clutter08>=0.8.7
|
||||
.include "../../graphics/clutter08/buildlink3.mk"
|
||||
.if !empty(PKG_BUILD_OPTIONS.clutter08:Mx11)
|
||||
CONFIGURE_ARGS+= --with-flavour=x11
|
||||
.else
|
||||
PKG_FAIL_REASON+= Require Clutter with X11 backend
|
||||
.endif
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,20 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/10/26 08:32:30 obache Exp $
|
||||
include/clutter-0.8/clutter-gtk/gtk-clutter-embed.h
|
||||
include/clutter-0.8/clutter-gtk/gtk-clutter-util.h
|
||||
lib/libclutter-gtk-0.8.la
|
||||
lib/pkgconfig/clutter-gtk-0.8.pc
|
||||
share/gtk-doc/html/clutter-gtk-0.8/GtkClutterEmbed.html
|
||||
share/gtk-doc/html/clutter-gtk-0.8/ch01.html
|
||||
share/gtk-doc/html/clutter-gtk-0.8/ch02.html
|
||||
share/gtk-doc/html/clutter-gtk-0.8/ch03.html
|
||||
share/gtk-doc/html/clutter-gtk-0.8/clutter-gtk-0.8.devhelp
|
||||
share/gtk-doc/html/clutter-gtk-0.8/clutter-gtk-0.8.devhelp2
|
||||
share/gtk-doc/html/clutter-gtk-0.8/clutter-gtk-Utility-Functions.html
|
||||
share/gtk-doc/html/clutter-gtk-0.8/home.png
|
||||
share/gtk-doc/html/clutter-gtk-0.8/index.html
|
||||
share/gtk-doc/html/clutter-gtk-0.8/index.sgml
|
||||
share/gtk-doc/html/clutter-gtk-0.8/left.png
|
||||
share/gtk-doc/html/clutter-gtk-0.8/license.html
|
||||
share/gtk-doc/html/clutter-gtk-0.8/right.png
|
||||
share/gtk-doc/html/clutter-gtk-0.8/style.css
|
||||
share/gtk-doc/html/clutter-gtk-0.8/up.png
|
|
@ -1,17 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.18 2013/06/06 12:53:50 wiz Exp $
|
||||
#
|
||||
|
||||
BUILDLINK_TREE+= clutter08-gtk
|
||||
|
||||
.if !defined(CLUTTER08_GTK_BUILDLINK3_MK)
|
||||
CLUTTER08_GTK_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.clutter08-gtk+= clutter08-gtk>=0.8.0
|
||||
BUILDLINK_ABI_DEPENDS.clutter08-gtk+= clutter08-gtk>=0.8.3nb16
|
||||
BUILDLINK_PKGSRCDIR.clutter08-gtk?= ../../graphics/clutter08-gtk
|
||||
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.include "../../graphics/clutter08/buildlink3.mk"
|
||||
.endif # CLUTTER_GTK_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -clutter08-gtk
|
|
@ -1,5 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2009/10/26 08:32:30 obache Exp $
|
||||
|
||||
SHA1 (clutter-gtk-0.8.3.tar.gz) = dcc53c9051bf3c0e54a2d06d88fa56aaeb6c6054
|
||||
RMD160 (clutter-gtk-0.8.3.tar.gz) = c25801af9dd560a70953dc85d5fe7f00be131f43
|
||||
Size (clutter-gtk-0.8.3.tar.gz) = 390360 bytes
|
|
@ -1,2 +0,0 @@
|
|||
Clutter it an open source software library for creating fast, visually
|
||||
rich and animated graphical user interfaces.
|
|
@ -1,42 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.19 2013/06/06 12:53:48 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= clutter-0.8.8
|
||||
PKGNAME= ${DISTNAME:S/clutter/clutter08/}
|
||||
PKGREVISION= 17
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://www.clutter-project.org/sources/clutter/0.8/
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= http://clutter-project.org/
|
||||
COMMENT= Open GL based interactive canvas library
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
CONFLICTS+= clutter-0.8.*{,nb*}
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= gmake pkg-config
|
||||
|
||||
CONFIGURE_ARGS+= --with-json=check
|
||||
|
||||
PKGCONFIG_OVERRIDE+= clutter/x11/clutter-x11.pc.in
|
||||
PKGCONFIG_OVERRIDE+= clutter/win32/clutter-win32.pc.in
|
||||
PKGCONFIG_OVERRIDE+= clutter.pc.in
|
||||
|
||||
# Workaround for Upstream Bug#562310.
|
||||
# for more detail, see also PR#41475.
|
||||
TOOLS_NOOP+= gtkdoc-rebase
|
||||
|
||||
MAKE_ENV+= DOC_MODULE_VERSION=0.8
|
||||
|
||||
.include "options.mk"
|
||||
|
||||
TEST_TARGET= check
|
||||
|
||||
BUILDLINK_API_DEPENDS.glib2+= glib2>=2.14.0
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.pango+= pango>=1.18.0
|
||||
.include "../../devel/pango/buildlink3.mk"
|
||||
.include "../../textproc/json-glib/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,162 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/10/26 08:30:16 obache Exp $
|
||||
include/clutter-0.8/clutter/clutter-actor.h
|
||||
include/clutter-0.8/clutter/clutter-alpha.h
|
||||
include/clutter-0.8/clutter/clutter-backend.h
|
||||
include/clutter-0.8/clutter/clutter-behaviour-bspline.h
|
||||
include/clutter-0.8/clutter/clutter-behaviour-depth.h
|
||||
include/clutter-0.8/clutter/clutter-behaviour-ellipse.h
|
||||
include/clutter-0.8/clutter/clutter-behaviour-opacity.h
|
||||
include/clutter-0.8/clutter/clutter-behaviour-path.h
|
||||
include/clutter-0.8/clutter/clutter-behaviour-rotate.h
|
||||
include/clutter-0.8/clutter/clutter-behaviour-scale.h
|
||||
include/clutter-0.8/clutter/clutter-behaviour.h
|
||||
include/clutter-0.8/clutter/clutter-child-meta.h
|
||||
include/clutter-0.8/clutter/clutter-clone-texture.h
|
||||
include/clutter-0.8/clutter/clutter-color.h
|
||||
include/clutter-0.8/clutter/clutter-container.h
|
||||
include/clutter-0.8/clutter/clutter-deprecated.h
|
||||
include/clutter-0.8/clutter/clutter-effect.h
|
||||
include/clutter-0.8/clutter/clutter-entry.h
|
||||
include/clutter-0.8/clutter/clutter-enum-types.h
|
||||
include/clutter-0.8/clutter/clutter-event.h
|
||||
include/clutter-0.8/clutter/clutter-feature.h
|
||||
include/clutter-0.8/clutter/clutter-fixed.h
|
||||
include/clutter-0.8/clutter/clutter-frame-source.h
|
||||
include/clutter-0.8/clutter/clutter-group.h
|
||||
include/clutter-0.8/clutter/clutter-json.h
|
||||
include/clutter-0.8/clutter/clutter-keysyms.h
|
||||
include/clutter-0.8/clutter/clutter-label.h
|
||||
include/clutter-0.8/clutter/clutter-list-model.h
|
||||
include/clutter-0.8/clutter/clutter-main.h
|
||||
include/clutter-0.8/clutter/clutter-media.h
|
||||
include/clutter-0.8/clutter/clutter-model.h
|
||||
${PLIST.osx}include/clutter-0.8/clutter/clutter-osx.h
|
||||
include/clutter-0.8/clutter/clutter-rectangle.h
|
||||
include/clutter-0.8/clutter/clutter-score.h
|
||||
include/clutter-0.8/clutter/clutter-script.h
|
||||
include/clutter-0.8/clutter/clutter-scriptable.h
|
||||
include/clutter-0.8/clutter/clutter-shader.h
|
||||
include/clutter-0.8/clutter/clutter-stage-manager.h
|
||||
include/clutter-0.8/clutter/clutter-stage.h
|
||||
include/clutter-0.8/clutter/clutter-texture.h
|
||||
include/clutter-0.8/clutter/clutter-timeline.h
|
||||
include/clutter-0.8/clutter/clutter-timeout-pool.h
|
||||
include/clutter-0.8/clutter/clutter-types.h
|
||||
include/clutter-0.8/clutter/clutter-units.h
|
||||
include/clutter-0.8/clutter/clutter-util.h
|
||||
include/clutter-0.8/clutter/clutter-version.h
|
||||
include/clutter-0.8/clutter/clutter.h
|
||||
${PLIST.x11}include/clutter-0.8/clutter/glx/clutter-glx-texture-pixmap.h
|
||||
${PLIST.x11}include/clutter-0.8/clutter/glx/clutter-glx.h
|
||||
include/clutter-0.8/clutter/pangoclutter.h
|
||||
${PLIST.x11}include/clutter-0.8/clutter/x11/clutter-x11-enum-types.h
|
||||
${PLIST.x11}include/clutter-0.8/clutter/x11/clutter-x11-texture-pixmap.h
|
||||
${PLIST.x11}include/clutter-0.8/clutter/x11/clutter-x11.h
|
||||
include/clutter-0.8/cogl/cogl-defines-gl.h
|
||||
include/clutter-0.8/cogl/cogl.h
|
||||
${PLIST.x11}lib/libclutter-glx-0.8.la
|
||||
${PLIST.osx}lib/libclutter-osx-0.8.la
|
||||
lib/pkgconfig/clutter-0.8.pc
|
||||
${PLIST.x11}lib/pkgconfig/clutter-glx-0.8.pc
|
||||
${PLIST.osx}lib/pkgconfig/clutter-osx-0.8.pc
|
||||
${PLIST.x11}lib/pkgconfig/clutter-x11-0.8.pc
|
||||
share/gtk-doc/html/clutter-0.8/ClutterActor.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterAlpha.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterBehaviour.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterBehaviourBspline.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterBehaviourDepth.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterBehaviourEllipse.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterBehaviourOpacity.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterBehaviourPath.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterBehaviourRotate.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterBehaviourScale.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterChildMeta.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterCloneTexture.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterContainer.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterEntry.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterGroup.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterLabel.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterListModel.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterMedia.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterModel.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterModelIter.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterRectangle.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterScore.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterScript.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterShader.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterStage.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterTexture.html
|
||||
share/gtk-doc/html/clutter-0.8/ClutterTimeline.html
|
||||
share/gtk-doc/html/clutter-0.8/actor-box.png
|
||||
share/gtk-doc/html/clutter-0.8/alpha-func.png
|
||||
share/gtk-doc/html/clutter-0.8/building-clutter.html
|
||||
share/gtk-doc/html/clutter-0.8/ch01.html
|
||||
share/gtk-doc/html/clutter-0.8/ch02.html
|
||||
share/gtk-doc/html/clutter-0.8/ch03.html
|
||||
share/gtk-doc/html/clutter-0.8/ch04.html
|
||||
share/gtk-doc/html/clutter-0.8/ch05.html
|
||||
share/gtk-doc/html/clutter-0.8/ch06.html
|
||||
share/gtk-doc/html/clutter-0.8/ch07.html
|
||||
share/gtk-doc/html/clutter-0.8/ch08.html
|
||||
share/gtk-doc/html/clutter-0.8/ch09.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-0.8.devhelp
|
||||
share/gtk-doc/html/clutter-0.8/clutter-0.8.devhelp2
|
||||
share/gtk-doc/html/clutter-0.8/clutter-Clutter-Effects.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-ClutterBackend.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-ClutterScriptable.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-Colors.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-Events.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-Fixed-Point-Support.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-General.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-Unit-conversion.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-Utilities.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-Versioning-Macros.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-Win32-Specific-Support.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-X11-Specific-Support.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-animation-behaviours.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-animation-conclusion.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-animation-effects.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-animation-timelines.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-animations.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-overview.html
|
||||
share/gtk-doc/html/clutter-0.8/clutter-subclassing-ClutterActor.html
|
||||
share/gtk-doc/html/clutter-0.8/clutteranimation.html
|
||||
share/gtk-doc/html/clutter-0.8/clutterbase.html
|
||||
share/gtk-doc/html/clutter-0.8/creating-your-own-behaviours.html
|
||||
share/gtk-doc/html/clutter-0.8/event-flow.png
|
||||
share/gtk-doc/html/clutter-0.8/home.png
|
||||
share/gtk-doc/html/clutter-0.8/index.html
|
||||
share/gtk-doc/html/clutter-0.8/index.sgml
|
||||
share/gtk-doc/html/clutter-0.8/ix01.html
|
||||
share/gtk-doc/html/clutter-0.8/ix02.html
|
||||
share/gtk-doc/html/clutter-0.8/ix03.html
|
||||
share/gtk-doc/html/clutter-0.8/ix04.html
|
||||
share/gtk-doc/html/clutter-0.8/ix05.html
|
||||
share/gtk-doc/html/clutter-0.8/ix06.html
|
||||
share/gtk-doc/html/clutter-0.8/left.png
|
||||
share/gtk-doc/html/clutter-0.8/license.html
|
||||
share/gtk-doc/html/clutter-0.8/path-alpha-func.png
|
||||
share/gtk-doc/html/clutter-0.8/pt05.html
|
||||
share/gtk-doc/html/clutter-0.8/pt06.html
|
||||
share/gtk-doc/html/clutter-0.8/pt07.html
|
||||
share/gtk-doc/html/clutter-0.8/right.png
|
||||
share/gtk-doc/html/clutter-0.8/style.css
|
||||
share/gtk-doc/html/clutter-0.8/up.png
|
||||
share/gtk-doc/html/cogl-0.8/ch01.html
|
||||
share/gtk-doc/html/cogl-0.8/cogl-0.8.devhelp
|
||||
share/gtk-doc/html/cogl-0.8/cogl-0.8.devhelp2
|
||||
share/gtk-doc/html/cogl-0.8/cogl-General-API.html
|
||||
share/gtk-doc/html/cogl-0.8/cogl-Offscreen-Buffers.html
|
||||
share/gtk-doc/html/cogl-0.8/cogl-Primitives.html
|
||||
share/gtk-doc/html/cogl-0.8/cogl-Shaders-and-Programmable-Pipeline.html
|
||||
share/gtk-doc/html/cogl-0.8/cogl-Textures.html
|
||||
share/gtk-doc/html/cogl-0.8/cogl-Utility-API.html
|
||||
share/gtk-doc/html/cogl-0.8/home.png
|
||||
share/gtk-doc/html/cogl-0.8/index.html
|
||||
share/gtk-doc/html/cogl-0.8/index.sgml
|
||||
share/gtk-doc/html/cogl-0.8/ix01.html
|
||||
share/gtk-doc/html/cogl-0.8/left.png
|
||||
share/gtk-doc/html/cogl-0.8/license.html
|
||||
share/gtk-doc/html/cogl-0.8/right.png
|
||||
share/gtk-doc/html/cogl-0.8/style.css
|
||||
share/gtk-doc/html/cogl-0.8/up.png
|
|
@ -1,31 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.18 2013/06/06 12:53:48 wiz Exp $
|
||||
#
|
||||
|
||||
BUILDLINK_TREE+= clutter08
|
||||
|
||||
.if !defined(CLUTTER08_BUILDLINK3_MK)
|
||||
CLUTTER08_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.clutter08+= clutter08>=0.8.0
|
||||
BUILDLINK_ABI_DEPENDS.clutter08+= clutter08>=0.8.8nb17
|
||||
BUILDLINK_PKGSRCDIR.clutter08?= ../../graphics/clutter08
|
||||
|
||||
pkgbase := clutter08
|
||||
.include "../../mk/pkg-build-options.mk"
|
||||
|
||||
.if !empty(PKG_BUILD_OPTIONS.clutter08:Mx11)
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../x11/libXdamage/buildlink3.mk"
|
||||
.include "../../x11/libXfixes/buildlink3.mk"
|
||||
.include "../../x11/libXcomposite/buildlink3.mk"
|
||||
.include "../../x11/libXi/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.endif
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/pango/buildlink3.mk"
|
||||
.include "../../textproc/json-glib/buildlink3.mk"
|
||||
.endif # CLUTTER08_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -clutter08
|
|
@ -1,11 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.4 2013/05/30 15:35:46 joerg Exp $
|
||||
|
||||
SHA1 (clutter-0.8.8.tar.gz) = 560e127b99494131ec3b901f53bd93d6809d79ea
|
||||
RMD160 (clutter-0.8.8.tar.gz) = 400c97617cd26ae9e338cedddce8b67bc3fe4293
|
||||
Size (clutter-0.8.8.tar.gz) = 2153665 bytes
|
||||
SHA1 (patch-aa) = 639cd5709b8423ccd5c42b77231fefaaa9af072d
|
||||
SHA1 (patch-ab) = 4aa8988640df604f727a45229d2f9b0326df069d
|
||||
SHA1 (patch-clutter_Makefile.am) = 47fa8731d7f621512e799e2cae009fa9af4ac847
|
||||
SHA1 (patch-clutter_Makefile.in) = 0d707044acbd28e7aae8de19e03f1e95f30ecd60
|
||||
SHA1 (patch-clutter_clutter-script-private.h) = 381c7f05f9b4389100915828dabe03159f767e31
|
||||
SHA1 (patch-clutter_clutter-script.c) = ab712d9e8440477417238a66a2546a38e046c765
|
|
@ -1,33 +0,0 @@
|
|||
# $NetBSD: options.mk,v 1.1.1.1 2009/10/26 08:30:16 obache Exp $
|
||||
#
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.clutter
|
||||
PKG_SUPPORTED_OPTIONS= x11
|
||||
PKG_SUGGESTED_OPTIONS= x11
|
||||
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
PLIST_VARS+= x11 osx
|
||||
|
||||
.if !empty(PKG_OPTIONS:Mx11)
|
||||
PLIST.x11= yes
|
||||
CONFIGURE_ARGS+= --with-x
|
||||
CONFIGURE_ARGS+= --with-flavour=glx
|
||||
CONFIGURE_ARGS+= --with-imagebackend=gdk-pixbuf
|
||||
BUILDLINK_API_DEPENDS.MesaLib+= MesaLib>=7.0
|
||||
.include "../../graphics/MesaLib/buildlink3.mk"
|
||||
.include "../../x11/libX11/buildlink3.mk"
|
||||
.include "../../x11/libXdamage/buildlink3.mk"
|
||||
.include "../../x11/libXfixes/buildlink3.mk"
|
||||
.include "../../x11/libXcomposite/buildlink3.mk"
|
||||
.include "../../x11/libXi/buildlink3.mk"
|
||||
.include "../../x11/gtk2/buildlink3.mk"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --without-x
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
. if ${OPSYS} == Darwin
|
||||
PLIST.osx= yes
|
||||
CONFIGURE_ARGS+= --with-flavour=osx
|
||||
CONFIGURE_ARGS+= --with-imagebackend=quartz
|
||||
. endif
|
||||
.endif
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/10/26 08:30:16 obache Exp $
|
||||
|
||||
--- clutter/clutter-json.h.in.orig 2008-12-10 22:44:39.000000000 +0000
|
||||
+++ clutter/clutter-json.h.in
|
||||
@@ -6,8 +6,6 @@
|
||||
* without changing the other headers.
|
||||
*/
|
||||
|
||||
-#include "@JSON_PREFIX@/json-types.h"
|
||||
-#include "@JSON_PREFIX@/json-parser.h"
|
||||
-#include "@JSON_PREFIX@/json-generator.h"
|
||||
+#include "@JSON_PREFIX@/json-glib.h"
|
||||
|
||||
#endif /* __CLUTTER_JSON_H__ */
|
|
@ -1,36 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2010/05/25 07:25:44 obache Exp $
|
||||
|
||||
falls back to gmodule, same as clutter-1.x.
|
||||
|
||||
--- clutter/cogl/gl/cogl.c.orig 2009-02-20 15:41:39.000000000 +0000
|
||||
+++ clutter/cogl/gl/cogl.c
|
||||
@@ -82,6 +82,7 @@ _cogl_error_string(GLenum errorCode)
|
||||
CoglFuncPtr
|
||||
cogl_get_proc_address (const gchar* name)
|
||||
{
|
||||
+ static GModule *module = NULL;
|
||||
/* Sucks to ifdef here but not other option..? would be nice to
|
||||
* split the code up for more reuse (once more backends use this
|
||||
*/
|
||||
@@ -122,11 +123,10 @@ cogl_get_proc_address (const gchar* name
|
||||
|
||||
return (CoglFuncPtr) wglGetProcAddress ((LPCSTR) name);
|
||||
|
||||
-#else /* HAVE_CLUTTER_WIN32 */
|
||||
+#endif /* HAVE_CLUTTER_WIN32 */
|
||||
|
||||
/* this should find the right function if the program is linked against a
|
||||
* library providing it */
|
||||
- static GModule *module = NULL;
|
||||
if (module == NULL)
|
||||
module = g_module_open (NULL, G_MODULE_BIND_LAZY | G_MODULE_BIND_LOCAL);
|
||||
|
||||
@@ -138,8 +138,6 @@ cogl_get_proc_address (const gchar* name
|
||||
return symbol;
|
||||
}
|
||||
|
||||
-#endif /* HAVE_CLUTTER_WIN32 */
|
||||
-
|
||||
return NULL;
|
||||
}
|
||||
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-clutter_Makefile.am,v 1.1 2012/02/03 01:18:09 sbd Exp $
|
||||
|
||||
--- clutter/Makefile.am.orig 2009-02-20 15:41:39.000000000 +0000
|
||||
+++ clutter/Makefile.am
|
||||
@@ -27,7 +27,6 @@ INCLUDES = \
|
||||
-DCLUTTER_LIBDIR=\""$(libdir)"\" \
|
||||
-DCLUTTER_DATADIR=\""$(datadir)"\" \
|
||||
-DCLUTTER_COMPILATION=1 \
|
||||
- -DG_DISABLE_DEPRECATED \
|
||||
-DG_LOG_DOMAIN=\"Clutter\" \
|
||||
$(GCC_FLAGS) \
|
||||
$(CLUTTER_CFLAGS) \
|
|
@ -1,12 +0,0 @@
|
|||
$NetBSD: patch-clutter_Makefile.in,v 1.1 2012/02/03 01:18:09 sbd Exp $
|
||||
|
||||
--- clutter/Makefile.in.orig 2009-02-20 15:58:02.000000000 +0000
|
||||
+++ clutter/Makefile.in
|
||||
@@ -296,7 +296,6 @@ INCLUDES = \
|
||||
-DCLUTTER_LIBDIR=\""$(libdir)"\" \
|
||||
-DCLUTTER_DATADIR=\""$(datadir)"\" \
|
||||
-DCLUTTER_COMPILATION=1 \
|
||||
- -DG_DISABLE_DEPRECATED \
|
||||
-DG_LOG_DOMAIN=\"Clutter\" \
|
||||
$(GCC_FLAGS) \
|
||||
$(CLUTTER_CFLAGS) \
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-clutter_clutter-script-private.h,v 1.1 2013/05/30 15:35:46 joerg Exp $
|
||||
|
||||
--- clutter/clutter-script-private.h.orig 2013-05-29 19:54:53.000000000 +0000
|
||||
+++ clutter/clutter-script-private.h
|
||||
@@ -27,7 +27,7 @@
|
||||
#define __CLUTTER_SCRIPT_PRIVATE_H__
|
||||
|
||||
#include <glib-object.h>
|
||||
-#include "json/json-types.h"
|
||||
+#include <json-glib/json-glib.h>
|
||||
#include "clutter-color.h"
|
||||
#include "clutter-types.h"
|
||||
#include "clutter-script.h"
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-clutter_clutter-script.c,v 1.1 2013/05/30 15:35:46 joerg Exp $
|
||||
|
||||
--- clutter/clutter-script.c.orig 2013-05-29 19:56:00.000000000 +0000
|
||||
+++ clutter/clutter-script.c
|
||||
@@ -183,7 +183,7 @@
|
||||
#include "clutter-private.h"
|
||||
#include "clutter-debug.h"
|
||||
|
||||
-#include "json/json-parser.h"
|
||||
+#include <json-glib/json-glib.h>
|
||||
|
||||
enum
|
||||
{
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.211 2013/06/13 13:47:25 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.212 2013/06/13 14:01:34 obache Exp $
|
||||
#
|
||||
|
||||
COMMENT= Multimedia utilities
|
||||
|
@ -14,7 +14,6 @@ SUBDIR+= bsdav
|
|||
SUBDIR+= ccxstream
|
||||
SUBDIR+= cfourcc
|
||||
SUBDIR+= clutter-gst
|
||||
SUBDIR+= clutter08-gst
|
||||
SUBDIR+= deforaos-player
|
||||
SUBDIR+= dirac
|
||||
SUBDIR+= divxplayer
|
||||
|
|
|
@ -1,14 +0,0 @@
|
|||
Clutter-GStreamer (clutter-gst) is an integration library for using GStreamer
|
||||
with Clutter.
|
||||
|
||||
Clutter is an open source software library for creating fast, visually
|
||||
rich and animated graphical user interfaces. It uses OpenGL for drawing
|
||||
primitives and has multiple backends, allowing its usage on different
|
||||
platforms.
|
||||
|
||||
GStreamer is a streaming media framework, based on graphs of filters
|
||||
which operate on media data. Applications using this library can do
|
||||
anything from real-time sound processing to playing videos, and just
|
||||
about anything else media-related. Its plugin-based architecture means
|
||||
that new data types or processing capabilities can be added simply by
|
||||
installing new plug-ins.
|
|
@ -1,30 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.19 2013/06/06 12:53:51 wiz Exp $
|
||||
#
|
||||
|
||||
DISTNAME= clutter-gst-0.8.0
|
||||
PKGNAME= ${DISTNAME:S/clutter/clutter08/}
|
||||
PKGREVISION= 17
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://www.clutter-project.org/sources/clutter-gst/0.8/
|
||||
|
||||
MAINTAINER= obache@NetBSD.org
|
||||
HOMEPAGE= http://www.clutter-project.org/
|
||||
COMMENT= Clutter GStreamer integration
|
||||
LICENSE= gnu-lgpl-v2.1
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config
|
||||
|
||||
# Workaround for Upstream Bug#562310.
|
||||
# for more detail, see also PR#41475.
|
||||
TOOLS_NOOP+= gtkdoc-rebase
|
||||
|
||||
MAKE_ENV+= DOC_MODULE_VERSION=0.8
|
||||
|
||||
PKGCONFIG_OVERRIDE+= clutter-gst.pc.in
|
||||
|
||||
.include "../../graphics/clutter08/buildlink3.mk"
|
||||
.include "../../multimedia/gstreamer0.10/buildlink3.mk"
|
||||
.include "../../multimedia/gst-plugins0.10-base/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
|
@ -1,27 +0,0 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2009/10/26 08:35:18 obache Exp $
|
||||
include/clutter-0.8/clutter-gst/clutter-gst-audio.h
|
||||
include/clutter-0.8/clutter-gst/clutter-gst-shaders.h
|
||||
include/clutter-0.8/clutter-gst/clutter-gst-util.h
|
||||
include/clutter-0.8/clutter-gst/clutter-gst-version.h
|
||||
include/clutter-0.8/clutter-gst/clutter-gst-video-sink.h
|
||||
include/clutter-0.8/clutter-gst/clutter-gst-video-texture.h
|
||||
include/clutter-0.8/clutter-gst/clutter-gst.h
|
||||
lib/libclutter-gst-0.8.la
|
||||
lib/pkgconfig/clutter-gst-0.8.pc
|
||||
share/gtk-doc/html/clutter-gst-0.8/ClutterGstAudio.html
|
||||
share/gtk-doc/html/clutter-gst-0.8/ClutterGstVideoSink.html
|
||||
share/gtk-doc/html/clutter-gst-0.8/ClutterGstVideoTexture.html
|
||||
share/gtk-doc/html/clutter-gst-0.8/ch01.html
|
||||
share/gtk-doc/html/clutter-gst-0.8/ch02.html
|
||||
share/gtk-doc/html/clutter-gst-0.8/clutter-gst-Utilities.html
|
||||
share/gtk-doc/html/clutter-gst-0.8/clutter-gst-Versioning-Macros.html
|
||||
share/gtk-doc/html/clutter-gst-0.8/clutter-gst.devhelp
|
||||
share/gtk-doc/html/clutter-gst-0.8/clutter-gst.devhelp2
|
||||
share/gtk-doc/html/clutter-gst-0.8/home.png
|
||||
share/gtk-doc/html/clutter-gst-0.8/index.html
|
||||
share/gtk-doc/html/clutter-gst-0.8/index.sgml
|
||||
share/gtk-doc/html/clutter-gst-0.8/left.png
|
||||
share/gtk-doc/html/clutter-gst-0.8/license.html
|
||||
share/gtk-doc/html/clutter-gst-0.8/right.png
|
||||
share/gtk-doc/html/clutter-gst-0.8/style.css
|
||||
share/gtk-doc/html/clutter-gst-0.8/up.png
|
|
@ -1,18 +0,0 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.19 2013/06/06 12:53:51 wiz Exp $
|
||||
#
|
||||
|
||||
BUILDLINK_TREE+= clutter08-gst
|
||||
|
||||
.if !defined(CLUTTER08_GST_BUILDLINK3_MK)
|
||||
CLUTTER08_GST_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.clutter08-gst+= clutter08-gst>=0.8.0
|
||||
BUILDLINK_ABI_DEPENDS.clutter08-gst+= clutter08-gst>=0.8.0nb17
|
||||
BUILDLINK_PKGSRCDIR.clutter08-gst?= ../../multimedia/clutter08-gst
|
||||
|
||||
.include "../../graphics/clutter08/buildlink3.mk"
|
||||
.include "../../multimedia/gstreamer0.10/buildlink3.mk"
|
||||
.include "../../multimedia/gst-plugins0.10-base/buildlink3.mk"
|
||||
.endif # CLUTTER08_GST_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -clutter08-gst
|
|
@ -1,7 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.2 2012/06/25 11:52:46 joerg Exp $
|
||||
|
||||
SHA1 (clutter-gst-0.8.0.tar.gz) = bcf485769a11f453a73a3c8b2499c5cf91fdc2d4
|
||||
RMD160 (clutter-gst-0.8.0.tar.gz) = ab872ff32d0b4f360fcc50a22a1d3e754fa3b8bf
|
||||
Size (clutter-gst-0.8.0.tar.gz) = 496402 bytes
|
||||
SHA1 (patch-aa) = 66babe3f1177fb5f8cc4d4d939f65e5797f6e2e7
|
||||
SHA1 (patch-examples_video-player.c) = 2e2b8fb92cca81983bf7f3eda28ba31edb71293d
|
|
@ -1,22 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2009/10/26 08:35:18 obache Exp $
|
||||
|
||||
--- doc/reference/Makefile.in.orig 2008-07-18 13:16:50.000000000 +0000
|
||||
+++ doc/reference/Makefile.in
|
||||
@@ -542,13 +542,14 @@ install-data-local:
|
||||
if test "$$installfiles" = '$(srcdir)/html/*'; \
|
||||
then echo '-- Nothing to install' ; \
|
||||
else \
|
||||
- $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR); \
|
||||
+ installdir=${DESTDIR}${TARGET_DIR}-$(DOC_MODULE_VERSION); \
|
||||
+ $(mkinstalldirs) $${installdir}; \
|
||||
for i in $$installfiles; do \
|
||||
echo '-- Installing '$$i ; \
|
||||
- $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
|
||||
+ $(INSTALL_DATA) $$i $${installdir}; \
|
||||
done; \
|
||||
echo '-- Installing $(srcdir)/html/index.sgml' ; \
|
||||
- $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
|
||||
+ $(INSTALL_DATA) $(srcdir)/html/index.sgml $${installdir} || :; \
|
||||
which gtkdoc-rebase >/dev/null && \
|
||||
gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
|
||||
fi
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-examples_video-player.c,v 1.1 2012/06/25 11:52:46 joerg Exp $
|
||||
|
||||
--- examples/video-player.c.orig 2012-06-18 16:44:11.000000000 +0000
|
||||
+++ examples/video-player.c
|
||||
@@ -139,7 +139,7 @@ input_cb (ClutterStage *stage,
|
||||
if (actor == app->control_pause || actor == app->control_play)
|
||||
{
|
||||
toggle_pause_state (app);
|
||||
- return;
|
||||
+ return FALSE;
|
||||
}
|
||||
|
||||
if (actor == app->control_seek1
|
Loading…
Reference in a new issue