py-iso8601: fix Python 3.6 build
This commit is contained in:
parent
07c7375011
commit
3a9957f088
2 changed files with 18 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.5 2020/09/14 07:36:25 adam Exp $
|
||||
$NetBSD: distinfo,v 1.6 2020/09/16 03:00:37 gutteridge Exp $
|
||||
|
||||
SHA1 (iso8601-0.1.13.tar.gz) = afae97b918ae0d3714dac485ddad822d3c693955
|
||||
RMD160 (iso8601-0.1.13.tar.gz) = af366917acf562295251bf6775d0c3acffb75844
|
||||
SHA512 (iso8601-0.1.13.tar.gz) = 0a16e2699ba3f33cec57acdd2be70c64d0e2655f08d30581f56997992945b700e6bfb14164f1f422e073eefeaefab4377a56ec6b3800156347e1568172c32737
|
||||
Size (iso8601-0.1.13.tar.gz) = 12205 bytes
|
||||
SHA1 (patch-setup.py) = b481fec7957732797c377880a585dd8d146e51da
|
||||
|
|
16
time/py-iso8601/patches/patch-setup.py
Normal file
16
time/py-iso8601/patches/patch-setup.py
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-setup.py,v 1.1 2020/09/16 03:00:37 gutteridge Exp $
|
||||
|
||||
Fix packaging with Python 3.6. Taken from upstream commit:
|
||||
https://github.com/micktwomey/pyiso8601/commit/b5544878bc799bdd77d63d3c9e78c4fcc4e018ad
|
||||
|
||||
--- setup.py.orig 2020-09-11 17:04:56.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -5,7 +5,7 @@ try:
|
||||
except ImportError:
|
||||
from distutils import setup
|
||||
|
||||
-long_description = open(os.path.join(os.path.dirname(__file__), "README.rst")).read()
|
||||
+long_description = open(os.path.join(os.path.dirname(__file__), "README.rst"), "rb").read().decode("UTF-8")
|
||||
|
||||
setup(
|
||||
name="iso8601",
|
Loading…
Reference in a new issue