slightly better shm_open check fix

This commit is contained in:
dbj 2016-03-06 19:41:24 +00:00
parent 8f5d6b0d1a
commit 3aafc198b9
2 changed files with 8 additions and 9 deletions

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.112 2016/03/06 09:55:58 dbj Exp $
$NetBSD: distinfo,v 1.113 2016/03/06 19:41:24 dbj Exp $
SHA1 (qemu-2.5.0.tar.bz2) = ed6c02a267f9edf98058743f0f76a25743a0dfe7
RMD160 (qemu-2.5.0.tar.bz2) = 51007a50ddbeae1ba2c986e0cb0b110efeae2dc9
SHA512 (qemu-2.5.0.tar.bz2) = 12153f94cc7f834fd6a85f25690c36f2331d88d414426fb8b9ac20a34e6f9222b1eda30b727674af583580fae90dfd6d0614a905dce1567d94cd049d426b9dd3
Size (qemu-2.5.0.tar.bz2) = 25464996 bytes
SHA1 (patch-Makefile.objs) = 81274d0dde593a8379428df1f974d6c50a65dd92
SHA1 (patch-configure) = fb89393c1f45b24cb7a85d53a516050b2249e8c9
SHA1 (patch-configure) = c15a44d127d7bdd82285d0b81b710cef7ad81e83
SHA1 (patch-default-configs_pci.mak) = 09567d0d56cdee3d72ae93c0609dee7ca749ef18
SHA1 (patch-ef) = 6e57de87f91067e8a9a1388c91133a31b3582b3a
SHA1 (patch-et) = e9b850ac5985cbe934b541acbfdb330cce421d50

View file

@ -1,4 +1,4 @@
$NetBSD: patch-configure,v 1.10 2016/03/06 09:55:58 dbj Exp $
$NetBSD: patch-configure,v 1.11 2016/03/06 19:41:24 dbj Exp $
Don't use gld on SunOS
add check for shm_open
@ -13,7 +13,7 @@ add check for shm_open
smbd="${SMBD-/usr/sfw/sbin/smbd}"
needs_libsunmath="no"
solarisrev=`uname -r | cut -f2 -d.`
@@ -3672,6 +3671,28 @@ if compile_prog "" "" ; then
@@ -3672,6 +3671,27 @@ if compile_prog "" "" ; then
fallocate_zero_range=yes
fi
@ -33,8 +33,7 @@ add check for shm_open
+EOF
+if compile_prog "" "" ; then
+ shm_open=yes
+fi
+if compile_prog "" "-lrt" ; then
+elif compile_prog "" "-lrt" ; then
+ LIBS="$LIBS -lrt"
+ shm_open=yes
+fi
@ -42,7 +41,7 @@ add check for shm_open
# check for posix_fallocate
posix_fallocate=no
cat > $TMPC << EOF
@@ -3935,8 +3956,13 @@ fi
@@ -3935,8 +3955,13 @@ fi
cat > $TMPC <<EOF
#include <signal.h>
#include <time.h>
@ -56,7 +55,7 @@ add check for shm_open
return clock_gettime(CLOCK_REALTIME, NULL);
}
EOF
@@ -4568,7 +4594,9 @@ if test "$want_tools" = "yes" ; then
@@ -4568,7 +4593,9 @@ if test "$want_tools" = "yes" ; then
tools="qemu-img\$(EXESUF) qemu-io\$(EXESUF) $tools"
if [ "$linux" = "yes" -o "$bsd" = "yes" -o "$solaris" = "yes" ] ; then
tools="qemu-nbd\$(EXESUF) $tools"
@ -67,7 +66,7 @@ add check for shm_open
fi
fi
if test "$softmmu" = yes ; then
@@ -5049,6 +5077,9 @@ fi
@@ -5049,6 +5076,9 @@ fi
if test "$fallocate_zero_range" = "yes" ; then
echo "CONFIG_FALLOCATE_ZERO_RANGE=y" >> $config_host_mak
fi