Update nmap to 3.00. Changes:

* Added protocol scan (-sO), which determines what IP protocols
      (TCP, IGMP, GRE, UDP, ICMP, etc) are supported by a given host.
      This uses a clever technique designed and implemented by Gerhard
      Rieger .
    * Nmap now recognizes more than 700 operating system versions and
      network devices (printers, webcams, routers, etc) thanks to
      thousands of contributions from the user community! Many
      operating systems were even recognized by Nmap prior to their
      official release. Nmap3 also recognizes 2148 port assignments,
      451 SunRPC services, and 144 IP protocols.
    * Added Idlescan (-sI), which bounces the scan off a "zombie"
      machine. This can be used to bypass certain (poorly configured)
      firewalls and packet filters. In addition, this is the most
      stealthy Nmap scan mode, as no packets are sent to the target
      from your true IP address.
    * The base Nmap package now builds and functions under Windows! It
      is distributed in three forms: build-it-yourself source code, a
      simple command-line package, or along with a nice GUI interface
      (NmapWin) and a fancy installer. This is due to the hard work of
      Ryan Permeh (from eEye), Andy Lutomirski, and Jens Vogt.
    * Mac OS X is now supported, as well as the latest versions of
      Linux, OpenBSD, Solaris, FreeBSD, and most other UNIX platforms.
      Nmap has also been ported to several handheld devices -- see the
      Related Projects page for further information.
    * XML output (-oX) is now available for smooth interoperability
      between Nmap and other tools.
    * Added ICMP Timestamp and Netmask ping types (-PP and -PM). These
      (especially timestamp) can be useful against some hosts that do
      not respond to normal ping (-PI) packets. Nmap still allows TCP
      "ping" as well.
    * Nmap can now detect the uptime of many hosts when the OS Scan
      option (-O) is used.
    * Several new tests have been added to make OS detection more
      accurate and provide more granular version information.
    * Removed 128.210.*.* addresses from Nmap man page examples due to
      complaints from Purdue security staff.
    * The --data_length option was added, allowing for longer probe
      packets. Among other uses, this defeats certain simplistic IDS
      signatures.
    * You can now specify distinct port UDP and TCP port numbers in a
      single scan command using a command like 'nmap -sSU -p
      U:53,111,137,T:21-25,80,139,515,6000,8080 target.com'. See the
      man page for more usage info.
    * Added mysterious, undocumented --scanflags and --fuzzy options.
    * Nmap now provides IPID as well as TCP ISN sequence
      predictability reports if you use -v and -O.
    * SYN scan is now the default scan type for privileged (root)
      users. This is usually offers greater performance while reducing
      network traffic.
    * Capitalized all references to God in error messages.
    * Added List scan (-sL) which enumerates targets without scanning
      them.
    * The Nmap "random IP" scanning mode is now smart enough to skip
      many unallocated netblocks.
    * Tons of more minor features, bugfixes, and portability enhancements.
This commit is contained in:
hubertf 2002-08-03 12:23:57 +00:00
parent e7adfda4c1
commit 3b198b7b76
9 changed files with 62 additions and 97 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.16 2001/09/10 17:04:37 wiz Exp $
# $NetBSD: Makefile,v 1.17 2002/08/03 12:23:57 hubertf Exp $
#
DISTNAME= nmap-2.53
DISTNAME= nmap-3.00
CATEGORIES= net security
MASTER_SITES= http://www.insecure.org/nmap/dist/
EXTRACT_SUFX= .tgz
@ -10,9 +10,11 @@ MAINTAINER= hubertf@netbsd.org
HOMEPAGE= http://www.insecure.org/nmap/index.html
COMMENT= Network/port scanner with OS detection
GNU_CONFIGURE= YES
HAS_CONFIGURE= YES
CONFIGURE_ENV+= INSTALL=${INSTALL}
CONFIGURE_ENV+= GTK_CONFIG=no
CONFIGURE_ARGS+=--with-libpcap=${BUILDLINK_DIR}
CONFIGURE_ARGS+=--prefix=${PREFIX}
.include "../../mk/bsd.prefs.mk"

View file

@ -1,7 +1,8 @@
@comment $NetBSD: PLIST,v 1.1 2001/10/31 22:56:57 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2002/08/03 12:23:57 hubertf Exp $
bin/nmap
share/nmap/nmap-os-fingerprints
share/nmap/nmap-services
share/nmap/nmap-rpc
@dirrm share/nmap
man/man1/nmap.1
share/nmap/nmap-os-fingerprints
share/nmap/nmap-protocols
share/nmap/nmap-rpc
share/nmap/nmap-services
@dirrm share/nmap

View file

@ -1,10 +1,8 @@
$NetBSD: distinfo,v 1.5 2001/12/06 14:51:07 rafal Exp $
$NetBSD: distinfo,v 1.6 2002/08/03 12:23:58 hubertf Exp $
SHA1 (nmap-2.53.tgz) = 208979028c8b02e882e452e94280f09bc617490f
Size (nmap-2.53.tgz) = 584385 bytes
SHA1 (patch-aa) = e669fe70e3d6102bcfad2328c7329733d6795b09
SHA1 (patch-ab) = 691a4b1a226a93ae3d4f52ad96bebacaed9dd452
SHA1 (patch-ac) = 59fbb788a76f53a99bc411ba44f514d694990852
SHA1 (patch-ad) = 3f9d55ec44fa017f77d7e042185bdc3cfcc3fefa
SHA1 (patch-ae) = 3f9d04156506a9df3b55bba0c7da4ff772478302
SHA1 (patch-af) = 3225b7698640cb142f6c45ef48ea2677efe793ba
SHA1 (nmap-3.00.tgz) = 7c51c4013bf70c223b81af5a5a171fc9af011df2
Size (nmap-3.00.tgz) = 922293 bytes
SHA1 (patch-aa) = baa9ef7b31f8e1c74c9acdf17a71517bfc262de1
SHA1 (patch-ab) = 590271ab5edd85ec8304ae5ee2248c8249b42195
SHA1 (patch-ad) = 28a0bc76dbb8fd271c52f26f2b1d95152da129d7
SHA1 (patch-af) = e4a0ed033d2931b4e3bd7d9897d3ee079585ef54

View file

@ -1,27 +1,26 @@
$NetBSD: patch-aa,v 1.7 2001/08/24 11:23:16 abs Exp $
$NetBSD: patch-aa,v 1.8 2002/08/03 12:23:59 hubertf Exp $
--- Makefile.in.orig Tue May 9 07:25:42 2000
--- Makefile.in.orig Sun Jul 28 05:48:15 2002
+++ Makefile.in
@@ -12,8 +12,9 @@
@@ -14,8 +14,8 @@
NBASEDIR=@NBASEDIR@
CC = @CC@
CCOPT =
-LIBPCAPDIR = @libpcapdir@
-INCLS = -I. -I$(LIBPCAPDIR)
-INCLS = -I$(LIBPCAPDIR)
+#LIBPCAPDIR = @libpcapdir@
+INCLS = -I.
+#INCLS += -I$(LIBPCAPDIR)
DEFS = @DEFS@ -DNMAP_VERSION=\"$(NMAP_VERSION)\" -DNMAP_NAME=\"$(NMAP_NAME)\" -DNMAP_URL=\"$(NMAP_URL)\" -DNMAPDATADIR=\"$(nmapdatadir)\"
CFLAGS = @CFLAGS@ $(CCOPT) $(DEFS) $(INCLS)
DEFS = @DEFS@ -DNMAP_VERSION=\"$(NMAP_VERSION)\" -DNMAP_NAME=\"$(NMAP_NAME)\" -DNMAP_URL=\"$(NMAP_URL)\" -DNMAP_PLATFORM=\"$(NMAP_PLATFORM)\" -DNMAPDATADIR=\"$(nmapdatadir)\"
CFLAGS = -g @CFLAGS@ $(CCOPT) $(DEFS) $(INCLS)
# CFLAGS = -g -Wall $(DEFS) $(INCLS)
@@ -36,15 +37,15 @@
@@ -37,15 +37,15 @@
DEPS = nmap.h error.h targets.h osscan.h tcpip.h utils.h global_structures.h charpool.h services.h rpc.h portlist.h
DEPS = nmap.h nmap_error.h targets.h idle_scan.h osscan.h output.h scan_engine.h timing.h tcpip.h utils.h global_structures.h charpool.h services.h protocols.h nmap_rpc.h portlist.h
-all: $(TARGET) nmapfe/nmapfe
+all: $(TARGET)
+all: $(TARGET) #HF#nmapfe/nmapfe
$(TARGET): $(DEPS) @PCAP_DEPENDS@ $(OBJS)
$(TARGET): $(DEPS) @PCAP_DEPENDS@ $(NBASEDIR)/libnbase.a $(OBJS)
@echo Compiling nmap
rm -f $@
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS)
@ -31,9 +30,9 @@ $NetBSD: patch-aa,v 1.7 2001/08/24 11:23:16 abs Exp $
+#$(LIBPCAPDIR)/libpcap.a: $(LIBPCAPDIR)/Makefile
+# @echo Compiling libpcap; cd $(LIBPCAPDIR); $(MAKE)
#$(LIBPCAPDIR)/Makefile:
# @echo Configuring libpcap; cd $(LIBPCAPDIR); ./configure
@@ -140,7 +141,7 @@
$(NBASEDIR)/libnbase.a: $(NBASEDIR)/Makefile
@echo Compiling libnbase;
@@ -174,7 +174,7 @@
$(MAKEDEPEND) $(INCLS) -s "# DO NOT DELETE" -- $(DEFS) -- $(SRCS)
install: $(TARGET)

View file

@ -1,12 +1,12 @@
$NetBSD: patch-ab,v 1.5 2001/08/24 11:23:16 abs Exp $
$NetBSD: patch-ab,v 1.6 2002/08/03 12:23:59 hubertf Exp $
--- configure.orig Tue May 9 07:27:48 2000
--- configure.orig Sat Jul 20 09:48:46 2002
+++ configure
@@ -1507,6 +1507,7 @@
@@ -3450,6 +3450,7 @@
extern char pcap_version[];
int main() {
int major, minor;
+ exit(0); /*fool it*/
sscanf(pcap_version,"%d.%d", &major, &minor);
if (major > 0)
if (major > 0)
exit(0);

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ac,v 1.3 2001/08/24 11:23:16 abs Exp $
--- libpcap-possiblymodified/bpf/net/bpf.h.orig Wed Oct 14 22:27:16 1998
+++ libpcap-possiblymodified/bpf/net/bpf.h
@@ -52,7 +52,7 @@
* Alignment macros. BPF_WORDALIGN rounds up to the next
* even multiple of BPF_ALIGNMENT.
*/
-#define BPF_ALIGNMENT sizeof(bpf_int32)
+#define BPF_ALIGNMENT sizeof(long)
#define BPF_WORDALIGN(x) (((x)+(BPF_ALIGNMENT-1))&~(BPF_ALIGNMENT-1))
#define BPF_MAXINSNS 512

View file

@ -1,20 +1,20 @@
$NetBSD: patch-ad,v 1.3 2001/08/24 11:23:17 abs Exp $
$NetBSD: patch-ad,v 1.4 2002/08/03 12:24:00 hubertf Exp $
--- nmap-services.orig Tue May 9 07:21:44 2000
--- nmap-services.orig Sat Jul 20 11:19:26 2002
+++ nmap-services
@@ -1725,7 +1725,7 @@
@@ -1748,7 +1748,7 @@
dls-monitor 2048/udp #
nfs 2049/tcp # networked file system
nfs 2049/udp # networked file system
-distrib-netassholes 2064/tcp # A group of lamers working on a silly closed-source client for solving the RSA cryptographic challenge. This is the keyblock proxy port.
-distrib-net-losers 2064/tcp # A group of lamers working on a silly closed-source client for solving the RSA cryptographic challenge. This is the keyblock proxy port.
+distrib-net-kbproxy 2064/tcp # keyblock proxy port for distributed.net-clients
knetd 2053/tcp #
dlsrpn 2065/tcp # Data Link Switch Read Port Number
dlsrpn 2065/udp # Data Link Switch Read Port Number
dlswpn 2067/tcp # Data Link Switch Write Port Number
@@ -1783,7 +1783,7 @@
deslogind 3006/tcp #
@@ -1809,7 +1809,7 @@
cfs 3049/tcp # cryptographic file system (nfs) (proposed)
cfs 3049/udp # cryptographic file system (nfs)
PowerChute 3052/tcp
-distrib-net-proxy 3064/tcp # Stupid closed source distributed.net project proxy port
+distrib-net-proxy 3064/tcp # distributed.net project proxy port
sj3 3086/tcp # SJ3 (kanji input)

View file

@ -1,17 +0,0 @@
$NetBSD: patch-ae,v 1.3 2001/08/24 11:23:17 abs Exp $
--- tcpip.c.orig Sun Apr 30 01:12:24 2000
+++ tcpip.c
@@ -995,6 +995,12 @@
#ifdef DLT_PPP_BSDOS
case DLT_PPP_BSDOS:
#endif
+#ifdef DLT_PPP_SERIAL
+ case DLT_PPP_SERIAL:
+#endif
+#ifdef DLT_PPP_ETHER
+ case DLT_PPP_ETHER:
+#endif
#if (FREEBSD || OPENBSD || NETBSD || BSDI)
offset = 4;
#else

View file

@ -1,25 +1,20 @@
$NetBSD: patch-af,v 1.1 2001/12/06 14:49:33 rafal Exp $
$NetBSD: patch-af,v 1.2 2002/08/03 12:24:01 hubertf Exp $
--- config.sub.orig Thu Jun 14 12:19:01 2001
+++ config.sub Thu Jun 14 12:20:44 2001
@@ -154,7 +154,8 @@
| 580 | i960 | h8300 | hppa | hppa1.0 | hppa1.1 | hppa2.0 \
| alpha | alphaev5 | alphaev56 | we32k | ns16k | clipper \
| i370 | sh | powerpc | powerpcle | 1750a | dsp16xx | pdp11 \
- | mips64 | mipsel | mips64el | mips64orion | mips64orionel \
+ | mips64 | mipsel | mips64el | mipseb \
+ | mips64orion | mips64orionel \
| mipstx39 | mipstx39el \
| sparc | sparclet | sparclite | sparc64 | v850)
basic_machine=$basic_machine-unknown
@@ -179,8 +180,8 @@
| alpha-* | alphaev5-* | alphaev56-* | we32k-* | cydra-* \
| ns16k-* | pn-* | np1-* | xps100-* | clipper-* | orion-* \
| sparclite-* | pdp11-* | sh-* | powerpc-* | powerpcle-* \
- | sparc64-* | mips64-* | mipsel-* \
- | mips64el-* | mips64orion-* | mips64orionel-* \
+ | sparc64-* | mips64-* | mipseb-* \
+ | mipsel-* | mips64el-* | mips64orion-* | mips64orionel-* \
| mipstx39-* | mipstx39el-* \
| f301-*)
;;
--- config.sub.orig Mon Jul 1 07:56:09 2002
+++ config.sub
@@ -236,6 +236,7 @@
| i370 | i860 | i960 | ia64 \
| m32r | m68000 | m68k | m88k | mcore \
| mips | mips16 | mips64 | mips64el | mips64orion | mips64orionel \
+ | mipseb | mipsel \
| mips64vr4100 | mips64vr4100el | mips64vr4300 \
| mips64vr4300el | mips64vr5000 | mips64vr5000el \
| mipsbe | mipseb | mipsel | mipsle | mipstx39 | mipstx39el \
@@ -296,6 +297,7 @@
| m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
| m88110-* | m88k-* | mcore-* \
| mips-* | mips16-* | mips64-* | mips64el-* | mips64orion-* \
+ | mipseb | mipsel \
| mips64orionel-* | mips64vr4100-* | mips64vr4100el-* \
| mips64vr4300-* | mips64vr4300el-* | mipsbe-* | mipseb-* \
| mipsle-* | mipsel-* | mipstx39-* | mipstx39el-* \