Update to miniupnpd-1.4.20100308

Changes include:
* ipfilter fixes
* NAT-PMP source address should now be right
This commit is contained in:
roy 2010-05-11 08:53:29 +00:00
parent 5d2e6b2b16
commit 3b7c825384
7 changed files with 10 additions and 150 deletions

View file

@ -1,9 +1,7 @@
# $NetBSD: Makefile,v 1.4 2009/11/26 00:35:00 joerg Exp $
# $NetBSD: Makefile,v 1.5 2010/05/11 08:53:29 roy Exp $
#
DISTNAME= miniupnpd-20081009
PKGREVISION= 1
PKGNAME= ${DISTNAME:S/miniupnpd-/&1.2.0./}
DISTNAME= miniupnpd-1.4.20100308
CATEGORIES= net
MASTER_SITES= http://miniupnp.free.fr/files/download.php?file=
@ -20,8 +18,10 @@ CONF_FILES= ${EGDIR}/miniupnpd.conf ${PKG_SYSCONFDIR}/miniupnpd.conf
.include "../../mk/bsd.prefs.mk"
.include "options.mk"
MAKE_ENV+= ${BSD_MAKE_ENV}
MAKE_ENV+= PKG_CFLAGS="-DPKG_DEFAULT_CONFIG=\\\"${PKG_SYSCONFDIR:Q}/miniupnpd.conf\\\""
CFLAGS+= -DDEFAULT_CONFIG=\"${PKG_SYSCONFDIR:Q}/miniupnpd.conf\"
INSTALL_MAKE_FLAGS+= INSTALLETCDIR=${EGDIR}
INSTALL_MAKE_FLAGS+= INSTALLMANDIR=${PREFIX}/${PKGMANDIR}/man1
RCD_SCRIPTS= miniupnpd

View file

@ -1,10 +1,5 @@
$NetBSD: distinfo,v 1.3 2009/06/04 07:54:26 hasso Exp $
$NetBSD: distinfo,v 1.4 2010/05/11 08:53:29 roy Exp $
SHA1 (miniupnpd-20081009.tar.gz) = 9006d433053c237ccb6628e1856b7cd99a79d989
RMD160 (miniupnpd-20081009.tar.gz) = 16c36151d7f7058c2579dbba33e92b417304453c
Size (miniupnpd-20081009.tar.gz) = 81732 bytes
SHA1 (patch-aa) = 2e4d6a8b3ab975657d3c857167601b77e3d84883
SHA1 (patch-ab) = fa9c272f80629da6ed50a6acaca7e0dd92283f9e
SHA1 (patch-ac) = b92d83113f55b1e1b5f9c88f52bebba45f7d746f
SHA1 (patch-ad) = aa9ffe0963026c52b2bc17b899f1a5d042a86f55
SHA1 (patch-ae) = 59dfed6777874a545fdfe63bc9e8263d1776be76
SHA1 (miniupnpd-1.4.20100308.tar.gz) = f10be7da41dab4bb3faf083af71c421462048826
RMD160 (miniupnpd-1.4.20100308.tar.gz) = 7e34a3787ff25251e16b581608fa1a2791f7ca59
Size (miniupnpd-1.4.20100308.tar.gz) = 92889 bytes

View file

@ -1,35 +0,0 @@
$NetBSD: patch-aa,v 1.2 2009/06/04 07:54:26 hasso Exp $
--- genconfig.sh.orig 2008-10-01 15:49:26 +0300
+++ genconfig.sh 2009-05-07 11:23:34 +0300
@@ -96,14 +96,25 @@ case $OS_NAME in
;;
NetBSD)
OS_URL=http://www.netbsd.org/
- if [ -f /usr/include/net/pfvar.h ] ; then
- echo "#define USE_PF 1" >> ${CONFIGFILE}
- FW=pf
+ FWNAME_UPPER="$(echo $FWNAME | tr '[a-z]' '[A-Z]')"
+ if [ ! "x$FWNAME" = "x" ]; then
+ FW=${FWNAME}
+ echo "#define USE_${FWNAME_UPPER} 1" >> ${CONFIGFILE}
else
- echo "#define USE_IPF 1" >> ${CONFIGFILE}
- FW=ipf
+ if [ -f /usr/include/net/pfvar.h ] ; then
+ echo "#define USE_PF 1" >> ${CONFIGFILE}
+ FW=pf
+ else
+ echo "#define USE_IPF 1" >> ${CONFIGFILE}
+ FW=ipf
+ fi
fi
;;
+ DragonFly)
+ OS_URL=http://www.dragonflybsd.org/
+ echo "#define USE_PF 1" >> ${CONFIGFILE}
+ FW=pf
+ ;;
SunOS)
echo "#define USE_IPF 1" >> ${CONFIGFILE}
FW=ipf

View file

@ -1,37 +0,0 @@
$NetBSD: patch-ab,v 1.2 2009/01/06 23:39:53 jmcneill Exp $
--- Makefile.orig 2008-10-09 08:50:46.000000000 -0400
+++ Makefile 2009-01-06 18:32:05.000000000 -0500
@@ -5,7 +5,7 @@
# This Makefile should work for *BSD and SunOS/Solaris
# Linux users, please use Makefile.linux
#CFLAGS = -Wall -Os
-CFLAGS = -Wall -O -g -DDEBUG
+CFLAGS = -Wall -O -g -DDEBUG $(PKG_CFLAGS)
CC = gcc
RM = rm -f
MV = mv
@@ -83,8 +83,8 @@ LIBS += -lsocket -lnsl -lkstat -lresolv
# set PREFIX variable to install in the wanted place
-INSTALLBINDIR = $(PREFIX)/sbin
-INSTALLETCDIR = $(PREFIX)/etc
+INSTALLBINDIR = $(DESTDIR)$(PREFIX)/sbin
+INSTALLETCDIR = $(DESTDIR)$(PREFIX)/share/examples/miniupnpd
all: $(EXECUTABLES)
@@ -97,8 +97,10 @@ clean:
install: miniupnpd genuuid
strip miniupnpd
- $(INSTALL) -m 555 miniupnpd $(INSTALLBINDIR)
- $(INSTALL) miniupnpd.conf $(INSTALLETCDIR)
+ $(BSD_INSTALL_PROGRAM_DIR) $(INSTALLBINDIR)
+ $(BSD_INSTALL_DATA_DIR) $(INSTALLETCDIR)
+ $(BSD_INSTALL_PROGRAM) miniupnpd $(INSTALLBINDIR)
+ $(BSD_INSTALL) -m 644 miniupnpd.conf $(INSTALLETCDIR)
# genuuid is using the uuid cli tool available under OpenBSD 4.0 in
# the uuid-1.5.0 package

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ac,v 1.1 2009/01/06 23:39:53 jmcneill Exp $
--- miniupnpd.c.orig 2009-01-06 18:28:56.000000000 -0500
+++ miniupnpd.c 2009-01-06 18:29:19.000000000 -0500
@@ -344,7 +344,7 @@ init(int argc, char * * argv, struct run
struct sigaction sa;
/*const char * logfilename = 0;*/
const char * presurl = 0;
- const char * optionsfile = "/etc/miniupnpd.conf";
+ const char * optionsfile = PKG_DEFAULT_CONFIG;
/* first check if "-f" option is used */
for(i=2; i<argc; i++)

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ad,v 1.1 2009/06/04 07:54:26 hasso Exp $
--- pf/obsdrdr.c.orig 2008-08-24 22:54:57 +0300
+++ pf/obsdrdr.c 2009-06-04 10:35:24 +0300
@@ -7,11 +7,16 @@
#include <sys/types.h>
#include <sys/socket.h>
+#include <sys/param.h>
#include <net/if.h>
#include <netinet/in.h>
#include <netinet/tcp.h>
#include <arpa/inet.h>
+#ifdef __DragonFly__
+#include <net/pf/pfvar.h>
+#else
#include <net/pfvar.h>
+#endif
#include <fcntl.h>
#include <sys/ioctl.h>
#include <unistd.h>

View file

@ -1,29 +0,0 @@
$NetBSD: patch-ae,v 1.1 2009/06/04 07:54:26 hasso Exp $
--- bsd/getifstats.c.orig 2009-05-07 11:38:00 +0300
+++ bsd/getifstats.c 2009-05-07 11:40:14 +0300
@@ -11,10 +11,14 @@
#include <net/if.h>
#include <arpa/inet.h>
#include <netinet/in.h>
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__DragonFly__)
#include <net/if_var.h>
#endif
+#if defined(__DragonFly__)
+#include <net/pf/pfvar.h>
+#else
#include <net/pfvar.h>
+#endif
#include <kvm.h>
#include <fcntl.h>
#include <nlist.h>
@@ -34,7 +38,7 @@ struct nlist list[] = {
int
getifstats(const char * ifname, struct ifdata * data)
{
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__DragonFly__)
struct ifnethead ifh;
#elif defined(__OpenBSD__) || defined(__NetBSD__)
struct ifnet_head ifh;