Initial import of fusepod-0.5.1 into the Packages Collection as

fuse-pod-0.5.1.

	FUSEPod is a userspace filesystem which mounts your iPod into a directory
	for easy browsing of your songs on your iPod.

	Features
	========

		* Read and Write support
		* Viewing/Removing playlists
		* Configurable directory layout
		* Transparent copying of files onto iPod
		* Tracks have tags in extended attributes
		* Discovers where your iPod is mounted
		* Statistics file
This commit is contained in:
agc 2007-05-04 23:48:33 +00:00
parent 99c925d952
commit 3bae979cf3
6 changed files with 71 additions and 0 deletions

View file

@ -0,0 +1,13 @@
FUSEPod is a userspace filesystem which mounts your iPod into a directory
for easy browsing of your songs on your iPod.
Features
========
* Read and Write support
* Viewing/Removing playlists
* Configurable directory layout
* Transparent copying of files onto iPod
* Tracks have tags in extended attributes
* Discovers where your iPod is mounted
* Statistics file

View file

@ -0,0 +1,22 @@
# $NetBSD: Makefile,v 1.1.1.1 2007/05/04 23:48:33 agc Exp $
#
DISTNAME= fusepod-0.5.1
PKGNAME= fuse-pod-0.5.1
CATEGORIES= filesystems
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=fusepod/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://fusepod.sourceforge.net/
COMMENT= FUSE-based filesystem for iPod
GNU_CONFIGURE= yes
USE_LANGUAGES+= c c++
USE_TOOLS+= gmake pkg-config
.include "../../audio/libgpod/buildlink3.mk"
.include "../../audio/taglib/buildlink3.mk"
.include "../../mk/fuse.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2007/05/04 23:48:33 agc Exp $
bin/fusepod
man/man1/fusepod.1

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2007/05/04 23:48:33 agc Exp $
SHA1 (fusepod-0.5.1.tar.bz2) = 61fda80b27b0305fbfa26ba58d395b4ddbd72525
RMD160 (fusepod-0.5.1.tar.bz2) = ad68b3f6c81a3ce7546771a8b2fd3dd6ce061447
Size (fusepod-0.5.1.tar.bz2) = 78547 bytes
SHA1 (patch-aa) = cb2aceb2aefaa8b99dc95fce70835edb85ab1a92
SHA1 (patch-ab) = 923f7f7449c85d2ea537845b779aebec6aede1e8

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2007/05/04 23:48:33 agc Exp $
--- src/fusepod.cpp 2007/05/04 23:21:09 1.1
+++ src/fusepod.cpp 2007/05/04 23:23:52
@@ -672,7 +672,7 @@
return paths;
}
-void * fusepod_init () {
+void * fusepod_init (fuse_conn_info *connection) {
syncing = false;
syncing_file = "";

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.1.1.1 2007/05/04 23:48:33 agc Exp $
--- src/fusepod_ipod.cpp 2007/05/04 23:28:59 1.1
+++ src/fusepod_ipod.cpp 2007/05/04 23:30:15
@@ -417,7 +417,7 @@
stats << "FUSEPod Version: " << PACKAGE_VERSION << endl;
stats << "ITunesDB Version: " << this->ipod->version << endl;
- stats << "Real Mountpoint: " << this->ipod->mountpoint << endl;
+ stats << "Real Mountpoint: " << this->mount_point << endl;
Playlist * mpl = itdb_playlist_mpl (ipod);
stats << "iPod Name: " << (mpl && mpl->name ? string(mpl->name) : "Unknown") << endl;