Update to 2.2.2. Upstream changes:

General:
- Change: Add the ability of allied players to share sensors (ticket:636,
  r7900)
- Change: Stop rotation when "Continue" is pressed after winning a
  multiplayer/skirmish game (r7887)
- Change: Show when a game was saved in a tooltip on the loading screen.
  (r7864, ticket:682)
- Fix: Cannot display more than one game from lobby. Also fix a lobby display
  issue. (r7839, ticket:691)
- Fix: Various checks and workarounds to make game run more stable (r7836,
  r7894, r7889, r7883, r7881, r7851, r7847, r7842, r7822, r7910 / ticket:759)
- Fix: Crash due to path length overflow (r7916, ticket:738, ticket:765)
- Fix: Bug that caused some keyboard shortcuts to be unusable in multiplayer
  since they were considered cheats (r7856)
- Fix: Verify that our "target" is still around before doing fire support
  with it. (r7910, ticket:759)
- Fix: Fix crash length overflow by capping path lengths to max 255 nodes.
  (r7916, ticket:738)
- Fix: Fix a typo, we wanted to display "???" when ping is >=2000 (r7922)
- Fix: Fix camera bug in warcam code. Patch by i-NoD (r7924, ticket:757)
- Fix: General order/action code cleanup (r7926)
- Fix: Fix segfault when trying to read target of droid with no target in
  aiUpdateStructure (r7928)
- Fix: Use _NSIG in the exceptionhandler if available for *BSD compatibility.
  (r7972, ticket:818)
- Fix: Add correct linker flags for openbsd to configure. (r7974, ticket:819)
- Fix: Disable locales without translation. (r7969, ticket:813)
- Fix: NTW updated to 1.8.7 (r7998 - r8009)
- Fix: When babas are burning, we always play the scream now. (r8025,
  ticket:830)
- Fix: Make sure we have a valid color choice for our SP game, when we are
  coming from a MP game. (r8032)

Translations:
- Fix: Commit Portuguese translation. (r7943, ticket:783)
- Fix: Updated translations (r7880, r7877, r7875, r7871, r7868, r7863, r7861)


Graphics:
- Fix: Increase video buffer size from 4K to 256K. This fixes playback of
  videos with a bitrate larger than ~2000kbps. (r7981)
- Change: Add a north pointer for the rotating radar. (r8013, ticket:769)

Sound:
- Fix: Fixes the removal of unused (sound) sources. (r8012, r8026, ticket:770)
This commit is contained in:
hasso 2009-08-26 17:36:45 +00:00
parent bc22653099
commit 3bc05d5ff7
3 changed files with 115 additions and 20 deletions

View file

@ -1,10 +1,9 @@
# $NetBSD: Makefile,v 1.8 2009/08/16 21:21:51 wiz Exp $
# $NetBSD: Makefile,v 1.9 2009/08/26 17:36:45 hasso Exp $
#
DISTNAME= warzone2100-2.2.1
DISTNAME= warzone2100-2.2.2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=warzone2100/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://wz2100.net/

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.3 2009/08/16 21:21:51 wiz Exp $
$NetBSD: distinfo,v 1.4 2009/08/26 17:36:45 hasso Exp $
SHA1 (warzone2100-2.2.1.tar.bz2) = b993827a5972cacaa236512870f50361b4b2677a
RMD160 (warzone2100-2.2.1.tar.bz2) = 0cb42f6d3bb3beeac6dd8dccb662d867c30bbeb6
Size (warzone2100-2.2.1.tar.bz2) = 47907534 bytes
SHA1 (warzone2100-2.2.2.tar.gz) = d61bd1a87f0a6c1184c640987f759b1ac702b9e1
RMD160 (warzone2100-2.2.2.tar.gz) = d7af614267acdb548fcbe5f78ed46e8c4d6f33de
Size (warzone2100-2.2.2.tar.gz) = 50163580 bytes
SHA1 (patch-aa) = 95c066ff4340ba6e4c021846541b53eb4cad0704
SHA1 (patch-ab) = e82a085ddf27a5443e011ada57e78cca1ab66c79
SHA1 (patch-ac) = b15234c26cbbeffe58e623feb49e9930bd3846d0
SHA1 (patch-ac) = c09fcad63f725f414667980efce48157a04169a9
SHA1 (patch-ad) = af29beef3b2014bf1b3d1068b2b3caa7d948de80
SHA1 (patch-ae) = 9a5f2fccd93100e87968d2dc9d783acc595ad5d3
SHA1 (patch-af) = 46ea523fb72ed0f081d85dfea0813fde79087c82

View file

@ -1,13 +1,109 @@
$NetBSD: patch-ac,v 1.1.1.1 2009/02/15 16:05:43 jmcneill Exp $
$NetBSD: patch-ac,v 1.2 2009/08/26 17:36:45 hasso Exp $
--- lib/exceptionhandler/exceptionhandler.c.orig 2008-12-21 13:41:15.000000000 -0500
+++ lib/exceptionhandler/exceptionhandler.c
@@ -134,6 +134,8 @@ typedef void(*SigActionHandler)(int, sig
#ifdef WZ_OS_MAC
static struct sigaction oldAction[32];
+#elif defined(_NSIG)
+static struct sigaction oldAction[_NSIG];
#else
static struct sigaction oldAction[NSIG];
#endif
--- lib/exceptionhandler/exceptionhandler.c.orig 2009-08-23 07:05:11 +0300
+++ lib/exceptionhandler/exceptionhandler.c 2009-08-26 19:09:43 +0300
@@ -170,18 +170,21 @@ static const char * wz_strsignal(int sig
case SIGBUS:
switch (sigcode)
{
+#if !defined(__DragonFly__)
case BUS_ADRALN:
return "SIGBUS: Access to an undefined portion of a memory object: Invalid address alignment";
case BUS_ADRERR:
return "SIGBUS: Access to an undefined portion of a memory object: Nonexistent physical address";
case BUS_OBJERR:
return "SIGBUS: Access to an undefined portion of a memory object: Object-specific hardware error";
+#endif
default:
return "SIGBUS: Access to an undefined portion of a memory object";
}
case SIGCHLD:
switch (sigcode)
{
+#if !defined(__DragonFly__)
case CLD_EXITED:
return "SIGCHLD: Child process terminated, stopped, or continued: Child has exited";
case CLD_KILLED:
@@ -194,12 +197,16 @@ static const char * wz_strsignal(int sig
return "SIGCHLD: Child process terminated, stopped, or continued: Child has stopped";
case CLD_CONTINUED:
return "SIGCHLD: Child process terminated, stopped, or continued: Stopped child has continued";
+#endif
+ default:
+ return "SIGCHLD: Child process terminated, stopped, or continued";
}
case SIGCONT:
return "SIGCONT: Continue executing, if stopped";
case SIGFPE:
switch (sigcode)
{
+#if !defined(__DragonFly__)
case FPE_INTDIV:
return "SIGFPE: Erroneous arithmetic operation: Integer divide by zero";
case FPE_INTOVF:
@@ -216,6 +223,7 @@ static const char * wz_strsignal(int sig
return "SIGFPE: Erroneous arithmetic operation: Invalid floating-point operation";
case FPE_FLTSUB:
return "SIGFPE: Erroneous arithmetic operation: Subscript out of range";
+#endif
default:
return "SIGFPE: Erroneous arithmetic operation";
};
@@ -224,6 +232,7 @@ static const char * wz_strsignal(int sig
case SIGILL:
switch (sigcode)
{
+#if !defined(__DragonFly__)
case ILL_ILLOPC:
return "SIGILL: Illegal instruction: Illegal opcode";
case ILL_ILLOPN:
@@ -240,6 +249,7 @@ static const char * wz_strsignal(int sig
return "SIGILL: Illegal instruction: Coprocessor error";
case ILL_BADSTK:
return "SIGILL: Illegal instruction: Internal stack error";
+#endif
default:
return "SIGILL: Illegal instruction";
}
@@ -254,10 +264,12 @@ static const char * wz_strsignal(int sig
case SIGSEGV:
switch (sigcode)
{
+#if !defined(__DragonFly__)
case SEGV_MAPERR:
return "SIGSEGV: Invalid memory reference: Address not mapped to object";
case SEGV_ACCERR:
return "SIGSEGV: Invalid memory reference: Invalid permissions for mapped object";
+#endif
default:
return "SIGSEGV: Invalid memory reference";
}
@@ -276,6 +288,7 @@ static const char * wz_strsignal(int sig
case SIGUSR2:
return "SIGUSR2: User-defined signal 2";
#if _XOPEN_UNIX
+#if !defined(__DragonFly__)
case SIGPOLL:
switch (sigcode)
{
@@ -307,6 +320,7 @@ static const char * wz_strsignal(int sig
default:
return "SIGPOLL: Pollable event";
}
+#endif
case SIGPROF:
return "SIGPROF: Profiling timer expired";
case SIGSYS:
@@ -314,10 +328,12 @@ static const char * wz_strsignal(int sig
case SIGTRAP:
switch (sigcode)
{
+#if !defined(__DragonFly__)
case TRAP_BRKPT:
return "SIGTRAP: Trace/breakpoint trap: Process breakpoint";
case TRAP_TRACE:
return "SIGTRAP: Trace/breakpoint trap: Process trace trap";
+#endif
default:
return "SIGTRAP: Trace/breakpoint trap";
}