Use PYVERSSUFFIX to differentiate between versions built for different

versions of Python and to resolve conflicts with other packages.

Bump PKGREVISION.
This commit is contained in:
darcy 2005-01-07 16:17:42 +00:00
parent 84e48d0fa3
commit 3bd858ee9b
5 changed files with 43 additions and 26 deletions

View file

@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.1.1.1 2004/12/31 10:13:56 darcy Exp $
# $NetBSD: Makefile,v 1.2 2005/01/07 16:17:42 darcy Exp $
#
DISTNAME= Pyro-3.4
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
PKGREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=pyro/}
@ -13,6 +14,20 @@ COMMENT= Distributed Object Technology system in Python
USE_BUILDLINK3= yes
PY_PATCHPLIST= yes
PYDISTUTILSPKG= yes
PLIST_SUBST+= PYVERSSUFFIX="-${PYVERSSUFFIX}"
MAKE_ENV+= PKGSRC="1" PYVERSSUFFIX="-${PYVERSSUFFIX}"
post-extract:
cd ${WRKSRC}/bin; \
${MV} es es-${PYVERSSUFFIX}; \
${MV} esd esd-${PYVERSSUFFIX}; \
${MV} genguid genguid-${PYVERSSUFFIX}; \
${MV} ns ns-${PYVERSSUFFIX}; \
${MV} nsc nsc-${PYVERSSUFFIX}; \
${MV} nsd nsd-${PYVERSSUFFIX}; \
${MV} pyroc pyroc-${PYVERSSUFFIX}; \
${MV} rns rns-${PYVERSSUFFIX}; \
${MV} wxnsc wxnsc-${PYVERSSUFFIX}; \
${MV} xnsc xnsc-${PYVERSSUFFIX}
.include "../../lang/python/extension.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,14 +1,14 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2004/12/31 10:13:56 darcy Exp $
bin/es
bin/genguid
bin/ns
bin/nsc
bin/pyroc
bin/rns
bin/xnsc
bin/wxnsc
bin/esd
bin/nsd
@comment $NetBSD: PLIST,v 1.2 2005/01/07 16:17:42 darcy Exp $
bin/es${PYVERSSUFFIX}
bin/genguid${PYVERSSUFFIX}
bin/ns${PYVERSSUFFIX}
bin/nsc${PYVERSSUFFIX}
bin/pyroc${PYVERSSUFFIX}
bin/rns${PYVERSSUFFIX}
bin/xnsc${PYVERSSUFFIX}
bin/wxnsc${PYVERSSUFFIX}
bin/esd${PYVERSSUFFIX}
bin/nsd${PYVERSSUFFIX}
${PYSITELIB}/Pyro/EventService/Clients.py
${PYSITELIB}/Pyro/EventService/Clients.pyc
${PYSITELIB}/Pyro/EventService/Clients.pyo

View file

@ -1,8 +0,0 @@
$Id: TODO,v 1.1.1.1 2004/12/31 10:13:57 darcy Exp $
Make scripts installed with ${PYPKGSUFX} so they don't conflict each other
when it is installed for >1 versions of Python.
(same as wip/py-twisted)
-- dotz@irc.pl

View file

@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2004/12/31 10:13:56 darcy Exp $
$NetBSD: distinfo,v 1.2 2005/01/07 16:17:42 darcy Exp $
SHA1 (Pyro-3.4.tar.gz) = 9df62d1fd9036e5b5a468ab4c9670a2fcf79b331
Size (Pyro-3.4.tar.gz) = 217795 bytes
SHA1 (patch-aa) = 3298dd9fe932169dc7914b8d0658ac6ce1506a66
SHA1 (patch-aa) = e359095c9fed22be396633703fc3f9886f6fe4f6

View file

@ -1,8 +1,18 @@
$NetBSD: patch-aa,v 1.1.1.1 2004/12/31 10:13:57 darcy Exp $
$NetBSD: patch-aa,v 1.2 2005/01/07 16:17:42 darcy Exp $
--- setup.py.orig Tue May 20 21:43:07 2003
+++ setup.py Thu Jan 1 21:52:52 2004
@@ -33,9 +33,12 @@
--- setup.py.orig 2003-05-20 15:43:07.000000000 -0400
+++ setup.py
@@ -16,7 +16,8 @@ def gather_scripts():
names = map( lambda x: x+'.bat', names)
else:
names.extend(['esd', 'nsd']) # scripts that are not for Windows
- names = map( lambda x: os.path.join( 'bin', x), names )
+ pyverssuffix = os.getenv("PYVERSSUFFIX")
+ names = [os.path.join( 'bin', x) + pyverssuffix for x in names]
return names
if __name__ == '__main__' :
@@ -33,9 +34,12 @@ if __name__ == '__main__' :
unattended=cp.get('install-options','unattended')
else:
unattended=0