fna3d: update to 22.05 to fix build with current graphics/mojoshader

This commit is contained in:
tnn 2022-05-15 11:50:53 +00:00
parent 3ce041eff1
commit 3c162cc961
5 changed files with 25 additions and 44 deletions

View file

@ -1,20 +1,15 @@
# $NetBSD: Makefile,v 1.4 2022/03/28 10:44:21 tnn Exp $
# $NetBSD: Makefile,v 1.5 2022/05/15 11:50:53 tnn Exp $
GITHUB_PROJECT= FNA3D
GITHUB_TAG= 21.01
DISTNAME= 21.01
PKGNAME= ${GITHUB_PROJECT:tl}-${DISTNAME}
PKGREVISION= 3
DISTNAME= FNA3D-22.05
PKGNAME= ${DISTNAME:tl}
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_GITHUB:=FNA-XNA/}
DIST_SUBDIR= ${GITHUB_PROJECT}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://fna-xna.github.io/
COMMENT= 3D graphics library for FNA
LICENSE= zlib
WRKSRC= ${WRKDIR}/FNA3D-21.01
USE_CMAKE= yes
# No upstream install target

View file

@ -1,6 +1,7 @@
@comment $NetBSD: PLIST,v 1.1 2021/01/24 19:03:46 maya Exp $
@comment $NetBSD: PLIST,v 1.2 2022/05/15 11:50:53 tnn Exp $
include/FNA3D.h
include/FNA3D_Image.h
include/FNA3D_SysRenderer.h
lib/libFNA3D.so
lib/libFNA3D.so.0
lib/libFNA3D.so.0.${PKGVERSION}

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.3 2021/10/26 10:46:07 nia Exp $
$NetBSD: distinfo,v 1.4 2022/05/15 11:50:53 tnn Exp $
BLAKE2s (FNA3D/21.01.tar.gz) = eb254434bbdc468c33264d6618a42caf19c03107cac19b1bc9fb4203bab83264
SHA512 (FNA3D/21.01.tar.gz) = ae99280d2b160cbadf19df60aa2e81eb3ae4da4267613f97aa8e132b0b743068091460d8f3097d47adbd6a7b7292a7640088ae7104e2a3a783e0050b72ca497a
Size (FNA3D/21.01.tar.gz) = 315856 bytes
SHA1 (patch-CMakeLists.txt) = 27ebc2e42a5819b6298b6faa8488234e8f3ecbb1
SHA1 (patch-src_FNA3D__Driver__Vulkan.c) = b9eb107f3d0430ab9536f709871c5d1af1d1e06a
BLAKE2s (FNA3D-22.05.tar.gz) = 97e3ee16e30889ff1e7b65214190725ead2cecad7a9951bc04499babbcf33115
SHA512 (FNA3D-22.05.tar.gz) = 702ffde8ee537fbcef4078e9d59a9aa82a7f67ed65d6b0a9f5e0087d0ef97339030c911c3a018b16cbd3f95413fc37384b44d5a4ecca22d81299e4b80ce5e069
Size (FNA3D-22.05.tar.gz) = 315171 bytes
SHA1 (patch-CMakeLists.txt) = 905b792729524ecc51dede035e2d2442cab9d262

View file

@ -1,9 +1,9 @@
$NetBSD: patch-CMakeLists.txt,v 1.1 2021/01/24 19:03:47 maya Exp $
$NetBSD: patch-CMakeLists.txt,v 1.2 2022/05/15 11:50:53 tnn Exp $
set correct library version
disable bundled mojoshader in favor of the one from pkgsrc
--- CMakeLists.txt.orig 2021-01-01 16:22:56.000000000 +0000
--- CMakeLists.txt.orig 2022-05-01 15:39:21.000000000 +0000
+++ CMakeLists.txt
@@ -3,6 +3,9 @@
cmake_minimum_required(VERSION 2.8.12)
@ -14,10 +14,10 @@ disable bundled mojoshader in favor of the one from pkgsrc
+
# Options
option(BUILD_SHARED_LIBS "Build shared library" ON)
option(DISABLE_D3D11 "Disable D3D11 backend")
@@ -105,28 +108,11 @@ add_library(FNA3D
src/FNA3D_Image.c
option(TRACING_SUPPORT "Build with tracing enabled" OFF)
@@ -100,18 +103,7 @@ add_library(FNA3D
src/FNA3D_PipelineCache.c
src/FNA3D_Tracing.c
)
-add_library(mojoshader STATIC
- MojoShader/mojoshader.c
@ -25,16 +25,17 @@ disable bundled mojoshader in favor of the one from pkgsrc
- MojoShader/mojoshader_common.c
- MojoShader/mojoshader_d3d11.c
- MojoShader/mojoshader_opengl.c
- MojoShader/mojoshader_metal.c
- MojoShader/mojoshader_vulkan.c
- MojoShader/profiles/mojoshader_profile_common.c
- MojoShader/profiles/mojoshader_profile_glsl.c
- MojoShader/profiles/mojoshader_profile_hlsl.c
- MojoShader/profiles/mojoshader_profile_metal.c
- MojoShader/profiles/mojoshader_profile_spirv.c
-)
# Build flags
+
if(TRACING_SUPPORT)
add_executable(fna3d_replay replay/replay.c)
target_link_libraries(fna3d_replay FNA3D)
@@ -124,9 +116,6 @@ endif()
if(NOT MSVC)
set_property(TARGET FNA3D PROPERTY COMPILE_FLAGS "-std=gnu99 -Wall -Wno-strict-aliasing -pedantic")
endif()
@ -44,10 +45,10 @@ disable bundled mojoshader in favor of the one from pkgsrc
# FNA3D folders as includes, for other targets to consume
target_include_directories(FNA3D PUBLIC
@@ -134,10 +120,6 @@ target_include_directories(FNA3D PUBLIC
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/include>
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/Vulkan-Headers/include>
)
@@ -147,10 +136,6 @@ if(BUILD_DXVK_NATIVE)
$<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/../dxvk-native/include/native/wsi>
)
endif()
-target_include_directories(mojoshader PUBLIC
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/MojoShader>
- $<BUILD_INTERFACE:${CMAKE_CURRENT_SOURCE_DIR}/Vulkan-Headers/include>
@ -55,7 +56,7 @@ disable bundled mojoshader in favor of the one from pkgsrc
# MinGW builds should statically link libgcc
if(MINGW)
@@ -165,7 +147,6 @@ else()
@@ -178,7 +163,6 @@ else()
if (TARGET SDL2::SDL2)
message(STATUS "using TARGET SDL2::SDL2")
target_link_libraries(FNA3D PUBLIC SDL2::SDL2)

View file

@ -1,15 +0,0 @@
$NetBSD: patch-src_FNA3D__Driver__Vulkan.c,v 1.1 2021/01/24 19:03:47 maya Exp $
Match the headers in vulkan-headers
--- src/FNA3D_Driver_Vulkan.c.orig 2021-01-01 16:22:56.000000000 +0000
+++ src/FNA3D_Driver_Vulkan.c
@@ -4444,7 +4444,7 @@ static void VULKAN_INTERNAL_SubmitComman
/* Present, if applicable */
if (present && acquireSuccess)
{
- if (renderer->physicalDeviceDriverProperties.driverID == VK_DRIVER_ID_GGP_PROPRIETARY)
+ if (renderer->physicalDeviceDriverProperties.driverID == VK_DRIVER_ID_GGP_PROPRIETARY_KHR)
{
const void* token = SDL_GetWindowData(
(SDL_Window*) renderer->presentOverrideWindowHandle,