mail/distribute from freebsd-current
This commit is contained in:
parent
9c5bfd98fb
commit
3c54ad1e74
8 changed files with 146 additions and 0 deletions
50
mail/distribute/Makefile
Normal file
50
mail/distribute/Makefile
Normal file
|
@ -0,0 +1,50 @@
|
|||
# New ports collection makefile for: distribute
|
||||
# Version required: 2.1pl24
|
||||
# Date created: 1 Oct 1997
|
||||
# Whom: itojun@itojun.org
|
||||
#
|
||||
# $FreeBSD: ports/mail/distribute/Makefile,v 1.3 1999/08/31 06:47:17 mharo Exp $
|
||||
#
|
||||
|
||||
DISTNAME= distribute-2.1-pl19
|
||||
PKGNAME= distribute-2.1.24
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= ftp://ftp.foretune.co.jp/pub/network/mail/distribute/
|
||||
|
||||
PATCH_SITES= ${MASTER_SITES}BETA/
|
||||
PATCHFILES= patch.20.gz patch.21e.gz patch.22e.gz patch.23e.gz patch.24e.gz
|
||||
|
||||
MAINTAINER= kuriyama@FreeBSD.org
|
||||
|
||||
WRKSRC= ${WRKDIR}/distribute-pl19
|
||||
MAN1= distribute.1
|
||||
DIST_SUBDIR= distribute
|
||||
# Compile time configuration required.
|
||||
IS_INTERACTIVE= YES
|
||||
|
||||
# customize below if you would like to
|
||||
MAILINGLIST_DIR= ${PREFIX}/majordomo/lists
|
||||
MAJORDOMO_DIR= ${PREFIX}/majordomo # mail/majordomo likes this
|
||||
MAJORDOMO_LIST_DIR= ${MAJORDOMO_DIR}/lists
|
||||
ARCHIVE_DIR= /var/spool/mail-list
|
||||
DEF_DOMAINNAME= your.domain.here
|
||||
|
||||
MAKE_ENV+= DEFAULTCONFIG="-DDEF_SEQ_PATH=\\\"$(MAILINGLIST_DIR)\\\" \
|
||||
-DDEF_RECIPIENT_PATH=\\\"$(MAILINGLIST_DIR)\\\" \
|
||||
-DDEF_MAJORDOMO_RECIPIENT_PATH=\\\"$(MAJORDOMO_LIST_DIR)\\\" \
|
||||
-DDEF_DOMAINNAME=\\\"$(DEF_DOMAINNAME)\\\" \
|
||||
-DDEF_ARCHIVE_PATH=\\\"$(ARCHIVE_DIR)\\\"" \
|
||||
INSTALL="${INSTALL}" \
|
||||
INSTALL_MAN="${INSTALL_MAN}"
|
||||
|
||||
post-build: message
|
||||
post-install: message
|
||||
message::
|
||||
@${ECHO} "===> distribute was compiled with the following configuration:"
|
||||
@${ECHO} " membership file directory: ${MAILINGLIST_DIR}"
|
||||
@${ECHO} " membership file directory: ${MAJORDOMO_LIST_DIR} (for majordomo)"
|
||||
@${ECHO} " archiving directory: ${ARCHIVE_DIR}"
|
||||
@${ECHO} " if necessery, override them and perform compilation again."
|
||||
@${ECHO} " there's no way to override them at runtime."
|
||||
|
||||
.include <bsd.port.mk>
|
6
mail/distribute/files/md5
Normal file
6
mail/distribute/files/md5
Normal file
|
@ -0,0 +1,6 @@
|
|||
MD5 (distribute/distribute-2.1-pl19.tar.gz) = 8f37899f0101423dba732718da64d97c
|
||||
MD5 (distribute/patch.20.gz) = c530466c690baf410ec50b014c3d3aa6
|
||||
MD5 (distribute/patch.21e.gz) = e9465e3a1f34d9fd6a5d40704024e3a7
|
||||
MD5 (distribute/patch.22e.gz) = 44e86eed0bb78522a2a5eab0dc8cb1dd
|
||||
MD5 (distribute/patch.23e.gz) = fb7043530b09b391568ee72f36cba2c0
|
||||
MD5 (distribute/patch.24e.gz) = 078daebdd79c62374f6c20c76a7c0c97
|
46
mail/distribute/patches/patch-aa
Normal file
46
mail/distribute/patches/patch-aa
Normal file
|
@ -0,0 +1,46 @@
|
|||
--- Makefile.orig Thu Oct 2 01:18:07 1997
|
||||
+++ Makefile Thu Oct 2 01:21:10 1997
|
||||
@@ -66,7 +66,7 @@
|
||||
## -DDEF_ALIAS_CHAR_OPTION=\"b\"
|
||||
|
||||
#
|
||||
-DESTDIR=
|
||||
+DESTDIR= ${PREFIX}
|
||||
#
|
||||
CFLAGS= -g ${OPTIONS} ${DEFAULTCONFIG} ${RCONFIG}
|
||||
# -Wall
|
||||
@@ -75,8 +75,8 @@
|
||||
MAKE= make
|
||||
CC= ${PURIFY} ${PURIFYOPTS} cc
|
||||
|
||||
-WHERE= /usr/local/libexec
|
||||
-MANDIR= /usr/local/man
|
||||
+WHERE= /sbin
|
||||
+MANDIR= /man
|
||||
MANSEC= 1
|
||||
|
||||
# Install as
|
||||
@@ -84,7 +84,7 @@
|
||||
GROUP= daemon
|
||||
|
||||
# install
|
||||
-INSTALL= install -c
|
||||
+#INSTALL= install -c
|
||||
|
||||
# perl
|
||||
PERL=perl
|
||||
@@ -130,11 +130,11 @@
|
||||
@size xarchive
|
||||
|
||||
install: xdistribute distribute.1 xarchive
|
||||
- ${INSTALL} -s -o ${OWNER} -g ${GROUP} -m 511 xdistribute \
|
||||
+ ${INSTALL} -c -s -o ${OWNER} -g ${GROUP} -m 511 xdistribute \
|
||||
${DESTDIR}${WHERE}/distribute
|
||||
- ${INSTALL} -s -o ${OWNER} -g ${GROUP} -m 511 xarchive \
|
||||
+ ${INSTALL} -c -s -o ${OWNER} -g ${GROUP} -m 511 xarchive \
|
||||
${DESTDIR}${WHERE}/archive
|
||||
- ${INSTALL} -m 444 distribute.1 \
|
||||
+ ${INSTALL_MAN} distribute.1 \
|
||||
${DESTDIR}${MANDIR}/man${MANSEC}/distribute.${MANSEC}
|
||||
|
||||
testinst: xdistribute xarchive
|
11
mail/distribute/patches/patch-ab
Normal file
11
mail/distribute/patches/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- config.h.orig Sun Sep 14 09:25:53 1997
|
||||
+++ config.h Sun Sep 14 09:26:01 1997
|
||||
@@ -86,6 +86,8 @@
|
||||
* Other set-ups
|
||||
*/
|
||||
|
||||
+#if 0
|
||||
#ifndef _PATH_SENDMAIL
|
||||
# define _PATH_SENDMAIL "/usr/lib/sendmail" /* default */
|
||||
+#endif
|
||||
#endif
|
12
mail/distribute/patches/patch-ac
Normal file
12
mail/distribute/patches/patch-ac
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- distribute.c.orig Sun Sep 14 09:26:57 1997
|
||||
+++ distribute.c Sun Sep 14 09:27:09 1997
|
||||
@@ -37,7 +37,8 @@
|
||||
#include <unistd.h>
|
||||
#include <string.h>
|
||||
|
||||
-#if defined(__bsdi__) /* may be wrong -- we need to use NET/2 def.*/
|
||||
+/* may be wrong -- we need to use NET/2 def.*/
|
||||
+#if defined(__bsdi__) || defined(__FreeBSD__)
|
||||
# include <paths.h> /* for sendmail path */
|
||||
#endif
|
||||
|
1
mail/distribute/pkg/COMMENT
Normal file
1
mail/distribute/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
Mail dispatcher for mailing list. Fits nicely with majordomo
|
18
mail/distribute/pkg/DESCR
Normal file
18
mail/distribute/pkg/DESCR
Normal file
|
@ -0,0 +1,18 @@
|
|||
distribute - reforward incoming messages to a mailing list
|
||||
|
||||
Distribute takes as its standard input a mail message, modifies
|
||||
the header (and optionally the body) of that message, then invokes
|
||||
sendmail to send the message to the specified recipients. It is
|
||||
primarily useful for those who run large mailing lists.
|
||||
|
||||
Distribute does not include membership management. It only does the
|
||||
rewrite and dispatch of the mailng list emails.
|
||||
Use majordomo (ports/mail/majordomo) for membership management.
|
||||
|
||||
Facilities include:
|
||||
Article numbering
|
||||
Subject rewrite to Subject: (mailing-list 1234)
|
||||
Proper handling of error related headers
|
||||
Reply-to rewrite/insertion if necessery
|
||||
Archiving
|
||||
membership file from Majordomo's configuration directory
|
2
mail/distribute/pkg/PLIST
Normal file
2
mail/distribute/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
sbin/distribute
|
||||
sbin/archive
|
Loading…
Reference in a new issue