Complete rewrite of PNG plugin for new API to make this package build
with the latest version of the "png" package. Bump package revision because of this fix.
This commit is contained in:
parent
bf9177ddfa
commit
3cf65b08ff
3 changed files with 32 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.139 2006/04/17 13:46:00 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.140 2006/04/18 20:24:48 tron Exp $
|
||||
|
||||
DISTNAME= gimp-2.2.11
|
||||
PKGREVISION= 1
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/v2.2/ \
|
||||
ftp://ftp.cs.umn.edu/pub/gimp/v2.2/ \
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.27 2006/04/14 10:02:31 adam Exp $
|
||||
$NetBSD: distinfo,v 1.28 2006/04/18 20:24:48 tron Exp $
|
||||
|
||||
SHA1 (gimp-2.2.11.tar.bz2) = 11d22fb8448a87968e03cacf7f30cd7f6725d7c3
|
||||
RMD160 (gimp-2.2.11.tar.bz2) = 0304a859d53e4e6b7520b5e8634e64e07911eeba
|
||||
Size (gimp-2.2.11.tar.bz2) = 12854751 bytes
|
||||
SHA1 (patch-aa) = 269ef6f5a7744b8e5ee546140ca0076456df3b97
|
||||
SHA1 (patch-ab) = 3709d31062dec70daa09399f05fa61f91ed843b8
|
||||
SHA1 (patch-ac) = 796018e782611b71d68c365bf9dc2ab56126c2fa
|
||||
SHA1 (patch-ad) = 632c34e0fbeda69139b2b674d9c5ef80db40dcca
|
||||
|
|
28
graphics/gimp/patches/patch-ac
Normal file
28
graphics/gimp/patches/patch-ac
Normal file
|
@ -0,0 +1,28 @@
|
|||
$NetBSD: patch-ac,v 1.12 2006/04/18 20:24:48 tron Exp $
|
||||
|
||||
--- plug-ins/common/png.c.orig 2004-11-23 14:28:43.000000000 +0000
|
||||
+++ plug-ins/common/png.c 2006-04-18 21:20:36.000000000 +0100
|
||||
@@ -1012,7 +1012,11 @@
|
||||
* Done with the file...
|
||||
*/
|
||||
|
||||
+#if PNG_LIBPNG_VER > 88
|
||||
+ png_destroy_read_struct(&pp, &info, NULL);
|
||||
+#else
|
||||
png_read_destroy (pp, info, NULL);
|
||||
+#endif
|
||||
|
||||
g_free (pixel);
|
||||
g_free (pixels);
|
||||
@@ -1441,7 +1445,11 @@
|
||||
};
|
||||
|
||||
png_write_end (pp, info);
|
||||
+#if PNG_LIBPNG_VER > 88
|
||||
+ png_destroy_write_struct(&pp, &info);
|
||||
+#else
|
||||
png_write_destroy (pp);
|
||||
+#endif
|
||||
|
||||
g_free (pixel);
|
||||
g_free (pixels);
|
Loading…
Reference in a new issue