Update parrot to version 3.10.0. Subsequent updates to follow...
Pkgsrc changes: * Adapt to changes in list of installed files * Remove a now-irrelevant patch, add another as a workaround for a timing-dependent patch (done differently in later revisions) Upstream changes: - Core + The mark VTABLE was added to the Select PMC + The Parrot::Embed Perl 5 module was removed from parrot.git and now lives at https://github.com/parrot/parrot-embed + A set_random method was added to the Integer PMC, so random numbers can be generated without needing to load math dynops + A new implementation of green threads was added to Parrot, in preparation for a robust hybrid threading system. Green threads are currently not available on Windows. - Languages + Winxed - 'multi' modifier improved - throw "string" now emits throw instead of die - several optimizations in generated code - improved some error dianostics - Community + Parrot Foundation was accepted to Google Code-In 2011. We could always use more volunteers. Task ideas are on the wiki: https://github.com/parrot/parrot/wiki/Google-Code-In-Task-Ideas - Documentation - Tests + Added tests for recently-fixed bugs using return :flat and ResizableStringArrays.
This commit is contained in:
parent
74d06fff7d
commit
3d2133c5e3
5 changed files with 37 additions and 25 deletions
|
@ -1,8 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.53 2012/02/26 10:00:03 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.54 2012/03/08 10:11:23 he Exp $
|
||||
#
|
||||
|
||||
VERSION= 3.9.0
|
||||
RTYPE= supported
|
||||
VERSION= 3.10.0
|
||||
RTYPE= devel
|
||||
DISTNAME= parrot-${VERSION}
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= ftp://ftp.parrot.org/pub/parrot/releases/${RTYPE}/${VERSION}/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.29 2012/02/09 10:39:25 he Exp $
|
||||
@comment $NetBSD: PLIST,v 1.30 2012/03/08 10:11:23 he Exp $
|
||||
bin/ops2c
|
||||
bin/parrot
|
||||
bin/parrot-nqp
|
||||
|
@ -13,6 +13,7 @@ bin/winxed
|
|||
include/parrot/${PKGVERSION}/imcc/api.h
|
||||
include/parrot/${PKGVERSION}/imcc/embed.h
|
||||
include/parrot/${PKGVERSION}/imcc/yyscanner.h
|
||||
include/parrot/${PKGVERSION}/parrot/alarm.h
|
||||
include/parrot/${PKGVERSION}/parrot/api.h
|
||||
include/parrot/${PKGVERSION}/parrot/caches.h
|
||||
include/parrot/${PKGVERSION}/parrot/call.h
|
||||
|
@ -24,10 +25,11 @@ include/parrot/${PKGVERSION}/parrot/core_pmcs.h
|
|||
include/parrot/${PKGVERSION}/parrot/core_types.h
|
||||
include/parrot/${PKGVERSION}/parrot/datatypes.h
|
||||
include/parrot/${PKGVERSION}/parrot/debugger.h
|
||||
include/parrot/${PKGVERSION}/parrot/disassemble.h
|
||||
include/parrot/${PKGVERSION}/parrot/dynext.h
|
||||
include/parrot/${PKGVERSION}/parrot/embed.h
|
||||
include/parrot/${PKGVERSION}/parrot/encoding.h
|
||||
include/parrot/${PKGVERSION}/parrot/enums.h
|
||||
include/parrot/${PKGVERSION}/parrot/events.h
|
||||
include/parrot/${PKGVERSION}/parrot/exceptions.h
|
||||
include/parrot/${PKGVERSION}/parrot/exit.h
|
||||
include/parrot/${PKGVERSION}/parrot/extend.h
|
||||
|
@ -80,11 +82,13 @@ include/parrot/${PKGVERSION}/parrot/vtables.h
|
|||
include/parrot/${PKGVERSION}/parrot/warnings.h
|
||||
include/parrot/${PKGVERSION}/pmc/dummy
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_addrregistry.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_alarm.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_arrayiterator.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_bigint.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_bignum.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_boolean.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_bytebuffer.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_callback.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_callcontext.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_capture.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_class.h
|
||||
|
@ -144,6 +148,7 @@ include/parrot/${PKGVERSION}/pmc/pmc_packfilesegment.h
|
|||
include/parrot/${PKGVERSION}/pmc/pmc_packfileview.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_parrotinterpreter.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_parrotlibrary.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_pmclist.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_pmcproxy.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_pointer.h
|
||||
include/parrot/${PKGVERSION}/pmc/pmc_ptr.h
|
||||
|
@ -195,6 +200,7 @@ lib/parrot/${PKGVERSION}/include/errors.pasm
|
|||
lib/parrot/${PKGVERSION}/include/except_severity.pasm
|
||||
lib/parrot/${PKGVERSION}/include/except_types.pasm
|
||||
lib/parrot/${PKGVERSION}/include/fp_equality.pasm
|
||||
lib/parrot/${PKGVERSION}/include/green_threads.pir
|
||||
lib/parrot/${PKGVERSION}/include/hash_key_type.pasm
|
||||
lib/parrot/${PKGVERSION}/include/hllmacros.pir
|
||||
lib/parrot/${PKGVERSION}/include/iglobals.pasm
|
||||
|
@ -498,6 +504,7 @@ lib/parrot/${PKGVERSION}/tools/lib/Parrot/H2inc.pm
|
|||
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Harness/DefaultTests.pm
|
||||
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Harness/Options.pm
|
||||
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Harness/Smoke.pm
|
||||
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Harness/TestSets.pm
|
||||
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Headerizer.pm
|
||||
lib/parrot/${PKGVERSION}/tools/lib/Parrot/Headerizer/Functions.pm
|
||||
lib/parrot/${PKGVERSION}/tools/lib/Parrot/IO/Directory.pm
|
||||
|
@ -547,11 +554,13 @@ share/doc/parrot/${PKGVERSION}/README_win32.pod
|
|||
share/doc/parrot/${PKGVERSION}/RESPONSIBLE_PARTIES
|
||||
share/doc/parrot/${PKGVERSION}/TODO
|
||||
src/parrot/${PKGVERSION}/pmc/addrregistry.dump
|
||||
src/parrot/${PKGVERSION}/pmc/alarm.dump
|
||||
src/parrot/${PKGVERSION}/pmc/arrayiterator.dump
|
||||
src/parrot/${PKGVERSION}/pmc/bigint.dump
|
||||
src/parrot/${PKGVERSION}/pmc/bignum.dump
|
||||
src/parrot/${PKGVERSION}/pmc/boolean.dump
|
||||
src/parrot/${PKGVERSION}/pmc/bytebuffer.dump
|
||||
src/parrot/${PKGVERSION}/pmc/callback.dump
|
||||
src/parrot/${PKGVERSION}/pmc/callcontext.dump
|
||||
src/parrot/${PKGVERSION}/pmc/capture.dump
|
||||
src/parrot/${PKGVERSION}/pmc/class.dump
|
||||
|
@ -611,6 +620,7 @@ src/parrot/${PKGVERSION}/pmc/packfilesegment.dump
|
|||
src/parrot/${PKGVERSION}/pmc/packfileview.dump
|
||||
src/parrot/${PKGVERSION}/pmc/parrotinterpreter.dump
|
||||
src/parrot/${PKGVERSION}/pmc/parrotlibrary.dump
|
||||
src/parrot/${PKGVERSION}/pmc/pmclist.dump
|
||||
src/parrot/${PKGVERSION}/pmc/pmcproxy.dump
|
||||
src/parrot/${PKGVERSION}/pmc/pointer.dump
|
||||
src/parrot/${PKGVERSION}/pmc/ptr.dump
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.43 2012/02/09 10:39:25 he Exp $
|
||||
$NetBSD: distinfo,v 1.44 2012/03/08 10:11:23 he Exp $
|
||||
|
||||
SHA1 (parrot-3.9.0.tar.gz) = 47fdc8e78fd3b2592f0123392b65a3e5d605930e
|
||||
RMD160 (parrot-3.9.0.tar.gz) = d48c063660fa354cd560cd127a4b3fd09e924653
|
||||
Size (parrot-3.9.0.tar.gz) = 4509594 bytes
|
||||
SHA1 (parrot-3.10.0.tar.gz) = d7474f34907ea89678e1da4b32073f53a2394355
|
||||
RMD160 (parrot-3.10.0.tar.gz) = 12f41859d234b5ee6c52f269e91c38ec562bd10e
|
||||
Size (parrot-3.10.0.tar.gz) = 4507336 bytes
|
||||
SHA1 (patch-ad) = a972d48a879e541f6894f2eeb82a70b1756437d9
|
||||
SHA1 (patch-ak) = 19d7dfff43bb08ba046040771e45b95774e024b7
|
||||
SHA1 (patch-al) = 9d4a49f417d380676fc72f79b94041adec27ad78
|
||||
SHA1 (patch-am) = 51aa10c6f087a7af980356ec98510affaa747927
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-al,v 1.3 2012/02/09 10:39:25 he Exp $
|
||||
|
||||
Parrot may end up doing usleep(1000000), which is disallowed by SUSv2.
|
||||
|
||||
--- src/scheduler.c.orig 2011-10-18 22:44:11.000000000 +0000
|
||||
+++ src/scheduler.c
|
||||
@@ -993,7 +993,7 @@ Parrot_cx_schedule_sleep(PARROT_INTERP,
|
||||
Parrot_cx_runloop_wake(interp, interp->scheduler);
|
||||
|
||||
/* A more primitive, platform-specific, non-threaded form of sleep. */
|
||||
- if (time > 1) {
|
||||
+ if (time >= 1) {
|
||||
/* prevent integer overflow when converting to microseconds
|
||||
* and problems in platforms that doesn't allow usleep more
|
||||
* than 1 second */
|
17
lang/parrot/patches/patch-am
Normal file
17
lang/parrot/patches/patch-am
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-am,v 1.4 2012/03/08 10:11:24 he Exp $
|
||||
|
||||
This test is timing-dependent, allow more time for the asynchronous
|
||||
callbacks to complete and/or a slower build + test machine.
|
||||
(Reportedly fixed in newer versions.)
|
||||
|
||||
--- t/pmc/nci.t.orig 2012-03-06 08:42:14.000000000 +0000
|
||||
+++ t/pmc/nci.t
|
||||
@@ -1917,7 +1917,7 @@ OUTPUT
|
||||
|
||||
# Need to force reschedule to see async callbacks.
|
||||
# Chandon TODO: Is this a bug?
|
||||
- sleep 0.001
|
||||
+ sleep 0.02
|
||||
|
||||
# reset int_cb_D4 to 1
|
||||
int_cb_D4[0] = 1
|
Loading…
Reference in a new issue