Fix hunspell backend. Idea from Matthias Drochner, patch from Adam Hoka.

Fix path to hunspell directories. Make hunspell the default backend.

Bump PKGREVISION.
This commit is contained in:
wiz 2008-04-17 21:07:18 +00:00
parent 0d88a9376f
commit 3d2ddcbfa6
4 changed files with 30 additions and 5 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.24 2008/04/17 14:29:58 wiz Exp $
# $NetBSD: Makefile,v 1.25 2008/04/17 21:07:18 wiz Exp $
#
DISTNAME= enchant-1.4.0
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://www.abisource.com/downloads/enchant/1.4.0/
@ -20,6 +20,8 @@ PKGCONFIG_OVERRIDE+= enchant.pc.in
GNU_CONFIGURE= yes
CFLAGS.SunOS+= -D__EXTENSIONS__
CONFIGURE_ARGS+= --with-myspell-dir=${BUILDLINK_PREFIX.hunspell}/share/hunspell
pre-configure:
cd ${WRKSRC} && autoconf

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.10 2008/04/17 14:29:58 wiz Exp $
$NetBSD: distinfo,v 1.11 2008/04/17 21:07:18 wiz Exp $
SHA1 (enchant-1.4.0.tar.gz) = 1a3c140c96769d3268a7f1faf7d9400016985537
RMD160 (enchant-1.4.0.tar.gz) = 84a253e665f71ba5b3277ad95a403ea386d42ba4
Size (enchant-1.4.0.tar.gz) = 601930 bytes
SHA1 (patch-aa) = 56ca983fdd6de171aba956b46c673299dcb7549e
SHA1 (patch-ab) = fd2319dd225493d643facb8fbe7f88dee810b1db

View file

@ -1,4 +1,4 @@
# $NetBSD: options.mk,v 1.2 2008/04/17 14:29:58 wiz Exp $
# $NetBSD: options.mk,v 1.3 2008/04/17 21:07:18 wiz Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.enchant
PKG_SUPPORTED_OPTIONS= aspell enchant-zemberek hunspell ispell
@ -6,7 +6,7 @@ PKG_SUPPORTED_OPTIONS= aspell enchant-zemberek hunspell ispell
# hspell - Hebrew spelling
# uspell - Yiddish spelling
# voikko - Finnish spelling
PKG_SUGGESTED_OPTIONS= aspell ispell
PKG_SUGGESTED_OPTIONS= hunspell ispell
.include "../../mk/bsd.options.mk"

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ab,v 1.3 2008/04/17 21:07:18 wiz Exp $
--- src/myspell/myspell_checker.cpp.orig 2008-03-21 02:45:24.000000000 +0100
+++ src/myspell/myspell_checker.cpp
@@ -39,7 +39,7 @@
#include "enchant-provider.h"
/* built against hunspell 1.1.5 on 2007-03-19 */
-#include "hunspell.hxx"
+#include <hunspell/hunspell.hxx>
ENCHANT_PLUGIN_DECLARE("Myspell")
@@ -353,7 +353,7 @@ MySpellChecker::requestDictionary(const
strcpy(aff+len_dic-3, "aff");
if (g_file_test(aff, G_FILE_TEST_EXISTS))
{
- myspell = new Hunspell(aff, dic);
+ myspell = new Hunspell(aff, dic, NULL);
}
g_free(dic);
g_free(aff);