update to 4.10
changes: added some methods and options pkgsrc note: this changes the API revision compiled into the runtime library, so updates of py-qt* must be enforced
This commit is contained in:
parent
495b237d5a
commit
3d3b166365
4 changed files with 17 additions and 17 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.11 2009/11/24 17:17:35 drochner Exp $
|
||||
# $NetBSD: Makefile,v 1.12 2010/02/04 18:34:43 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= sip-4.9.3
|
||||
DISTNAME= sip-4.10
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= x11 devel python
|
||||
MASTER_SITES= http://www.riverbankcomputing.com/static/Downloads/sip4/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.4 2009/11/24 17:17:35 drochner Exp $
|
||||
# $NetBSD: buildlink3.mk,v 1.5 2010/02/04 18:34:43 drochner Exp $
|
||||
|
||||
BUILDLINK_TREE+= py-sip
|
||||
|
||||
|
@ -7,7 +7,7 @@ PY_SIP_BUILDLINK3_MK:=
|
|||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
|
||||
BUILDLINK_API_DEPENDS.py-sip+= ${PYPKGPREFIX}-sip>=4.9.1
|
||||
BUILDLINK_API_DEPENDS.py-sip+= ${PYPKGPREFIX}-sip>=4.10
|
||||
BUILDLINK_PKGSRCDIR.py-sip?= ../../x11/py-sip
|
||||
.endif # PY_SIP_BUILDLINK3_MK
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.8 2009/11/24 17:17:35 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.9 2010/02/04 18:34:43 drochner Exp $
|
||||
|
||||
SHA1 (sip-4.9.3.tar.gz) = 789be43920e8072a4d4d99fd40e4332fd63f54c4
|
||||
RMD160 (sip-4.9.3.tar.gz) = fae89ea6ca770e96953dfab4bb1fe29cdc28eb9c
|
||||
Size (sip-4.9.3.tar.gz) = 661144 bytes
|
||||
SHA1 (patch-aa) = 67da3bbb531ee50ba47b0ce4ee7a6edf5d0ad139
|
||||
SHA1 (sip-4.10.tar.gz) = 4dfe9e18dff6b6802c5e3f577346092619d5d59b
|
||||
RMD160 (sip-4.10.tar.gz) = ebb53aadd08cccbc3ad78175b604dc939eb164db
|
||||
Size (sip-4.10.tar.gz) = 702403 bytes
|
||||
SHA1 (patch-aa) = d6986bbc402fc8b345b2f624fbc2537bf6c275eb
|
||||
SHA1 (patch-ab) = f5ba9704fc3867a1273dca534b145cdb14b070e7
|
||||
|
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.2 2009/06/09 13:51:57 wiz Exp $
|
||||
$NetBSD: patch-aa,v 1.3 2010/02/04 18:34:43 drochner Exp $
|
||||
|
||||
--- configure.py.orig 2009-06-05 08:59:07.000000000 +0000
|
||||
--- configure.py.orig 2010-01-14 14:52:09.000000000 +0000
|
||||
+++ configure.py
|
||||
@@ -198,7 +198,7 @@ def set_platform_directories():
|
||||
@@ -208,7 +208,7 @@ def set_platform_directories():
|
||||
|
||||
plat_py_lib_dir = lib_dir + "/config"
|
||||
plat_bin_dir = sys.exec_prefix + "/bin"
|
||||
|
@ -11,7 +11,7 @@ $NetBSD: patch-aa,v 1.2 2009/06/09 13:51:57 wiz Exp $
|
|||
|
||||
|
||||
def create_config(module, template, macros):
|
||||
@@ -216,7 +216,7 @@ def create_config(module, template, macr
|
||||
@@ -226,7 +226,7 @@ def create_config(module, template, macr
|
||||
"sip_version": sip_version,
|
||||
"sip_version_str": sip_version_str,
|
||||
"platform": opts.platform,
|
||||
|
@ -20,12 +20,12 @@ $NetBSD: patch-aa,v 1.2 2009/06/09 13:51:57 wiz Exp $
|
|||
"sip_inc_dir": opts.sipincdir,
|
||||
"sip_mod_dir": opts.sipmoddir,
|
||||
"default_bin_dir": plat_bin_dir,
|
||||
@@ -249,7 +249,7 @@ def create_makefiles(macros):
|
||||
@@ -261,7 +261,7 @@ def create_makefiles(macros):
|
||||
sipconfig.ParentMakefile(
|
||||
configuration=cfg,
|
||||
subdirs=["sipgen", "siplib"],
|
||||
- installs=(["sipconfig.py", "sipdistutils.py"], cfg.sip_mod_dir)
|
||||
+ installs=(["sipconfig.py", "sipconfig.pyc", "sipdistutils.py"], cfg.sip_mod_dir)
|
||||
- installs=(["sipconfig.py", os.path.join(src_dir, "sipdistutils.py")],
|
||||
+ installs=(["sipconfig.py", "sipconfig.pyc", os.path.join(src_dir, "sipdistutils.py")],
|
||||
cfg.sip_mod_dir)
|
||||
).generate()
|
||||
|
||||
sipconfig.inform("Creating sip code generator Makefile...")
|
||||
|
|
Loading…
Reference in a new issue