Fixed a g++ error message.
Cleaned up the package Makefile.
This commit is contained in:
parent
e2ab3e78c4
commit
3d5b9a46ac
4 changed files with 25 additions and 54 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.10 2007/03/08 19:25:32 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2007/03/17 15:59:12 rillig Exp $
|
||||
|
||||
DISTNAME= lincvs-1.4.4-0-generic-src
|
||||
PKGNAME= ${DISTNAME:S/-0-generic-src//}
|
||||
|
@ -24,24 +24,19 @@ SUBST_FILES.appdir= src/lincvs.cpp src/main.cpp src/cvscontrol.cpp
|
|||
SUBST_SED.appdir= -e 's,%%PREFIX%%,${PREFIX},'
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
|
||||
INSTALLATION_DIRS_FROM_PLIST= yes
|
||||
|
||||
do-configure:
|
||||
${QTDIR}/bin/qmake -o ${WRKSRC}/Makefile ${WRKSRC}/lincvs.pro
|
||||
cd ${WRKSRC} && qmake -o Makefile lincvs.pro
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/lincvs.bin ${PREFIX}/bin/lincvs
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/contrib/rshwrapper/rshwrapper ${PREFIX}/libexec/rshwrapper
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/lincvs
|
||||
.for FILE in FAM-HOWTO.txt FAQ.txt INFO.txt INSTALL INSTALL.html PROXY-HOWTO.txt README README.html SSH-HOWTO.txt
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${PREFIX}/share/doc/lincvs/
|
||||
cd ${WRKSRC}/doc && ${INSTALL_DATA} FAM-HOWTO.txt FAQ.txt INFO.txt INSTALL INSTALL.html PROXY-HOWTO.txt README README.html SSH-HOWTO.txt ${PREFIX}/share/doc/lincvs/
|
||||
.for lang in de it ru
|
||||
cd ${WRKSRC}/doc/translations/${lang} && ${INSTALL_DATA} * ${PREFIX}/share/doc/lincvs/${lang}/
|
||||
.endfor
|
||||
.for LANG in de it ru
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/lincvs/${LANG}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/translations/${LANG}/* ${PREFIX}/share/doc/lincvs/${LANG}/
|
||||
.endfor
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/lincvs/messages
|
||||
${INSTALL_DATA} ${WRKSRC}/ts/*.qm ${PREFIX}/share/lincvs/messages/
|
||||
|
||||
.include "../../x11/qt3-libs/buildlink3.mk"
|
||||
.include "../../x11/qt3-tools/buildlink3.mk"
|
||||
.include "../../x11/qt3/application.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.2 2005/12/31 09:08:22 ghen Exp $
|
||||
$NetBSD: distinfo,v 1.3 2007/03/17 15:59:12 rillig Exp $
|
||||
|
||||
SHA1 (lincvs-1.4.4-0-generic-src.tgz) = b144d4faf67a0e6a45a925e7937cccfd4084049e
|
||||
RMD160 (lincvs-1.4.4-0-generic-src.tgz) = 163d85fa2567fe6f1eeacfeb080a188e2ff04bef
|
||||
Size (lincvs-1.4.4-0-generic-src.tgz) = 1232079 bytes
|
||||
SHA1 (patch-aa) = 386b98a60c614a467932768709b9772160e328f4
|
||||
SHA1 (patch-ah) = 781ddbcbbd310f1db3d2dfbc3b3f0042dd5e4bcb
|
||||
SHA1 (patch-ai) = 4a748fd61e552f3503f025027a9c9e50e3d79e64
|
||||
SHA1 (patch-aj) = 5c39c28df7a4723bd1d10341b38ecaff70d7bf21
|
||||
SHA1 (patch-ak) = 0a308bb9fd9729c65997718fffb64fc1364d8d5d
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2005/12/28 13:07:14 ghen Exp $
|
||||
|
||||
--- lincvs.pro.orig 2005-07-31 14:32:58.000000000 +0200
|
||||
+++ lincvs.pro
|
||||
@@ -22,7 +22,7 @@ unix {
|
||||
# check timezone functions (Unix only)
|
||||
!mac:unix {
|
||||
message( "Check for timezone function..." )
|
||||
- system(cd test && qmake -o Makefile check_tz.pro && make)
|
||||
+ system(cd test && %%QTDIR%%/bin/qmake -o Makefile check_tz.pro && make)
|
||||
exists(test/check_tz) {
|
||||
# use gmtoff member of tm structure
|
||||
message("Use gmtoff member of tm structure")
|
||||
@@ -42,7 +42,7 @@ mac {
|
||||
# check for standard compliant compiler (Unix only)
|
||||
!mac:unix {
|
||||
message( "Check for standard compliant compiler..." )
|
||||
- system(cd test && qmake -o Makefile check_std.pro && make)
|
||||
+ system(cd test && %%QTDIR%%/bin/qmake -o Makefile check_std.pro && make)
|
||||
exists(test/check_std) {
|
||||
# compiler knows std
|
||||
message("Use std namespace")
|
||||
@@ -59,7 +59,7 @@ mac {
|
||||
# check for working exception handling (Unix only)
|
||||
!mac:unix {
|
||||
message( "Check for working exception handling..." )
|
||||
- system(cd test && qmake -o Makefile check_exc.pro && make)
|
||||
+ system(cd test && %%QTDIR%%/bin/qmake -o Makefile check_exc.pro && make)
|
||||
exists(test/check_exc) {
|
||||
# exception handling works
|
||||
message("Exception handling works")
|
||||
@@ -76,7 +76,7 @@ mac {
|
||||
# check for nanosleep (Unix only)
|
||||
!mac:unix {
|
||||
message( "Check for nanosleep..." )
|
||||
- system(cd test && qmake -o Makefile check_nano.pro && make)
|
||||
+ system(cd test && %%QTDIR%%/bin/qmake -o Makefile check_nano.pro && make)
|
||||
exists(test/check_nano) {
|
||||
# use nanosleep
|
||||
message("Use nanosleep")
|
16
devel/lincvs/patches/patch-ak
Normal file
16
devel/lincvs/patches/patch-ak
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-ak,v 1.1 2007/03/17 15:59:12 rillig Exp $
|
||||
|
||||
g++4 complains:
|
||||
src/PixmapTimer.h:87: error: extra qualification 'CPixmapTimer::' on member 'CPixmapTimer'
|
||||
|
||||
--- src/PixmapTimer.h.orig 2005-07-25 22:13:55.000000000 +0200
|
||||
+++ src/PixmapTimer.h 2007-03-17 16:02:46.000000000 +0100
|
||||
@@ -84,7 +84,7 @@ class CPixmapTimer : public QObject
|
||||
|
||||
public:
|
||||
CPixmapTimer(QObject * parent = 0, const char * name = 0);
|
||||
- CPixmapTimer::~CPixmapTimer();
|
||||
+ ~CPixmapTimer();
|
||||
|
||||
signals:
|
||||
void signalTimeout(const QPixmap &);
|
Loading…
Reference in a new issue