Update to 1.33, as requested in pkg/16254.

Changes:
    Added make file options for SCO and NetBSD.  The Makefile has been
    reconfigured a touch to make it clearer what needs to be done for each
    OS.

    Turn was accepting invalid option as in heyu turn allaskljas.  It now
    complains and exits.

    Found bug in scanning the macros. (thanks to David Pointer)

    Dan Eble reported a bug (or feature) that allows chaining macros
    with delays.  I've fixed the bug but not enabled the feature.

    Makesched utility created.  This utility pre-preocesses a file in the
    x10sched format and sends a revised version to standard output with the
    strings "dawn" and "dusk" expanded to appropriate values.

    Cleaned up some error messages to give feedback when the locks fail.

    A coding error was causing the dates in the schedule loader to be off
    in some cases.  Thanks to Charles Sullivan for finding and reporting
    the bug and it's fix

    The use of just the -v option caused a sigfault.  The errant code
    was corrected in x10.c main().
This commit is contained in:
wiz 2002-07-02 14:03:48 +00:00
parent 66332a11fc
commit 3d6cf2dc00
10 changed files with 129 additions and 80 deletions

View file

@ -1,17 +1,22 @@
# $NetBSD: Makefile,v 1.2 2001/02/17 18:09:06 wiz Exp $
# $NetBSD: Makefile,v 1.3 2002/07/02 14:03:48 wiz Exp $
#
DISTNAME= x10_heyu
PKGNAME= x10_heyu-1.29
PKGNAME= x10_heyu-1.33
CATEGORIES= misc
MASTER_SITES= http://heyu.tanj.com/heyu/
MASTER_SITES= http://heyu.tanj.com/
EXTRACT_SUFX= .tgz
MAINTAINER= damon@brodiefamily.org
HOMEPAGE= http://heyu.tanj.com/heyu/index.html
HOMEPAGE= http://heyu.tanj.com/
COMMENT= Home Automation Software for the X10 CM11A
ALL_TARGET= # Defined
DIST_SUBDIR= ${PKGNAME}
CONFIGURE_SCRIPT= ./Configure
WRKSRC= ${WRKDIR}/heyu.dir
pre-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/heyu
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +1,7 @@
@comment $NetBSD: PLIST,v 1.1 2001/11/01 01:28:17 zuntum Exp $
@comment $NetBSD: PLIST,v 1.2 2002/07/02 14:03:49 wiz Exp $
bin/heyu
man/man1/heyu.1
man/man5/x10config.5
man/man5/x10sched.5
share/examples/heyu/x10config
@dirrm share/examples/heyu

View file

@ -1,8 +1,11 @@
$NetBSD: distinfo,v 1.2 2001/05/09 20:50:35 wiz Exp $
$NetBSD: distinfo,v 1.3 2002/07/02 14:03:50 wiz Exp $
SHA1 (x10_heyu.tgz) = a35ab200e4039b373795986609c3d1fe866c27c8
Size (x10_heyu.tgz) = 67832 bytes
SHA1 (patch-aa) = 0f56432dbbbf84a4d59f987330d1922e82edc811
SHA1 (patch-ab) = 1700d36fb281543df2e53c305f9390137d133409
SHA1 (patch-ac) = fc325b009515f700b42b8f55c9712599667b9699
SHA1 (patch-ad) = 749fbc64ad6566c5d268f3d511122ab94f36b53e
SHA1 (x10_heyu-1.33/x10_heyu.tgz) = 73e588ca76c6402a911452bb68717c8c0ba8dbe7
Size (x10_heyu-1.33/x10_heyu.tgz) = 75670 bytes
SHA1 (patch-aa) = a0430f7d74c2e87017b8146447d913365ae45f0a
SHA1 (patch-ab) = 42e9cb8480b1526124dd286b37a1eb7eb819eb4c
SHA1 (patch-ac) = 502fc98e81fdda9f5269ab3b2d1a6338f3745b9c
SHA1 (patch-ad) = 2efc8ff608a5d5761e0a0e96244510756e0ad27a
SHA1 (patch-ae) = d1c8aba7aadc28347c8fa180e8c3cf2d15aea5b6
SHA1 (patch-af) = f35f99727d31764d8c3445193f4b0469dc6308df
SHA1 (patch-ag) = 053a71f18936ee326cc826bffcacf254a1d6cf76

View file

@ -1,55 +1,16 @@
$NetBSD: patch-aa,v 1.1.1.1 2000/07/15 06:50:36 rh Exp $
$NetBSD: patch-aa,v 1.2 2002/07/02 14:03:51 wiz Exp $
--- Makefile.orig Thu Jul 6 23:34:32 2000
+++ Makefile Thu Jul 6 23:35:19 2000
@@ -1,10 +1,7 @@
# Makefile for CM11, a program to control an X10 CM11A computer interface.
-# Makefile $Revision: 1.1.1.1 $
-BIN = /usr/local/bin
-MAN = /usr/local/man/man1
-MAN5 = /usr/local/man/man5
-GROUP = sys
-OWNER = bin
+BIN = ${PREFIX}/bin
+MAN = ${PREFIX}/man/man1
+MAN5 = ${PREFIX}/man/man5
--- stop.c.orig Thu Dec 7 06:42:20 2000
+++ stop.c
@@ -33,9 +33,11 @@
char *argv[];
{
unsigned long pid;
+#ifdef __linux__
FILE * pidfile;
char buf[80];
char procname[80];
+#endif
extern unsigned long lockpid();
extern void quit();
# set DFLAGS equal to:
@@ -22,10 +19,10 @@
## For LINUX, use the following
#DFLAGS = -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX
CC = gcc
-CFLAGS = -g -O $(DFLAGS) -Wall
-DFLAGS = -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT
+#CFLAGS = -g -O $(DFLAGS) -Wall
+#DFLAGS = -DSYSV -DPOSIX -DHAS_ITIMER -DLINUX -DHASSELECT
#LIBS = -lm -lc_s # uncomment if using shared libraries
-LIBS = -lm -lc # uncoment if not using shared libraries
+#LIBS = -lm -lc # uncoment if not using shared libraries
## For solaris, use the following defines in addition to what's above
# CC = gcc
@@ -41,6 +38,12 @@
# LIBS = -lm -lc
# DFLAGS= -DHASSELECT
+## if you're using NetBSD:
+CC = gcc
+CFLAGS = -g -O $(DFLAGS) -Wall
+LIBS = -lm -lc
+DFLAGS= -DHASSELECT -DPOSIX -DNETBSD -DLOCKDIR=\"/var/spool/lock\"
+
## for Alpha, OSF1 v4.0 , Use this
# GROUP = uucp
# CC = gcc
@@ -96,9 +99,7 @@
$(BIN)/heyu: heyu
cp heyu $(BIN)
- chgrp $(GROUP) $(BIN)/heyu
chmod 755 $(BIN)/heyu
- chown $(OWNER) $(BIN)/heyu
$(MAN)/heyu.1: heyu.1
cp heyu.1 $(MAN)

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ab,v 1.1.1.1 2000/07/15 06:50:36 rh Exp $
$NetBSD: patch-ab,v 1.2 2002/07/02 14:03:51 wiz Exp $
--- heyu.1.orig Thu Jul 6 23:01:16 2000
+++ heyu.1 Thu Jul 6 23:01:27 2000
--- heyu.1.orig Sun May 28 20:26:25 2000
+++ heyu.1
@@ -242,7 +242,7 @@
.br
.x10sched.conf - CM11A schedule information for timers and macros.

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ac,v 1.1.1.1 2000/07/15 06:50:36 rh Exp $
$NetBSD: patch-ac,v 1.2 2002/07/02 14:03:52 wiz Exp $
--- tty.c.orig Thu Jul 6 23:01:40 2000
+++ tty.c Thu Jul 6 23:01:49 2000
@@ -87,7 +87,12 @@
--- tty.c.orig Sat Feb 10 21:45:49 2001
+++ tty.c
@@ -92,7 +92,12 @@
#endif
struct termio oldsb, newsb;
#else

View file

@ -1,14 +1,31 @@
$NetBSD: patch-ad,v 1.1.1.1 2000/07/15 06:50:36 rh Exp $
$NetBSD: patch-ad,v 1.2 2002/07/02 14:03:52 wiz Exp $
--- xread.c.orig Thu Jul 6 23:02:14 2000
+++ xread.c Thu Jul 6 23:02:23 2000
@@ -29,6 +29,9 @@
--- xread.c.orig Wed Apr 11 06:49:48 2001
+++ xread.c
@@ -28,7 +28,7 @@
#include <stdio.h>
#include <signal.h>
#include <setjmp.h>
-#if (defined(SCO) || defined (SOLARIS))
+#if (defined(SCO) || defined (SOLARIS) || defined(NETBSD))
#include <errno.h>
#else
#include <sys/errno.h>
+#ifdef NETBSD
+ #include <errno.h>
+#endif
@@ -36,7 +36,7 @@
#include <syslog.h>
#include <unistd.h>
#include "x10.h"
-#if (defined(LINUX) || defined(SOLARIS) || defined(FREEBSD))
+#if (defined(LINUX) || defined(SOLARIS) || defined(FREEBSD) || defined(NETBSD))
#include <string.h> /* char *strerror(); */
#endif
@@ -128,7 +128,7 @@
if( (i < 0) && (i_am_relay != 1) )
{
syslog(LOG_ERR,"Xread read error");
- syslog(LOG_ERR, strerror(errno));
+ syslog(LOG_ERR, "%s", strerror(errno));
}
(void) alarm(0);
(void) signal(SIGALRM, SIG_IGN);

View file

@ -0,0 +1,26 @@
$NetBSD: patch-ae,v 1.1 2002/07/02 14:03:53 wiz Exp $
--- Configure.orig Mon Apr 16 07:24:14 2001
+++ Configure
@@ -15,9 +15,9 @@
# paths:
cat >> Makefile <<EoF
-BIN = /usr/local/bin
-MAN = /usr/local/man/man1
-MAN5 = /usr/local/man/man5
+BIN = ${PREFIX}/bin
+MAN = ${PREFIX}/man/man1
+MAN5 = ${PREFIX}/man/man5
GROUP = sys
OWNER = bin
@@ -111,7 +111,7 @@
;;
netbsd)
cat >> Makefile <<-EoF
- DFLAGS = -DPOSIX -DLOCKDIR=\"/var/spool/lock\"
+ DFLAGS = -DPOSIX -DLOCKDIR=\"/var/spool/lock\" -DNETBSD
CC = gcc
CFLAGS = -g -O \$(DFLAGS) -Wall
LIBS = -lm -lc

View file

@ -0,0 +1,13 @@
$NetBSD: patch-af,v 1.1 2002/07/02 14:03:54 wiz Exp $
--- xwrite.c.orig Wed Apr 11 06:46:26 2001
+++ xwrite.c
@@ -47,7 +47,7 @@
# endif
#endif
-#ifdef OSF
+#if (defined(OSF) || defined(NETBSD))
#include <sys/ioctl.h>
#endif

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ag,v 1.1 2002/07/02 14:03:54 wiz Exp $
--- install.sh.orig Sat Jan 27 22:55:57 2001
+++ install.sh
@@ -28,7 +28,7 @@
while : ; do
echo "Where would you like the sample X10 configuration installed?"
echo "The default is $HOME/.x10config"
- read WHERE
+ WHERE=${PREFIX}/share/examples/heyu/x10config
if [ "$WHERE" = "" ] ; then
FOUND=$HOME/.x10config
break
@@ -56,7 +56,7 @@
;;
esac
echo "To which port is the CM11 attached?"
- read WHERE
+ WHERE=/dev/tty01
if [ "$WHERE" != "" ] ; then
if [ -e $WHERE ] ; then
TTY=$WHERE