Fix png-1.5 fix. From drochner@

Bump PKGREVISION.
This commit is contained in:
wiz 2011-01-18 09:01:29 +00:00
parent d35eb2de2b
commit 3d7c9fd46d
3 changed files with 9 additions and 14 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.33 2011/01/13 13:36:08 wiz Exp $
# $NetBSD: Makefile,v 1.34 2011/01/18 09:01:29 wiz Exp $
DISTNAME= gdal-1.7.3
PKGNAME= gdal-lib-1.7.3
PKGREVISION= 1
PKGREVISION= 2
CATEGORIES= geography
MASTER_SITES= http://download.osgeo.org/gdal/

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.11 2011/01/17 09:14:15 wiz Exp $
$NetBSD: distinfo,v 1.12 2011/01/18 09:01:29 wiz Exp $
SHA1 (gdal-1.7.3.tar.gz) = 58d4355fe792ad618bb74605dc1a084a0aeb7cb1
RMD160 (gdal-1.7.3.tar.gz) = ce84a12d48c85a58c56a17381aee1c4f2ba08b57
Size (gdal-1.7.3.tar.gz) = 7757684 bytes
SHA1 (patch-aa) = 2c017bda45d4ed4fb10f7e70d33b707ca33149d1
SHA1 (patch-ab) = 77c034b05151a7a300b302b79ba803212db297b1
SHA1 (patch-ab) = 566dadb4e710207a42acd07e216496b6e476e6b4

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ab,v 1.6 2011/01/17 09:14:15 wiz Exp $
$NetBSD: patch-ab,v 1.7 2011/01/18 09:01:29 wiz Exp $
Fix build with png-1.5.
@ -31,20 +31,15 @@ Fix build with png-1.5.
}
/************************************************************************/
@@ -1338,10 +1338,13 @@ static void png_gdal_error( png_structp
@@ -1338,10 +1338,10 @@ static void png_gdal_error( png_structp
// libpng is generally not built as C++ and so won't honour unwind
// semantics. Ugg.
- jmp_buf* psSetJmpContext = (jmp_buf*) png_ptr->error_ptr;
- if (psSetJmpContext)
+ if (png_jmpbuf(png_ptr))
+ jmp_buf* psSetJmpContext = (jmp_buf*) png_get_error_ptr(png_ptr);
if (psSetJmpContext)
{
- longjmp( *psSetJmpContext, 1 );
+#if (PNG_LIBPNG_VER < 10500)
+ longjmp( (jmp_buf*) png_ptr->error_ptr, 1 );
+#else
+ png_longjmp (png_ptr, 1);
+#endif
longjmp( *psSetJmpContext, 1 );
}
}