pinentry*: updated to 1.3.0

Noteworthy changes in version 1.3.0 (2024-03-18)
------------------------------------------------
* qt: Add new Qt6 frontend.
* qt: Set parent window on Wayland.
* qt: Fix capslock detection on Wayland.
* qt: Fix window icon on Wayland.
* qt: Add support for external password manager with libsecret.
* qt: Remove focus indication by text selection.
* qt: Use same focus indication for labels as Kleopatra.
* qt: Improve accessibility.
* gnome3: Prefer gcr-4.
* curses: Fix timeout handling.
* curses: Add SETREPEATOK and quality bar colors.
* curses: Add password quality meter.
* curses,tty: Upon SIGINT, let pinentry exit gracefully.
* w32: Fix non-focused window and simplify code.
* Disable secret storage integration when running on KDE Plasma.
* The Windows CE support has been removed.
This commit is contained in:
adam 2024-03-20 15:46:37 +00:00
parent 81ed0bc757
commit 3d863d3f62
14 changed files with 91 additions and 47 deletions

View File

@ -1,21 +1,20 @@
# $NetBSD: Makefile,v 1.8 2023/11/12 13:23:25 wiz Exp $
# $NetBSD: Makefile,v 1.9 2024/03/20 15:46:37 adam Exp $
PKGNAME= ${DISTNAME:S/pinentry-/pinentry-fltk-/}
PKGREVISION= 2
COMMENT= Applications for entering PINs or Passphrases, FLTK enabled
.include "../../security/pinentry/Makefile.common"
USE_LANGUAGES+= c c++
USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config
CONFIGURE_ARGS+= --disable-libsecret
CONFIGURE_ARGS+= --disable-pinentry-curses
CONFIGURE_ARGS+= --disable-pinentry-efl
CONFIGURE_ARGS+= --disable-pinentry-emacs
CONFIGURE_ARGS+= --disable-pinentry-gnome3
CONFIGURE_ARGS+= --disable-pinentry-gtk2
CONFIGURE_ARGS+= --disable-pinentry-qt
CONFIGURE_ARGS+= --disable-libsecret
CONFIGURE_ARGS+= --disable-pinentry-qt5
CONFIGURE_ARGS+= --enable-pinentry-fltk
INSTALL_DIRS= fltk

View File

@ -1,19 +1,19 @@
# $NetBSD: Makefile,v 1.11 2023/11/14 14:02:48 wiz Exp $
# $NetBSD: Makefile,v 1.12 2024/03/20 15:46:38 adam Exp $
PKGNAME= ${DISTNAME:S/pinentry-/pinentry-gnome3-/}
PKGREVISION= 5
COMMENT= Applications for entering PINs or Passphrases, GNOME 3 enabled
.include "../../security/pinentry/Makefile.common"
USE_TOOLS+= pkg-config
CONFIGURE_ARGS+= --disable-libsecret
CONFIGURE_ARGS+= --disable-pinentry-curses
CONFIGURE_ARGS+= --disable-pinentry-emacs
CONFIGURE_ARGS+= --disable-pinentry-efl
CONFIGURE_ARGS+= --disable-pinentry-fltk
CONFIGURE_ARGS+= --disable-pinentry-gtk2
CONFIGURE_ARGS+= --disable-pinentry-qt
CONFIGURE_ARGS+= --disable-libsecret
CONFIGURE_ARGS+= --disable-pinentry-qt5
CONFIGURE_ARGS+= --enable-pinentry-gnome3
INSTALL_DIRS= gnome3

View File

@ -1,20 +1,20 @@
# $NetBSD: Makefile,v 1.60 2023/11/14 14:02:48 wiz Exp $
# $NetBSD: Makefile,v 1.61 2024/03/20 15:46:38 adam Exp $
PKGNAME= ${DISTNAME:S/pinentry-/pinentry-gtk2-/}
PKGREVISION= 5
COMMENT= Applications for entering PINs or Passphrases, GTK+ enabled
.include "../../security/pinentry/Makefile.common"
USE_TOOLS+= pkg-config
CONFIGURE_ARGS+= --enable-pinentry-gtk2
CONFIGURE_ARGS+= --disable-libsecret
CONFIGURE_ARGS+= --disable-pinentry-curses
CONFIGURE_ARGS+= --disable-pinentry-emacs
CONFIGURE_ARGS+= --disable-pinentry-efl
CONFIGURE_ARGS+= --disable-pinentry-fltk
CONFIGURE_ARGS+= --disable-pinentry-gnome3
CONFIGURE_ARGS+= --disable-pinentry-qt
CONFIGURE_ARGS+= --disable-libsecret
CONFIGURE_ARGS+= --disable-pinentry-qt5
CONFIGURE_ARGS+= --enable-pinentry-gtk2
INSTALL_DIRS= gtk+-2

View File

@ -3,4 +3,4 @@ utilize the Assuan protocol as described by the aegypten project.
It provides programs for several graphical toolkits, such as GTK+ and
QT, as well as for the console, using curses.
This package contains the QT5 frontend.
This package contains the Qt5 frontend.

View File

@ -1,25 +1,26 @@
# $NetBSD: Makefile,v 1.14 2023/11/12 13:23:25 wiz Exp $
# $NetBSD: Makefile,v 1.15 2024/03/20 15:46:38 adam Exp $
PKGNAME= ${DISTNAME:S/pinentry-/pinentry-qt5-/}
PKGREVISION= 8
COMMENT= Applications for entering PINs or Passphrases, qt5 enabled
COMMENT= Applications for entering PINs or Passphrases, Qt5 enabled
CONFLICTS= pinentry-qt4-[0-9]*
.include "../../security/pinentry/Makefile.common"
USE_LANGUAGES+= c c++
USE_TOOLS+= pkg-config gmake autoconf
CONFIGURE_ARGS+= --disable-libsecret
CONFIGURE_ARGS+= --disable-pinentry-curses
CONFIGURE_ARGS+= --disable-pinentry-emacs
CONFIGURE_ARGS+= --disable-pinentry-efl
CONFIGURE_ARGS+= --disable-pinentry-fltk
CONFIGURE_ARGS+= --disable-pinentry-gnome3
CONFIGURE_ARGS+= --disable-pinentry-gtk2
CONFIGURE_ARGS+= --disable-libsecret
CONFIGURE_ARGS+= --enable-pinentry-qt
CONFIGURE_ENV+= RCC="${QTDIR}/bin/rcc"
CONFIGURE_ARGS+= --disable-pinentry-qt
CONFIGURE_ARGS+= --enable-pinentry-qt5
CONFIGURE_ENV+= MOC5="${QTDIR}/bin/moc"
CONFIGURE_ENV+= RCC5="${QTDIR}/bin/rcc"
INSTALL_DIRS= qt
INSTALL_DIRS= qt5
pre-configure:
cd ${WRKSRC} && autoreconf -i -f

View File

@ -1,2 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2021/02/06 10:26:54 wiz Exp $
bin/pinentry-qt
@comment $NetBSD: PLIST,v 1.2 2024/03/20 15:46:38 adam Exp $
bin/pinentry-qt5
share/applications/org.gnupg.pinentry-qt5.desktop

View File

@ -0,0 +1,6 @@
This is a collection of simple PIN or passphrase entry dialogs which
utilize the Assuan protocol as described by the aegypten project.
It provides programs for several graphical toolkits, such as GTK+ and
QT, as well as for the console, using curses.
This package contains the Qt6 frontend.

View File

@ -0,0 +1,32 @@
# $NetBSD: Makefile,v 1.1 2024/03/20 15:46:38 adam Exp $
PKGNAME= ${DISTNAME:S/pinentry-/pinentry-qt6-/}
COMMENT= Applications for entering PINs or Passphrases, Qt6 enabled
CONFLICTS= pinentry-qt4-[0-9]*
.include "../../security/pinentry/Makefile.common"
USE_CXX_FEATURES= c++17
USE_LANGUAGES= c c++
USE_TOOLS+= pkg-config gmake autoconf
FORCE_CXX_STD= c++17
CONFIGURE_ARGS+= --disable-libsecret
CONFIGURE_ARGS+= --disable-pinentry-curses
CONFIGURE_ARGS+= --disable-pinentry-emacs
CONFIGURE_ARGS+= --disable-pinentry-efl
CONFIGURE_ARGS+= --disable-pinentry-fltk
CONFIGURE_ARGS+= --disable-pinentry-gnome3
CONFIGURE_ARGS+= --disable-pinentry-gtk2
CONFIGURE_ARGS+= --disable-pinentry-qt5
CONFIGURE_ARGS+= --enable-pinentry-qt
CONFIGURE_ENV+= MOC6="${QTDIR}/libexec/moc"
CONFIGURE_ENV+= RCC6="${QTDIR}/libexec/rcc"
INSTALL_DIRS= qt
pre-configure:
cd ${WRKSRC} && autoreconf -i -f
BUILDLINK_API_DEPENDS.libgpg-error+= libgpg-error>=1.0.0
.include "../../x11/qt6-qtbase/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View File

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1 2024/03/20 15:46:38 adam Exp $
bin/pinentry-qt
share/applications/org.gnupg.pinentry-qt.desktop

View File

@ -1,14 +1,15 @@
# $NetBSD: Makefile,v 1.53 2022/01/13 08:05:48 adam Exp $
# $NetBSD: Makefile,v 1.54 2024/03/20 15:46:37 adam Exp $
COMMENT= Applications for entering PINs or Passphrases
CONFIGURE_ARGS+= --enable-pinentry-tty
CONFIGURE_ARGS+= --enable-pinentry-emacs
CONFIGURE_ARGS+= --disable-pinentry-fltk
CONFIGURE_ARGS+= --disable-pinentry-gnome3
CONFIGURE_ARGS+= --disable-pinentry-gtk2
CONFIGURE_ARGS+= --disable-pinentry-qt
CONFIGURE_ARGS+= --disable-pinentry-qt5
CONFIGURE_ARGS+= --disable-pinentry-tqt
CONFIGURE_ARGS+= --enable-pinentry-emacs
CONFIGURE_ARGS+= --enable-pinentry-tty
.include "../../security/pinentry/Makefile.common"

View File

@ -1,12 +1,13 @@
# $NetBSD: Makefile.common,v 1.17 2022/09/01 09:15:16 adam Exp $
# $NetBSD: Makefile.common,v 1.18 2024/03/20 15:46:37 adam Exp $
#
# used by security/pinentry/Makefile
# used by security/pinentry-fltk/Makefile
# used by security/pinentry-gnome3/Makefile
# used by security/pinentry-gtk2/Makefile
# used by security/pinentry-qt5/Makefile
# used by security/pinentry-qt6/Makefile
DISTNAME= pinentry-1.2.1
DISTNAME= pinentry-1.3.0
CATEGORIES= security
MASTER_SITES= ftp://ftp.gnupg.org/gcrypt/pinentry/

View File

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.29 2022/09/01 09:15:16 adam Exp $
$NetBSD: distinfo,v 1.30 2024/03/20 15:46:37 adam Exp $
BLAKE2s (pinentry-1.2.1.tar.bz2) = 818e0aa67ef36f51704e031882eb3b74196dcbcc7df5dbbc80c6ee8c3ab7c603
SHA512 (pinentry-1.2.1.tar.bz2) = a665315628f4dcf07e16a22db3f3be15d7e7e93b3deec0546c7275b71b0e3bd65535a08af5e12d6339fd6595132df86529401d9d12bd17c428a3466e8dfafab6
Size (pinentry-1.2.1.tar.bz2) = 547698 bytes
SHA1 (patch-m4_qt.m4) = eeb1e8fcba15c0458d9ccf8ab77a5bb66bc1bae8
BLAKE2s (pinentry-1.3.0.tar.bz2) = 39e01333ae946a46c30cbbb90672068f56a7ec94463ce66e162acc737dded6e5
SHA512 (pinentry-1.3.0.tar.bz2) = 1bbac81c6811cffc8969a46494e6daa6b8447802f47ff6fa3e4dc9ac244cf6e5f629834c9b6a60770d06bff6c9932ad4059f10d2fdf93fd9e26fd5d21c0e3732
Size (pinentry-1.3.0.tar.bz2) = 610363 bytes
SHA1 (patch-m4_qt5.m4) = 2c436880dc564386e7548a1834848c0a50252ad2

View File

@ -1,15 +0,0 @@
$NetBSD: patch-m4_qt.m4,v 1.1 2022/01/13 08:05:48 adam Exp $
The "-rpath" option requires an equal sign.
--- m4/qt.m4.orig 2021-08-12 14:30:43.000000000 +0000
+++ m4/qt.m4
@@ -60,7 +60,7 @@ AC_DEFUN([FIND_QT],
qtlibdir=`"$PKG_CONFIG" --variable libdir Qt5Core`
if test -n "$qtlibdir"; then
if test "$enable_rpath" != "no"; then
- PINENTRY_QT_LDFLAGS="$PINENTRY_QT_LDFLAGS -Wl,-rpath \"$qtlibdir\""
+ PINENTRY_QT_LDFLAGS="$PINENTRY_QT_LDFLAGS -Wl,-rpath=\"$qtlibdir\""
fi
fi

View File

@ -0,0 +1,15 @@
$NetBSD: patch-m4_qt5.m4,v 1.1 2024/03/20 15:46:37 adam Exp $
The "-rpath" option requires an equal sign.
--- m4/qt5.m4.orig 2023-03-20 07:10:22.000000000 +0000
+++ m4/qt5.m4
@@ -59,7 +59,7 @@ AC_DEFUN([FIND_QT5],
qt5libdir=`"$PKG_CONFIG" --variable libdir Qt5Core`
if test -n "$qt5libdir"; then
if test "$enable_rpath" != "no"; then
- PINENTRY_QT5_LDFLAGS="$PINENTRY_QT5_LDFLAGS -Wl,-rpath \"$qt5libdir\""
+ PINENTRY_QT5_LDFLAGS="$PINENTRY_QT5_LDFLAGS -Wl,-rpath=\"$qt5libdir\""
fi
fi