Add php-apc 4.0.7.

APCu is userland caching: APC stripped of opcode caching in preparation for
the deployment of Zend Optimizer+ as the primary solution to opcode caching
in future versions of PHP.

APCu has a revised and simplified codebase, by the time the PECL release is
available, every part of APCu being used will have received review and where
necessary or appropriate, changes.

Simplifying and documenting the API of APCu completely removes the barrier to
maintenance and development of APCu in the future, and additionally allows us
to make optimizations not possible previously because of APC's inherent
complexity.

APCu only supports userland caching (and dumping) of variables, providing an
upgrade path for the future. When O+ takes over, many will be tempted to use
3rd party solutions to userland caching, possibly even distributed solutions;
this would be a grave error. The tried and tested APC codebase provides far
superior support for local storage of PHP variables.
This commit is contained in:
taca 2015-02-01 08:11:20 +00:00
parent 2e5803a2bc
commit 3d8c946009
6 changed files with 92 additions and 0 deletions

18
www/php-apcu/DESCR Normal file
View file

@ -0,0 +1,18 @@
APCu is userland caching: APC stripped of opcode caching in preparation for
the deployment of Zend Optimizer+ as the primary solution to opcode caching
in future versions of PHP.
APCu has a revised and simplified codebase, by the time the PECL release is
available, every part of APCu being used will have received review and where
necessary or appropriate, changes.
Simplifying and documenting the API of APCu completely removes the barrier to
maintenance and development of APCu in the future, and additionally allows us
to make optimizations not possible previously because of APC's inherent
complexity.
APCu only supports userland caching (and dumping) of variables, providing an
upgrade path for the future. When O+ takes over, many will be tempted to use
3rd party solutions to userland caching, possibly even distributed solutions;
this would be a grave error. The tried and tested APC codebase provides far
superior support for local storage of PHP variables.

24
www/php-apcu/Makefile Normal file
View file

@ -0,0 +1,24 @@
# $NetBSD: Makefile,v 1.1 2015/02/01 08:11:20 taca Exp $
MODNAME= apcu
PECL_VERSION= 4.0.7
CATEGORIES+= sysutils
MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= APCu - APC User Cache
LICENSE= php
CONFIGURE_ARGS+= --enable-${MODNAME}
PLIST_SRC+= ${.CURDIR}/PLIST.extras
PLIST_SUBST+= PKGBASE=${PKGBASE:Q}
DOCDIR= ${PREFIX}/share/doc/${PKGBASE}
INSTALLATION_DIRS= ${DOCDIR}
post-install:
${INSTALL_DATA} ${WRKSRC}/INSTALL ${DESTDIR}${DOCDIR}
.include "../../lang/php/ext.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,2 @@
@comment $NetBSD: PLIST.extras,v 1.1 2015/02/01 08:11:20 taca Exp $
share/doc/${PKGBASE}/INSTALL

7
www/php-apcu/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2015/02/01 08:11:20 taca Exp $
SHA1 (php-apcu/apcu-4.0.7.tgz) = 84d68cbafea61df1ff864c7a3e8d2302a2879347
RMD160 (php-apcu/apcu-4.0.7.tgz) = 9b5f01dbefff164cd519ced448b62620e6770df8
Size (php-apcu/apcu-4.0.7.tgz) = 118670 bytes
SHA1 (patch-.._package.xml) = 8a30b47ce2276448e98462bda3d8fc145637ea03
SHA1 (patch-config.m4) = 4a5e49577068b0d5c610148f560e565e3dcfc50a

View file

@ -0,0 +1,15 @@
$NetBSD: patch-.._package.xml,v 1.1 2015/02/01 08:11:20 taca Exp $
Update md5 sum.
--- ../package.xml.orig 2014-10-12 02:02:21.000000000 +0900
+++ ../package.xml 2015-02-01 16:50:25.000000000 +0900
@@ -105,7 +105,7 @@
<file md5sum="2a8437130a0d8b546a4ad0a4c46f6e6b" name="pgsql_s_lock.h" role="src" />
<file md5sum="f779685bd4d96e1d925ea93b73131d9c" name="pgsql_s_lock.c" role="src" />
<file md5sum="54bfc8892372c1cf55cfa069aaf81eb2" name="apc_serializer.h" role="src" />
- <file md5sum="5be4ac2cf190c97d2933e008b57d1055" name="config.m4" role="src" />
+ <file md5sum="5a19fef359933bfc9b208a4598f3ce53" name="config.m4" role="src" />
<file md5sum="8c723e3d9a87c81326117fc32e56edff" name="config.w32" role="src" />
<file md5sum="d6c836c279b1fbabf69ada700dd5cdfc" name="INSTALL" role="doc" />
<file md5sum="de1caba45c42bd445f33d52eb1e82339" name="LICENSE" role="doc" />

View file

@ -0,0 +1,26 @@
$NetBSD: patch-config.m4,v 1.1 2015/02/01 08:11:20 taca Exp $
Fix bashism.
--- config.m4.orig 2014-10-11 17:02:21.000000000 +0000
+++ config.m4
@@ -140,7 +140,7 @@ if test "$PHP_APCU" != "no"; then
LIBS="$orig_LIBS"
fi
- if test "$PHP_APCU_RWLOCKS" == "no"; then
+ if test "$PHP_APCU_RWLOCKS" = "no"; then
orig_LIBS="$LIBS"
LIBS="$LIBS -lpthread"
AC_TRY_RUN(
@@ -193,8 +193,8 @@ if test "$PHP_APCU" != "no"; then
LIBS="$orig_LIBS"
fi
- if test "$PHP_APCU_RWLOCKS" == "no"; then
- if test "$PHP_APCU_MUTEX" == "no"; then
+ if test "$PHP_APCU_RWLOCKS" = "no"; then
+ if test "$PHP_APCU_MUTEX" = "no"; then
if test "$PHP_APCU_SPINLOCK" != "no"; then
AC_DEFINE(APC_SPIN_LOCK, 1, [ ])
AC_MSG_WARN([APCu spin locking enabled])