Import js_of_ocaml-1.2 as devel/js_of_ocaml.

Packaged by Jaap Boender.

Js_of_ocaml is a compiler of OCaml bytecode to Javascript. It makes it possible
to run OCaml programs in a Web browser.
This commit is contained in:
wiz 2012-07-11 15:35:06 +00:00
parent ebcdacf794
commit 3d902f596c
6 changed files with 123 additions and 0 deletions

2
devel/js_of_ocaml/DESCR Normal file
View file

@ -0,0 +1,2 @@
Js_of_ocaml is a compiler of OCaml bytecode to Javascript. It makes it possible
to run OCaml programs in a Web browser.

View file

@ -0,0 +1,34 @@
# $NetBSD: Makefile,v 1.1 2012/07/11 15:35:06 wiz Exp $
#
DISTNAME= js_of_ocaml-1.2
CATEGORIES= devel
MASTER_SITES= http://ocsigen.org/download/
MAINTAINER= jaapb@kerguelen.org
HOMEPAGE= http://ocsigen.org/js_of_ocaml/
COMMENT= Compiler of OCaml bytecode to Javascript
LICENSE= gnu-lgpl-v2
DEPENDS+= ocaml-findlib-[0-9]*:../../devel/ocaml-findlib
DEPENDS+= ocaml-lwt>=2.3.0:../../devel/ocaml-lwt
DEPENDS+= ocaml-deriving-ocsigen>=0.3:../../devel/ocaml-deriving-ocsigen
PKG_DESTDIR_SUPPORT= user-destdir
USE_LANGUAGES= c
USE_TOOLS= gmake
MAKE_ENV= BINDIR=${DESTDIR}${PREFIX}/bin DESTDIR=${DESTDIR} OCAML_SITELIBDIR=${PREFIX}/lib/ocaml/site-lib
PLIST_VARS= opt
.if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "powerpc") || \
(${MACHINE_ARCH} == "sparc") || (${MACHINE_ARCH} == "x86_64")
PLIST.opt= yes
.endif
pre-install:
${MKDIR} ${DESTDIR}${PREFIX}/lib/ocaml/site-lib
.include "../../lang/ocaml/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

53
devel/js_of_ocaml/PLIST Normal file
View file

@ -0,0 +1,53 @@
@comment $NetBSD: PLIST,v 1.1 2012/07/11 15:35:06 wiz Exp $
@unexec %D/libexec/ocaml-findlib-register del %D/lib/ocaml/site-lib/js_of_ocaml
bin/js_of_ocaml
lib/ocaml/site-lib/js_of_ocaml/META
lib/ocaml/site-lib/js_of_ocaml/CSS.cmi
lib/ocaml/site-lib/js_of_ocaml/CSS.mli
${PLIST.opt}lib/ocaml/site-lib/js_of_ocaml/deriving_Json.cmx
lib/ocaml/site-lib/js_of_ocaml/deriving_Json.mli
${PLIST.opt}lib/ocaml/site-lib/js_of_ocaml/deriving_Json_lexer.cmx
lib/ocaml/site-lib/js_of_ocaml/deriving_Json_lexer.mli
lib/ocaml/site-lib/js_of_ocaml/deriving_Json.cmi
lib/ocaml/site-lib/js_of_ocaml/deriving_Json_lexer.cmi
${PLIST.opt}lib/ocaml/site-lib/js_of_ocaml/deriving_json.a
lib/ocaml/site-lib/js_of_ocaml/deriving_json.cma
${PLIST.opt}lib/ocaml/site-lib/js_of_ocaml/deriving_json.cmxa
${PLIST.opt}lib/ocaml/site-lib/js_of_ocaml/deriving_json.cmxs
lib/ocaml/site-lib/js_of_ocaml/dlljs_of_ocaml.so
lib/ocaml/site-lib/js_of_ocaml/dom.cmi
lib/ocaml/site-lib/js_of_ocaml/dom.mli
lib/ocaml/site-lib/js_of_ocaml/dom_events.cmi
lib/ocaml/site-lib/js_of_ocaml/dom_events.mli
lib/ocaml/site-lib/js_of_ocaml/dom_html.cmi
lib/ocaml/site-lib/js_of_ocaml/dom_html.mli
lib/ocaml/site-lib/js_of_ocaml/event_arrows.cmi
lib/ocaml/site-lib/js_of_ocaml/event_arrows.mli
lib/ocaml/site-lib/js_of_ocaml/file.cmi
lib/ocaml/site-lib/js_of_ocaml/file.mli
lib/ocaml/site-lib/js_of_ocaml/firebug.cmi
lib/ocaml/site-lib/js_of_ocaml/firebug.mli
lib/ocaml/site-lib/js_of_ocaml/form.cmi
lib/ocaml/site-lib/js_of_ocaml/form.mli
lib/ocaml/site-lib/js_of_ocaml/js.cmi
lib/ocaml/site-lib/js_of_ocaml/js.mli
lib/ocaml/site-lib/js_of_ocaml/js_of_ocaml.cma
lib/ocaml/site-lib/js_of_ocaml/json.cmi
lib/ocaml/site-lib/js_of_ocaml/json.mli
${PLIST.opt}lib/ocaml/site-lib/js_of_ocaml/libjs_of_ocaml.a
lib/ocaml/site-lib/js_of_ocaml/lwt_js.cmi
lib/ocaml/site-lib/js_of_ocaml/lwt_js.mli
lib/ocaml/site-lib/js_of_ocaml/pa_deriving_Json.cmo
lib/ocaml/site-lib/js_of_ocaml/pa_js.cmo
lib/ocaml/site-lib/js_of_ocaml/regexp.cmi
lib/ocaml/site-lib/js_of_ocaml/regexp.mli
lib/ocaml/site-lib/js_of_ocaml/runtime.js
lib/ocaml/site-lib/js_of_ocaml/typed_array.cmi
lib/ocaml/site-lib/js_of_ocaml/typed_array.mli
lib/ocaml/site-lib/js_of_ocaml/url.cmi
lib/ocaml/site-lib/js_of_ocaml/url.mli
lib/ocaml/site-lib/js_of_ocaml/webGL.cmi
lib/ocaml/site-lib/js_of_ocaml/webGL.mli
lib/ocaml/site-lib/js_of_ocaml/xmlHttpRequest.cmi
lib/ocaml/site-lib/js_of_ocaml/xmlHttpRequest.mli
@exec %D/libexec/ocaml-findlib-register add %D/lib/ocaml/site-lib/js_of_ocaml

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2012/07/11 15:35:06 wiz Exp $
SHA1 (js_of_ocaml-1.2.tar.gz) = c1adcc06a2e2847ef24647deff865574d5050c61
RMD160 (js_of_ocaml-1.2.tar.gz) = ccb515b97f9c55e258bae3a6191a7df372c0670f
Size (js_of_ocaml-1.2.tar.gz) = 1883833 bytes
SHA1 (patch-Makefile) = 82f76c28cdb034105b1a4a0d16058a41c976a501
SHA1 (patch-Makefile.conf) = e21058295b9c94760d5a0ff4225baade98911c7c

View file

@ -0,0 +1,14 @@
$NetBSD: patch-Makefile,v 1.1 2012/07/11 15:35:06 wiz Exp $
Make package support DESTDIR
--- Makefile.orig 2012-03-16 13:02:12.000000000 +0000
+++ Makefile
@@ -31,7 +31,7 @@ include Makefile.filelist
VERSION := $(shell head -n 1 VERSION)
install:
- ocamlfind install -patch-version ${VERSION} $(LIBRARY) lib/META $(INTF) $(IMPL) $(OTHERS) $(DOC)
+ ocamlfind install -ldconf /dev/null -destdir ${DESTDIR}${OCAML_SITELIBDIR} -patch-version ${VERSION} $(LIBRARY) lib/META $(INTF) $(IMPL) $(OTHERS) $(DOC)
install -d -m 755 $(BINDIR)
install $(BIN) $(BINDIR)

View file

@ -0,0 +1,13 @@
$NetBSD: patch-Makefile.conf,v 1.1 2012/07/11 15:35:06 wiz Exp $
Have BINDIR be determined from package Makefile
--- Makefile.conf.orig 2011-11-30 14:25:06.000000000 +0000
+++ Makefile.conf
@@ -1,6 +1,6 @@
# Where binaries are installed:
-BINDIR := /usr/local/bin
+# BINDIR := /usr/local/bin
####