vile, xvile: update to 9.8v

Update provided by Thomas Dickey.

Changes:
 20211212 (v)
	> Lois Mansot
	+ corrected range for &random function.
	+ move the reframe_cursor_position() in update() to ensure that $cwline
	  is shown correctly when viewing [Variables] while showvariables is
	  set.
 	> Mark Robinson:
	+ modify c-filt.c
	  + include the quote chars in the literal colouring for C/C++/Java/etc
	    to make it the same as most other syntax highlighting
	  + add backquote "`" as a quoting character for JavaScript, e.g., for
	    multi-line quotes.
	  + highlight embedded "${xxx}" markers in JavaScript strings using the
	    Ident2 color.
	+ modify sh-filt.l
	  + improve parsing of the beginning of here-document to allow for
	    here-documents piped to programs, e.g.,
	    	cat <<EOF | pr
		something
		EOF
	    or
	    	cat <<EOF && date
		something
		EOF
	  + do not treat "#" as a comment marker if it is adjacent to nonblank
	    text.
 	> Stephan Schulz:
	+ add popup-choices mode (Savannah #58999)
	> Tom Dickey:
	+ eliminate filename conflict between vile/xvile in test-packages for
	  FreeBSD ports, e.g., xvile's vileget becomes xvileget.
	+ suppress some of the gcc warnings due to perl header-files.
	+ updated plink.sh, from xterm, to work around poor performance of gcc
	  on Fedora.
	+ modify perl scripts to use /usr/bin/env to locate the perl program,
	  and eliminate sinstall.sh
	+ modify curses-driver to support italics, e.g., as in ncurses 6.
	+ apply Xaw header-fix for XawPlus, neXtaw and Xaw3dxft.
	+ use Xaw3d menu-headers for x11vile.h and x11menu.c (FreeBSD #186420).
	+ replace Header keywords with Id, to make Git-snapshots match.
	+ continue development of xftplain.c (--enable-freetype).  The current
	  driver is able to display a single TrueType font using Xft.  The
	  menu entries for the bitmap-fonts are replaced by a single menu with
	  sizes.
	  Some of the remaining issues:
	  + provide conversion for X displays other than 24-bit TrueColor
	  + implement fallback fonts, i.e., --enable-fontsets
	+ modify configure script to check for ssp library, needed for some
	  misconfigured libraries when cross-compiling to MinGW.
	+ fix a case in vile-manfilt where cur_line may not have been allocated
	  before first use.
	+ update configure script to work with _Noreturn changes in ncurses
	  20210320 development version.
	+ modify makefile.in, wrapping cd commands in a subshell to work around
	  "jobs" misfeature of pmake.
	+ improve c-filt.c support for JavaScript
	  + handle ranges, i.e., to avoid stopping on "/"
	  + check for regex after ":"
	  + add m,s,u,y to permissable flags ending regex
	+ quoting-fixes in autoconf macros, per shellcheck warnings.
	+ add check for 'U' in read_quoted() needed to make ^VUxxxx work.
	+ modify lins_chars() to handle a case where a script inserts a UTF-8
	  character (report by Thomas Dupond).
	+ modify configure/makefiles to support ".PHONY" feature.
	+ change configure/makefiles to use ARFLAGS rather than AR_OPTS
	+ change configure --with-warnings to --enable-warnings for consistency
	  with other configure scripts, using recent changes in that to filter
	  gcc -Werror options to avoid breaking configure checks.
	+ fix a few build problems with --disable-extensions
	+ split-out x11plain.c, to start work on TrueType font support in xvile
	+ modify configure script to allow clang to support loadable filters,
	  since recent configurations work.
	+ add/fix NetBSD pkgsrc-files for 9.8u
	+ update FreeBSD package-files for 9.8u
	+ update config.guess, config.sub
This commit is contained in:
wiz 2021-12-13 08:56:32 +00:00
parent 85ed798a6b
commit 3da891bbd0
5 changed files with 23 additions and 57 deletions

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.75 2021/05/24 19:52:08 wiz Exp $
# $NetBSD: Makefile,v 1.76 2021/12/13 08:56:32 wiz Exp $
DISTNAME= vile-9.8u
PKGREVISION= 2
DISTNAME= vile-9.8v
CATEGORIES= editors
MASTER_SITES= ftp://ftp.invisible-island.net/vile/current/
MASTER_SITES= ftp://ftp.invisible-island.net/pub/vile/current/ \
https://invisible-mirror.net/archives/vile/current/
EXTRACT_SUFX= .tgz
MAINTAINER= pkgsrc-users@NetBSD.org
@ -15,7 +15,7 @@ LICENSE= gnu-gpl-v2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-perl
CONFIGURE_ARGS+= --datadir=${DATADIR:Q}
CONFIGURE_ARGS+= --datadir=${PREFIX}/share
CONFIGURE_ARGS+= --with-libdir-path=${FILTERDIR:Q}
USE_TOOLS+= perl:run

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.19 2021/10/26 10:21:42 nia Exp $
$NetBSD: distinfo,v 1.20 2021/12/13 08:56:32 wiz Exp $
BLAKE2s (vile-9.8u.tgz) = 407e9469ad657a5b9582f9acce7cc9b434ff634d889cf1e576cde3d1d32071f2
SHA512 (vile-9.8u.tgz) = fad06c8e341feec7e9aed1e53cd9a1e7fe79fdeb050aba743ac4edfb6096db88c1ef63377d6ecbeddd0eb8ad46a323bcc55d09b1ff221a75cd74a3f991e3f24d
Size (vile-9.8u.tgz) = 2375989 bytes
SHA1 (patch-filters_makefile.in) = c2127de2f65ee09bce3ee0fd9163be95bf686c61
SHA1 (patch-makefile.in) = ed2be4b98d6a44231271c79c9cbe1b93bc410a4b
BLAKE2s (vile-9.8v.tgz) = 111282085e4670d2dbdef36cd9b4dee7c1a756b7862d1fa8965b62b67f8155b7
SHA512 (vile-9.8v.tgz) = b752f26148bd4411ab6b31697459a16d8168f79ffad6b3509d6cf5d40611176b833e56f4bac21fe18ecdd256be467ba96ea98149daceab671002df49508eb8d2
Size (vile-9.8v.tgz) = 2405398 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-filters_makefile.in,v 1.1 2012/07/20 14:38:51 marino Exp $
Carryover from vile 0.97, patch-ab
--- filters/makefile.in.orig 2012-07-20 00:50:45.000000000 +0000
+++ filters/makefile.in
@@ -48,7 +48,7 @@ bindir = @bindir@
libdir = @libdir@
filters_bindir = @filters_bindir@
-datadir = @datadir@/vile
+datadir = @datadir@
#### End of system configuration section. ####

View file

@ -1,26 +0,0 @@
$NetBSD: patch-makefile.in,v 1.3 2019/02/16 00:52:06 wiz Exp $
Carryover from vile 0.97, patch-aa (updated)
--- makefile.in.orig 2010-06-11 23:32:31.000000000 +0000
+++ makefile.in
@@ -62,8 +62,8 @@ PROGRAM = $(TARGET)$x
AWK = @AWK@
PERL = @PERL@
PERL_XSUBPP = @PERL_XSUBPP@
-INSTALL_PL_EXE = $(SHELL) $(srcdir)/sinstall.sh $(PERL) $(INSTALL_PROGRAM)
-INSTALL_MODULE = $(SHELL) $(srcdir)/sinstall.sh $(PERL) $(INSTALL_DATA)
+INSTALL_PL_EXE = ${BSD_INSTALL_SCRIPT}
+INSTALL_MODULE = ${BSD_INSTALL_DATA}
prefix = @prefix@
exec_prefix = @exec_prefix@
@@ -71,7 +71,7 @@ exec_prefix = @exec_prefix@
manext = 1
libdir = @libdir@
bindir = @bindir@
-datadir = @datadir@/vile
+datadir = @datadir@
docdir = $(datadir)/doc
htmldir = $(datadir)/html
perldir = $(datadir)/perl

View file

@ -1,10 +1,10 @@
# $NetBSD: Makefile,v 1.78 2021/05/24 19:52:09 wiz Exp $
# $NetBSD: Makefile,v 1.79 2021/12/13 08:56:32 wiz Exp $
DISTNAME= vile-9.8u
DISTNAME= vile-9.8v
PKGNAME= x${DISTNAME}
PKGREVISION= 2
CATEGORIES= editors
MASTER_SITES= ftp://ftp.invisible-island.net/vile/current/
MASTER_SITES= ftp://ftp.invisible-island.net/vile/current/ \
https://invisible-mirror.net/archives/vile/current/
EXTRACT_SUFX= .tgz
MAINTAINER= pkgsrc-users@NetBSD.org
@ -18,8 +18,9 @@ PATCHDIR= ${.CURDIR}/../../editors/vile/patches
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-imake
CONFIGURE_ARGS+= --with-perl
CONFIGURE_ARGS+= --datadir=${DATADIR:Q}
CONFIGURE_ARGS+= --datadir=${PREFIX}/share
CONFIGURE_ARGS+= --with-libdir-path=${FILTERDIR:Q}
CONFIGURE_ARGS+= --with-startup-path=${DATADIR:Q}
MAKE_FILE= makefile
INSTALL_TARGET= install install-doc install-perl
@ -43,6 +44,14 @@ CONFIGURE_ARGS+= --with-screen=Xaw
.endif
CONFIGURE_ARGS+= --with-xpm
pre-configure:
for f in \
${WRKDIR}/${DISTNAME}/makefile.in \
${WRKDIR}/${DISTNAME}/filters/makefile.in; do \
${MV} $$f $$f.bak; \
sed -e '/^datadir[ ]*=[ ]*@datadir@/s%/vile%/xvile%' $$f.bak >$$f; \
done
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/perl/vileget \
${DESTDIR}${PREFIX}/bin/xvileget