Import codeblocks-16.01 as editors/codeblock
Code::Blocks is a free C++ IDE built to meet the most demanding needs of its users. It is designed to be very extensible and fully configurable. Finally, an IDE with all the features you need, having a consistent look, feel and operation across platforms. Built around a plugin framework, Code::Blocks can be extended with plugins. Any kind of functionality can be added by installing/coding a plugin. For instance, compiling and debugging functionality is already provided by plugins! Originally packaged in pkgsrc-wip by: - Ondrej Tuma, - Joerg Sonnenberg, - Thomas Klausner, - Tobias Nygren, - Mark Davies, - Blue Rats, - Aleksej Saushev, - Aleksej Lebedev, - K.I.A.Derouiche and - myself.
This commit is contained in:
parent
1a0cbbdc8d
commit
3dafe5cc41
9 changed files with 1262 additions and 0 deletions
9
editors/codeblocks/DESCR
Normal file
9
editors/codeblocks/DESCR
Normal file
|
@ -0,0 +1,9 @@
|
|||
Code::Blocks is a free C++ IDE built to meet the most demanding needs of its
|
||||
users. It is designed to be very extensible and fully configurable.
|
||||
|
||||
Finally, an IDE with all the features you need, having a consistent look, feel
|
||||
and operation across platforms.
|
||||
|
||||
Built around a plugin framework, Code::Blocks can be extended with plugins. Any
|
||||
kind of functionality can be added by installing/coding a plugin. For instance,
|
||||
compiling and debugging functionality is already provided by plugins!
|
31
editors/codeblocks/Makefile
Normal file
31
editors/codeblocks/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# $NetBSD: Makefile,v 1.1 2016/06/16 02:28:51 kamil Exp $
|
||||
#
|
||||
|
||||
DISTNAME= codeblocks_16.01
|
||||
PKGNAME= ${DISTNAME:S/_/-/}
|
||||
CATEGORIES= editors x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=codeblocks/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.codeblocks.org/
|
||||
COMMENT= Open source, cross platform, free C++ IDE
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}.release
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_TOOLS+= pkg-config gmake
|
||||
USE_LANGUAGES= c c++
|
||||
|
||||
CONFIGURE_ARGS+= --with-contrib-plugins=AutoVersioning,BrowseTracker,byogames,cbkoders,codesnippets,codestat,dragscroll,envvars,help,keybinder,libfinder,profiler,regex,exporter,symtab
|
||||
# wxsmith makes error in build process
|
||||
|
||||
BUILD_DEPENDS+= zip-[0-9]*:../../archivers/zip
|
||||
|
||||
PKGCONFIG_OVERRIDE+= codeblocks.pc.in
|
||||
|
||||
.include "../../databases/shared-mime-info/mimedb.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../x11/wxGTK30/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
1115
editors/codeblocks/PLIST
Normal file
1115
editors/codeblocks/PLIST
Normal file
File diff suppressed because it is too large
Load diff
11
editors/codeblocks/distinfo
Normal file
11
editors/codeblocks/distinfo
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.1 2016/06/16 02:28:51 kamil Exp $
|
||||
|
||||
SHA1 (codeblocks_16.01.tar.gz) = 70aabe8a948dbaa919eb4b87bc74a600e0d93516
|
||||
RMD160 (codeblocks_16.01.tar.gz) = e98b034eb8d6cf52a89312f2d5eaa10b17f1355e
|
||||
SHA512 (codeblocks_16.01.tar.gz) = 496ff2dbcf9a8248fa9f1060d50567d1fc6480cc9d8fc9f7d2cd532c82f4344deafe9b43f2b17d2510c74851e21acf2ca90d5cc7b61237d69a17e78e9907a63a
|
||||
Size (codeblocks_16.01.tar.gz) = 20250097 bytes
|
||||
SHA1 (patch-src_plugins_contrib_wxContribItems_wxchart_configure) = 57f52bac348192b1dbfa63b012a48ed259e5933d
|
||||
SHA1 (patch-src_plugins_contrib_wxContribItems_wxthings_configure) = 645d331fc86c872e522ed56fc0764e2a2a77c3c2
|
||||
SHA1 (patch-src_sdk_wxpropgrid_configure) = fc842f5964e7a213907d93b81ef35a3f1a4edf19
|
||||
SHA1 (patch-src_src_appglobals.cpp) = cb561786251fe14ed777105f207635c219f8634b
|
||||
SHA1 (patch-src_src_prefix.cpp) = 941fe61e81427990ed45b414a0bf98ceb40557cc
|
|
@ -0,0 +1,21 @@
|
|||
$NetBSD: patch-src_plugins_contrib_wxContribItems_wxchart_configure,v 1.1 2016/06/16 02:28:51 kamil Exp $
|
||||
|
||||
Fix shell portability issue.
|
||||
|
||||
--- src/plugins/contrib/wxContribItems/wxchart/configure.orig 2016-01-23 16:43:13.000000000 +0000
|
||||
+++ src/plugins/contrib/wxContribItems/wxchart/configure
|
||||
@@ -5618,7 +5618,7 @@ echo "${ECHO_T}$bakefile_cv_gcc31" >&6
|
||||
SHARED_LD_CXX="\${CXX} -dynamiclib -single_module -headerpad_max_install_names -o"
|
||||
fi
|
||||
|
||||
- if test "x$GCC" == "xyes"; then
|
||||
+ if test "x$GCC" = "xyes"; then
|
||||
PIC_FLAG="-dynamic -fPIC"
|
||||
fi
|
||||
if test "x$XLCC" = "xyes"; then
|
||||
@@ -7811,5 +7811,3 @@ echo "$as_me: error:
|
||||
echo " Now, just run make."
|
||||
echo " ----------------------------------------------------------------"
|
||||
echo
|
||||
-
|
||||
-
|
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-src_plugins_contrib_wxContribItems_wxthings_configure,v 1.1 2016/06/16 02:28:51 kamil Exp $
|
||||
|
||||
Fix shell portability issue.
|
||||
|
||||
--- src/plugins/contrib/wxContribItems/wxthings/configure.orig 2016-01-23 16:43:14.000000000 +0000
|
||||
+++ src/plugins/contrib/wxContribItems/wxthings/configure
|
||||
@@ -4619,7 +4619,7 @@ echo "${ECHO_T}$bakefile_cv_gcc31" >&6;
|
||||
SHARED_LD_CXX="\${CXX} -dynamiclib -single_module -headerpad_max_install_names -o"
|
||||
fi
|
||||
|
||||
- if test "x$GCC" == "xyes"; then
|
||||
+ if test "x$GCC" = "xyes"; then
|
||||
PIC_FLAG="-dynamic -fPIC"
|
||||
fi
|
||||
if test "x$XLCC" = "xyes"; then
|
||||
@@ -6966,6 +6966,3 @@ fi
|
||||
echo " Now, just run make."
|
||||
echo " ----------------------------------------------------------------"
|
||||
echo
|
||||
-
|
||||
-
|
||||
-
|
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-src_sdk_wxpropgrid_configure,v 1.1 2016/06/16 02:28:51 kamil Exp $
|
||||
|
||||
Fix shell portability issue.
|
||||
|
||||
--- src/sdk/wxpropgrid/configure.orig 2016-01-23 16:43:00.000000000 +0000
|
||||
+++ src/sdk/wxpropgrid/configure
|
||||
@@ -4628,7 +4628,7 @@ echo "${ECHO_T}$bakefile_cv_gcc31" >&6
|
||||
SHARED_LD_CXX="\${CXX} -dynamiclib -single_module -headerpad_max_install_names -o"
|
||||
fi
|
||||
|
||||
- if test "x$GCC" == "xyes"; then
|
||||
+ if test "x$GCC" = "xyes"; then
|
||||
PIC_FLAG="-dynamic -fPIC"
|
||||
fi
|
||||
if test "x$XLCC" = "xyes"; then
|
||||
@@ -6835,6 +6835,3 @@ fi
|
||||
echo " Now, just run make."
|
||||
echo " ----------------------------------------------------------------"
|
||||
echo
|
||||
-
|
||||
-
|
||||
-
|
15
editors/codeblocks/patches/patch-src_src_appglobals.cpp
Normal file
15
editors/codeblocks/patches/patch-src_src_appglobals.cpp
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_src_appglobals.cpp,v 1.1 2016/06/16 02:28:51 kamil Exp $
|
||||
|
||||
Detect NetBSD as NetBSD.
|
||||
|
||||
--- src/src/appglobals.cpp.orig 2016-01-23 16:43:03.000000000 +0000
|
||||
+++ src/src/appglobals.cpp
|
||||
@@ -49,6 +49,8 @@ namespace appglobals
|
||||
const wxString AppPlatform = _T("Darwin");
|
||||
#elif defined(__FreeBSD__)
|
||||
const wxString AppPlatform = _T("FreeBSD");
|
||||
+#elif defined(__NetBSD__)
|
||||
+ const wxString AppPlatform = _T("NetBSD");
|
||||
#elif defined(__UNIX__)
|
||||
const wxString AppPlatform = _T("Linux");
|
||||
#else
|
16
editors/codeblocks/patches/patch-src_src_prefix.cpp
Normal file
16
editors/codeblocks/patches/patch-src_src_prefix.cpp
Normal file
|
@ -0,0 +1,16 @@
|
|||
$NetBSD: patch-src_src_prefix.cpp,v 1.1 2016/06/16 02:28:51 kamil Exp $
|
||||
|
||||
Unbreak build on NetBSD. Stop redefining NULL as an arbitrary value.
|
||||
|
||||
--- src/src/prefix.cpp.orig 2016-01-23 16:43:04.000000000 +0000
|
||||
+++ src/src/prefix.cpp
|
||||
@@ -55,9 +55,6 @@ extern "C" {
|
||||
#endif /* __cplusplus */
|
||||
|
||||
|
||||
-#undef NULL
|
||||
-#define NULL ((void *) 0)
|
||||
-
|
||||
#ifdef __GNUC__
|
||||
#define br_return_val_if_fail(expr,val) if (!(expr)) {fprintf (stderr, "** BinReloc (%s): assertion %s failed\n", __PRETTY_FUNCTION__, #expr); return val;}
|
||||
#else
|
Loading…
Reference in a new issue