okular: fix build with latest poppler-qt5

which needs c++17 now
This commit is contained in:
wiz 2023-07-09 20:31:46 +00:00
parent 557aac12ca
commit 3db1dbb9d3
3 changed files with 20 additions and 2 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.139 2023/06/06 12:42:11 riastradh Exp $
# $NetBSD: Makefile,v 1.140 2023/07/09 20:31:46 wiz Exp $
DISTNAME= okular-${KAPPSVER}
PKGREVISION= 9
@ -14,6 +14,8 @@ TOOL_DEPENDS+= kdoctools>=5.19.0:../../devel/kdoctools
USE_TOOLS+= msgmerge pkg-config
GCC_REQD+= 8 # std::optional
# generation of kded.moc fails when ${PREFIX}/include in the moc include path
SUBST_CLASSES+= fix-moc
SUBST_STAGE.fix-moc= post-configure

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.21 2022/09/29 01:10:58 markd Exp $
$NetBSD: distinfo,v 1.22 2023/07/09 20:31:46 wiz Exp $
BLAKE2s (okular-22.08.1.tar.xz) = 44487711f16fc0a0753f121a658dd53a48486a90021986f5e25768e57ce6f467
SHA512 (okular-22.08.1.tar.xz) = 1fa3c8763d7432a21448c3715e69658609bf9cc50d767f74db89a37f0ef890dff97d276526aa6f41a0fcb91c36df39a1274d243785da74ce811448d896588d43
Size (okular-22.08.1.tar.xz) = 8225648 bytes
SHA1 (patch-CMakeLists.txt) = 02a25bb2a13adfc2530ff51558343d9bebd20f25

View file

@ -0,0 +1,15 @@
$NetBSD: patch-CMakeLists.txt,v 1.1 2023/07/09 20:31:46 wiz Exp $
poppler-qt5 needs c++17 for std::optional.
--- CMakeLists.txt.orig 2022-09-04 20:26:23.000000000 +0000
+++ CMakeLists.txt
@@ -93,7 +93,7 @@ elseif(WIN32)
set(ENV{QT_PLUGIN_PATH} "$ENV{QT_PLUGIN_PATH};${KDE_INSTALL_FULL_QTPLUGINDIR}")
endif()
-set(CMAKE_CXX_STANDARD 14)
+set(CMAKE_CXX_STANDARD 17)
set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)