Changes 6.47:

o Integrated all of your IPv4 OS fingerprint submissions since June 2013
  (2700+ of them). Added 366 fingerprints, bringing the new total to 4485.
  Additions include Linux 3.10 - 3.14, iOS 7, OpenBSD 5.4 - 5.5, FreeBSD 9.2,
  OS X 10.9, Android 4.3, and more. Many existing fingerprints were improved.
  Highlights: http://seclists.org/nmap-dev/2014/q3/325

o (Windows) Upgraded the included OpenSSL to version 1.0.1i.

o (Windows) Upgraded the included Python to version 2.7.8.

o Removed the External Entity Declaration from the DOCTYPE in Nmap's XML. This
  was added in 6.45, and resulted in trouble for Nmap XML parsers without
  network access, as well as increased traffic to Nmap's servers. The doctype
  is now:
  <!DOCTYPE nmaprun>

o [Ndiff] Fixed the installation process on Windows, which was missing the
  actual Ndiff Python module since we separated it from the driver script.

o [Ndiff] Fixed the ndiff.bat wrapper in the zipfile Windows distribution,
  which was giving the error, "\Microsoft was unexpected at this time." See
  https://support.microsoft.com/kb/2524009

o [Zenmap] Fixed the Zenmap .dmg installer for OS X. Zenmap failed to launch,
  producing this error:
    Could not import the zenmapGUI.App module:
    'dlopen(/Applications/Zenmap.app/Contents/Resources/lib/python2.6/lib-dynload/glib/_glib.so, 2):
    Library not loaded: /Users/david/macports-10.5/lib/libffi.5.dylib\n
    Referenced from:
    /Applications/Zenmap.app/Contents/Resources/lib/python2.6/lib-dynload/glib/_glib.so\n
    Reason: image not found'.

o [Ncat] Fixed SOCKS5 username/password authentication. The password length was
  being written in the wrong place, so authentication could not succeed.

o Avoid formatting NULL as "%s" when running nmap --iflist. GNU libc converts
  this to the string "(null)", but it caused segfault on Solaris.

o [Zenmap][Ndiff] Avoid crashing when users have the antiquated PyXML package
  installed. Python tries to be nice and loads it when we import xml, but it
  isn't compatible. Instead, we force Python to use the standard library xml
  module.

o Handle ICMP admin-prohibited messages when doing service version detection.
  Crash reported by Nathan Stocks was: Unexpected error in NSE_TYPE_READ
  callback.  Error code: 101 (Network is unreachable)

o [NSE] Fix a bug causing http.head to not honor redirects.

o [Zenmap] Fix a bug in DiffViewer causing this crash:
     TypeError: GtkTextBuffer.set_text() argument 1 must be string or read-only
     buffer, not NmapParserSAX
  Crash happened when trying to compare two scans within Zenmap.
This commit is contained in:
adam 2014-09-05 11:51:41 +00:00
parent 34a2260b73
commit 3dbdc66427
4 changed files with 17 additions and 29 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.120 2014/05/05 00:48:15 ryoon Exp $
# $NetBSD: Makefile,v 1.121 2014/09/05 11:51:41 adam Exp $
DISTNAME= nmap-6.40
PKGREVISION= 8
DISTNAME= nmap-6.47
CATEGORIES= net security
MASTER_SITES= http://nmap.org/dist/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,9 +1,8 @@
$NetBSD: distinfo,v 1.62 2014/06/07 23:12:16 rodent Exp $
$NetBSD: distinfo,v 1.63 2014/09/05 11:51:41 adam Exp $
SHA1 (nmap-6.40.tar.bz2) = ee1bec1bb62045c7c1fc69ff183b2ae9b97bd0eb
RMD160 (nmap-6.40.tar.bz2) = 6da4bd1a71386e52d4c76d3c3c1773c989e72c55
Size (nmap-6.40.tar.bz2) = 7871636 bytes
SHA1 (nmap-6.47.tar.bz2) = 0c917453a91a5e85c2a217d27c3853b0f3e0e6ac
RMD160 (nmap-6.47.tar.bz2) = 20c4023935e53fbceb2ef33205cb301fb29bd0b2
Size (nmap-6.47.tar.bz2) = 7878122 bytes
SHA1 (patch-ab) = 442683349642a665e7d0a90bc581b971919ead8b
SHA1 (patch-ac) = a5904d0f6c47198c5022b75b612f01e5708db593
SHA1 (patch-ad) = 278be81387bc47566ee498a4f6ef4e2d4c1d522f
SHA1 (patch-ac) = 807ace5f25bb9fd07ca4947a9debbb390fa80403
SHA1 (patch-libnetutil_netutil.cc) = 7bd1059d6cbcf4f6d129730d6c6f6bc3ab54c0a0

View file

@ -1,11 +1,13 @@
$NetBSD: patch-ac,v 1.8 2014/06/07 23:12:16 rodent Exp $
$NetBSD: patch-ac,v 1.9 2014/09/05 11:51:41 adam Exp $
--- ndiff/setup.py.orig 2009-04-20 19:15:00.000000000 +0000
Use PKGMANDIR.
--- ndiff/setup.py.orig 2014-04-12 01:24:32.000000000 +0000
+++ ndiff/setup.py
@@ -29,5 +29,5 @@ class checked_install(distutils.command.
+ "Installing your distribution's python-dev package may solve this problem.")
@@ -112,5 +112,5 @@ Installing your distribution's python-de
distutils.core.setup(name = u"ndiff", scripts = [u"ndiff"],
- data_files = [(u"share/man/man1", [u"docs/ndiff.1"])],
+ data_files = [(u"@@PKGMANDIR@@/man1", [u"docs/ndiff.1"])],
cmdclass = {"install_egg_info": null_command, "install": checked_install})
distutils.core.setup(name=u"ndiff", scripts=[u"scripts/ndiff"],
py_modules=[u"ndiff"],
- data_files=[(u"share/man/man1", [u"docs/ndiff.1"])],
+ data_files=[(u"@@PKGMANDIR@@/man1", [u"docs/ndiff.1"])],
cmdclass={"install_egg_info": null_command, "install": checked_install})

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ad,v 1.17 2013/09/24 21:29:21 drochner Exp $
--- ncat/ncat_posix.c.orig 2013-07-29 00:03:01.000000000 +0000
+++ ncat/ncat_posix.c
@@ -123,5 +123,7 @@
#include "ncat.h"
+#ifdef HAVE_LUA
#include "ncat_lua.h"
+#endif
char **cmdline_split(const char *cmdexec);