Make sure that builds with g95 create position independent code.

Bump revision.
This commit is contained in:
joerg 2011-12-20 16:38:30 +00:00
parent 140f05437c
commit 3dc2bdb235
3 changed files with 23 additions and 3 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.14 2011/04/19 15:32:28 roy Exp $
# $NetBSD: Makefile,v 1.15 2011/12/20 16:38:30 joerg Exp $
#
DISTNAME= numpy-1.4.1
PKGREVISION= 1
PKGREVISION= 2
PKGNAME= ${PYPKGPREFIX}-numpy-1.4.1
CATEGORIES= math python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=numpy/}

View file

@ -1,8 +1,9 @@
$NetBSD: distinfo,v 1.5 2011/11/22 20:56:13 minskim Exp $
$NetBSD: distinfo,v 1.6 2011/12/20 16:38:30 joerg Exp $
SHA1 (numpy-1.4.1.tar.gz) = ec6078aa09acbcca3d90f9f36353fc83e7e1daa0
RMD160 (numpy-1.4.1.tar.gz) = a0bbebd1138ffc93517095e3c06459cd9744a9d6
Size (numpy-1.4.1.tar.gz) = 2201795 bytes
SHA1 (patch-aa) = 5dc5d8c1ffb2bbbb6c89656aaa6404ac01e977ed
SHA1 (patch-ab) = 18ef5b7ad8386a4e991bde9f7112ec7b13d2a39c
SHA1 (patch-numpy_distutils_fcompiler_g95.py) = a45933022149d7a6ccac5f50d66afc6038d6ed95
SHA1 (patch-numpy_distutils_fcompiler_gnu.py) = 4e0c8cfd2893c050872061ce3b7fc87fda4b03ac

View file

@ -0,0 +1,19 @@
$NetBSD: patch-numpy_distutils_fcompiler_g95.py,v 1.1 2011/12/20 16:38:30 joerg Exp $
Band aid to make sure that pic_flags is actually used.
--- numpy/distutils/fcompiler/g95.py.orig 2010-04-18 10:06:17.000000000 +0000
+++ numpy/distutils/fcompiler/g95.py
@@ -18,9 +18,9 @@ class G95FCompiler(FCompiler):
executables = {
'version_cmd' : ["<F90>", "--version"],
- 'compiler_f77' : ["g95", "-ffixed-form"],
- 'compiler_fix' : ["g95", "-ffixed-form"],
- 'compiler_f90' : ["g95"],
+ 'compiler_f77' : ["g95", "-ffixed-form", "-fpic"],
+ 'compiler_fix' : ["g95", "-ffixed-form", "-fpic"],
+ 'compiler_f90' : ["g95", "-fpic"],
'linker_so' : ["<F90>","-shared"],
'archiver' : ["ar", "-cr"],
'ranlib' : ["ranlib"]