Fix issues with newer OpenSSL

This commit is contained in:
joerg 2011-11-25 22:12:28 +00:00
parent 82fc19b24e
commit 3dd9a92d49
2 changed files with 15 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.7 2007/05/28 21:54:41 markd Exp $
$NetBSD: distinfo,v 1.8 2011/11/25 22:12:28 joerg Exp $
SHA1 (kftpgrabber-0.8.1.tar.bz2) = da5c6100a6e3129bc1f845c35475cd48b42afc8a
RMD160 (kftpgrabber-0.8.1.tar.bz2) = a0f724bce57becdbfb4c4ceb130039f9df256129
Size (kftpgrabber-0.8.1.tar.bz2) = 1349940 bytes
SHA1 (patch-aa) = 243ed3196298121553039d1c827f7042f69eb033
SHA1 (patch-kftpgrabber_src_engine_ssl.cpp) = 1164f2d875943f4924ef32646637a4a11a779061

View file

@ -0,0 +1,13 @@
$NetBSD: patch-kftpgrabber_src_engine_ssl.cpp,v 1.1 2011/11/25 22:12:28 joerg Exp $
--- kftpgrabber/src/engine/ssl.cpp.orig 2011-11-25 18:51:58.000000000 +0000
+++ kftpgrabber/src/engine/ssl.cpp
@@ -169,7 +169,7 @@ bool Ssl::setClientCertificate(KSSLPKCS1
void Ssl::setConnectionInfo()
{
- SSL_CIPHER *cipher;
+ const SSL_CIPHER *cipher;
char buffer[1024];
buffer[0] = 0;