Add a package for GALasm, a portable GAL assembler.

This commit is contained in:
thorpej 2023-04-25 03:28:37 +00:00
parent b7f913e0c3
commit 3e2532eaa6
7 changed files with 142 additions and 1 deletions

View File

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.3956 2023/04/22 17:08:38 nikita Exp $
# $NetBSD: Makefile,v 1.3957 2023/04/25 03:28:37 thorpej Exp $
#
COMMENT= Development utilities
@ -379,6 +379,7 @@ SUBDIR+= frink
SUBDIR+= fromcvs
SUBDIR+= ftnchek
SUBDIR+= g-wrap
SUBDIR+= galasm
SUBDIR+= galette
SUBDIR+= garden
SUBDIR+= gccmakedep

4
devel/galasm/DESCR Normal file
View File

@ -0,0 +1,4 @@
GALasm is a portable GAL assembler that takes a set of equations, and
generates a JEDEC file suitable for feeding to a GAL programmer. The
assembler core is from GALer, a GAL development environment for the Amiga
platform.

34
devel/galasm/Makefile Normal file
View File

@ -0,0 +1,34 @@
# $NetBSD: Makefile,v 1.1 2023/04/25 03:28:37 thorpej Exp $
# There is no tag on Github for 2.1, but that's what the program
# claims to be when you run it.
GALASM_VERSION=2.1
DISTNAME= GALasm-${GALASM_VERSION}
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=daveho/}
GITHUB_TAG= 290d0cf9dcd0d9749167c9019ad694db2c3360dd
MAINTAINER= thorpej@NetBSD.org
HOMEPAGE= https://github.com/daveho/GALasm
COMMENT= Portable GAL assembler
LICENSE= galasm-license
RESTRICTED= Commercial use is strictly forbidden
NO_BIN_ON_CDROM= ${RESTRICTED}
NO_BIN_ON_FTP= ${RESTRICTED}
INSTALLATION_DIRS= bin share/doc/galasm
do-build:
cd ${WRKSRC}/src && ${MAKE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/galasm \
${DESTDIR}${PREFIX}/bin
for file in ${WRKSRC}/galer/*; do \
${INSTALL_DATA} $$file ${DESTDIR}${PREFIX}/share/doc/galasm; \
done
.include "../../mk/bsd.pkg.mk"

71
devel/galasm/PLIST Normal file
View File

@ -0,0 +1,71 @@
@comment $NetBSD: PLIST,v 1.1 2023/04/25 03:28:37 thorpej Exp $
bin/galasm
share/doc/galasm/asmerr.html
share/doc/galasm/assembler.html
share/doc/galasm/construction.html
share/doc/galasm/errors.html
share/doc/galasm/example16v8.html
share/doc/galasm/example20ra10.html
share/doc/galasm/example22v10.html
share/doc/galasm/examples.html
share/doc/galasm/gal16_20v8.html
share/doc/galasm/gal20ra10.html
share/doc/galasm/gal22v10.html
share/doc/galasm/galer.html
share/doc/galasm/history.html
share/doc/galasm/important.html
share/doc/galasm/index.gif
share/doc/galasm/index.html
share/doc/galasm/installation.html
share/doc/galasm/intstruktur.html
share/doc/galasm/jedecerr.html
share/doc/galasm/jedecfile.html
share/doc/galasm/keywords.html
share/doc/galasm/literature.html
share/doc/galasm/main.html
share/doc/galasm/menabout.html
share/doc/galasm/menacw.html
share/doc/galasm/menasm.html
share/doc/galasm/mencalleditor.html
share/doc/galasm/menchecker.html
share/doc/galasm/menclearnames.html
share/doc/galasm/mencmp.html
share/doc/galasm/mencopy.html
share/doc/galasm/meneditor.html
share/doc/galasm/menempty.html
share/doc/galasm/menerase.html
share/doc/galasm/mengalinfo.html
share/doc/galasm/mengaltype.html
share/doc/galasm/menhardver.html
share/doc/galasm/menhelp.html
share/doc/galasm/menjedecpar.html
share/doc/galasm/menmakejedec.html
share/doc/galasm/menoptimizer.html
share/doc/galasm/menprog.html
share/doc/galasm/menquit.html
share/doc/galasm/menreadsig.html
share/doc/galasm/menreasm.html
share/doc/galasm/mensaveconfig.html
share/doc/galasm/mensetsec.html
share/doc/galasm/menshownames.html
share/doc/galasm/mentestsec.html
share/doc/galasm/mentypereq.html
share/doc/galasm/menus.html
share/doc/galasm/menwriteacc.html
share/doc/galasm/next.gif
share/doc/galasm/optimizer.html
share/doc/galasm/partlist.html
share/doc/galasm/prev.gif
share/doc/galasm/proggal.html
share/doc/galasm/proglogik.html
share/doc/galasm/program.html
share/doc/galasm/reasmerr.html
share/doc/galasm/schaltbesch.html
share/doc/galasm/shareware.html
share/doc/galasm/software.html
share/doc/galasm/sourcefile.html
share/doc/galasm/systemreq.html
share/doc/galasm/testing.html
share/doc/galasm/thanks.html
share/doc/galasm/toc.gif
share/doc/galasm/usage.html

6
devel/galasm/distinfo Normal file
View File

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2023/04/25 03:28:37 thorpej Exp $
BLAKE2s (GALasm-2.1-290d0cf9dcd0d9749167c9019ad694db2c3360dd.tar.gz) = e11de6c366d16762d98ed712717c57ffd72fbeeac84dc306688201f488861ca3
SHA512 (GALasm-2.1-290d0cf9dcd0d9749167c9019ad694db2c3360dd.tar.gz) = 37b2de0c51579154183b9af87585636bc708a2a7d062fd65ff77f4c69cb29ab8d659ce6db02a757f57959386313d5f9cd8422ffee0d902abab703d1e5218b449
Size (GALasm-2.1-290d0cf9dcd0d9749167c9019ad694db2c3360dd.tar.gz) = 65614 bytes
SHA1 (patch-src_Makefile) = dc2a2a6f96c52d2dcf3d8bbfed3fbca969112125

View File

@ -0,0 +1,24 @@
$NetBSD: patch-src_Makefile,v 1.1 2023/04/25 03:28:38 thorpej Exp $
Consistently use the the compiler specified by the make(1) environment.
--- src/Makefile.orig 2022-03-30 02:23:47.000000000 +0000
+++ src/Makefile 2023-04-24 23:06:03.125669633 +0000
@@ -2,7 +2,7 @@
TARGET = galasm
OBJS = galasm.o support.o jedec.o localize.o
-CC = gcc
+#CC = gcc
CFLAGS = -Wall -O2
LDFLAGS =
@@ -11,7 +11,7 @@ LDFLAGS =
all: $(TARGET)
$(TARGET): $(OBJS)
- gcc $(LDFLAGS) -o $@ $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS)
clean:
-rm $(OBJS)

1
licenses/galasm-license Normal file
View File

@ -0,0 +1 @@
Commercial use is strictly forbidden.