Don't hardcode /dev/tty00 as the serial device; use ${DEFAULT_SERIAL_DEVICE}
instead. This has no user-visible effect, as the serial device name is only used for the test framework.
This commit is contained in:
parent
1996e6b345
commit
3e280f70a3
3 changed files with 5 additions and 17 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.3 2001/10/18 15:20:04 veego Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2001/11/25 18:01:58 jlam Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Device-SerialPort-0.070
|
||||
|
@ -15,7 +15,9 @@ COMMENT= POSIX-based Perl module to control your serial port
|
|||
USE_PERL5= # defined
|
||||
PERL5_PACKLIST= ${PERL5_SITEARCH}/auto/Device/SerialPort/.packlist
|
||||
|
||||
MAKE_PARAMS= ${DEFAULT_SERIAL_DEVICE}
|
||||
|
||||
do-configure:
|
||||
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
|
||||
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL ${MAKE_PARAMS}
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/20 09:04:23 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/11/25 18:01:58 jlam Exp $
|
||||
|
||||
SHA1 (Device-SerialPort-0.070.tar.gz) = f5bb56453b838cd5220f7ded8981e0286c215ddf
|
||||
Size (Device-SerialPort-0.070.tar.gz) = 60085 bytes
|
||||
SHA1 (patch-aa) = 5fcf0ee6d8124ba4da2f1572a70178a064e3b9dc
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2000/12/18 23:04:26 tsarna Exp $
|
||||
|
||||
--- Makefile.PL.orig Sun Dec 17 21:32:55 2000
|
||||
+++ Makefile.PL
|
||||
@@ -8,7 +8,7 @@
|
||||
'clean' => {FILES => "t/DefaultPort.pm *.cfg t/*.cfg"},
|
||||
);
|
||||
|
||||
-my $file = "/dev/ttyS0";
|
||||
+my $file = "/dev/tty00";
|
||||
if (@ARGV) {
|
||||
$file = shift @ARGV;
|
||||
}
|
Loading…
Reference in a new issue