Deal with const changes in xulrunner.

This commit is contained in:
joerg 2011-12-29 16:34:02 +00:00
parent 977c3e0aca
commit 3e565f611a
4 changed files with 46 additions and 1 deletions

View file

@ -1,6 +1,9 @@
$NetBSD: distinfo,v 1.3 2011/07/12 14:11:58 obache Exp $
$NetBSD: distinfo,v 1.4 2011/12/29 16:34:02 joerg Exp $
SHA1 (gecko-mediaplayer-1.0.4.tar.gz) = 1ad7de0a3ac5a9fa4680228f1b5f58831a8079f9
RMD160 (gecko-mediaplayer-1.0.4.tar.gz) = 163dd0363a8369c66fa04533791e1977c1fd0d7b
Size (gecko-mediaplayer-1.0.4.tar.gz) = 275024 bytes
SHA1 (patch-Makefile.in) = 4decd30aa412333e1c1c2adf8540b51a37201cb2
SHA1 (patch-src_np__entry.cpp) = ec30faec30744af0f9e96be632feadf9f3fc29a4
SHA1 (patch-src_npp__gate.cpp) = aa0b9a44eeff25b251962eb01b65ae1f7434354b
SHA1 (patch-src_npupp.h) = 71ca14069a56ad8c73682252bc938a56bd99dc23

View file

@ -0,0 +1,16 @@
$NetBSD: patch-src_np__entry.cpp,v 1.1 2011/12/29 16:34:03 joerg Exp $
--- src/np_entry.cpp.orig 2011-12-29 14:02:59.000000000 +0000
+++ src/np_entry.cpp
@@ -80,9 +80,9 @@ NPError OSCALL NP_GetEntryPoints(NPPlugi
#endif /* XP_WIN */
-char *NPP_GetMIMEDescription();
+const char *NPP_GetMIMEDescription();
-char *NP_GetMIMEDescription()
+const char *NP_GetMIMEDescription()
{
return NPP_GetMIMEDescription();
}

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_npp__gate.cpp,v 1.1 2011/12/29 16:34:03 joerg Exp $
--- src/npp_gate.cpp.orig 2011-12-29 14:05:17.000000000 +0000
+++ src/npp_gate.cpp
@@ -44,7 +44,7 @@
#include "plugin_types.h"
#include "plugin_setup.h"
-char *NPP_GetMIMEDescription(void)
+const char *NPP_GetMIMEDescription(void)
{
return GetMIMEDescription();
}

View file

@ -0,0 +1,13 @@
$NetBSD: patch-src_npupp.h,v 1.1 2011/12/29 16:34:03 joerg Exp $
--- src/npupp.h.orig 2011-12-29 14:02:31.000000000 +0000
+++ src/npupp.h
@@ -700,7 +700,7 @@ extern "C" {
/* plugin meta member functions */
- NP_EXPORT(char *) NP_GetMIMEDescription(void);
+ NP_EXPORT(const char *) NP_GetMIMEDescription(void);
NP_EXPORT(NPError) NP_Initialize(NPNetscapeFuncs *, NPPluginFuncs *);
NP_EXPORT(NPError) NP_Shutdown(void);
NP_EXPORT(NPError) NP_GetValue(void *future, NPPVariable aVariable, void *aValue);