update to 0.80
this has been massively extended (since 0.32), too much to list here
This commit is contained in:
parent
ccf8e31485
commit
3e813bd0e0
4 changed files with 2138 additions and 21 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.3 2005/04/11 21:46:08 tv Exp $
|
||||
# $NetBSD: Makefile,v 1.4 2005/05/31 18:09:13 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= matplotlib-0.32
|
||||
DISTNAME= matplotlib-0.80
|
||||
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=matplotlib/}
|
||||
|
@ -13,7 +13,8 @@ COMMENT= Matlab-style plotting package for Python
|
|||
PY_PATCHPLIST= yes
|
||||
PYDISTUTILSPKG= yes
|
||||
|
||||
DEPENDS+= ${PYPKGPREFIX}-Numeric>=23.1:../../math/py-Numeric
|
||||
|
||||
.include "../../lang/python/extension.mk"
|
||||
.include "../../math/py-Numeric/buildlink3.mk"
|
||||
.include "../../x11/py-gtk2/buildlink3.mk"
|
||||
.include "../../x11/py-Tk/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2005/02/24 08:45:12 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2005/05/31 18:09:13 drochner Exp $
|
||||
|
||||
SHA1 (matplotlib-0.32.tar.gz) = d700acd8b10d046918fd0c1e64e1de651a034a46
|
||||
RMD160 (matplotlib-0.32.tar.gz) = 951035ad665937a1f53c7dea60b4036e9b5b8d3d
|
||||
Size (matplotlib-0.32.tar.gz) = 769706 bytes
|
||||
SHA1 (matplotlib-0.80.tar.gz) = 639bc10a311319459214d4d23c8c94003d2589ac
|
||||
RMD160 (matplotlib-0.80.tar.gz) = 503924ec1567605f53b3f01656129035b688362e
|
||||
Size (matplotlib-0.80.tar.gz) = 2332845 bytes
|
||||
SHA1 (patch-aa) = a18d4af17526047d3d70cb0d1685365891b7d75c
|
||||
|
|
17
graphics/py-matplotlib/patches/patch-aa
Normal file
17
graphics/py-matplotlib/patches/patch-aa
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-aa,v 1.1 2005/05/31 18:09:13 drochner Exp $
|
||||
|
||||
--- setupext.py.orig 2005-05-12 17:44:54.000000000 +0200
|
||||
+++ setupext.py
|
||||
@@ -87,10 +87,8 @@ def temp_copy(_from, _to):
|
||||
globals()["_cleanup_"+_to] = CleanUpFile(_to)
|
||||
|
||||
def add_base_flags(module):
|
||||
- incdirs = [os.path.join(p, 'include') for p in basedir[sys.platform]
|
||||
- if os.path.exists(p)]
|
||||
- libdirs = [os.path.join(p, 'lib') for p in basedir[sys.platform]
|
||||
- if os.path.exists(p)]
|
||||
+ incdirs = os.path.join(os.environ['LOCALBASE'], 'include')
|
||||
+ libdirs = os.path.join(os.environ['LOCALBASE'], 'lib')
|
||||
module.include_dirs.extend(incdirs)
|
||||
module.library_dirs.extend(libdirs)
|
||||
|
Loading…
Reference in a new issue