Add fcntl.h for openat(). Might help build on NetBSD-6.

This commit is contained in:
wiz 2014-08-21 10:37:47 +00:00
parent e1e10ec9b7
commit 3ea38ac2a2
2 changed files with 17 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.5 2014/02/12 01:23:33 prlw1 Exp $
$NetBSD: distinfo,v 1.6 2014/08/21 10:37:47 wiz Exp $
SHA1 (gnome-desktop-3.10.2.tar.xz) = fd13640ad7f096f29267366bcdf4cf8dc95af07a
RMD160 (gnome-desktop-3.10.2.tar.xz) = 9d59c58c497eafa75a5ae7a38edaa740c8c77726
Size (gnome-desktop-3.10.2.tar.xz) = 1062876 bytes
SHA1 (patch-aa) = 0553828a17b36a1a7ce2fb66ed1ae0ce6eaa8075
SHA1 (patch-libgnome-desktop_libgsystem_gsystem-file-utils.c) = 9c015507b6ab5bb820651d326979e00f86c5a59f

View file

@ -0,0 +1,15 @@
$NetBSD: patch-libgnome-desktop_libgsystem_gsystem-file-utils.c,v 1.1 2014/08/21 10:37:48 wiz Exp $
Add fcntl.h for openat().
--- libgnome-desktop/libgsystem/gsystem-file-utils.c.orig 2013-10-04 22:18:43.000000000 +0000
+++ libgnome-desktop/libgsystem/gsystem-file-utils.c
@@ -37,6 +37,8 @@
#include <glib-unix.h>
#include <limits.h>
#include <dirent.h>
+/* for openat() */
+#include <fcntl.h>
static int
close_nointr (int fd)