Make compile on 2.0_BETA. Also tested on 1.6.2.

This commit is contained in:
wiz 2004-09-10 21:12:21 +00:00
parent 17d08e9e92
commit 3eb6f998ca
3 changed files with 35 additions and 8 deletions

View file

@ -1,9 +1,10 @@
$NetBSD: distinfo,v 1.5 2003/06/19 11:45:02 seb Exp $
$NetBSD: distinfo,v 1.6 2004/09/10 21:12:21 wiz Exp $
SHA1 (cfengine-1.6.5.tar.gz) = 0e40c6094cb4fa12b34920d30e789719e04df511
Size (cfengine-1.6.5.tar.gz) = 879792 bytes
SHA1 (patch-aa) = 49deaa907644bdc2199a861f653d888581d4a681
SHA1 (patch-aa) = dd6adaef964ad78f2b12d8714099c111f5152b2e
SHA1 (patch-ab) = dc6a9d7381778b5f3c2fdb16e65204d5c3faac0d
SHA1 (patch-ac) = 417ca3785c7d7d668a08d4aad298a8d2ec4a6571
SHA1 (patch-ad) = 047e02555d541c22f07cb3e3a102beb0be32df6d
SHA1 (patch-ae) = 283e129a515b664f651fd2272e3f9f8d7f99b60f
SHA1 (patch-af) = 202bd09675ce4e861d2df01f6e52a05dcb4a4a7c

View file

@ -1,8 +1,16 @@
$NetBSD: patch-aa,v 1.4 2003/06/19 11:45:02 seb Exp $
$NetBSD: patch-aa,v 1.5 2004/09/10 21:12:21 wiz Exp $
--- configure.in.orig 2002-08-15 05:59:16.000000000 +0000
--- configure.in.orig 2002-08-15 07:59:16.000000000 +0200
+++ configure.in
@@ -159,17 +159,17 @@ dnl ####################################
@@ -86,6 +86,7 @@ AC_CHECK_LIB(wrap, main) dnl TCP wrapp
AC_CHECK_LIB(nsl, main) dnl Debian -lwrap needs nsl
AC_CHECK_LIB(rx, main) dnl GNU regex lib if you have regcomp in libc you shouldn't have this
AC_CHECK_LIB(crypto,main)
+AC_CHECK_LIB(des,main)
dnl ######################################################################
@@ -159,17 +160,17 @@ dnl ####################################
dnl Handle DCE + threading stuff
dnl #######################################################################
@ -27,7 +35,7 @@ $NetBSD: patch-aa,v 1.4 2003/06/19 11:45:02 seb Exp $
AC_ARG_ENABLE(DCE,[ --enable-DCE support for DCE and ACLs],[
case "$enableval" in
@@ -235,8 +235,8 @@ case "$target_os" in
@@ -235,8 +236,8 @@ case "$target_os" in
aix*)
AC_DEFINE(AIX)
CPPFLAGS="$CPPFLAGS -w"
@ -38,7 +46,7 @@ $NetBSD: patch-aa,v 1.4 2003/06/19 11:45:02 seb Exp $
;;
osf*)
AC_DEFINE(OSF)
@@ -261,8 +261,8 @@ case "$target_os" in
@@ -261,8 +262,8 @@ case "$target_os" in
;;
freebsd*)
AC_DEFINE(FREEBSD)
@ -49,7 +57,7 @@ $NetBSD: patch-aa,v 1.4 2003/06/19 11:45:02 seb Exp $
;;
netbsd*)
AC_DEFINE(NETBSD)
@@ -301,10 +301,10 @@ case "$target_os" in
@@ -301,10 +302,10 @@ case "$target_os" in
sysv4.2MP|unix_sv*)
AC_DEFINE(UNIXWARE)

View file

@ -0,0 +1,18 @@
$NetBSD: patch-af,v 1.4 2004/09/10 21:12:21 wiz Exp $
--- src/encrypt.c.orig 2002-06-20 15:38:34.000000000 +0200
+++ src/encrypt.c
@@ -38,7 +38,12 @@
#if defined(HAVE_LIBCRYPTO) || defined(HAVE_OPENSSL_DES_H)
/* must be des.h from OpenSSL */
-# include <openssl/des.h>
+# include <openssl/opensslv.h>
+# if OPENSSL_VERSION_NUMBER < 0x0090700fL
+# include <openssl/des.h>
+# else
+# include <des.h>
+# endif
# define USE_SSL 1
#endif