EPM is an open source UNIX software and file packaging program that

generates distribution archives from a list of files. EPM provides a
complete, cross-platform software distribution solution for your
applications.

ESP generates both native and "portable" script-based distribution packages
complete with installation and removal scripts and standard
install/uninstall GUIs. The installers can be customized with product logos,
"readme" files, and click-wrap licenses as desired.
This commit is contained in:
cheusov 2011-05-08 21:50:48 +00:00
parent 5a652472f1
commit 3ec8a996eb
7 changed files with 412 additions and 0 deletions

9
misc/epm/DESCR Normal file
View file

@ -0,0 +1,9 @@
EPM is an open source UNIX software and file packaging program that
generates distribution archives from a list of files. EPM provides a
complete, cross-platform software distribution solution for your
applications.
ESP generates both native and "portable" script-based distribution packages
complete with installation and removal scripts and standard
install/uninstall GUIs. The installers can be customized with product logos,
"readme" files, and click-wrap licenses as desired.

40
misc/epm/Makefile Normal file
View file

@ -0,0 +1,40 @@
# $NetBSD: Makefile,v 1.1.1.1 2011/05/08 21:50:48 cheusov Exp $
#
VERSION= 4.2
DISTNAME= epm-${VERSION}-source
PKGNAME= epm-${VERSION}
CATEGORIES= misc
MASTER_SITES= http://ftp.easysw.com/pub/epm/${VERSION}/ \
http://ftp2.easysw.com/pub/epm/${VERSION}/ \
http://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/epm/${VERSION}/
EXTRACT_SUFX= .tar.bz2
MAINTAINER= vle@gmx.net
HOMEPAGE= http://epmhome.org/
COMMENT= ESP generates software packages from a list of files
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
USE_TOOLS+= autoconf #gzip:run tar:run
#TEST_TARGET= test
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV}
GNU_CONFIGURE= yes
USE_LANGUAGES= c c++
DOCDIR= ${PREFIX}/share/doc/epm
CONFIGURE_ARGS+= --disable-gui
CONFIGURE_ARGS+= --with-docdir=${DOCDIR}
CONFIGURE_ENV+= STRIP=${TOOLS_PATH.strip}
pre-configure:
set -e; cd ${WRKSRC}; autoconf;
${CP} ${PKGSRCDIR}/mk/gnu-config/config.guess ${WRKSRC}/
${CP} ${PKGSRCDIR}/mk/gnu-config/config.sub ${WRKSRC}/
${CP} ${.CURDIR}/files/install-sh ${WRKSRC}/
.include "../../mk/bsd.pkg.mk"

13
misc/epm/PLIST Normal file
View file

@ -0,0 +1,13 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2011/05/08 21:50:48 cheusov Exp $
bin/epm
bin/epminstall
bin/mkepmlist
man/man1/epm.1
man/man1/epminstall.1
man/man1/mkepmlist.1
man/man1/setup.1
man/man5/epm.list.5
man/man5/setup.types.5
share/doc/epm/COPYING
share/doc/epm/README
share/doc/epm/epm-book.html

7
misc/epm/distinfo Normal file
View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2011/05/08 21:50:48 cheusov Exp $
SHA1 (epm-4.2-source.tar.bz2) = e11049c6bb77432e3c4784aa44b6e05ace5a4de9
RMD160 (epm-4.2-source.tar.bz2) = 31b84c74fd66b470b88c6fec49e9fe9a04abe055
Size (epm-4.2-source.tar.bz2) = 458362 bytes
SHA1 (patch-aa) = 6aa91315b8d8d632dd9d2013d15693877ae5861e
SHA1 (patch-ab) = 3ae0ce21cf43e7bf0e28a1cd54ec239aa67d6542

238
misc/epm/files/install-sh Executable file
View file

@ -0,0 +1,238 @@
#! /bin/sh
#
# install - install a program, script, or datafile
# This comes from X11R5.
#
# Calling this script install-sh is preferred over install.sh, to prevent
# `make' implicit rules from creating a file called install from it
# when there is no Makefile.
#
# This script is compatible with the BSD install script, but was written
# from scratch.
#
# set DOITPROG to echo to test this script
# Don't use :- since 4.3BSD and earlier shells don't like it.
doit="${DOITPROG-}"
# put in absolute paths if you don't have them in your path; or use env. vars.
mvprog="${MVPROG-mv}"
cpprog="${CPPROG-cp}"
chmodprog="${CHMODPROG-chmod}"
chownprog="${CHOWNPROG-chown}"
chgrpprog="${CHGRPPROG-chgrp}"
stripprog="${STRIPPROG-strip}"
rmprog="${RMPROG-rm}"
mkdirprog="${MKDIRPROG-mkdir}"
transformbasename=""
transform_arg=""
instcmd="$mvprog"
chmodcmd="$chmodprog 0755"
chowncmd=""
chgrpcmd=""
stripcmd=""
rmcmd="$rmprog -f"
mvcmd="$mvprog"
src=""
dst=""
dir_arg=""
while [ x"$1" != x ]; do
case $1 in
-c) instcmd="$cpprog"
shift
continue;;
-d) dir_arg=true
shift
continue;;
-m) chmodcmd="$chmodprog $2"
shift
shift
continue;;
-o) chowncmd="$chownprog $2"
shift
shift
continue;;
-g) chgrpcmd="$chgrpprog $2"
shift
shift
continue;;
-s) stripcmd="$stripprog"
shift
continue;;
-t=*) transformarg=`echo $1 | sed 's/-t=//'`
shift
continue;;
-b=*) transformbasename=`echo $1 | sed 's/-b=//'`
shift
continue;;
*) if [ x"$src" = x ]
then
src=$1
else
# this colon is to work around a 386BSD /bin/sh bug
:
dst=$1
fi
shift
continue;;
esac
done
if [ x"$src" = x ]
then
echo "install: no input file specified"
exit 1
else
true
fi
if [ x"$dir_arg" != x ]; then
dst=$src
src=""
if [ -d $dst ]; then
instcmd=:
else
instcmd=mkdir
fi
else
# Waiting for this to be detected by the "$instcmd $src $dsttmp" command
# might cause directories to be created, which would be especially bad
# if $src (and thus $dsttmp) contains '*'.
if [ -f $src -o -d $src ]
then
true
else
echo "install: $src does not exist"
exit 1
fi
if [ x"$dst" = x ]
then
echo "install: no destination specified"
exit 1
else
true
fi
# If destination is a directory, append the input filename; if your system
# does not like double slashes in filenames, you may need to add some logic
if [ -d $dst ]
then
dst="$dst"/`basename $src`
else
true
fi
fi
## this sed command emulates the dirname command
dstdir=`echo $dst | sed -e 's,[^/]*$,,;s,/$,,;s,^$,.,'`
# Make sure that the destination directory exists.
# this part is taken from Noah Friedman's mkinstalldirs script
# Skip lots of stat calls in the usual case.
if [ ! -d "$dstdir" ]; then
defaultIFS='
'
IFS="${IFS-${defaultIFS}}"
oIFS="${IFS}"
# Some sh's can't handle IFS=/ for some reason.
IFS='%'
set - `echo ${dstdir} | sed -e 's@/@%@g' -e 's@^%@/@'`
IFS="${oIFS}"
pathcomp=''
while [ $# -ne 0 ] ; do
pathcomp="${pathcomp}${1}"
shift
if [ ! -d "${pathcomp}" ] ;
then
$mkdirprog "${pathcomp}"
else
true
fi
pathcomp="${pathcomp}/"
done
fi
if [ x"$dir_arg" != x ]
then
$doit $instcmd $dst &&
if [ x"$chowncmd" != x ]; then $doit $chowncmd $dst; else true ; fi &&
if [ x"$chgrpcmd" != x ]; then $doit $chgrpcmd $dst; else true ; fi &&
if [ x"$stripcmd" != x ]; then $doit $stripcmd $dst; else true ; fi &&
if [ x"$chmodcmd" != x ]; then $doit $chmodcmd $dst; else true ; fi
else
# If we're going to rename the final executable, determine the name now.
if [ x"$transformarg" = x ]
then
dstfile=`basename $dst`
else
dstfile=`basename $dst $transformbasename |
sed $transformarg`$transformbasename
fi
# don't allow the sed command to completely eliminate the filename
if [ x"$dstfile" = x ]
then
dstfile=`basename $dst`
else
true
fi
# Make a temp file name in the proper directory.
dsttmp=$dstdir/#inst.$$#
# Move or copy the file name to the temp name
$doit $instcmd $src $dsttmp &&
trap "rm -f ${dsttmp}" 0 &&
# and set any options; do chmod last to preserve setuid bits
# If any of these fail, we abort the whole thing. If we want to
# ignore errors from any of these, just make sure not to ignore
# errors from the above "$doit $instcmd $src $dsttmp" command.
if [ x"$chowncmd" != x ]; then $doit $chowncmd $dsttmp; else true;fi &&
if [ x"$chgrpcmd" != x ]; then $doit $chgrpcmd $dsttmp; else true;fi &&
if [ x"$stripcmd" != x ]; then $doit $stripcmd $dsttmp; else true;fi &&
if [ x"$chmodcmd" != x ]; then $doit $chmodcmd $dsttmp; else true;fi &&
# Now rename the file to the real destination.
$doit $rmcmd -f $dstdir/$dstfile &&
$doit $mvcmd $dsttmp $dstdir/$dstfile
fi &&
exit 0

73
misc/epm/patches/patch-aa Normal file
View file

@ -0,0 +1,73 @@
$NetBSD: patch-aa,v 1.1.1.1 2011/05/08 21:50:48 cheusov Exp $
DESTDIR support
--- Makefile.in.orig 2006-11-30 23:59:27.000000000 +0200
+++ Makefile.in
@@ -31,7 +31,10 @@ RANLIB = @RANLIB@
RM = @RM@ -f
SHELL = /bin/sh
STRIP = @STRIP@
-
+INSTALL = @INSTALL@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
+INSTALL_DATA = @INSTALL_DATA@
#
# Program options...
@@ -155,39 +158,25 @@ distclean:
install: all @INSTALL_GUIS@ @INSTALL_OSX@
echo Installing EPM programs in $(bindir)
- -$(MKDIR) $(bindir)
- $(RM) $(bindir)/epm
- $(CP) epm $(bindir)
- $(STRIP) $(bindir)/epm
- $(RM) $(bindir)/epminstall
- $(CP) epminstall $(bindir)
- $(STRIP) $(bindir)/epminstall
- $(RM) $(bindir)/mkepmlist
- $(CP) mkepmlist $(bindir)
+ -$(MKDIR) $(DESTDIR)$(bindir)
+ $(INSTALL_PROGRAM) epm $(DESTDIR)$(bindir)
+ $(INSTALL_PROGRAM) epminstall $(DESTDIR)$(bindir)
+ $(INSTALL_PROGRAM) mkepmlist $(DESTDIR)$(bindir)
echo Installing EPM manpages in $(mandir)/man1
- -$(MKDIR) $(mandir)/man1
- $(RM) $(mandir)/man1/epm.1
- $(CP) $(srcdir)/doc/epm.man $(mandir)/man1/epm.1
- $(RM) $(mandir)/man1/epminstall.1
- $(CP) $(srcdir)/doc/epminstall.man $(mandir)/man1/epminstall.1
- $(RM) $(mandir)/man1/mkepmlist.1
- $(CP) $(srcdir)/doc/mkepmlist.man $(mandir)/man1/mkepmlist.1
- $(RM) $(mandir)/man1/setup.1
- $(CP) $(srcdir)/doc/setup.man $(mandir)/man1/setup.1
+ -$(MKDIR) $(DESTDIR)$(mandir)/man1
+ $(INSTALL_DATA) $(srcdir)/doc/epm.man $(DESTDIR)$(mandir)/man1/epm.1
+ $(INSTALL_DATA) $(srcdir)/doc/epminstall.man $(DESTDIR)$(mandir)/man1/epminstall.1
+ $(INSTALL_DATA) $(srcdir)/doc/mkepmlist.man $(DESTDIR)$(mandir)/man1/mkepmlist.1
+ $(INSTALL_DATA) $(srcdir)/doc/setup.man $(DESTDIR)$(mandir)/man1/setup.1
echo Installing EPM manpages in $(mandir)/man5
- -$(MKDIR) $(mandir)/man5
- $(RM) $(mandir)/man5/epm.list.5
- $(CP) $(srcdir)/doc/epm.list.man $(mandir)/man5/epm.list.5
- $(RM) $(mandir)/man5/setup.types.5
- $(CP) $(srcdir)/doc/setup.types.man $(mandir)/man5/setup.types.5
+ -$(MKDIR) $(DESTDIR)$(mandir)/man5
+ $(INSTALL_DATA) $(srcdir)/doc/epm.list.man $(DESTDIR)$(mandir)/man5/epm.list.5
+ $(INSTALL_DATA) $(srcdir)/doc/setup.types.man $(DESTDIR)$(mandir)/man5/setup.types.5
echo Installing EPM documentation in $(docdir)
- -$(MKDIR) $(docdir)
- $(RM) $(docdir)/COPYING
- $(CP) $(srcdir)/COPYING $(docdir)
- $(RM) $(docdir)/README
- $(CP) $(srcdir)/README $(docdir)
- $(RM) $(docdir)/epm-book.html
- $(CP) $(srcdir)/doc/epm-book.html $(docdir)
+ -$(MKDIR) $(DESTDIR)$(docdir)
+ $(INSTALL_DATA) $(srcdir)/COPYING $(DESTDIR)$(docdir)
+ $(INSTALL_DATA) $(srcdir)/README $(DESTDIR)$(docdir)
+ $(INSTALL_DATA) $(srcdir)/doc/epm-book.html $(DESTDIR)$(docdir)
install-guis: setup uninst
echo Installing EPM setup/uninst in $(libdir)/epm

32
misc/epm/patches/patch-ab Normal file
View file

@ -0,0 +1,32 @@
$NetBSD: patch-ab,v 1.1.1.1 2011/05/08 21:50:48 cheusov Exp $
DESTDIR support
--- configure.in.orig 2006-09-26 18:51:15.000000000 +0300
+++ configure.in
@@ -18,6 +18,7 @@ dnl
AC_INIT(epm.c)
AC_CONFIG_HEADER(config.h)
+AC_CONFIG_SRCDIR([epm.c])
AC_PREFIX_DEFAULT(/usr)
dnl Version number...
@@ -28,6 +29,8 @@ AC_SUBST(VERSION)
AC_SUBST(VERNUMBER)
AC_DEFINE_UNQUOTED(EPM_VERSION, "ESP Package Manager v$VERSION")
+AC_CANONICAL_HOST
+
dnl Get the operating system...
uname=`uname`
@@ -69,7 +72,9 @@ AC_ARG_WITH(softwaredir, [ --with-softw
dnl Checks for programs...
AC_PROG_CC
AC_PROG_CXX
+AC_PROG_INSTALL
AC_PROG_RANLIB
+
AC_PATH_PROG(AR,ar)
AC_PATH_PROG(CHMOD,chmod)
AC_PATH_PROG(CP,cp)